Hilfe f? WinRegatta

Hilfe für WinRegatta

Diese Online-Hilfe entspricht dem Standard für Online-Hilfe ab Windows 98. Dieses Hilfesystem arbeitet auf HTML-Basis.

Die Hilfedokumentation besteht aus folgenden Objekten:

  • Die Online-Hilfe (WR48Hilfe.chm) starten Sie in WinRegatta über das Menü "? / WinRegatta-Hilfe". Neben der gezielten Themensuche mit Indexwörtern oder einer Volltextsuche kann die Hilfe auch als Funktionshandbuch verwendet werden.

Verwenden der Hilfe

Ändern des Hilfefensters


Verwenden der Hilfe

Das Hilfefenster ist in zwei Ausschnitte unterteilt. Je nachdem, welche Registerkarte aktiviert ist (Inhalt, Index oder Suchen), zeigt der linke Ausschnitt das Inhaltsverzeichnis, den Index oder die Liste der Suchergebnisse an. Im rechten Ausschnitt wird das Hilfethema angezeigt, das zu dem ausgewählten Eintrag im linken Ausschnitt gehört.

So suchen Sie ein Hilfethema

  • Klicken Sie in der Hilfe auf eine der folgenden Registerkarten:
    • Klicken Sie auf die Registerkarte Inhalt, um die Themen nach Kategorien geordnet zu durchsuchen.
    • Eine Liste der Indexeinträge zeigen Sie an, indem Sie auf die Registerkarte Index klicken. Geben Sie dort ein Schlüsselwort ein, oder blättern Sie durch die Liste.
    • Klicken Sie auf die Registerkarte Suchen, um nach Wörtern oder Ausdrücken zu suchen, die in einem Hilfethema enthalten sind.
  • Klicken Sie im linken Frame des Hilfefensters auf das Thema, den Indexeintrag oder den Ausdruck, um im rechten Frame das zugehörige Hilfethema anzuzeigen.

So erhalten Sie zusätzliche Hilfeinformationen

Sie können in einem Hilfethema auf die unterstrichenen Wörter klicken, um zusätzliche Informationen im Zusammenhang mit diesem Thema zu erhalten.

  • Sie öffnen eine Anwendung, eine Seite im Internet oder ein anderes Hilfethema, indem Sie auf die farblich hervorgehobenen, unterstrichenen Wörter klicken. Probieren Sie es aus: Klicken Sie hierauf, Ändern des Hilfefensters um zu einem anderen Thema zu springen.
  • Um ein verwandtes Thema mit weiterführenden Informationen zu öffnen, klicken Sie auf die unterstrichenen Wörter "Siehe auch" am Ende eines Hilfethemas und dann auf den Titel des gewünschten Themas.

So kopieren Sie ein Hilfethema

  • Klicken Sie im rechten Frame des Hilfefensters mit der rechten Maustaste in das zu kopierende Thema, und klicken Sie auf Alles markieren.
  • Klicken Sie erneut innerhalb des Themas mit der rechten Maustaste, und klicken Sie dann auf Kopieren.
  • Dadurch wird das Hilfethema in die Zwischenablage kopiert.
  • Öffnen Sie das Dokument, in das Sie das Thema kopieren möchten.
  • Klicken Sie in dem Dokument an die Stelle, an der die Informationen angezeigt werden sollen.
  • Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkung

  • Wenn Sie nur einen Teil eines Themas kopieren möchten, markieren Sie den zu kopierenden Teil, klicken mit der rechten Maustaste auf den markierten Text und klicken dann auf Kopieren.

So drucken Sie ein Hilfethema

  • Klicken Sie im rechten Frame des Hilfefensters auf das zu druckende Thema.
  • Klicken Sie auf der Hilfesymbolleiste auf Drucken.

Anmerkungen

  • Wenn Sie von der Registerkarte Inhalt aus drucken, können Sie auswählen, ob Sie das aktuelle Thema oder alle Themen unter der ausgewählten Überschrift drucken möchten.
  • Um ein Popuphilfethema zu drucken, klicken Sie mit der rechten Maustaste auf eine Stelle in dem Popupfenster und klicken dann auf Thema drucken.

So gehen Sie zu den Themen zurück, die Sie bereits geöffnet haben

  • Klicken Sie auf der Hilfesymbolleiste auf Zurück , um das Hilfethema anzuzeigen, das Sie zuletzt gelesen haben.
  • Klicken Sie auf der Hilfesymbolleiste auf Optionen und dann auf Vorwärts , um das nächste Thema in der Abfolge der bereits gelesenen Hilfethemen zu öffnen.


?ndern des Hilfefensters

Ändern des Hilfefensters

So blenden Sie den Inhalt des Hilfefensters ein und aus

  • Klicken Sie auf der Hilfesymbolleiste auf Ausblenden, um den Inhalt, den Index oder die Liste der Suchergebnisse auszublenden.
  • Klicken Sie auf der Hilfesymbolleiste auf Einblenden, um den Inhalt, den Index oder die Liste der Suchergebnisse einzublenden.

So ändern Sie die Fenstergröße

  • Um den linken oder rechten Frame zu verschmälern oder zu verbreitern, zeigen Sie auf den Trennbalken zwischen den beiden Frames. Wenn der Zeiger sich in einen Doppelpfeil verwandelt, halten Sie die linke Maustaste gedrückt und ziehen den Trennbalken nach links oder nach rechts.
  • Wenn Sie das gesamte Hilfefenster proportional verkleinern oder vergrößern möchten, zeigen Sie auf eine beliebige Ecke des Hilfefensters. Wenn der Zeiger sich in einen Doppelpfeil verwandelt, halten Sie die linke Maustaste gedrückt und ziehen die Ecke.
  • Um die Höhe oder Breite des gesamten Hilfefensters zu ändern, zeigen Sie auf die obere, untere, linke oder rechte Kante des Hilfefensters. Wenn der Zeiger sich in einen Doppelpfeil verwandelt, halten Sie die linke Maustaste gedrückt und ziehen die Kante.

So ändern Sie die Schriftgröße

  • Starten Sie den MS Internet Explorer
  • Wählen Sie Menü "Ansicht / Schriftgrad"
  • Wählen Sie die gewünschte Schriftgröße zwischen "Sehr klein" bis "Sehr groß" (zu empfehlen ist "Mittel"). Starten Sie die Winregatta Hilfe neu, damit die Einstellung wirksam wird.


Willkommen bei WinRegatta

Nach langer Entwicklungszeit wurde WinRegatta im April 2001 fertiggestellt. WinRegatta ist eine moderne 32-Bit-Anwendung, die aber auch auf Vista 64Bit und Windows 7, Windows 8.1 und Windows 10 64Bit läuft. WinRegatta unterstützt in umfassender Weise die Abwicklung von Regatta-Veranstaltungen. Besonderer Wert wurde auf sachgerechte Funktionsabläufe und auf eine komfortable Benutzeroberfläche gelegt.

Einleitung

Versions-Informationen

WinRegatta-Funktionen

Systemvoraussetzung, Installation

Arbeiten mit WinRegatta

Funktionsbeschreibung


Einleitung

Regatta für Windows - im folgenden „WinRegatta“ genannt - unterstützt in umfassender Weise die Abwicklung von Segel-Regatta-Veranstaltungen. Teile der bewährten Konzeption der Regatta-Anwendung für Dos wurden für WinRegatta übernommen und mit den Möglichkeiten der Windows-Technologie zu einer modernen Anwendung entwickelt. Besonderer Wert wurde hierbei auf sachgerechte Funktionsabläufe und auf eine komfortable Benutzeroberfläche gelegt. WinRegatta ist eine 32-Bit-Anwendung und wurde auf folgenden Betriebssystemen erfolgreich getestet: Windows 98, 2000, ME, NT, XP, VISTA 32Bit und 64Bit, Windows 7 32Bit und 64Bit, Windows 8.1 32Bit und 64Bit sowie Windows 10 32Bit und 64Bit.

Zwei WinRegatta Versionen:
Winregatta wird in zwei Versionen mit unterschiedlichen Funktionsinhalten angeboten. Für normale Anforderungen eines Segelclubs wird Winregatta als Standard-Version empfohlen. Für besondere Anforderungen steht WinRegatta Plus zur Verfügung, mit zusätzlichen Funktionen wie z. B. Gruppenwertung und ORC-Club-Wertung.

Funktionsinhalte: (siehe Funktionsliste)
Die Regatta-Veranstaltung kann aus mehreren Wertungsklassen mit unterschiedlichen Ergebnis- und Wertungsarten bestehen. Maximal können 15 verschiedene Wertungsklasssen mit einer unbegrenzten Zahl von Booten gewertet werden.
Bei Veranstaltungen mit mehr als 15 verschiedenen Wertungsklassen können die Daten auf mehrere Dateien aufgeteilt und so die Anzahl der Wertungsklassen beliebig erhöht werden.

Die Wettfahrtergebnisse können als gesegelte Rangfolge oder als Zielzeit eingegeben werden. Des Weiteren können Schiedsgerichts-Ergebnisse berücksichtigt werden, z.B. Disqualifikationen, Punkte für Wiedergutmachung oder Wertungsstrafen.

Pro Wettfahrt kann ein umfangreiches Wettfahrt-Protokoll geführt werden, das wahlweise auf den Ergebnislisten gedruckt wird.

Die Wertung kann nach dem Low-Point-System oder dem Bonuspunkt-System geschehen. Wahlweise kann eine Klassenwertung oder Yardstickwertung, mit oder ohne Streicher vorgenommen werden. WinRegatta Plus beinhaltet zusätzlich zwei verschiedene ORC-Club-Wertungen, die Gruppenwertung für große Starterfelder und die Wertung nach der Meisterschaftsordnung für olympische Klassen (MO-F).

Für Kombinationswertungen können die Segler unterschiedlicher Klassen zusätzlich bis zu fünf Sekundärklassen zugeordnet werden, z.B. die heimischen Segler einer Veranstaltung zu einer Club-Wertung und junge Segler zu einer Juniorenwertung.

Pro Klasse können bis zu 15 Wettfahrten gewertet werden.


WinRegatta-Funktionen

WinRegatta - Funktionen

  • Komfortable grafische Oberfläche im modernen Windows-Stil erlaubt ein sicheres und intuitives Arbeiten.
  • Kontextsensitive Hilfen in der Statuszeile zu jeder Zeit.
  • Umfangreiche On-Line-Hilfe auf HTML-Basis.
  • WinRegatta-Betrieb in einem Benutzerkonto mit eingeschränkten Zugriffsrechten Neu in Vers. 4.2 für Windows XP, Windows 7, 8.1 und 10.
  • WR 2017-2020 und neueste Ordnungsvorschriften des DSV voll unterstützt.
  • Es können 15 verschiedene Wertungsklassen verarbeitet werden. Wenn dies nicht ausreicht, können weitere Dateien angelegt und die Anzahl der Klassen vervielfacht werden.
  • Bis zu 15 Wettfahrten pro Wertungsklasse, wahlweise mit bis zu 6 Streichern.
  • Die Anzahl der Boote ist unbegrenzt.
  • Segelnummer wahlweise mit oder ohne Nationalitätskennzeichen.
  • Wahlweise Yachtnamen oder Bugnummern zusätzlich zur Segelnummer.
  • Mannschaftsstärke von 1, 2 oder 3 pro Wertungsklasse wählbar. Bis zu 6 Segler pro Boot mit WinRegatta Plus .
  • Import von Seglermeldedaten aus einer CSV-Datei. Neu in Vers. 4.2
  • Import von Seglermeldedaten aus dem Online-Portal "raceoffice.org" Neu ab Vers. 4.5
  • Wahlweise Plausibilitätsprüfung beim Import von Seglermeldedaten. Erkannte Fehler werden in einem Protokoll ausgegeben. Neu in Vers. 4.4
  • Integrierte Club-Datenbank mit 1330 Clubs (Stand: April 2016). DSV-Nummern der Segelclubs werden automatisch aus der Club-Datenbank zugeordnet. Ab WinRegatta Version 4.4 kann umgekehrt ein Club mittels der DSV-Nummer gesucht werden. Ab WinRegatta Version 4.1 kann wahlweise in einer Regatta auch auf DSV-Nummern verzichtet werden. Ab WinRegatta Version 4.5 können unterschiedliche Club-Datenbanken geöffnet und auch unter geänderten Dateinamen in beliebigen Ordnern gespeichert werden.
  • Die Club-Datenbank kann mit einem Mausklick in eine Excel-Tabelle exportiert werden. Neu Vers. 4.4
  • Ergebniseingabe wahlweise nach Rangfolge, nach Zieleinlauffolge, nach gestoppter Zeit oder nach Uhrzeit. Die gesegelte Zeit wird auch bei mehreren Startgruppen automatisch ermittelt. Eingabe nach Uhrzeit: Neu in Vers. 4.1

  • In einem vorgegebenen Zeitfenster kann jede Yacht ihren Startzeitpunkt selbst wählen. Bei der Ergebniseingabe wird pro Yacht die individuelle Startzeit und die Zielzeit eingegeben. WinRegatta ermittelt hieraus die gesegelte Zeit. Neu in Vers. 4.4b

  • "Totes Rennen" von zwei oder mehr Seglern nach gesegeltem Rang, gesegelter Zeit oder berechneter Zeit.

  • Wertung wahlweise nach dem Low-Point-System oder Bonuspunkt-System mit bis zu 6 Streichern.
  • Klassenwertung mit Ranglistenpunkte-Berechnung unter Berücksichtigung von Ranglistenfaktoren.
  • Integrierte Bootstypen/Yardstick-Datenbank mit ca. 1880 Bootstypen. Diese Yardstick-Tabelle 2017 der Kreuzerabteilung ist urheberrechtlich geschützt durch Copyright des DSV. Ab WinRegatta Version 4.5 können unterschiedliche Bootstypen/Yardstick-Datenbanken geöffnet und auch unter geänderten Dateinamen in beliebigen Ordnern gespeichert werden.
  • Die Bodensee-Yardstick-Tabelle mit ca. 1300 Einträgen steht auf Wunsch ebenfalls zur Verfügung. Neu in Vers. 4.1
  • Die Chiemsee-Yardstick-Tabelle mit ca. 500 Einträgen steht auf Wunsch ebenfalls zur Verfügung. Neu in Vers. 4.4
  • Die jeweils aktive Yardstick-Tabelle kann mit einem Mausklick in eine Excel-Tabelle exportiert werden. Neu Vers. 4.4
  • Yardstick-Wertung mit automatischer Zuordnung von Yardstick-Zahlen aus der Bootstypen-Datenbank.
  • Individuelle Anpassung des Yardsticks eines Bootes, um Abweichungen vom Standard der Bootsklasse auszugleichen.
  • Känguruh-Start: Berechnung und Druck einer Känguruh-Startliste. Neu in Vers. 4.2
  • Wertung mit Schabrod-Stromformel für Yardstick-Regatten auf Flußrevieren. Bisher war der verwendete Stromfaktor 0,75.
    Ab Vers. 4.5 kann der Faktor zwischen 0,75 und 1,0 in 0,05er-Schritten gewählt werden.
  • Fünffache Kombinations-Wertung über mehrere Klassen oder als Teilmenge von einer Klasse.
  • Junioren-/Senioren-Wertung mit Angabe des Geburtsdatums.
  • Teamwertung mit bis zu 8 Teams mit bis zu 3 Teamstreichern. Neu in Vers. 4.6
  • Berücksichtigung von Schiedsgerichts-Entscheidungen, wie Disqualifikation, Wiedergutmachung oder Wertungsstrafen.
  • Wettfahrt-Protokoll mit Wettfahrtzeiten, Wind- und Bahndaten und automatischer Berechnung der mittleren Geschwindigkeit des ersten Seglers pro Klasse.
  • Segler-Stammdatenbank zum Archivieren von Seglerdaten über mehrere Veranstaltungen hinweg. Für die nächste Regatta können diese Daten dann wieder reaktiviert werden. Die Seglerdaten können bequem exportiert werden in Text-Dateien, Excel-Tabellen oder HTML-Dateien.
  • Erfassung von Meldegeld mit Zahlungsart und Meldegeld-Abrechnung. Ab Vers. 4.5 kann wahlweise das Nachmeldegeld zusätzlich erfasst werden.
  • Bei der Eingabe von Seglerdaten können gleiche Daten für mehrere Boote gleichzeitig eingegeben werden, z. B. Meldegeld oder Klassenzuordnungen. Neu Vers. 4.4
  • Quittungsdruck für Segler mit Veranstaltungsdaten und gezahltem Meldegeld und Nachmeldegeld.
  • Vielfältiger Listendruck (Check-Listen, Meldelisten, Ergebnislisten) über Windows-Standarddrucker. Auch Ausgabe als PDF-Datei (wenn PDF-Writer vorhanden).
  • Wahlweise Druck einer Werbegrafik (Sponsoren) am unteren Seitenrand auf Melde- und Ergenislisten - auch beim Druck in eine PDF-Datei. Neu Vers. 4.4
  • Speichern von Melde- und Ergebnislisten als HTML-Datei zum direkten Hochladen ins Internet.
  • Speichern von Melde- und Ergebnislisten als Text-Datei, z. B. zur Weiterverarbeitung mit Excel.
  • Speicherung aller relevanten Daten zum automatisierten Urkundendruck mittels Serienbrieffunktion.
  • Die Melde- und Ergebnislisten sowie die Text- und HTML-Dateien können wahlweise in Deutsch oder Englisch erstellt werden. Neu Vers. 4.1
  • Export/Import der Regattadaten einer Veranstaltung in/aus eine(r) CSV-Datei. Hiermit ist es möglich Regattadaten zwischen verschiedenen WinRegatta-Versionen auszutauschen, auch wenn das Datenformat unterschiedlich ist. Neu Vers. 4.7
  • WinRegatta ist eine 32-Bit-Anwendung und wurde mit Delphi von Borland (heute Embarcadero) entwickelt.
    Ab Vers. 4.5 läuft WinRegatta auch auf Vista 64Bit, auf Windows 7, 8.1 und 10 jeweils 32Bit und 64Bit.
  • Alle Daten werden in einer Paradox-Datenbank gespeichert.
  • Ab Vers. 4.5 wird das Installationspaket von WinRegatta mit InstallShield Express Version 4 erstellt. Dies stellt sicher, dass WinRegatta auch auf Vista 64Bit sowie auf Windows 7, 8.1 und 10 32Bit und 64Bit installiert werden kann.

Funktionen nur in WinRegatta Plus:

  • Crew-Stärke bis sechs Segler pro Boot
  • Meisterschaftsordnung für olympische Klassen (MO-F) - gültig ab April 2006 - wird komfortabel unterstützt. Neu Vers. 4.3
  • Gruppenwertung in zwei Varianten für große Starterfelder. Optional mit Final-Wettfahrten. Die Gruppeneinteilung der Boote erfolgt nach einem komfortablen Dialog automatisch.
  • ORC-Club-Wertung auf Zeit/Zeit-Basis.
  • ORC-Club-Wertung auf Zeit/Distanz-Basis. Neu Vers. 4.1


Versions-Informationen

Weiterentwicklung von WinRegatta

WinRegatta unterliegt einer ständigen Weiterentwicklung, um Verbesserungen und neue Anwendungsfunktionen zu implementieren.

Diese Erweiterungen werden in Form von neuen Programmversionen (Upgrades) bereitgestellt.

Versions-Philosophie

Version 4 Erweiterungen

Version 3 Erweiterungen


Versions-Philosophie

  • Upgrades zum Download
    • WinRegatta unterliegt einer ständigen Weiterentwicklung, um Verbesserungen vorzunehmen, neue Anwendungsfunktionen zu implementieren und Änderungen der Wettfahrt-Regeln der ISAF oder des DSV aufzunehmen.
    • Diese Änderungen werden in der Regel in Form eines Upgrades bereitgestellt, das von den Anwendern kostenfrei von der Website www.WinRegatta.de heruntergeladen werden kann.
  • Hauptversion auf CD
    • In größeren Zeitabständen ist die Entwicklung einer neuen Hauptversion erforderlich, da zur Aufnahme von bestimmten neuen Funktionen die Struktur und Datenbasis der Anwendung erweitert werden muß.
    • Die Version 4.5 ist eine solche Hauptversion , die den Anwendern vorhergehender Versionen gegen eine angemessene Upgrade-Gebühr zur Verfügung steht. Der Entwicklungsaufwand, der hier investiert wurde, ist erheblich. Aus urheberrechtlichen Gründen ist auch kein Download möglich, sondern ein CD-Versand oder ein Download von DropBox erforderlich.
    • Auf der Basis dieser erweiterten Struktur können dann wieder Upgrades entwickelt werden, die die Anwender wieder kostenfrei von der Website herunterladen können. Die Versionen 4.1, 4.2, 4.3, 4.4, 4.6, 4.7 und 4.8 waren bzw. sind solche kostenfreien Upgrades .


Version 4 Informationen

Änderungen in WinRegatta Version 4.8 - verfügbar Juni 2017

  • WinRegatta Version 4.8 gibt es nur als Plus-Version - und zwar kostenfrei:

    • Da inzwischen die meisten Clubs die Plus-Version einsetzen, wird darauf verzichtet, ein Upgrade für die Standard-Version bereizustellen. Hierdurch soll der künftige Pflegeaufwand verringert werden.
    • Die noch verbliebenen Anwender der Standard-Version können ohne zusätzliche Kosten die Plus-Version 4.8 einsetzen. Ein Nachteil für diese Anwender entsteht hierdurch nicht - auch wenn sie die zusätzlichen Funktionen der Plus-Version nicht benötigen.
    • Der Upgrade auf WinRegatta Version 4.8 steht allen bisherigen Anwendern der Versionen 4.5 bis 4.7b kostenfreizur Verfügung.
    • Die Version 4.8 Plus steht nicht als Download von der Website zur Verfügung, sondern muss per E-Mail oder Telefon beim Autor bestellt werden. Ein Download-Link wird dnn mitgeteilt, um das Installationspaket von Drop Box herunter zu laden.
    • WinRegatta Version 4.5 Plus ist auch für die Version 4.8 eine Vorraussetzung.
      Den bisherigen Anwendern der Standard-Version wird bei der Bestellung der Version 4.8, die Version 4.5 Plus automatisch im Download von Drop Box enthalten sein.
  • Flagge "U":
    • Die Startflagge "U" wurde gemäß der WR 2017-2020 implementiert.
    • Ein Frühstart wird mit "UFD" gekennzeichnet.
  • Wettfahrtleiter und Jurymitglieder dokumentieren:
    • Die neuen Ordnungsvorschriften des DSV fordern die Dukumentation von Namen und Lizenznummern der Wetfahrtleiter und Jurymitglieder auf den Ergebnislisten.
    • Unter "Optionen > Veranstalter" können Name, Club-Zugehörigkeit und Lizenznummer des Wetfahrtleiters, senes Stellvertreters und bis zu fünf Jurymitglieder eingegeben werden. Diese Daten werden in der Regatta-Datei (*.R08) gespeichert.
    • Zusätzlich werden diese Daten in der Ini-Datei "WinReg48P.ini" gespeichert. Bei der Erzeugung einer neuen WinRegatta-Dateigruppe werden diese Daten aus der Ini-Datei in die neue Regatta-Datei voreingestellt.
    • In der Druckfunktion können diese Daten mit dem Listentyp "WfLtr / Jury-Dokumentation gedruckt werden. Dieser Ausdruck kann am Schwarzen Brett ausgehangen werden, und als Anlage an die Ergebnisliste angeheftet werden. Falls die Ergebnisliste elektronisch verschickt wird, kann diese Liste als PDF-Anhang beigefügt werden.
    • Wie bisher wird der WfLtr und der Jury-Obmann integriert in den ergebnislisten ausgegeben.
  • Datenbank-Erweiterung:
    • Die Datenbank-Tabellen wurden zum Teil erheblich mit neuen Datenfeldern erweitert.
    • Da die Datenbank mit den früeren WinRegatta-Versionen nicht mehr kompatibel ist, wurde die Dateinamen-Extention in ".*08" geändert. Zum Beispiel R08, K08, S08 usw.
    • Über das Datei-Menü kann eine Konvertierung der Daten mittels einer CSV-Datei gestartet werden. Auf diese Weise können die Daten Versions-kompatibel verarbeitet werden.
  • Nachmelde-Geld:
    • Für das Nachmeldegeldwurde eine Zahlungsart (wie bisher schon für das Meldegeld) hinzugefügt.
    • Das Meldegeld, Nachmeldegeld und zugehörige Zahlungsarten können auch beim Meldedaten-Import importiert werden.
  • Clubs-Tabelle 2017:
    • Dei Clubs-Tabelle "Clubs-04_2017.db" wurde aktualisiert (Stand: April 2017).
      Die Clubs-Tabelle hat ca 1300 Enträge.
  • Yardstick-Tabelle 2017:
    • Die Yardstick-Tabelle "Boote-04_2017 wurde aktualisiert (Stand: April 2017).
      Die Yardstick-Tabelle hat ca. 1900 Einträge.
  • Bediener-Freundlichkeit:
    • Eine Reihe von kleinen Änderungen wurden vorgenommen, um die Bediener-Freundlichkeit weiter zu vebessern.

Änderungen in WinRegatta Version 4.7b - verfügbar Juni 2014

  • Ergebniseingabe nach Bugnummern:
    • Die entwickelte Lösung beinhaltet die Ergebniseingabe nach Bugnummern in gleicher Weise wie die Ergebniseingabe nach Segelnummern.
    • Sortierung der Boote nach Bugnummern numerisch im Fenster Ergebnisei aus der Ini-Datei in diengabe und im Fenster Ergebniseingabe nach Zieleinlauf.
    • Unter „Optionen > Daten-Konfiguration“ die Verwendung von Bugnummern wählen. Jetzt erscheint in der Funktion „Ergebnisse“ die Spalte „Bug-Nr“.
      Mit Klick auf den Spaltenkopf kann nach Bugnummern sortiert werden.
    • Durch Eingabe einer Bugnummer im Feld „Suche Bug-Nr“ (unten links) kann nach Bugnummern für die Ergebniseingabe gesucht werden.
    • Durch Eingabe einer Bugnummer im Feld „Suche Bug-Nr“ (unten links) kann nach Bugnummern für die Ergebniseingabe gesucht werden.
    • Obwohl die Verwendung von Bugnummern unter „Optionen“ gewählt wurde, kann die Ergebniseingabe auch nach Segelnummern umgeschaltet werden.
      Dies geschieht mit Doppelklick auf das Feld „Suche Bug-Nr“. Ein erneuter Doppelklick schaltet wieder auf Bugnummern zurück.
    • Bei der Ergebniseingabe nach Zieleinlauf funktioniert die Eingabe der Ergebnisse nach Bugnummern in gleicher Weise wie nach Segelnummern.
  • Ergebnisliste für Einzelwettfahrt und Klassenwertung mit Zeitnahme:
    • Die HTML-Datei der Ergebnisliste für Einzelwettfahrt enthielt bisher keine gesegelte Zeit. Diese ist aber nötig, um bei einer Startgruppe von unterschiedlichen Bootstypen eine Reihenfolge der gesegelten Zeit (schnellstes Boot) zu ermitteln.
    • Die gleiche Lösung wurde auch für die Text-Datei der Ergebnisliste für Einzelwettfahrt entwickelt.
  • Stellv. WfLtr. und alle Schiedsrichter auf den Ergebnislisten dokumentieren:
    • Die neuen Ordnungsvorschriften des DSV (gültig ab 01.03.2014) fordern die Dokumentation von Namen und Lizenznummer des Stellv. Wettfahrtleiters und aller Schiedsrichter auf den Ergebnislisten.
    • Der Wettfahrtleiter und der Obmann des Schiedsgerichts können heute bereits in WinRegatta eingegeben und auf den Listen gedruckt werden. Die Eingabe des Jury-Obmanns muss unter „Optionen“ aktiviert werden.
      Die Eingabefelder haben 30 Stellen, so dass hier „Vorname Name / Lizenz-Nr.“ eingegeben werden können.
    • Eine umfassende Lösung dieser Anforderung des DSV ist für den Upgrade auf die Version 4.8 geplant. Dies erfordert eine größerer Änderung der Datenbankstruktur, um den Stellv. WfLtr. und bis zu vier zusätzliche Schiedsrichter mit Lizenznummern. zu erfassen.
    • Vorschlag für eine temporäre Lösung:
        • Im Feld „Hinweis“ (Funktion „Drucken“ Ergebnislisten) die zusätzlichen Namen und Lizenznummern eingeben.
          Diese Informationen werden dann am Ende der Ergebnislisten gedruckt.
        • Ein Beispiel einer Ergebnisliste mit diesen Daten finden Sie im Dokument „WfLtr_Jury_Dokumentation.pdf“ im Unterordner „Doc“
    • Clubs-Tabelle 2014:
      • Die Clubs-Tabelle "Clubs-04_2014.db" wurde aktualisiert (Stand: März 2014).
    • Yardstick-Tabelle 2014:
      • Die Yardstick-Tabelle "Boote-04_2014.db" wurde aktualisiert (Stand: März 2014).
    • Gleichnamige Clubabkürzungen:
      • Eine Erweiterung, die mit WinRegatta Version 4.6 eingeführt wurde, ist wohl in Vergessenheit geraten und soll deshalb hier noch einmal erwähnt werden:
          • Wenn in der Funktion "Segler" eine Clubabkürzung eingegeben wird, die in der Club-Datei mehrfach vorkommt, dann erscheint eine Auswahlliste der gleichnamigen Clubabkürzungen, aus der der gewünschte Club gewählt werden kann. Wenn nun häufig eine Clubabkürzung eingegeben wird, die mehrfach vorkommt (z. B. wenn es der eigene Club ist), dann ist der Umweg über die Auswahlliste recht lästig.
          • Abhilfe: In der Funktion "Clubs" kann die normalerweise gewünschte Clubabkürzung in der ersten Stelle des Feldes "Bemerkungen" mit "#" gekennzeichnet werden. Bei der Seglereingabe wird dieser Club dann ohne Umweg über die Auswahlliste direkt eingesteuert. Mit Doppelklick auf das Clubfeld (nach Eingabe der Clubabkürzung) kann aber jede andere der gleichnamigen Clubabkürzungen gewählt werden.

Änderungen in WinRegatta Version 4.7 - verfügbar April 2013

  • Daten-Export/Import in/von einer CSV-Datei:

    • Funktionserweiterungen in WinRegatta machten erhebliche Erweiterungen der Datenbankstruktur (zusätzliche Datenfelder) nötig. Die Regattadaten sind dadurch ab der Version 4.7 nicht mehr versions-kompatibel. Eine Export/Import-Funktion zwischen den Versionen musste geschaffen werden.
    • Alle Regattadaten einer Dateigruppe können ab der Version 4.6 in eine CSV-Datei exportiert werden.
    • Die Daten dieser CSV-Datei können wieder mit WinRegatta Version 4.6 oder 4.7 importiert werden.
    • Die Dateierweiterungen der Regattadateien der Version 4.6 waren bekanntlich *.r04, *.k04, usw.
      Bei der Version 4.7 lauten die Dateierweiterungen *.r47, *.k47, usw.
      Die Regattadateien der Version 4.6 können mit der Version 4.7 also nicht direkt geöffnet werden. Es muß zuerst ein CSV-Export/Import durchgeführt werden.
    • Daten, die mit WinRegatta Version 4.6 in eine CSV-Datei exportiert wurden, können z. B. mit der Version 4.7 importiert werden und umgekehrt.
    • Auf diese Weise können in der weiteren Entwicklung von WinRegatta Erweiterungen in der Datenbank vorgenommen werden, und die Daten bleiben Versions-kompatibel.

  • Anpassung an WR 2013-2016:

    • DPL (Discretionary Penalty) wurde in DPI geändert.
    • Bei DPI wird der gesegelte Platz um die im Feld "Strafe" eingegebenen Plätze erhöht. Gleiches gilt für die SCP-Strafe.
    • RAF (Retired after Finish) wurde in RET geändert.

  • Nachmeldegeld kann gesondert erfasst werden:

    • Die zusätzliche Erfassung des Nachmeldegeldes kann unter „Optionen“ aktiviert werden.
    • Wenn aktiviert, dann wird in der Funktion „Segler“ das zusätzliches Feld "NM-Geld" zur Eingabe des Nachmeldegeldes eingefügt.
    • In der Quittung für die Segler wird das Nachmeldegeld gesondert ausgewiesen.
    • In der Liste „Meldegeldabrechnung“ wird das eingenommene Nachmeldegeld pro Wertungsklasse aufgeführt.

  • Ergebnislisten für Wf-Leitung und Presse wurde erweitert:

    • Diese Ergebnislisten können jetzt auch als HTML-Dateien gespeichert werden.

  • Ergebniseingabe RDG, SCP und DPI:

    • Die Eingabe der Werte als Dezimalzahlen führte bei falschem Dezimalzeichen zur Verwirrung.
    • Zum besseren Verständnis wurde die Fehlermeldung erweitert.

  • Rumpfnummer wurde in Bugnummer umbenannt:

    • In den Segelclubs ist die Bezeichnung „Bugnummer“ üblicher.
      Deshalb wurde in allen Fenstern und Listen die „Rumpfnummer.“ in "Bugnummer" geändert.
  • Clubs-Tabelle 2013:
    • Die Clubs-Tabelle "Clubs-04_2013.db" wurde aktualisiert (Stand: März 2013).
  • Yardstick-Tabelle 2013:
    • Die Yardstick-Tabelle "Boote-04_2013.db" wurde aktualisiert (Stand: März 2013).

Zuaetzliche Änderungen in WinRegatta Version 4.6 - verfuegbar April 2013

  • Daten-Export/Import in/von einer CSV-Datei:
    • Alle Regattadaten einer Dateigruppe können in eine CSV-Datei exportiert werden.
    • Die Daten dieser CSV-Datei können wieder mit WinRegatta Version 4.6 oder höher importiert werden.
    • Auf diese Weise können Erweiterungen in der Datenbank vorgenommen werden, und die Daten bleiben Versions-kompatibel.

Änderungen in WinRegatta Version 4.6 - verfügbar April 2012

  • Achtung! Folgendes Problem kann auftreten: Siehe auch Bekannte Fehler
    ================================
    • Wenn mit WinRegatta Version 4.6 eine Regatta-Dateigruppe geöffnet wird, die mit WinRegatta Version 4.1 bis 4.5 erstellt wurde, dann kann unter bestimmten Umständen ein Fehler auftreten.
    • Lösung: Mit Menü "Datei > Neu" eine neue Dateigruppe erstellen. Die neue Regatta-Datei "*.R04" umbenennen in den Dateinamen der fehlerhaften Dateigruppe und die alte Regatta-Datei (*.R04) durch die neue Datei ersetzen. Die Seglerdaten und die Ergebnisdaten der alten Dateigruppe bleiben dabei erhalten.

=================================

  • Wettfahrtprotokoll - Windstärke in kn:

    • Zusätzlich zu den bisherigen Einheiten m/s und Bft kann jetzt auch Knoten (kn) für die Windstärke gewählt werden.
  • Checkliste für den Start: Details
    • Bei einspaltigem Format der Liste werden zusätzliche Spalten gedruckt. Hierdurch kann das Startgeschehen besser überwacht und dokumentiert werden.
    • Wenn unter Optionen "Yachtname" gewählt wurde, oder wenn es sich um eine Yardstick-Klasse handelt, dann erfolgt zwangsläufig ein einspaltiger Druck. In diesen Fällen wird auch der Yachtname und/oder der Bootstyp gedruckt.
    • Bei grossen Starterfeldern wird die Liste wie bisher zwei- oder dreispaltig gedruckt, vorausgesetzt, "Yachtname" wurde nicht gewählt, und es handelt sich auch nicht um eine Yardstick-Klasse.
  • Teamwertung: Details
    • Boote können Teams zugeordnet werden. Die Teams segeln dann gegeneinander. Maximal sind acht Teams möglich.
    • In der Funktion "Klassen" wird die entsprechende Wertungsklasse für eine Teamwertung gekennzeichnet. In der Funktion "Segler" erscheint für die Seglereingabe dann eine Spalte "Team". Hier können die Boote mit den Ziffern 1 bis 8 den Teams zugeordnet werden.
    • In der Teamwertung werden die Gesamtpunkte der Wettfahrtserie der zugeordneten Boote eines Teams addiert und durch die Anzahl der Boote des Teams dividiert. Dieser Mittelwert der Punkte ergibt das Teamergebnis. Es können 1 bis 3 Teamstreicher angegeben werden, die zu Streichungen der jeweils schlechtesten Ergebnisse führen.
    • Mit der Ergebnisliste "Teamwertung, 1 bis 8 Teams..." können die Teamergebnisse gedruckt werden
  • Rumpfnummer pro Boot: Details
    • Oft sind die Segelnummern sehr lang und können durch die Segel anderer Boote verdeckt werden.
      Um die Identifikation der Boote im Start-/Zielbereich zu erleichtern, kann jedem Boot eine Rumpfnummer zugeordnet werden. Die Rumpfnummer ist eine Art Startnummer und wird am Bug des Bootes angeheftet.
    • Die Funktion "Rumpfnummer" wird unter "Optionen" aktiviert. Allerdings kann nur entweder "Rumpfnummer" oder "Yachtname" für eine Regatta aktiviert werden - nicht beides gleichzeitig.
    • Bei der Seglereingabe wird ein Eingabefeld für die Rumpfnummer angeboten, die dann pro Boot in der Segler-Datei (*.S04) im Feld "Sonstiges" gespeichert wird. Das Feld "Sonstiges" gehört eigentlich zur Adresse des Steuermannes und steht dann natürlich nicht zum Speichern anderer Merkmale zur Verfügung.
    • Wie bei "Yachtnamen" kann auch für die Rumpfnummern gewählt werden, ob sie auf den Listen zusätzlich zu Land/Segelnummer gedruckt wird oder auch nur alleine ohne Land/Segelnummer.
  • Druck von Logo-Grafik und Werbebanner auf Listen: Details
    • Bisher wurden die gewählten Logo-Grafiken (oben links) und Werbebanner (unterer Seitenrand) auf den Listen für alle Regatten (Dateigruppen) einheitlich gedruckt. Wenn für die einzelnen Regatten unterschiedliche Grafiken gewünscht wurden, dann mußten diese unter "Optionen > Listendruck" jeweils neu ausgewählt werden.
    • Ab der Version 4.6 werden die gewählten Grafik-Dateinamen in der jeweiligen Regatta-Dateigruppe gespeichert und beim erneuten Öffnen der Regatta wieder verwendet.
    • Es gelten folgende Einschränkungen: die Grafik-Dateien müssen in einem (beliebigen) gemeinsamen Ordner gespeichert werden, und die Länge der Dateinamen darf nur maximal 18 Stellen lang sein.
    • Der Pfad zu den Grafik-Dateien wird in "WinReg46.ini" abgelegt und die Dateinamen werden in der Regatta-Datei "*.R04" gespeichert
  • Funktion "Segler":
    • Das Auswahlfenster für Segelclubs hat einen Button erhalten zur Aufnahme eines neuen Clubs in die Club-Tabelle.
    • Das Auswahlfenster für Bootstypen hat einen Button erhalten zur Aufnahme eines neuen Bootstypen in die Boote-Tabelle (Yardstick-Tabelle).
      Außerdem kann gewählt werden, ob alle Bootstypen oder nur die aktivierten (x) Boote angezeigt werden. Zusätzlich kann in diesem Fenster eingestellt werden, dass jeder gewählte Bootstyp automatisch aktiviert wird, d. h. ein "x" in der Boote-Tabelle erhält.
  • Gleichnamige Clubabkürzungen:
    • Wenn in der Funktion "Segler" eine Clubabkürzung eingegeben wird, die in der Clubs-Datei mehrfach vorkommt, dann erscheint eine Auswahlliste der gleichnamigen Clubs, aus der der richtige Club gewählt werden kann. Wenn nun häufig eine Clubabkürzung gewählt wird, die mehrfach vorkommt (z. B. wenn es der eigene Club ist), dann ist der Umweg über die Auswahlliste recht lästig.
    • Abhilfe: In der Funktion "Clubs" kann die normalerweise gewünschte Clubabkürzung in der ersten Stelle des Feldes "Bemerkungen" mit "#" gekennzeichnet werden. Bei der Seglereingabe wird dieser Club dann ohne Umweg über die Auswahlliste direkt eingesteuert. Mit Doppelklick auf das Clubfeld kann jede andere der gleichnamigen Clubabkürzungen gewählt werden.
  • WinRegatta-Installation auf einen USB-Stick: Details
    • WinRegatta 4.6 kann mit allen Ini-Dateien und den aktuellen Regatta-Daten des Clubs auf einen USB-Stick installiert werden.
    • Dies bedeutet eine hohe Flexibilität und Portabilität für den WinRegatta-Einsatz.
      Zum Beispiel: Während der Wettfahrt wird der Stick in den Notebook auf dem Start-/Zielschiff gesteckt zur Datenkontrolle und Ergebniseingabe. Nach der Wettfahrt wird der Stick in den Club-PC gesteckt zur Auswertung und zum Listendruck.
    • Die sich häufig ändernden Laufwerksbuchstaben des USB-Sticks auf den verschiedenen PCs kontrolliert und aktualisiert WinRegatta automatisch.
  • WinRegatta-Anwender als eingeschränkter Benutzer: Details
    • Der Betrieb von WinRegatta in einem Benutzerkonto mit eingeschränkten Zugriffsrechten war bisher auch schon möglich. In der Version 4.6 wurde diese Funktion noch besser an die Gegebenheiten von Windows7 angepasst und der Ablauf sicherer gestaltet. Weitere Details und einen Organisationsvorschlag finden Sie in der PDF-Datei "Benutzer_mit_eingeschraenkten_Rechten_Windows7.pdf" im Unterordner "\Doc" des WinRegatta-Installationsordners und auf der Installations-CD.
  • Clubs-Tabelle 2012:
    • Die Clubs-Tabelle "Clubs-04_2012.db" wurde aktualisiert (Stand: April 2012).
  • Yardstick-Tabelle 2012:
    • Die Yardstick-Tabelle "Boote-04_2012.db" wurde aktualisiert (Stand: April 2012).

Änderungen in WinRegatta Version 4.5 - verfügbar im Mai 2010

  • Neues Installationspaket:

    • Installationspakete, die mit dem bisherigen InstallShield erstellt wurden, ließen sich auf Vista 64Bit und auf Windows 7-Systemen nicht mehr installieren.
    • Deshalb wurde jetzt InstallShield Express Version 4 eingesetzt.
    • Mehrere Segelclubs haben dankenswerterweise dies neue Installationspaket von WinRegatta Version 4.5 auf Vista 64Bit sowie auf Windows 7 32Bit und 64Bit getestet.
      Die Tests waren auf allen Windows-Systemen erfolgreich.

  • Z-Flaggenstrafe (ZFP) kann mit 20%, 40% oder auch 60% zur Anwendung kommen: Details

    • Bei der Eingabe der Z-Flaggenstrafe (ZFP) wird ein Feld sichtbar, in dem eingegeben werden kann, wie oft der Segler bei Startwiederholungen einer Wettfahrt Frühstarts verursacht hat.

  • Der "Hinweis zur Regatta" kann nun zusätzlich auch in der Funktion "Drucken" eingegeben werden:

    • Wird der Druck einer Ergebnisliste einer einzelnen Klasse gewählt, so wird ein Memofeld zur Eingabe oder Änderung des Hinweises angeboten. Dies vereinfacht die Handhabung, denn bisher konnte der Hinweis nur in der Funktion "Wertung" eingegeben werden.
    • Dieser Hinweis zur Regatta wird wahlweise am Ende einer Ergebnisliste gedruckt.
  • Gruppenwertung - die Berechnung der Wettfahrtpunkte wurde geändert:
    • Bei Gruppen mit ungleicher Anzahl von Seglern werden jetzt die Wettfahrtpunkte für DNC, DNF, DSQ usw. nach der Seglerzahl der größten Gruppe + 1 berechnet.
      Siehe Wettsegelordnung 2010 des DSV, Punkt 11.2.
  • Der Strom-Faktor zur Wertung von Flußregatten mit der Schabrod-Stromformel wurde wählbar gemacht:
    • Der Strom-Faktor dient in der Schabrod-Stromformel der Gewichtung des Stromeinflusses. Bisher war ein Faktor 0,75 fest einprogrammiert. Auf Vorschlag von einigen Segelclubs wurde dieser Faktur nun wählbar gemacht. Unter Optionen / Daten-Konfiguration kann ein Faktor mit den Werten 0,75 bis 1,00 gewählt werden.
  • Unterschiedliche Clubs-Dateien können geöffnet und gespeichert werden: Details
    • Bisher war der Name der Clubs-Datei mit "Clubs-4.db" vorgegeben. "Clubs-4.db" wurde normalerweise im Installationsverzeichnis von WinRegatta gespeichert.
    • Jetzt ist es möglich Clubs-Dateien mit unterschiedlichen Dateinamen in einem "Öffnen-Dialog" zu öffnen und mit einem "Speichern unter-Dialog" in einen beliebigen Ordner mit geändertem Dateinamen zu speichen. Mit einem "Neu-Dialog" kann auch eine neue, leere Clubs-Datei erzeugt werden.
    • Entsprechende Symbolschalter sind in der Funktion "Clubs" im unteren Bereich angeordnet.
  • Unterschiedliche Bootedateien (Yardstick-Tabellen) können geöffnet und gespeichert werden: Details
    • Bisher war der Name der Bootedatei mit "Boote-4.db" vorgegeben. "Boote-4.db" wurde normalerweise im Installationsverzeichnis von WinRegatta gespeichert.
    • Jetzt ist es möglich Bootedateien mit unterschiedlichen Dateinamen in einem "Öffnen-Dialog" zu öffnen und mit einem "Speichern-unter-Dialog" in einen beliebigen Ordner mit geändertem Dateinamen zu speichen. Mit einem "Neu-Dialog" kann auch eine neue, leere Bootedatei erzeugt werden.
    • Entsprechende Symbolschalter sind in der Funktion "Boote" im unteren Bereich angeordnet.
  • Kleine Grafik oben links und Werbegrafik am unteren Seitenrand von Melde- und Ergebnislisten:
    • Bisher mußten sich die Bitmap-Dateien dieser Grafiken im Installationsverzeichnis von WinRegatta befinden.
      Jetzt können die gewünschten Grafikdateien unter Optionen / Listendruck aus beliebigen Verzeichnissen gewählt werden.
  • Neue Druckliste: Boote Check-Out / Check-IN: Details

    • Diese Liste zeigt alle Boote der gewählten Klasse(n) sortiert nach Segelnummern. Die Liste enthält folgende Spalten: Landeskenner, Segelnummer, Yachtname (optional), Steuermann-Name, Auslaufen und Rückkehr.

    • Die Steuerleute unterschreiben vor dem Auslaufen zur Wettfahrt in der Spalte "Auslaufen" und nach der Rückkehr in der Spalte "Rückkehr".
  • Ergebnisliste "Einzelwettfahrt" wurde optimiert:
    • Für Klassenwertung war diese Liste bisher wenig aussagefähig. Jetzt wurden zusätzliche Spalten eingefügt, um den gesegelten Rang/die gesegelte Zeit, den berechneten Rang und Details zu RDG, ZFP, SCP und DPL zu zeigen.
    • Für Yardstick- und ORC-Wertung, wird in der linken Rangspalte nicht mehr RDG, ZPF, SCP oder DPL gedruckt, sondern der entsprechende korrigierte Rang.
    • Für die Einzelergebnisliste als HTML- oder Text-Datei wird wie bei Yardstick-Wertung verfahren.
  • Check-Listen wurden erweitert:
    • Check-Listen für Start und Bahnmarkenkontrolle mit Segel-Nr:
      • Hier wurde ganz rechts eine Spalte "Check-In" eingefügt. Ein Boot, das vom Meldebüro ein Check-In-Kennzeichen erhalten hat, wird in dieser Spalte mit "Ja" gekennzeichnet. Beim Startcheck ist es hilfreich zu erkennen, wenn ein nicht zum Start erschienenes Boot auch beim Check-In im Meldebüro fehlte.
      • Diese Check-In-Spalte wird nur auf einspaltigen CheckListen gedruckt und auch nur dann, wenn unter "Optionen" der Check-In aktiviert wurde.
    • Check-Listen für Zieleinlauf und beide Arten der Bahnmarkenkontrolle:
      • Die Spalte "Bemerkung" wurde in der Überschrift um "Uhrzeit" erweitert, um dem Anwender zu signalisieren, dass hier die Uhrzeit des Zieleinlaufs bzw. der Bahnmarkenrundung eingetragen werden sollte.
      • Bei der Liste für Zieleinlauf wird "Uhrzeit" für Wertungsklassen mit Ergebnisart "Rang" natürlich nicht gedruckt.
  • Sortierung der Spalte "Geburtsdatun" in der Funktion "Segler":
    • Die Spalten Geburtsdatum und Jahrgang wurden bisher mit Klick auf den Spaltenkopf falsch sortiert. Dies wurde nun wie folgt korrigiert:
      • Das gespeicherte Geburtsdatum im Format ttmmjj wird temporär in das Format jjjjmmtt geändert. Wobei das gespeicherte Jahr > 20 in 19jj und sonst in 20jj temporär geändert wird.
      • Mit Klick auf den Spaltenkopf der Spalten Geburtstagsdatum bzw. Jahrgang wird aufsteigend sortiert. Ein erneuter Klick führt zur absteigenden Sortierung.
      • Diese Korrektur gilt nur für den Steuermann/die Steuerfrau.

  • Känguruh-Startliste erweitert:

    • Die Startliste wurde um einige Daten erweitert. Hierdurch wird die Liste für die Wettfahrtleitung und für die Segler informativer.
    • Bisher wurde eine Zeile pro Bootstyp gedruckt. Jetzt wird eine Zeile pro Boot gedruckt mit folgenden zusätzlichen Spalten: Segelnummer, Yachtname (wenn der Yachtname unter Optionen aktiviert wurde) und Steuermann/frau.
    • Der Yardstick des Nullbootes (größter Yardstick) wird durch WinRegatta automatisch ermittelt und braucht nicht mehr durch den Anwender eingegeben werden.
  • Meldedaten-Import vom Online-Meldesystem "raceoffice.org":
    • Mit einem neuen Menüpunkt im Datei-Menü wurde der Meldedaten-Import aus einer CSV-Datei, die von raceoffice.org heruntergeladen wurde, implementiert.
      Eine Anpassung der Feldfolge in der Meldedaten-Inidatei ist damit nicht mehr nötig.
  • Clubs-Tabelle 2010:
    • Die Clubs-Tabelle "Clubs-04_2010.db" wurde aktualisiert (Stand: April 2010).
  • Yardstick-Tabelle 2010:
    • Die Yardstick-Tabelle "Boote-04_2010.db" wurde aktualisiert (Stand: April 2010).

  • Änderungen in WinRegatta Version 4.4b - verfügbar ab 01.09.2008

    • Individueller Startzeit:

      • Hier starten die Boote nicht gleichzeitig beim Startsignal, sondern die Boote können in einem festgelegten Zeitfenster (z. B. innerhalb von 15 Minuten) ihren Startzeitpunkt individuell wählen. Diese Startmethode bietet sich bei größeren Yachten an, wenn das Startgebiet beengt ist.

      • Für jede Yacht wird die Uhrzeit des Starts und des Zieldurchgangs notiert. Bei der Ergebniseingabe werden diese beiden Zeiten pro Yacht eingegeben. WinRegatta errechnet dann die gesegelte Zeit.

      • Diese Startmethode wird bei der Klassendefinition bestimmt, in dem als Ergebnisart "Indiv. Startzeit" gewählt wird.

    • Verbesserungen / Korrekturen:

      • Quittungsdruck:

        • Nach dem Quittungsdruck in der Segler-Funktion sind die Eingabefelder gesperrt (grau). Dies wurde korrigiert.

        • Beim Druck einer Quittung wird zuerst das Vorschaufenster gezeigt, aus dem der Druck dann gestartet werden kann. Dies wurde geändert - der Druck erfolgt jetzt ohne Vorschau.

      • Import aus CSV-Datei:

        • Nach dem Import von Seglerdaten sind die Checkboxen für Check-In, Meldekarte usw. grau mit Häkchen. Dies irritiert und wurde geändert. Die Checkboxen sind jetzt weiß und leer.

      • Ergebniseingabe:

        • Wenn im Feld "Suche Segel-Nr" eine Segel-Nr. gesucht wird, die mit einem anderen Landeskenner oder in einer anderen Klasse doppelt vorkommt, dann erscheint das kleine Auswahlfenster nicht, sondern die Anwendung bleibt hängen. Dieser Fehler wurde korrigiert.

    Änderungen in WinRegatta Version 4.4a - verfügbar ab 27.05.2008

    • Fehlerkorrektur:

      • Die Option "Individuelle Yardstick-Korrektur" (Optionen / Daten-Konfiguration) und die Option "Werbegrafik am unteren Seitenrand" (Optionen / Listendruck/Textdatei) waren fehlerhafterweise miteinander gekoppelt. Dieser Fehler wurde nun korrigiert.

    • Yardstick suchen und einsteuern:

      • Unter "Optionen / Daten-Konfiguration" wurde die neue Option "Yardstick immer einsteuern" eingefügt.

        • Wird diese Option aktiviert, so wird bei der Eingabe eines Bootstyps zwingend der Yardstick gesucht und eingesteuert. WinRegatta verhält sich also wie vor der Version 4.4.
        • Wird diese Option deaktiviert, so wird bei der Eingabe eines Bootstyps der Yardstick nur für Segler, die zu einer Klasse mit der Ergebnis-Art "Gestoppte Zeit" oder "Uhrzeit" oder der Wertungs-Art "Känguruh-Start" angehören, gesucht und eingesteuert. WinRegatta verhält sich wie in der Version 4.4 eingeführt.
        • Mit dieser Option kann der Anwender zwischen der alten und der neuen Funktionalität der Yardstick-Suche und -Einsteuerung wählen.
    • Wertung - maximale Anzahl Streicher:
      • Die maximale Anzahl Streicher wurde von 5 auf 6 erhöht.

    • Clubs-Tabelle 2008:

      • Die Clubs-Tabelle (Stand April 2008) mit ca. 1350 verschiedenen Segelclubs ist enthalten (Clubs-4.db).
    • Yardstick-Tabelle 2008:
      • Die Yardstick-Tabelle 2008 mit über 1650 Bootstypen ist enthalten.

    Änderungen in WinRegatta Version 4.4 - verfügbar ab 22.12.2007

    • Seglereingabe – Clubsuche mit DSV-Nummer: Details
      • Zusätzlich zu den bisherigen Suchfunktionen der DSV-Nr durch Eingabe der Clubabkürzung kann jetzt umgekehrt durch Eingabe der DSV-Nr die Clubabkürzung gesucht und in den Seglersatz übernommen werden.
    • Im Datei-Menue wurde der Eintrag "Dateigruppe Kopieren / Sichern" eingefügt: Details
      • Ein Sichern mit WinRegatta "Speichern unter" ist problematisch, weil ca. 20 Indexdateien geöffnet werden. Das bisher empfohlene Sichern mit dem Windows Explorer ist jetzt nicht mehr nötig.
    • Die Clubs-Datei und die Boote-Datei nach Excel exportieren: Details
      • Die Clubs-Datei und die Boote-Datei können jetzt jeweils mit einem Mausklick in eine Excel-Tabelle exportiert werden.
        Dies geschieht in der Funktion "Clubs" bzw. "Boote" mit Klick auf das Symbol unten rechts.
    • Meldedaten-Import – drei zusätzliche Felder können jetzt importiert werden: Details

      • Die Feldliste der möglichen Importe wurde um folgende Felder erweitert:

        • Primärklassen-Nr. – Wenn vor dem Import bereits entsprechende Klassen definiert wurden, dann erübrigt sich die nachträgliche Zuordnung der Boote zu den Klassen.
          Die Klassen-Nr wird nur importiert, wenn es sich um eine gültige Nummer (1 bis 15) handelt und wenn diese Klasse vorher als Primärklasse definiert wurde. Sonst bleibt das Klassenfeld "P" leer.
        • "Individuelle Yst-Korrektur"
        • "Yst-Korrekturgrund"
    • Meldedaten-Import – Plausibilitätsprüfung: Details
      • Beim Import erfolgt wahlweise eine Prüfung der Daten, um Probleme durch fehlerhafte Daten zu vermeiden.
      • Die Ergebnisse dieser Prüfung werden in einem Fehlerprotokoll angezeigt und können wahlweise gedruckt werden.
    • Zieleinlaufliste: Details
      • Eine neue Druckliste wurde unter "Listen für Wettfahrt-Leitung" hinzugefügt.
      • Diese Liste kann für Primärklassen pro Wettfahrt gedruckt werden.
      • Die Liste zeigt die Segelnummer, den Namen des Steuermannes / der Steuerfrau und den Rang bzw. die gesegelte Zeit beim Zieleinlauf.
      • Diese Liste kann nach der Ergebniseingabe einer Wettfahrt und vor dem Wertungslauf gedruckt und zur Eingabekontrolle der Ergebnisse verwendet werden. Andererseits kann die Liste auch zu jeder späteren Zeit – auch für zurückliegende Wettfahrten - gedruckt werden.
    • Ergebnisliste für Siegerehrung: Details
      • Ein neuer Listentyp wurde unter "Listen für Wettfahrt-Leitung" hinzugefügt. Anstelle der Ergebnisse der Einzelwettfahrten wird der volle Club-Name der Steuerleute gedruckt.
      • Es kann gewählt werden:
        • alle Boote
        • das erste Drittel der Boote
        • eine bestimmte Anzahl der Boote zu drucken.
    • Ergebnisliste für die Presse: Details
      • Ein neuer Listentyp wurde unter "Listen für Wettfahrt-Leitung" hinzugefügt. Anstelle der Ergebnisse der Einzelwettfahrten wird der volle Club-Name der Steuerleute gedruckt.
      • Wahlweise kann anstelle von JG, Clubabkürzung und DSV-Nr. der Heimatort der Steuerleute ausgegeben werden.
      • Es kann gewählt werden:
        • alle Boote
        • das erste Drittel der Boote
        • eine bestimmte Anzahl der Boote zu drucken.
    • Werbegrafik am unteren Seitenrand drucken: Details
      • Eine Grafik (z. B. Werbung für Sponsoren) kann wahlweise am unteren Seitenrand (Fusszeile) über die ganze Seitenbreite auf allen Seiten von Melde- und Ergebnislisten gedruckt werden. Bei einem Druck in eine PDF-Datei erscheint diese Grafik ebenfalls.
      • Unter "Optionen / Listendruck" kann die Ausgabe der Grafik an- und abgeschaltet werden. Dies gilt dann für alle Klassen der Dateigruppe.
      • Bei Seiten im Hochformat hat die Grafik eine Größe von 715 x 50 Pixel. Bei Seiten im Querformat sind dies 1025 x 72 Pixel. Die Grafik wird automatisch auf obige Größen angepaßt.
      • Der Datei-Name der Grafik muß "Werbegrafik.bmp" heißen, und diese Datei muß im Installationsverzeichnis von WinRegatta gespeichert werden.
    • Funktion "Segler" – Mehrfacheingabe von gleichen Werten: Details
      • In der Funktion "Segler" können jetzt mit der Taste "Segler Multi-Auswahl" gleiche Werte für alle markierten Sätze eingegeben werden.
      • Dies gilt für alle Spalten, in denen üblicherweise gleiche Werte vorkommen und zwar für die Spalten "P" (Primärklasse) bis "Check-In".
    • Fehlerkorrektur bei Gruppenwertung:
      • Wenn eine nachträgliche Ergebniskorrektur einer zurückliegenden Wettfahrt, die in einer anderen Gruppenkonstellation gesegelt wurde (fixierte WF), vorgenommen wird und die Funktion "Ergebnisse" nach der Änderung – wie vorgeschrieben - nicht verlassen wird, sondern mit Doppelklick auf das Feld "KlNr" eine andere Klasse gewählt wird, kommt es zu einem Absturz der Anwendung. Die gewerteten Ergebnisse werden hierdurch verfälscht, weil durch den Anwendungsabsturz die alten Klassenzuordnungen bestehen bleiben.
      • Korrektur: Wenn bei Ergebnisänderung einer fixierten Wettfahrt irrtümlich ein Doppelklick auf das Feld "KlNr" erfolgt, wird jetzt automatisch eine Wertung vorgenommen, und der Doppelklick wird ignoriert.

    • Clubs-Tabelle 2007

      • Die vollständige Clubs-Tabelle des DSV (Stand April 2007) mit ca. 1350 verschiedenen Segelclubs ist enthalten (Clubs-4.db).
    • Yardstick-Tabelle 2007 (Copyright 2007 DSV)
      • Die vollständige Yardstick-Tabelle 2007 der Kreuzerabteilung mit über 1650 Bootstypen ist enthalten.

    Änderungen in WinRegatta Plus Version 4.3b - verfügbar ab 27.08.2006

    • Meisterschaftsordnung für olympische Klassen (MO-F) - Gruppenwertung des Flottenfinales wird unterstützt (nur WinRegatta Plus)
      • Bei großen Starterfeldern kann das Flottenfinale in bis zu drei Startgruppen gesegelt und gewertet werden. Details

    Änderungen in WinRegatta Version 4.3 - verfügbar ab 20.06.2006

    • Meisterschaftsordnung für olympische Klassen (MO-F) wird unterstützt (nur WinRegatta Plus)
      • Diese seit April 2006 gültige MO-F unterscheidet sich erheblich von der normalen MO.
      • Eine komfortable Anwendungslösung wurde in WinRegatta Plus implementiert und bei mehreren Clubs einem Feldtest unterzogen. Details
    • Wettfahrt-Protokoll
      • Bei der Eingabe des Wettfahrtprotokolls kann jetzt "M" für "Mehrere Klassen" gewählt, und so die Protokolldaten für mehrere Klassen gleichzeitig eingegeben werden. Details
    • HTML-Datei erweitert
      • Für die Melde- und Ergebnislisten im HTML-Format wurde ein erweiterter Listenkopf implementiert.
        • Es kann zwischen dem bisherigen Kopf und dem neuen erweiterten Kopf gewählt werden.
        • Unter "Optionen" können bis zu neun Elemente für den Erweiterten Kopf ausgewählt werden. Für jedes Element kann die Schriftgröße in vier Abstufungen eingestellt werden.
      • Das Wettfahrtprotokoll wird jetzt wahlweise in der HTML-Datei gespeichert und erscheint am Ende der HTML-Ergebnisliste in gleicher Form wie auf den gedruckten Listen.
      • Der Hinweistext der pro Klasse am Ende der Ergbnisliste gedruckt wird, kann jetzt in gleicher Weise auch in der HTML-Liste ausgegeben werden.
    • Obmann des Schiedsgerichts
      • Der Name des Obmanns des Schiedsgerichts kann jetzt wahlweise im Kopf von Melde- und Ergebnislisten ausgegeben werden. Aus Platzgründen wird dann allerdings das Regattarevier nicht gedruckt.
    • Clubabkürzung auf Ergebnislisten
      • Lange Clubabkürzungen (bestehend aus 8 Großbuchstaben) wurden z. T. unvollständig gedruckt. In solchen Fällen findet jetzt ein Wortumlauf statt, so dass eine zusätzliche Zeile eingeschoben wird.

    • Clubs-Tabelle 2006

      • Die vollständige Clubs-Tabelle des DSV (Stand April 2006) mit ca. 1350 verschiedenen Segelclubs ist enthalten (Clubs-4.db).
    • Yardstick-Tabelle 2006 (Copyright 2006 DSV)
      • Die vollständige Yardstick-Tabelle 2006 der Kreuzerabteilung mit über 1650 Bootstypen ist enthalten.

    Änderungen in WinRegatta Version 4.2.1 - verfügbar ab 03.08.2005

    • Gruppenwertung verbessert (nur WinRegatta Plus)
      • Die Gruppeneinteilung vor dem ersten Start wurde erheblich vielfältiger gestaltet.
      • Wenn für die automatisierte Gruppenbildung keine Rangliste mit Qualifikationsrängen zur Verfügung steht, dann kann die "Quali"-Spalte mit Zufallszahlen (Zufallsgenerator) gefüllt werden.
      • Wenn eine automatische Gruppeneinteilung anhand des Qualifikationsranges nicht gewünscht wird, so kann in dem Dialog auch eine manuelle Gruppeneinteilung nach beliebigen Kriterien gewählt werden.
    • Druck von Ergebnislisten

      • Vor der Vorschau und vor dem Druck einer Ergebnisliste prüft WinRegatta, ob die Anzahl der für diese Klasse gewerteten Wettfahrten auf den gewählten Listentyp paßt. Ist die Anzahl der Wettfahrten zu groß, wird eine Warnung an den Anwender gegeben.

    • Wichtig: Fehlerkorrektur:

      • Bei Verwendung der neuen Clubdatei (Stand April 2005) tritt mit WinRegatta Version 4.2 ein Fehler auf, wenn ein neuer Club eingegeben wird, und die gleiche Clubabkürzung bereits in der Clubsdatei enthalten ist.

      • Korrektur: Über den neuen Menüpunkt "Datei / Clubdatei prüfen, ggf. reparieren" wird die Struktur der Clubdatei verändert und damit der Fehler beseitigt.

    Änderungen in WinRegatta Version 4.2 - verfügbar ab 29.05.2005

    • Meldedaten-Import
      • Es können alle relevanten Seglerdaten importiert werden, einschließlich der 4., 5. und 6. Clrew-Mitglieder und der ORC-Faktoren.
      • Die Meldedaten werden aus einer CSV-Datei importiert. Als Feldseparator dient der Strichpunkt.
      • Die Reihenfolge der Felder in der CSV-Datei kann beliebig sein. Details
    • Känguruh-Start
      • Entsprechend der Yardstickzahlen der gemeldeten Bootstypen wird eine Startliste mit Zeitintervallen berechnet und gedruckt. Details
    • Die Limitierung der Pfadlänge von 75 Zeichen aufgehoben
      • Die Länge des Verzeichnisstrings wurde auf den Windows-Standard erweitert.
    • Clubsuche verbessert
      • Bei der Seglereingabe wird die Clubauswahlliste nicht mehr in einer Listbox, sondern in einem eigenständigen Fenster gezeigt. Die Spalte "Bemerkungen" wird ebenfalls angezeigt.
      • Die Lage und Größe des Fensters kann freigewählt werden. Details
    • Bootesuche verbessert
      • Bei der Seglereingabe wird die Booteauswahlliste nicht mehr in einer Listbox, sondern in einem eigenständigen Fenster gezeigt. Die Spalte "Bemerkungen" wird ebenfalls angezeigt.
      • Die Lage und Größe des Fensters kann freigewählt werden. Details
    • Boote-Funktion
      • Die mehrfache Eingabe von gleichen Bootstypen mit gleichen Yardsticks ist jetzt erlaubt.
    • Freie Wahl des Speicherortes für Clubs-, Boote- und Ini-Dateien
      • Bisher wurden diese Dateien zwangsweise im Installationsordner von WinRegatta gespeichert.
      • Die Wahl eines beliebigen Ordners ist jetzt möglich. Details
    • WinRegatta-Anwender mit eingeschränkten Zugriffsrechten
      • Bei Windows 2000 und XP kann WinRegatta in einem Benutzerkonto mit eingeschränkten Rechten betrieben werden. Details
    • Anpassung der Wertung an die Wettfahrt-Regeln (WR) 2005 - 2008
      • Die neue Abkürzung "DGM - Disqualifiziert, Streicher nicht möglich, Regel 69.1(b)(2)" wurde implementiert.

    • Clubs-Tabelle 2005

      • Die vollständige Clubs-Tabelle des DSV (Stand April 2005) mit ca. 1350 verschiedenen Segelclubs ist enthalten (Clubs-4.db).
    • Yardstick-Tabelle 2005 (Copyright 2005 DSV)
      • Die vollständige Yardstick-Tabelle 2005 der Kreuzerabteilung mit über 1600 Bootstypen ist enthalten.

    Änderungen in WinRegatta Version 4.1 - verfügbar ab 02.09.2004

    • Erweiterung der Datenbasis
      • Die Datenbasis musste erweitert werden, um neue Funktionen implementieren zu können.
      • Die Datei-Erweiterungen der Regatta-Dateien enden jetzt auf "04".
      • Mit dem integrierten Datenkonverter können die Dateien von WinRegatta Version 2 (*.R02) und Version 3 (*.R03) in das erweiterte Format der Version 4 (*.R04) konvertiert werden.
    • ORC-Club-Wertung nach dem Zeit/Distanz-System (nur WinRegatta Plus)
      • Die ORC-Club-Wertung wurde nun um das Zeit/Distanz-System erweitert.
      • Die Faktoren GPH, PLT und PLD werden für jedes Boot während der Seglereingabe erfasst.
    • Ergebniszeiten können als Uhrzeit eingegeben werden
      • Für jede Wettfahrt der Klasse wird einmal die Startuhrzeit eingegeben.
      • Beim Zieldurchgang eines Bootes wird die Uhrzeit notiert und bei der Ergebniseingabe eingegeben.
      • Winregatta errechnet mit diesen Daten die gesegelte Zeit.
    • Ergebniseingabe - DNC automatisch
      • Nachdem für eine WF alle regulären Ergebnisse eingegeben wurden, wird DNC mit nur einem Mausklick für alle restlichen Boote zugeordnet.
      • Bei einer "Längeren WF-Serie" gilt das Gleiche für DNA.
    • Max. Wettfahrten pro Klasse von 12 auf 15 erweitert
      • Es können nun bis zu 15 Wettfahrten pro Klasse gewertet werden.
      • Ergebnisse bis zu 15 Wettfahrten können mit dem Listetyp "15 WF, mehrzeilig.." gedruckt werden. Das Speichern von Ergebnissen in Text- oder HTML-Dateien wurde ebenfalls auf 15 Wettfahrten erweitert.
    • Zweisprachiger Listenkopf für Melde- und Ergebnislisten
      • Meldelisten, Ergebnislisten sowie Text- und HTML-Dateien können wahlweise mit deutschem oder englischem Kopf ausgegeben werden.
      • Unter Optionen kann die Sprache gewählt werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe.
    • DSV-Nummern können unterdrückt werden
      • Unter Optionen kann gewählt werden, die DSV-Nummern für die ganze Regatta (Dateigruppe) zu unterdrücken. Dies kann für Club-Regatten sinnvoll sein, da die DSV-Nummer zur Identifizierung des Clubs nicht erforderlich ist.
      • Wenn DSV-Nummern-Unterdrückung gewählt wurde, dann wird bei der Seglereingabe kein DSV-Nummernfeld angeboten, und es findet auch keine Suche in der Clubs-Datei statt.
    • Druck des Wettfahrtprotokolls am Ende von Ergebnislisten
      • Die gewählte Einstellung zum Druck des WF-Protokolls und des Hinweises am Ende der Ergebnislisten wird pro Klasse gespeichert. Beim späterem erneuten Ergebnisdruck der Klasse wird der gespeicherte Auswahlblock wieder automatisch voreingestellt.
    • Wertungslauf - Anzeige von Details
      • Die Einstellungen im Block "Details anzeigen" werden pro Klasse gespeichert. Bei der nächsten Wertung der Klasse werden diese Werte wieder voreingestellt.
    • Gruppenwertung - Änderung der Gruppenbezeichnungen (nur WinRegatta Plus)
      • Die bisherigen Bezeichnungen A, B, C, D wurden umbenannt in B, G, R, Y. Dies korrespondiert mit den üblichen Gruppenkennzeichnungen Blue, Green, Red und Yellow. Die zu den Gruppen zugeordneten Boote werden üblicherweise ebenfalls mit diesen Farben gekennzeichnet.

    • Clubs-Tabelle 2004

      • Die vollständige Clubs-Tabelle des DSV (Stand April 2004) mit ca. 1350 verschiedenen Segelclubs ist enthalten (Clubs-4.db).
    • Yardstick-Tabelle für den Bodensee
      • Die Bodensee-Yardstick-Tabelle mit ca. 1300 Einträgen wurde in das WinRegatta-Format konvertiert und steht bei Bedarf zur Verfügung.


Version 3 Informationen

Änderungen in WinRegatta Version 3.3 - verfügbar ab 24.03.2004

  • Online-Hilfe-Funktion
    • Diese neue umfassende Hilfefunktion entspricht dem Standard der Online-Hilfe für Windows 98 aufwärts. Dieses Hilfesystem arbeitet auf HTML-Basis. Neben der gezielten Themensuche mit Index-Wörtern, ist die Hilfe auch als Funktionshandbuch geeignet. Details
  • Ergebniseingabe-Funktion
    • Neue Datengitter-Komponenten mit erweiterter Funktionalität wurden für das Hauptfenster und für das Zieleinlauffenster eingeführt. Details
  • Ergebniseingabe - Doppelte Segelnummern
    • Bei der Suche einer Segelnummer über das Suchfeld "Suche S-Nr" stellt WinRegatta jetzt fest, ob diese Segelnummer mehrfach vorkommt (z. B. mit unterschiedlichen Landeskennern oder in verschiedenen Klassen).
    • Doppelte Segelnummern werden in einer Auswahlliste zur Wahl gestellt. Details
    • Das Suchfeld "Landeskenner" wurde entfernt, da nicht mehr nötig. Die Segelnummer alleine dient als Suchargument.
  • Streicher erhöht
    • Die maximale Anzahl Streicher wurde von bisher 3 auf 5 erhöht.
  • Listen für Bahnmarken-Kontrolle in zwei Varianten
    • Liste m i t Segelnummern, ähnlich der Checkliste für den Start.
      Vorteihaft für kleine Starterfelder. Details
    • Liste o h n e Segelnummern, ähnlich der Zieleinlaufliste.
      Vorteihaft für grosse Starterfelder. Details
  • Clubs-Funktion erweitert
    • Eine neue Datengitter-Komponente mit erweiterter Funktionalität wurde implementiert. Details
    • Neue Mechanismen zum Sortieren, Suchen und Editieren der Clubdaten wurden eingeführt.
    • Die Datenstruktur der Clubs-Datei wurde erweitert. Der Dateiname lautet nun "Clubs-4.db". Mit dem integrierten Datenkonverter können die bisherigen Dateien "Clubs-2.db" und "Clubs-3.db" in das neue Datenformat konvertiert werden.
  • Boote-Funktion erweitert
    • Eine neue Datengitter-Komponente mit erweiterter Funktionalität wurde implementiert. Details
    • Neue Mechanismen zum Sortieren, Suchen und Editieren der Bootedaten wurden eingeführt.
    • Die Datenstruktur der Boote-Datei wurde erweitert. Der Dateiname lautet nun "Boote-4.db". Mit dem integrierten Datenkonverter können die bisherigen Dateien "Boote-2.db" und "Boote-3.db" in das neue Datenformat konvertiert werden.
  • Yardstick-Tabelle 2004 (Copyright 2004 DSV)
    • Die vollständige Yardstick-Tabelle 2004 der Kreuzerabteilung des DSV ist enthalten.

  • Datenkonverter erweitert
    • Der integrierter Datenkonverter konvertiert jetzt auch die Clubs- und Boote-Dateien in das neue Datenformat. Details

Änderungen in WinRegatta Plus Version 3.2.1 - verfügbar ab 13.10.2003

  • Die Funktion "Gruppenwertung" wurde verbessert und erweitert
    • Korrekturen an Ergebnissen können jetzt auch rückwirkend (z. B. wegen später Jury-Entscheidungen) für Wettfahrten vorgenommen werden, die in einer früheren Gruppeneinteilung gesegelt wurden. Eine Aktualisierung der Wertung erfolgt dann automatisch. Details
    • Bei einer Gruppenwertung können sehr komplexe Situationen von Punktgleichheiten auftreten. In umfangreichen Tests wurde sichergestellt, dass a l l e Konstellationen entsprechend der WR gelöst werden.
    • Die Dialoge zur automatischen Gruppenbildung wurden überarbeitet und noch benutzerfreundlicher gestaltet. Details
    • Umfangreiche Beispiel-Dateigruppen wurden neu angelegt und mit Kommentaren versehen. Details

Änderungen in WinRegatta Version 3.2 - verfügbar ab 31.07.2003

  • Crew-Stärke erweitert (nur Winregatta Plus)
    • Die maximale Crew-Stärke wurde von bisher 3 auf 6 Segler pro Boot erweitert. Die zusätzlichen Crew-Mitglieder 4, 5 und 6 werden in einer neuen Datei mit der Erweiterung ".C03" gespeichert. Details
    • Für Regatten mit mehr als 3 Seglern pro Boot besteht die Dateigruppe also aus 6 Dateien.
  • HTML-Datei erweitert
    • In den HTML-Ergebnislisten für Yardstick- und ORC-Regatten werden jetzt zusätzlich Bootstyp, Yardstickzahl bzw. ILC, gesegelte und berechnete Zeit gespeichert. So können die Ergebnislisten mit gesegelten/berechneten Zeiten leicht im Internet publiziert werden. Details
  • Ergebnisstatus der Klasse wird gespeichert
    • Der Ergebnisstatus, z. B. "Zwischenergebnis" oder "Endergebnis", der beim Listendruck gewählt werden kann, wird jetzt pro Klasse gespeichert. Beim nächsten Listendruck der Klasse wird der Status wieder automatisch voreingestellt. Details
  • Club- und Boote-Auswahl verbessert
    • Wenn bei der Seglereingabe der eingegebene Club oder der Bootstyp nicht gefunden wurde, dann erscheint anstelle der bisherigen Mitteilung jetzt gleich eine Auswahlliste, aus der der gewünschte Club bzw. Bootstyp gewählt werden kann.
  • Fehlerkorrekturen
    • Verschiedene Probleme/Fehler, die für die Versiom 3.1 berichtet wurden, konnten korrigiert werden.


Systemvoraussetzung, Installation

Systemvoraussetzungen

  • Ein PC, der von seiner Ausstattung Windows 98-fähig ist, sollte ausreichen. WinRegatta wurde auf folgenden Betriebssystemen erfolgreich getestet: Windows 98, 2000, ME, NT, XP, VISTA 32Bit und 64Bit, Windows 7, 8.1 und 10 jeweils 32Bit und 64Bit.
  • Eine Bildschirmauflösung von mindestens 1024 x 600 ist erforderlich.
  • Bekanntlich kann die Bildschirmauflösung mittels "Systemsteuerung > Bildschirmauflösung" verändert werden. Bei Windows7 und neuer kann hier zusätzlich gewählt werden: "Text und weitere Elemente vergrößern oder verkleinern". Hier kann 100%, 125% oder 150% eingestellt werden. Bitte belassen Sie diese Einstellung bei 100%, weil es sonst in der Funktion "Segler" zu Überlappungen der Eingabefelder kommt. Eine saubere Seglereingabe ist dann nicht mehr möglich. Auf den Drucklisten können dann auch Feldüberlappungen entstehen.
  • Ein Drucker (Windows-Standarddrucker).

Installation

Installation unter Windows Vista

Installation unter Windows 7

Installation auf USB-Stick

Deinstallation


Installation

Installation von WinRegatta

Installation von CD:
Die CD von WinRegatta einlegen. Das Setup-Programm auf der CD starten. Dies geschieht durch Klick auf „Start“ und „Ausführen“, dann „D:\Setup“ eingeben, wobei „D“ durch den Buchstaben Ihres CD-Laufwerks zu ersetzen ist. Jetzt der Bedienerführung des Setup-Programms folgen.

Installation eines Updates oder einer Demo-Version:
 Updates und Demo-Versionen können von der Website www.WinRegatta.de als Zip-Dateien heruntergeladen werden. Nach dem Entpacken der Zip-Datei das Setup-Programm starten, z. B. mit Doppelklick im Windows-Explorer.
Die Plus-Version 4.8 muss per E-Mail oder Telefon beim Autor bestellt werden. Ein Download-Link von Drop Box wird dann bereitgestellt.
Verschiedene Versionen von WinRegatta können gemeinsam auf einem PC in unterschiedlichen Verzeichnissen installiert werden. Wenn Sie eine bestimmte WinRegatta-Version erneut installieren möchten, obwohl sie auf diesem PC bereits installiert ist, dann sollten Sie diese Version zuerst deinstallieren, bevor Sie sie erneut installieren.

Windows mit eingeschränkten Zugriffsrechten:
Wenn der System-Administrator für die Anwender eingeschränkte Zugriffsrechte in Form von Benutzerkonten vergeben hat, kann dies beim Arbeiten mit WinRegatta zu Problemen (Zugriffsverletzungen) führen. Im Abschnitt "Eingeschränktes Benutzerkonto " ist der Lösungsweg beschrieben.

Windows Vista:
siehe Installation unter Windows Vista

Windows 7:
siehe Installation unter Windows 7

Übernahme der bisherigen Clubs- und Boote-Datei:

  • WinRegatta Version 4.8 beinhaltet Clubs- und Boote-Dateien mit Stand April 2017.
  • Die Clubs-Datei "Clubs-4_2017.db" enthält alle DSV-Clubs (ca. 1300). Die Boote-Datei "Boote-4_2017.db" enthält die Yardstick-Tabelle der Kreuzer-Abteilung mit ca. 1900 Einträgen (Copyright DSV). Mit der Funktion „Boote“ können weitere Bootstypen aufgenommen werden.
  • Wenn Sie bereits vorher WinRegatta eingesetzt haben, dann haben Sie sicherlich die Clubs- und Boote-Dateien geändert bzw. erweitert. Falls Sie Ihre spezifischen Clubs- und Boote-Dateien auch weiterhin verwenden möchten, dann gehen Sie wie folgt vor:
    • Bis einschließlich WinRegatta Version 4.4b :
      • Die Clubs-Datei hat den vorgegebenen Namen "Clubs-4.db" und die Yardstick-Tabelle "Boote-4.db" .
      • Sichern Sie die neuinstallierten Dateien „Clubs-4.db“ und „Boote-4.db. Sie finden diese in dem Verzeichnis, in das WinRegatta installiert wurde.
      • Kopieren Sie Ihre bisherigen Clubs- und Boote-Dateien in das neue Installationsverzeichnis
      • Die Daten in Ihren Clubs- und Boote-Dateien sind dann möglicherweise aber auf einem älteren Stand. Eine andere Möglichkeit besteht darin, die neuen Dateien zu verwenden und Ihre spezifischen Änderungen mit den Clubs- und Boote-Funktionen von WinRegatta erneut einzugeben.
    • Ab WinRegatta Version 4.5:
      • Hier können Sie in der Clubs- bzw. Boote-Funktion von WinRegatta beliebige Clubs- und Boote-Dateien wählen und auch in beliebigen Ordnern abspeichern.


Installation unter Windows Vista

Windows Vista 32Bit

Winregatta verwendet die Borland Datenbank "Paradox". Die Steuerung der Datenbank übernimmt die Software "Borland Database Engine (BDE)".

Unter Windows Vista werden die Zugriffsrechte auf Daten und Anwendungen etwas restriktiver gehandhabt als unter Windows XP. Zum Beispiel hat der Anwender keine Zugriffsrechte auf das Root-Verzeichnis "C:\". Deshalb müssen einige Einstellungen der BDE geändert werden.

Folgende Änderungen sind vorzunehmen:

  1. Installieren Sie WinRegatta von CD unter Windows Vista. Starten Sie die Installation mit "Setup.exe".
  2. Öffnen Sie über die Systemsteuerung die "BDE-Verwaltung".
  3. Unter "Konfiguration / Treiber / Native / Paradox" ändern Sie rechts bei Net Dir den Eintrag von "C:\" in "C:\users\public".
  4. Speichern Sie diese Einstellung über den Menüpunkt "Objekt / Übernehmen".

Hinweis: Wenn Sie die BDE-Verwaltung über die Systemsteuerung nicht öffnen können, dann öffnen Sie mit dem Explorer das Verzeichnis "C: \ Programme \ Gemeinsame Dateien \ Borland Shared \ BDE". In diesem Verzeichnis finden Sie die Datei "bdeadmin.exe". Mit Doppelklick auf diese Datei öffnen Sie die BDE-Verwaltung. Nun weiter mit obigem Punkt 3.

WinRegatta muß unter Vista mit Administrator-Rechten arbeiten.

Nehmen Sie deshalb folgende Änderungen vor:

  1. Gehen Sie mit dem Explorer in das Installations-Verzeichnis von WinRegatta.
  2. Klicken Sie mit der rechten Maustaste auf die WinRegatta-Anwendung, z. B. "WinReg46.exe" bzw. "WinReg46P.exe" und mit der linken Taste auf "Eigenschaften".
  3. Wählen Sie den Reiter "Kompatibilität".
  4. Klicken Sie die Checkbox "Programm als Administrator ausführen" an.
  5. Klicken Sie auf "Übernehmen" und "OK".

Wenn Sie WinRegatta nun starten, sollte alles laufen.

Möglicherweise bekommen Sie beim ersten WinRegatta-Start noch eine Fehlermeldung. Diesen Fehler können Sie ignorieren, da er noch aus den alten Einstellungen resultiert.

Windows Vista 64Bit

Zur Installation auf einem 64Bit-Windows ist mindestens WinRegatta Version 4.5 erforderlich.
Frühere WinRegatta-Versionen lassen sich hier nicht installieren.

Bitte starten Sie die Installation von WinRegatta Version 4.6 mit Setup.exe und nicht mit der *.msi-Anwendung.

Unter Vista 64Bit wird WinRegatta Version 4.6 zwangsweise in das Verzeichnis
"c:\Program Files (x86)\Regatta\WinReg46..." installiert - auch wenn Sie als Installationsverzeichnis "c:\Programme\..." wählen.

Die Borland Database Engine (BDE) wird in das Verzeichnis
"c:\Program Files (x86)\Common Files\Borland Shared\BDE" installiert.

Unter Vista 64Bit läuft WinRegatta ohne weitere Anpassungen.


Installation unter Windows 7

Installation unter Windows 7 und höher

Diese Anleitung gilt für Windows 7 und neuere Windows-Versionen; also auch für 8.1 und 10.

Zur Installation unter Windws 7 ist mindestens WinRegatta Version 4.5 erforderlich.
Frühere WinRegatta-Versionen lassen sich hier nicht installieren.

Bitte starten Sie die Installation von WinRegatta Version 4.8 mit "Setup.exe" und nicht mit der *.msi-Anwendung.

Windows 7 32Bit

Unter Windows 7 32Bit wird für WinRegatta der Installationsordner
"c:\Program Files\Regatta\..." angeboten. Sie können dies aber mit "c:\Programme\Regatta\..." überschreiben.

Bitte starten Sie jetzt WinRegatta, und testen Sie die Anwendung.

Sollte WinRegatta nicht richtig laufen - z. B. beim Zugriff auf die Daten - dann sind Anpassungen der "Borland Database Engine (BDE)" erforderlich.
Winregatta verwendet die Borland Datenbank "Paradox". Die Steuerung der Datenbank übernimmt die Software "Borland Database Engine (BDE)".
Ab Windows Vista werden die Zugriffsrechte auf Daten und Anwendungen etwas restriktiver gehandhabt als unter Windows XP. Deshalb müssen einige Einstellungen der BDE geändert werden.

Nehmen Sie bitte folgende Änderungen vor:

  1. Die BDE finden Sie in
    "c:\Program Files\Common Files\Borland Shared\BDE".
  2. Die Datei "bdeadmin.exe" beinhaltet die "BDE-Verwaltung".
  3. Öffnen Sie die BDE-Verwaltung mit dem Explorer.
  4. Unter "Konfiguration / Treiber / Native / Paradox" ändern Sie rechts bei Net Dir den Eintrag von "C:\" in "C:\users\public".
  5. Speichern Sie diese Einstellung über den Menüpunkt "Objekt / Übernehmen".

WinRegatta muß mit Administrator-Rechten arbeiten (siehe unten).
Hierdurch erhalten Sie Schreibrechte im WinRegatta-Installationsordner für Ini-Dateien und für Clubs-, Boote- und Beispiel-Dateien.

Windows 7 64Bit

Unter Windows 7 64Bit wird WinRegatta Version 4.7 zwangsweise in das Verzeichnis
"c:\Program Files (x86)\Regatta\WinReg47..." installiert - auch wenn Sie als Installationsverzeichnis "c:\Programme\..." wählen.

Die Borland Database Engine (BDE) wird in das Verzeichnis
"c:\Program Files (x86)\Common Files\Borland Shared\BDE" installiert.

Bitte nehmen Sie die gleichen Anpassungen vor, wie unter 32Bit beschrieben.

WinRegatta muß mit Administrator-Rechten arbeiten (siehe unten).
Hierdurch erhalten Sie Schreibrechte im WinRegatta-Installationsordner für Ini-Dateien und für Clubs-, Boote- und Beispiel-Dateien.

Wichtig für Windows7 32Bit und 64Bit:

WinRegatta muß mit Administrator-Rechten arbeiten.
Hierdurch erhalten Sie Schreibrechte im WinRegatta-Installationsordner für Ini-Dateien und für Clubs-, Boote- und Beispiel-Dateien.

Nehmen Sie deshalb folgende Änderungen vor:

  1. Gehen Sie mit dem Explorer in den Installations-Ordner von WinRegatta.
  2. Klicken Sie mit der rechten Maustaste auf die WinRegatta-Anwendung, z. B. "WinReg48.exe" bzw. "WinReg48P.exe" und mit der linken Taste auf "Eigenschaften".
  3. Wählen Sie den Reiter "Kompatibilität".
  4. Klicken Sie die Checkbox "Programm als Administrator ausführen" an.
  5. Klicken Sie auf "Übernehmen" und "OK".


Installation auf USB-Stick

Es erscheint sehr verlockend, WinRegatta mit allen benötigten Dateien und Regatta-Daten auf einen USB-Stick zu installieren.

Dies bedeutet eine hohe Flexibilität und Portabilität für den WinRegatta-Einsatz. Der Anwender steckt den Stick in einen beliebigen PC und kann WinRegatta starten und hat alle Daten aktuell zur Verfügung.
Zum Beispiel: während der Wettfahrt mit dem Notebook auf dem Start-/Ziel-Schiff zur Ergebniseingabe und danach auf dem Club-PC zur Wertung und zum Listendruck.

Eine Voraussetzung ist allerdings, dass die Bordland Database Engine (BDE) auf dem PC installiert sein muss.

Durchführung der Installation von WinRegatta auf einen USB-Stick:

  • Hinweis:
    • WinRegatta kann auf einem beliebigen Laufwerk installiert werden, aber die Software zur Steuerung der Datenbank (Bordland Database Engine – BDE) wird bei der Installation immer und automatisch auf der Festplatte im Verzeichnis „c:\Programme\Gemeinsame Dateien\Borland Shared\BDE“ installiert. Außerdem werden einige System-Dateien im Windows System-Ordner installiert.
    • Dies bedeutet, dass auf dem PC, in den der WinRegatta-USB-Stick gesteckt wird, die BDE- und die besagten System-Dateien in den vorgegeben Ordnern vorhanden sein müssen. Da die BDE nur mit WinRegatta Version 4.5 installiert wird, muß also die Version 4.5 auf diesem PC installiert sein.
  • Installation auf einen USB-Stick:
    • Während des Installationsablaufs das Zielverzeichnis ändern. Und zwar nur den Laufwerks-Buchstaben „C“ gegen das Laufwerk des Sticks ersetzen. Bei WinRegatta Plus und einem Stick mit Laufwerk „F“ wäre das Zielverzeichnis dann „F:\Programme\Regatta\WinReg48P“.
    • Durch diese Installation werden auch die BDE-Dateien und die System-Dateien in den entsprechenden Ordnern der Festplatte installiert.
    • Wichtiger Hinweis: Die USB-Stick-Installation von WinRegatta kann nur auf einem PC geschehen, auf dem diese WinRegatta-Version noch nicht installiert ist. Die gleiche Version kann nämlich nur einmal auf einem PC installiert werden. Allerdings ist es kein Problem, mit einem WinRegatta-Stick auf einem PC zu arbeiten, obwohl auf dem PC die gleiche WinRegatta-Version bereits installiert ist.
    • Nach erfolgter Installation, mit dem Explorer in das Zielverzeichnis gehen und von der WinRegatta-Anwendung „WinReg47P.exe“ eine Verknüpfung erstellen, und diese auf den DeskTop ziehen. Über dies Symbol kann WinRegatta dann auf dem Stick gestartet werden.
    • Die Clubs- und Boote-Dateien und die Ini-Dateien wurden ebenfalls automatisch auf dem Stick in dem Zielverzeichnis angelegt.
    • Ihre Regattadaten speichern Sie auf dem Stick am besten in dem Unterverzeichnis „Regatta Daten“ des Zielverzeichnisses. Damit sind Ihre aktuellen Daten immer auf dem Stick und können beim nächsten PC weiterverarbeitet werden. Sie können die Regatta-Daten aber auch in einem beliebigen anderen Ordner auf dem Stick speichern.
  • Unterschiedliche Laufwerksbuchstaben des Sticks:
    • Üblicherweise werden einem USB-Stick in den verschiedenen PCs unterschiedliche Laufwerks-Buchstaben zugeordnet.
    • WinRegatta löst dies Problem automatisch. Wenn sich das LW des Sticks auf dem aktuellen PC gegenüber dem LW des vorhergehenden PCs geändert hat, dann aktualisiert WinRegatta alle Pfade in den Ini-Dateien auf das aktuelle LW.
    • Zum Beispiel: Wenn mit dem Stick auf einem PC gearbeitet wurde, und der Stick wurde als Laufwerk „F“ geführt, dann werden beim Beenden von WinRegatta in einer Ini-Datei viele Daten (z. B. Pfade) abgespeichert, um beim nächsten Start wieder verwendet zu werden.
      Wenn nun beim nächsten WinRegatta-Start der Stick sich in einem anderen PC befindet und ihm ein anderer Laufwerks-Buchstaben z. B. „G“ zugeordnet wurde, dann werden die LW-Buchstaben aller Pfade auf „G“ geändert, damit WinRegatta alle Tabellen und Dateien auf dem Stick wieder adressieren kann.

Wenn einer dieser PCs mit Vista oder Windows7 betrieben wird, dann müssen nach der Installation zusätzlich die Anpassungen vorgenommen werden, wie unter

Installation unter Windows Vista

Installation unter Windows 7

beschrieben.


Deinstallation

Deinstallation von WinRegatta

Das Setup-Programm zur Installation von WinRegatta hat auch Vorkehrungen getroffen, diese Anwendung wieder aus Ihrem PC zu entfernen. Bitte versuchen Sie nicht, WinRegatta durch Löschen von Dateien und Verzeichnissen zu entfernen. Viele Programmteile (DLL’s) würden Sie dabei übersehen. Außerdem wurde WinRegatta in die Registry Ihres Systems eingetragen, die manuell auch schwer zu löschen ist.
Benutzen Sie bitte die Funktion zum Entfernen von Software, die Windows bereitstellt (Systemsteuerung / Software).

Wichtig: Falls noch nicht geschehen, sollten Sie vor dem Entfernen von WinRegatta Ihre Clubs- und Boote-Datei sichern, damit Sie diese mit einer neuen WinRegatta-Version weiter verwenden können.


Arbeiten mit WinRegatta

In diesem Abschnitt wird das Arbeiten mit WinRegatta im Sinne einer Bedienungsanleitung beschrieben.

Nach einigen einleitenden Informationen wird in knapper Form die Abwicklung einer Regatta-Veranstaltung behandelt.

Festlegen der Arbeitsumgebung

Vorbereiten einer Regatta

Ergebnisse eingeben und auswerten


Benutzerführung

Die grafische Oberfläche von WinRegatta wurde durch die Aufnahme von neuen visuellen Komponenten weiter verbessert. Die Anwendungsoberfläche ist übersichtlich gestaltet und erlaubt eine einfache und intuitive Bedienung.

Die meisten Anwendungsfunktionen können durch Anklicken der Reiter (ähnlich wie Karteikarten) gewählt werden.

Zu jedem Eingabefeld oder Bedienelement erscheint ein erklärender Hinweis in der Statuszeile des Hauptfensters unten, sobald der Mauszeiger auf das Element zeigt.

Eingabefelder und Bedienelemente, die zu einem bestimmten Zeitpunkt des Programmablaufs nicht benötigt werden oder nicht gültig sind, werden inaktiv oder unsichtbar gemacht. Hierdurch werden Fehlbedienungen vermieden.

Alle eingegebenen Werte werden auf formale und logische Richtigkeit überprüft.

Mit der Tab- oder Entertaste und natürlich auch durch Mausklick auf ein anderes Element, wird ein Eingabefeld verlassen. Erst das Verlassen des Eingabefeldes beendet die Eingabe, so dass WinRegatta nun die eingegebenen Daten auf Plausibilität prüfen kann.


Datenbasis

Zur PC-gestützten Abwicklung einer Regatta-Veranstaltung müssen vielfältige Daten erfasst und gespeichert werden. Ein Großteil dieser Daten betrifft nur die jeweilige Veranstaltung, wie z.B. die Definition der Wertungsklassen, die Meldedaten der Segler mit ihren Club-Zugehörigkeiten und der gesegelten Bootstypen. Andere Daten bleiben über mehrere Veranstaltungen gültig, wie z.B. Informationen über den veranstaltenden Club, Details über die Heimat-Clubs der Segler und Details der gesegelten Bootstypen. All diese Daten werden in mehreren Dateien einer Datenbank gespeichert. Als Datenbanksystem wurde Paradox der Firma Borland gewählt.

Mit WinRegatta Version 4 wurde diese Datenbasis wiederum beträchtlich erweitert, um die Entwicklung zusätzlicher Anwendungsfunktionen zu ermöglichen.

Für eine anschauliche Beschreibung der einzelnen Dateien wird hier angenommen, dass die Veranstaltung „Maibock-Regatta“ heißt und entsprechend wird beispielhaft der Dateiname „Maibock“ gewählt:

Maibock.R48 enthält Daten, die die Veranstaltung beschreiben, z. B. Name und Datum der Veranstaltung und Name des Wettfahrtleiters und ggf. Name des Obmanns des Schiedsgerichts. Die eingestellten Optionen für diese Veranstaltung werden hier ebenfalls gespeichert, so dass beim erneuten Öffnen der Datei dieser Veranstaltung die gleichen Optionen eingestellt werden, wie beim letzten Schließen dieser Datei. Außerdem kann hier eine längere Bemerkung zu dieser Veranstaltung gespeichert werden.

Maibock.K48 enthält Daten, die die einzelnen Wertungsklassen beschreiben, z.B. Nummer und Name der Klasse, Wertungsart, Wertungssystem, Ranglistenfaktoren bei Ranglistenregatten uvm. Als Ordnungsbegriff gilt die Nummer der Wertungsklasse. Gültige Nummern sind 1 bis 15. Diese Nummern dürfen pro Veranstaltung (pro Dateigruppe) nicht mehrfach vorkommen.

Maibock.S48 enthält die Meldedaten der teilnehmenden Segler, z.B. Segelnummer, wahlweise das Landeskennzeichen (LK), Namen der Crew-Mitglieder, ggf. Geburtsjahrgänge, Heimat-Segelclub, Zuordnung zu den Wertungsklassen uvm. Nach dem Wertungslauf werden hier auch die berechneten Gesamtergebnisse pro Boot gespeichert. Als Ordnungsbegriff gilt die Segelnummer in Kombination mit dem LK (falls vorhanden). Dieser Ordnungsbegriff muss pro Klasse eindeutig sein, d.h. die Kombination Segel-Nr./LK darf pro Wertungsklasse nicht mehrfach vorkommen. Die Verknüpfung von Maibock.S48 mit Maibock.K48 geschieht über die Nummer der Wertungsklasse.

Maibock.C48 enthält die Daten des 4., 5. und 6. Seglers pro Boot. Ab WinRegatta Plus Version 3.2 wurde die maximale Crew-Stärke von bisher 3 auf nun 6 Segler pro Boot erweitert. Diese zusätzliche Datei wird nur erstellt, wenn in einer Wertungsklasse eine Crew-Stärke > 3 definiert wurde. Die Verknüpfung von Maibock.C48 mit Maibock.S48 geschieht über die Kombination Segelnummer / LK.

Maibock.E48 enthält Ergebnisdaten, und zwar die gesegelten Ergebnisse (gesegelter Rang oder gesegelte Zeit, usw.) pro Segler und Wettfahrt und die berechneten Wettfahrtergebnisse nach dem Wertungslauf. Als Ordnungsbegriff gilt die Kombination Segelnummer / LK / Wettfahrtnummer. Auch dieser Ordnungsbegriff muss eindeutig sein. Die Verknüpfung von Maibock.E48 mit Maibock.S48 geschieht über die Kombination Segelnummer / LK.

Maibock.W48 enthält Daten pro Wertungsklasse und Wettfahrt im Sinne eines Wettfahrtprotokolls. Einige Daten werden hier durch den Wertungslauf automatisch eingestellt, wie Anzahl der gemeldeten, gestarteten und gezeiteten Boote pro Wettfahrt. Andere Daten können durch die Wettfahrtleitung zusätzlich eingegeben werden, wie Status der Wettfahrtart (gültige Wettfahrt oder abgebrochene Wettfahrt), Datum, Startzeit, Zielzeit des Ersten der Klasse und Endzeit der Wettfahrt sowie Wind- und Bahndaten. Die mittlere Geschwindigkeit des Siegers der Wettfahrt wird automatisch errechnet und gespeichert. Außerdem kann ein längerer Kommentar zum Ablauf der Wettfahrt gespeichert werden, z.B. Grund für einen Wettfahrtabbruch oder Informationen über Protestverhandlungen. Als Ordnungsbegriff gilt die Kombination Wertungsklassennummer und Wettfahrtnummer. Die Verknüpfung von Maibock.W48 mit den anderen Dateien geschieht über die Nummern der Wertungsklasse und Wettfahrt.

Dateigruppe: Diese 5 bzw. 6 Dateien mit gleichem Dateinamen einer Veranstaltung werden als Dateigruppe bezeichnet.

Wichtig: Die obigen fünf bzw. sechs Dateien werden pro Veranstaltung jeweils neu als Dateigruppe angelegt, mit Daten gefüllt und gepflegt. Die Verarbeitung dieser Dateien durch das Paradox-Datenbanksystem macht es nötig, dass die Dateierweiterungen auf „*.DB“ lauten. Um dies zu erreichen, werden diese Dateien beim Öffnen in entsprechende Dateinamen kopiert, und zwar:

Maibock.R48 in MaibockR.DB
Maibock.K48 in MaibockK.DB
Maibock.S48 in MaibockS.DB
Maibock.C48 in MaibockC.DB (nur vorhanden, wenn mehr als 3 Segler pro Boot)
Maibock.E48 in MaibockE.DB
Maibock.W48 in MaibockW.DB

Beim Sichern und beim Schließen der Dateien werden diese wieder in die ursprünglichen Dateinamen zurückkopiert. Die „*.DB“ Dateien werden dann gelöscht, da sie nicht mehr nötig sind.

Wichtiger Hinweis: Beim Öffnen einer Dateigruppe werden durch das Datenbanksystem automatisch zahlreiche zusätzliche Dateien erstellt. Dies sind Indexdateien , die für einen schnellen Zugriff der Daten und für verschiedene Sortierfolgen notwendig sind. Wenn Sie sich mit dem Windows-Explorer das Verzeichnis ansehen, in dem Ihre Regatta-Daten gespeichert sind, dann sehen Sie diese zusätzlichen Indexdateien. Beim Schließen der Dateigruppe werden diese Indexdateien wieder automatisch gelöscht.

<Stamm>.DB enthält Segler-Stammdaten. Der Dateiname kann frei gewählt werden, und es können auch mehrere Stammdateien angelegt werden. Die Seglerdaten einer Regatta können auf einfache Weise in einer Stammdatei archiviert werden. In Vorbereitung der nächsten Regatta können dann diese Daten wieder reaktiviert werden, um die erneute Eingabe der Seglerdaten zu reduzieren.

Die nun folgenden Dateien bleiben ständig erhalten:

Clubs-4_2017.DB ist eine Datenbank der Segelclubs . Hier sind Club-Abkürzungen, Club-Namen und die entsprechenden DSV-Nummern von allen Clubs, die dem DSV angeschlossen sind, gespeichert. Der Änderungsstand der Club-Datenbank ist im Bemerkungsfeld des ersten Satzes der Tabelle vermerkt. Neue Clubs können zusätzlich eingegeben werden. Optional kann pro Club auch eine Bemerkung gespeichert werden. Die DSV-Nr. wird bei der Seglereingabe automatisch aus dieser Datei geholt, sofern der Club bereits gespeichert ist.

Bei ausländischen Clubs wird empfohlen, anstelle der DSV-Nr. das Landeskennzeichen zu speichern. Dies trägt zur besseren Übersichtlichkeit in den Drucklisten bei.

Nach der Installation von WinRegatta befindet sich diese Club-Datenbank mit dem Dateinamen "Clubs-4_2017.db" im Installationsordner von WinRegatta.
Ab WinRegatta Version 4.5 können mit einem "Öffnen-Dialog" unterschiedliche Club-Datenbanken geöffnet und mit einem "Speichern unter-Dialog" auch in andere Ordner mit geänderten Dateinamen gespeichert werden.

Boote-4_2017.DB ist eine Datenbank der Bootstypen. Hier sind die Bezeichnungen der Bootstypen mit den entsprechenden Yardstickzahlen gespeichert. Die einzelnen Bootstypen sind Bootskategorien zugeordnet, z.B. „Offenes Kielboot“. Optional kann auch eine Bemerkung pro Bootstyp eingegeben werden. Neue Bootstypen können zusätzlich eingegeben werden. Bei einer Klasse mit Yardstickwertung wird die entsprechende Yardstickzahl während der Seglereingabe automatisch aus dieser Datei geholt.

Die Yardstick-Tabelle der Kreuzer-Abteilung enthält über 1800 verschiedene Bootstypen. Diese Tabelle ist urheberrechtlich geschützt durch Copyright des DSV.

Auf Wunsch steht auch die Bodensee-Yardstick-Tabelle mit ca. 1300 Einträgen zur Verfügung.

Nach der Installation von WinRegatta befindet sich diese Boote-Datenbank mit dem Dateinamen "Boote-4_2017.db" im Installationsordner von WinRegatta.
Ab WinRegatta Version 4.5 können mit einem "Öffnen-Dialog" unterschiedliche Boote-Datenbanken (Yardstick-Tabellen) geöffnet und mit einem "Speichern unter-Dialog" auch in andere Ordner mit geänderten Dateinamen gespeichert werden.

WinReg48.INI bzw. WinReg48P.INI enthält Grunddaten und Umgebungsparameter für den Programmablauf, wie Name und Anschrift des veranstaltenden Clubs und Bezeichnung des Reviers, Position und Grösse der einzelnen Fenster von WinRegatta und verschiedene Optionen, die vom Anwender eingestellt wurden. Nach der Installation von WinRegatta befindet sich diese Ini-Datei im Installationsordner von WinRegatta. Mit Menü "Datei / Ordner für Ini-Dateien wählen " kann aber ein beliebiger anderer Ordner gewählt werden. WinRegatta kopiert dann automatisch die Ini-Dateien in den gewählten Ordner.

Diese Ini-Datei wird beim Programmstart automatisch von der Festplatte gelesen. Bei Verarbeitungsende wird diese Datei mit den aktuellen Daten automatisch auf die Festplatte geschrieben. Der Dateiname muß der gleiche sein, wie der Dateiname der WinRegatta Exe-Datei. Für die Version 4.8 also "WinReg48.INI" bzw. "WinReg48P.INI" für die Plus-Version.


WinRegatta starten

Auf „Start“ und dann auf „Programme“ klicken. Jetzt „Regatta Software“ und dann „WinRegatta 4.8“ bzw. „WinRegatta 4.8 Plus“ auswählen.

Sie können natürlich auch WinRegatta mit einem Doppelklick auf das WinRegatta-Icon auf dem Desktop starten.

Die weitere Möglichkeit: Mit dem Explorer das Verzeichnis öffnen, in das WinRegatta installiert wurde und Doppelklick auf „WinReg48.exe“.bzw. „WinReg48P.exe“.


Festlegen der Arbeitsumgebung

Nach dem ersten Start von WinRegatta sollten Sie Ihre persönliche Arbeitsumgebung definieren. Rufen Sie hierzu das Menü "Optionen" auf oder Klick auf [image]: Geben Sie die Daten Ihres Clubs als Veranstalter der Regatta ein. Im Kopf der Drucklisten werden diese Informationen später gedruckt. Details finden Sie hier .

Wählen Sie unter den zahlreichen Optionen die aus, die Ihrer Situation und Ihren Wünschen am besten entsprechen. Diese Daten werden in der Regattadatei (*.R48) und in der Ini-Datei gespeichert und werden beim nächsten Start von WinRegatta wieder geladen.

Wenn Sie bereits vorher mit WinRegatta gearbeitet haben, können Sie auch Ihre bisherige Ini-Datei übernehmen und ersparen sich so die erneute Eingabe dieser Daten. Der Name der Ini-Datei ist der gleiche wie die Anwendungsdatei (Exe-Datei) von WinRegatta. Für die Version 4.8 also "WinReg48.ini" bzw. "WinReg48P.ini" für die Plus-Version.

Diese Datei befindet sich in dem Ordner, der mit Menü "Datei > Ordner für Ini-Dateien wählen" gewählt wurde. Kopieren Sie bitte Ihre bisherige Ini-Datei in diesen Ordner und ändern Sie den Dateinamen in "WinReg48.ini" bzw. "WinReg48P.ini".


Vorbereiten einer Regatta

Um eine Regatta mit WinRegatta abwickeln zu können, muß eine neue Dateigruppe angelegt werden. Danach müssen Wertungsklassen definiert und die Meldedaten der Segler eingegeben werden.

Neue Dateigruppe anlegen

Klassen definieren

Seglerdaten eingeben

Seglerdaten aus Stammdatei

Check-Listen drucken


Neue Dateigruppe anlegen

Bevor Sie eine Regatta auswerten können, müssen Sie eine neue Dateigruppe zum Speichern der unterschiedlichen Daten anlegen.

  • Rufen Sie das Menü "Datei / Neu" auf oder klicken Sie auf [image] , um eine neue Dateigruppe anzulegen. Der vorläufige Dateiname dieser Gruppe heißt "Unbenannt.* "
  • Mit "Datei / Speichern unter" können Sie jetzt der Dateigruppe einen selbstgewählten Dateinamen geben. Dies sollten Sie möglichst gleich nach dem Erstellen der neuen Dateigruppe tun, da die Gruppe "Unbenannt.*" beim Schließen der Anwendung gelöscht wird.

Nach dem Anlegen dieser neuen Dateigruppe hat WinRegatta automatisch die Funktion "Klassen" geöffnet. Hier geben Sie nun in den entsprechenden Feldern Name und Datum der Veranstaltung und den Namen des Wettfahrtleiters ein.

Details zum Dateimenü.


Klassen definieren

Mit der Funktion "Klassen" können Sie die Wertungsklassen definieren, die Sie für diese Veranstaltung benötigen.

  • Für jede geplante Wertungsklasse legen Sie einen Datensatz an. Mit Klick auf [image] in der Navigationsleiste unten links wird ein neuer, leerer Datensatz bereitgestellt.
  • Geben Sie jeder Klasse eine Nummer im Wertebereich zwischen 1 und 15 und einen sinnvollen Namen, z.B. "Laser Rangliste".
  • Definieren Sie für jede Klasse, ob die Wertung als Klassen-, Yardstick- oder ORC-Wertung erfolgen soll, und ob die Ergebnisse pro Wettfahrt als gesegelter Rang, gestoppter Zeit oder Zieluhrzeit erfasst werden sollen.
  • Wenn bei einer Yardstickklasse ein Känguruh-Start geplant ist, dann ist als Wertungsart "Känguruh-Start" zu wählen.
  • Wählen Sie das gewünschte Punktesystem "Low-Point-System" (LPS) oder "Bonuspunkt-System" (BPS).
  • Bestimmen Sie, ob es sich bei dieser Klasse um Ein-, Zwei- oder Drei-Mann-Boote handelt.
  • Im Feld "P/S" müssen Sie noch "P" für Primärklasse oder "S" für Sekundärklasse wählen. Ergebnisse können nur für Primärklassen eingegeben werden. Mit einer Sekundärklasse kann eine Untermenge einer Primärklasse gewertet werden.

Das Abspeichern dieser Daten sollten Sie nicht vergessen. Rufen Sie "Datei / Speichern" auf oder klicken Sie auf [image] , wenn Sie vorher schon unter einem eigenen Dateinamen gespeichert hatten oder "Datei / Speichern unter", um diese Daten unter einem neuen Dateinamen und/oder Verzeichnis zu speichern. Die Klassendaten werden in der Datei "*.K48" gespeichert.

Details zur Klassendefinition.


Seglerdaten eingeben

Nachdem Sie die Wertungsklassen definiert haben, können als nächstes die Meldedaten der Segler eingegeben werden.

  • Öffnen Sie die Funktion "Segler" .
  • Im Feld oben links wird die Nummer der Wertungsklasse eingegeben, für die nun Segler erfasst werden sollen. Die Zuordnung der Segler zu der hier gewählten Klasse geschieht automatisch. Es kann aber auch ein "A" für "alle Klassen" eingegeben werden. In diesem Falle können die Segler gemischt für unterschiedliche Klassen erfasst werden. Die Zuordnung des Seglers zu einer Klasse muss nun aber manuell durch Eingabe der entsprechenden Klassennummer in dem Feld "P" (Primär-Klasse) geschehen. Durch Doppelklick auf das KlNr-Feld wird eine Liste aller definierten Klassen gezeigt, aus der alternativ die gewünschte Klasse durch Anklicken gewählt werden kann.
  • Für jedes Boot muss nun ein Datensatz angelegt werden. Mit Klick auf [image] der Navigationsleiste unten wird ein neuer Datensatz bereitgestellt.
  • Beginnen Sie die Eingabe der Daten eines Bootes mit der Segelnummer, ggf. zusätzlich das Landeskennzeichen (das normalerweise aber automatisch eingesteuert wird).
  • Abhängig von den Definitionen der ausgewählten Wertungsklasse(n) und den unter Menü "Optionen" gewählten Optionen werden für die Meldedatenerfassung der Segler entsprechende Eingabefelder gezeigt und aktiv gestellt.

Bitte speichern Sie in Zeitabständen die Daten über "Datei / Speichern" bzw. durch Klick auf [image] , damit Ihnen bei einem ungeplanten Systemproblem keine Daten verloren gehen. Die Seglerdaten werden in der Datei "*.S48" gespeichert.

Details zur Seglereingabe.


Seglerdaten aus Stammdatei

Seglerdaten aus Stammdatei übernehmen

Wenn Sie Seglerdaten aus einer ähnlichen, früheren Veranstaltung in einer Stammdatei archiviert hatten, dann können Sie diese Daten nun reaktivieren, um den Eingabeaufwand für eine neue Veranstaltung zu verringern.

Vorgehensweise:

  • Öffnen Sie die Dateigruppe für die neue Veranstaltung.
  • Klicken Sie auf die Funktion "Stammdaten".
  • Im oberen Datengitter erscheinen die Segler, die bereits in der geöffneten Dateigruppe enthalten sind. Im unteren Datengitter sehen Sie die Segler, die in der geöffneten Stammdatei gespeichert sind.
  • Mit Klick auf [image] die gewünschte Stammdatei öffnen.
  • Klicken Sie im Stammdatengitter auf den Spaltenkopf "Regatta-Veranstaltung" oder "Regatta-Datum" oder "Klassen-Namen", um nach der jeweiligen Spalte zu sortieren. Scrollen Sie jetzt zu der gewünschten Veranstaltung oder zu dem Klassen-Namen usw. und markieren Sie die Zeilen, die Sie reaktivieren wollen. Sie können natürlich auch bestimmte Seglernamen suchen und markieren. Mit der Shift- bzw. Strg-Taste können Sie mehrere Zeilen gleichzeitig markieren.
  • Mit dem Klick auf [image] werden die markierten Segler in die geöffnete Seglerdatei (Dateigruppe) übernommen.
  • Gehen Sie jetzt in die Funktion "Segler", und geben Sie in das Feld "KlNr" oben links "A" für Alle Klassen ein. Jetzt sehen Sie die aus der Stammdatei übernommenen Segler. Sie müssen diese Daten nun mit den aktuellen Meldedaten abgleichen und ggf. ändern, z. B. eine andere Segelnummer oder ein geänderter Vorschoter.
  • Die aus der Stammdatei übernommenen Segler haben keine Klassenzuordnung (das Feld "P" ist leer). Entsprechend der für die neue Regatta definierten Klassen sind die Segler durch Eingabe einer Klassennummer den Klassen zuzuordnen. Segler, die Sie übernommen haben, die aber für diese neue Veranstaltung nicht gemeldet haben, können Sie löschen oder auch inaktiv (Feld "P" leer) bestehen lassen.

Details zu Seglerstammdaten


Meldedaten aus CSV-Datei

Meldedaten aus CSV-Datei importieren

Wenn Sie für Ihre Regatten ein Online-Meldesystem verwenden, und diese Meldedaten in eine Datei im CSV-Format speichern, dann kann diese CSV-Datei direkt importiert werden.

Siehe "Funktionsbeschreibung / Meldedaten-Import" für Details .


Check-Listen drucken

Nachdem alle Meldedaten eingegeben wurden, können verschiedene Melde- und Check-Listen zur Unterstützung des Meldebüros und der Wettfahrtleitung gedruckt werden:

  • Mit der Funktion "Drucken" können verschiedene Listenformate ausgewählt werden. Im rechten Abschnitt des Fensters wird zur Orientierung eine Kurzbeschreibung der gewählten Liste gezeigt.
  • Im Feld "Kl-Nr" wird die Nummer der Wertungsklasse eingegeben bzw. mit Doppelklick gewählt.
  • Die "Check-Liste für Meldebüro" unterstützt den Meldevorgang.
  • Die "Meldeliste" zeigt die gemeldeten Segler mit den Klassenzuordnungen oder anderen wählbaren Informationen. Diese Liste kann auch als Text- und HTML-Datei gespeichert und damit exportiert werden.
  • Die Checklisten für Start, Zieleinlauf und Bahnmarkenkontrolle unterstützen die Wettfahrtleitung während der Wettfahrt.
  • Mit Klick auf "Vorschau" wird eine Listenvorschau im realistischen Layout angezeigt.
  • Mit Klick auf "Drucken" wird die Liste auf dem Windows Standarddrucker gedruckt.

Details zu Listen für Meldebüro.

Details zu Listen für Wettfahrtleitung.


Ergebnisse eingeben und werten

Ergebnisse eingeben und auswerten

Nachdem Wettfahrten gesegelt wurden, können die gesegelten Ergebnisse eingegeben werden. Danach kann in einem Wertungslauf die Auswertung dieser Ergebnisse erfolgen.

Ergebnisse eingeben

Wf-Protokoll eingeben

Wertung

Ergebnisse ausgeben


Ergebnisse eingeben

Mit der Funktion "Ergebnisse" werden die gesegelten Ergebnisse der Segler erfasst.

Ergebnisse können nur für Primärklassen eingegeben werden. Für die Wertung einer sekundären Klasse (Sekundärwertung) werden die eingegebenen Ergebnisse der primären Klasse des Seglers herangezogen.

Die Ergebniseingabe geschieht pro Wertungsklasse und Wettfahrt. Im Feld "Kl-Nr" oben links wird die Nummer der primären Wertungsklasse eingegeben. Durch Doppelklick auf das KlNr-Feld wird eine Liste aller definierten primären Klassen gezeigt, aus der alternativ die gewünschte Klasse durch Anklicken gewählt werden kann. Der Name dieser Klasse wird zur Information im Feld rechts daneben angezeigt. Im Feld "Wf-Nr" wird die Wettfahrt gewählt, für die die Ergebnisse erfasst werden sollen.

Nun werden im Datengitter die Segler der gewählten Klasse mit ihren möglicherweise schon eingegebenen Ergebnissen der gewählten Wettfahrt angezeigt.

Abhängig davon, wie die Ergebnisart für diese Klasse definiert wurde, werden Felder für Rangeingabe oder für Zeiteingabe angeboten.

  • Bei Ergebnisart "Rangplatz" wird im Feld "Rang" der gesegelte Rang eingegeben.
  • Bei Ergebnisart "Gestoppte Zeit" wird im Feld "Ziel-Zeit" die gestoppte Zeit des Zieldurchgangs eingegeben.
  • Bei Ergebnisart "Uhrzeit" wird im Feld "Ziel-Zeit" die Uhrzeit des Zieldurchgangs eingegeben. Bei dieser Ergebnisart muß auch eimal pro Klasse und Wettfahrt die Uhrzeit des Starts eingegeben werden. Dies kann mit Klick auf [image] in dem sich öffnenden Dialogfenster geschehen.

  • Neu ab Vers. 4.4b: Bei Ergebnisart "Indiv. Startzeit" können die Boote in einem festgelegten Zeitfenster (z. B. innerhalb von 15 Minuten) ihren Startzeitpunkt individuell wählen. Diese Startmethode bietet sich bei größeren Yachten an, wenn das Startgebiet beengt ist. Bei der Ergebniseingabe werden pro Boot die individuelle Startzeit und die Zielzeit eingegeben.

  • Durch Eingabe der Segelnummer im Feld "Suche S-Nr" wird zu dem entsprechenden Segler gesprungen, sobald das Feld mit der Tab- oder Enter-Taste verlassen wird. Ein Feld für den Landeskenner (LK) gibt es hier nicht. Denn wenn eine Segelnummer eingegeben wird, die bei unterschiedlichen LKs oder in verschiedenen Klassen mehrfach vorkommt, so wird ein Auswahlfenster angeboten, zur Wahl des richtigen Seglers.
  • Sind Besonderheiten im Ergebnis für einen Segler einzugeben, so kann dies im Feld "DNF.." geschehen. Mit Doppelklick auf das Feld "DNF.." oder auf die ausgewählte Zeile im Datengitter erscheint eine Auswahlliste mit den Kennzeichen, die in der WR hierfür definiert wurden, z.B. DNS, DNF, OCS, DSQ usw.

Bitte speichern Sie in Zeitabständen die Daten über "Datei / Speichern" bzw. durch Klick auf [image] , damit Ihnen bei einem ungeplanten Systemproblem keine Daten verloren gehen. Die Ergebnisdaten werden in der Datei "*.E48" gespeichert.

Details zur Ergebniseingabe.


Wf-Protokoll eingeben

Mit der Funktion "Wf-Protokoll" kann für jede Wettfahrt ein Protokoll geführt werden:

  • Im Feld "Kl-Nr" oben links wird mittels Tastatur oder Doppelklick die Nummer der Wertungsklasse eingegeben. Der Name dieser Klasse wird zur Information im Feld rechts daneben angezeigt. Wenn für mehrere Klassen gleichartige Protokolle einzugeben sind, dann kann im Feld "Kl-Nr" ein "M" für "Mehrere Klassen " gewählt werden.
  • Wurde für diese Klasse bereits ein Wertungslauf durchgeführt, dann existieren für die gewerteten Wettfahrten bereits Datensätze, die im Datengitter angezeigt werden. Andernfalls kann mit Klick auf [image] unten links für die gesegelten Wettfahrten, die noch nicht gewertet wurden, Protokollsätze manuell angelegt werden.
  • In das Wettfahrtprotokoll werden die Wettfahrtzeiten und die Wind- und Bahndaten eingegeben.
  • Die Geschwindigkeit des ersten Seglers der Klasse wird automatisch errechnet und angezeigt, sobald die hierfür erforderlichen Angaben (Startzeit, Zielzeit des Ersten und Bahnlänge) eingegeben wurden.

  • Die Anzahl der gemeldeten, gestarteten und gezeiteten Boote wird durch den Wertungslauf automatisch eingesteuert.

  • Im Eingabefeld ganz unten kann eine längere Bemerkung zum Ablauf und Ergebnis der Wettfahrt eingegeben werden.

  • Das Wettfahrtprotokoll kann wahlweise auf den Ergebnislisten gedruckt werden.

Die Wf-Protokolldaten werden in der Datei "*.W48" gespeichert.

Details zum Wettfahrtprotokoll.


Wertung

Nachdem für die durchgeführten Wettfahrten die gesegelten Ergebnisse eingegeben wurden, kann nun mit dem Wertungslauf die Berechnung der Regatta-Ergebnisse erfolgen.

Alle Segler, die der Klasse zugeordnet sind, die gewertet werden soll, werden in die Wertung einbezogen. Für diese Segler müssen die gesegelten Ergebnisse, einschliesslich der Besonderheiten wie "nicht gestartet" (DNS), "aufgegeben" (DNF), usw. für die zu wertenden Wettfahrten vollständig eingegeben sein.

Vorbereitung...

  • Mit der Funktion "Wertung" wird die Wertung vorgenommen.
  • Im Feld "Kl-Nr" wird mittels Tastatur oder Doppelklick die Nummer der zu wertenden Wertungsklasse eingegeben. Dies kann die Nummer einer primären wie auch sekundären Wertungsklasse sein. Der Name dieser Klasse wird zur Information in dem benachbarten Feld angezeigt.
  • Im Bereich "Wettfahrten, die gewertet werden sollen " die Wettfahrten "ankreuzen", die in die Wertung einbezogen werden sollen.
  • Soll eine Wertung mit Streicher vorgenommen werden, so ist die Anzahl der zu streichenden Wettfahrten im Feld "Streicher" zu setzen.
  • Andere Parameter wie Wertungsart (Klassen-, Yardstick- oder ORC-Wertung), das zu verwendende Punktsystem (LPS oder BPS), ob Ranglistenwertung sowie der Ranglistenfaktor wurden für diese Klasse schon im Rahmen der Klassendefinition festgelegt.
  • Mit einem Klick auf den Schalter "Start" wird die Wertung durchgeführt. Wurden die Ergebnisse der angekreuzten Wettfahrten unvollständig eingegeben, so wird der Wertungslauf mit einem entsprechenden Hinweis abgebrochen.

Nach erfolgreicher Wertung...

  • Die Segler werden in der Reihenfolge des Gesamtergebnisses der gewerteten Wettfahrtserie im Datengitter angezeigt.
  • Pro Wettfahrt werden berechneter Rang, berechnete Punkte, ganz rechts die Gesamtpunkte und bei Ranglisten-Regatten auch die Ranglistenpunkte angezeigt.
  • Bei Streicher werden die gestrichenen Wettfahrtpunkte in Klammern gesetzt.
  • Durch Ankreuzen von entsprechenden Feldern im Block "Details anzeigen" können wahlweise weitere Informationen zur Anzeige gebracht werden.
  • Im Eingabefeld unten rechts kann ein längerer Hinweis zur Wettfahrtserie eingegeben werden, z.B. Infos über vorliegende Proteste und Zeitpunkt der Protestverhandlung oder nach der letzten Wettfahrt der Serie gute Wünsche für die Heimreise der Segler. Dieser Hinweis kann wahlweise auf der Ergebnisliste gedruckt werden.

Details zur Wertung.


Ergebnisse ausgeben

Die Ergebnisse einer Wettfahrtserie können gedruckt oder in Text- oder HTML-Dateien gespeichert werden:

  • Mit der Funktion "Drucken" können verschiedene Listenformate ausgewählt werden. Im rechten Abschnitt des Fensters wird zur Orientierung eine Kurzbeschreibung der gewählten Liste gezeigt.
  • Im Feld "Kl-Nr" wird die Nummer der Wertungsklasse eingegeben bzw. mit Doppelklick gewählt, deren Ergebnisse gedruckt bzw. in Dateien gespeichert werden sollen.
  • Im Feld "Ergebnis" kann der derzeitige Status der Ergebnisse gewählt werden, z. B. "Zwischen-Ergebnis". Dieser Status wird im Listenkopf gedruckt.
  • Als Wettfahrtprotokoll können wahlweise die Wind- und Bahndaten, die Wettfahrtzeiten und ein Hinweis zur Regatta gedruckt werden. Dies Protokoll wird am Ende der Ergebnisliste gedruckt.
  • Mit Klick auf "Vorschau" wird eine Listenvorschau im realistischen Layout angezeigt. Mit Klick auf das Drucker-Symbol kann aus der Vorschau auch gedruckt werden.
  • Mit Klick auf "Drucken" wird die Liste auf dem Windows Standarddrucker gedruckt.
  • Mit Klick auf "Text-Datei" werden die Ergebnisse in einer Textdatei gespeichert. Als Spaltenseparator dient das Tab-Zeichen. Diese Datei kann einfach in Excel importiert werden.
  • Mit Klick auf "HTML-Datei" werden die Ergebnisse in einer HTML-Datei gespeichert. Für die HTML-Liste kann ein Standard-Listenkopf oder auch ein erweiterter Listenkopf gewählt werden. Diese Datei kann direkt ins Internet hochgeladen werden.
  • Vor dem Drucken oder Speichern von Ergebnissen erfolgt in jedem Falle ein automatischer Wertungslauf, um letzte Änderungen zu berücksichtigen.

Details zur Ergebnisausgabe.


Funktion Wertung

Funktionsbeschreibung

In den folgenden Kapiteln werden die wesentlichen Funktionen von WinRegatta beschrieben.

Menüs

Funktion Optionen

Funktion Klassen

Funktion Segler

Funktion Ergebnisse

Funktion Wettfahrt-Protokoll

Funktion Wertung

Funktion Drucken

Funktion Stammdaten

Funktion Clubs

Funktion Boote

Funktion Gruppenwertung

Funktion MO-Finale

Meldedaten-Import

Känguruh-Start

Eingeschränkter Benutzer

Datenbeispiele


Men?

Menüs

Im folgenden werden die Menü-Funktionen beschrieben:

Datei

Bearbeiten

Stammdaten

Optionen


Datei

Menü "Datei"

  • "Neu"
    Vor der Eingabe von Daten für eine neue Veranstaltung wird hier eine neue (leere) Dateigruppe angelegt. Wenn eine andere Dateigruppe noch aktiv ist und sich ungesicherte Daten im Speicher befinden, wird ein Hinweis zum Sichern gegeben. Als Dateinamen für die neuen Dateien wurde von WinRegatta "UnbenanntR.DB", "UnbenanntK.DB" usw. vergeben. Mit dem Menüpunkt "Datei / Speichern unter..." kann der Benutzer den Dateien einen selbstgewählten Namen geben.
  • "Öffnen"
    Diese Funktion ermöglicht die Auswahl und das Öffnen einer WinRegatta Dateigruppe. Das hier verwendete Dialog-Fenster und die Handhabung entspricht dem Windows 95- und höher-Standard und ist sicher vielen Anwendern bereits bekannt. Der Dateiname *.R48 steht im Öffnen-Dialog stellvertretend für die jeweilige Dateigruppe. Das Verzeichnis und der Name der geöffneten Dateigruppe werden in der Titelzeile des Hauptfensters von WinRegatta zur besseren Orientierung angezeigt. Das Öffnen der Dateigruppe bewirkt ein Kopieren von *.R48, *.K48 usw. nach *R.DB, *K.DB usw. Nachdem die Dateien auf diese Weise geöffnet wurden, können nun deren Daten bearbeitet werden.
  • "Schließen"
    Eine Dateigruppe, deren Bearbeitung beendet wurde, kann hier geschlossen werden. Wenn die Daten dieser Dateien verändert und noch nicht gespeichert wurden, wird der Anwender zum Speichern aufgefordert.
  • "Speichern"
    Während der Verarbeitung werden die Daten in den internen Datenbank-Dateien (*R.DB, *K.DB usw.) gehalten. Über diesen Menü-Punkt werden die geänderten Daten endgültig gespeichert. Dies geschieht dadurch, dass die internen Dateien in Dateien mit den Namen, unter denen sie ursprünglich geöffnet wurden (*.R48, *.K48 usw.), zurückkopiert werden.
  • "Speichern unter..."
    Hier können Daten unter einem neuen Dateinamen (ggf. auch in ein anderes Verzeichnis oder auf ein anderes Laufwerk) gespeichert werden. Dies ist z.B. nötig, um eine neue Dateigruppe (UnbenanntR.DB) endgültig zu speichern oder um eine Dateigruppe, deren Daten verändert wurden, unter einem neuen Namen zu speichern, ohne die ursprünglichen Dateien zu überschreiben.
  • "Daten kopieren/sichern..." Neu ab Vers. 4.4
    Hier können Regatta-Daten kopiert und gesichert werden. In einem Öffnen-Dialog wird die zu kopierende Dateigruppe ausgewählt und in dem nachfolgenden Speichern-Dialog wird das Zielverzeichnis und der Zieldateiname festgelegt.

    Ein Kopieren einer Dateigruppe mit "Speichern Unter..." auf einen portablen Datenträger sollte vermieden werden, da WinRegatta nach dem Kopieren die Dateigruppe auf dem neuen Speicherplatz wieder öffnet. Beim Öffnen werden über zwanzig temporäre Indexdateien erzeugt. Wenn der portable Datenträger bei noch geöffneter Dateigruppe entfernt wird, können Probleme entstehen, da die temporären Indexdateien dann bestehen bleiben.

    Das Kopieren einer Dateigruppe (5 oder 6 Dateien) z. B. zur Datensicherung sollte mit dieser Funktion "Daten kopieren/sichern..." oder mit dem Windows Explorer vorgenommen werden!
  • "Löschen Datei..."
    Hier kann eine Dateigruppe, die nicht mehr benötigt wird, gelöscht werden.
  • "Dateigruppe von CSV importieren..." und "Dateigruppe als CSV-Datei exportieren..." Neu ab Vers. 4.7
    Hiermit ist es möglich Regattadaten zwischen verschiedenen WinRegatta-Versionen auszutauschen, auch wenn das Datenformat unterschiedlich ist.
  • "Ordner für Ini-Dateien wählen..." Neu in Vers. 4.2 und geändert in Version 4.5
    Die verschiedenen Ini-Dateien werden normalerweise in dem Installationsordner von WinRegatta gespeichert. Es kann aber sinnvoll und auch bequem sein, einen beliebigen anderen Ordner für diese Dateien zu wählen.

    Wird ein anderer Ordner gewählt, so kopiert WinRegatta die Ini-Dateien automatisch in den gewählten Ordner. Der Pfad des gewählten Ordners wird in der Datei "IniDateiOrdner.ini" gespeichert. Diese Datei befindet sich immer im Installationsordner von WinRegatta. Somit weiß WinRegatta stets, wo sich die Ini-Dateien befinden.
  • "Meldedaten importieren..." Neu in Vers. 4.2
    Meldedaten zu Regatten, die z. B. online über die Website des Clubs eingegangen sind, können in eine CSV-Datei gespeichert werden. Diese CSV-Datei kann nach WinRegatta importiert werden, um die manuelle Eingabe der Meldedaten zu sparen. Details .
  • Meldedaten-Import von dem Online-Portal "raceoffice.org" (Neu ab Vers. 4.5):
    Mit einem neuen Menüpunkt im Datei-Menü wurde der Meldedaten-Import aus einer CSV-Datei, die von raceoffice.org heruntergeladen wurde, implementiert.
  • Meldedaten Ini-Datei..." Neu in Vers. 4.2
    Für den Meldedaten-Import wird eine Ini-Datei mit dem Namen "MeldeDaten.INI" verwendet, um die Datenfelder der CSV-Datei mit den Feldern von WinRegatta zu synchronisieren. Mit diesem Menüpunkt wird die Ini-Datei in einem Editor geöffnet und kann so vom Anwender bearbeitet werden.
  • "Känguruh-Startliste erstellen..." Neu in Vers. 4.2
    Es wird das Dialogfenster "Känguruh-Start" geöffnen, in dem alle nötigen Daten zur Berechnung einer Känguruh-Startliste eingegeben werden können. Details .
  • "Drucken"
    Über diesen Menü-Punkt wird das Funktionsregister "Drucken" geöffnet. Hier kann dann die gewünschte Druckliste ausgewählt und gedruckt oder in eine Text-Datei oder HTML-Datei gespeichert werden. Details .
  • "Drucker einrichten..."
    Hier wird der Drucker gewählt, auf dem die Listen gedruckt werden sollen. Das Seiten-Layout wird entsprechend der gewählten Druckliste von WinRegatta bestimmt.
    Das Druckabbild kann auch in eine PDF-Datei gespeichert werden, wenn eine entsprechende PDF-Erstellungs-Software auf dem PC installiert ist.
  • "Beenden"
    Die Anwendung WinRegatta wird beendet. Falls geänderte Daten noch nicht gespeichert wurden, wird ein entsprechender Hinweis gegeben.


Bearbeiten

Menü "Bearbeiten"

Die Funktionen dieses Menüs werden in den Kapiteln Funktion "Segler " und Funktion "Ergebnisse" behandelt.


Stammdaten

Menü "Stammdaten"

Die Funktionen dieses Menüs werden im Abschnitt Funktion "Stammdaten" behandelt


Clubs

Menü "Clubs"

Die Funktionen dieses Menüs werden im Abschnitt Funktion "Clubs" behandelt.


Boote

Menü "Boote"

Die Funktionen dieses Menüs werden im Abschnitt Funktion "Boote" behandelt


Optionen

Menü "Optionen"

Die Funktionen dieses Menüs werden im Abschnitt Funktion "Optionen" beschrieben.


Funktion "Optionen"

Über den Menüpunkt "Optionen" oder mit Klick auf [image] wird ein Fenster geöffnet, in dem bestimmte Grunddaten und Umgebungsparameter für den Programmablauf eingestellt werden können.

Veranstaltender Club

Daten-Konfiguration

Listendruck / Text-Datei

HTML-Datei


Veranstaltender Club

Hier können Daten des veranstaltenden Clubs eingegeben werden. Dies sind Name und Anschrift des Clubs und Bezeichnung des Segelreviers. Diese Daten des Veranstalters werden im Kopf der Listen gedruckt.

Ab Vers. 4.8 wurde diese Funktion erweitert mit Eingabefeldern für Namen, Club-Zugehörigkeit und Lizenznummenr des Wettfahrtleiters, dessen Stellvertreters und bis zu 5 Jurymitgliedern. Diese Daten werden in der Regatta-Datei "*.R08" gespeichert.

Mit "OK" werden die Daten übernommen und in der Ini-Datei gespeichert. Zusätzlich werden die Optionen in der Regatta-Datei "*.R48" gespeichert.
Mit "Abbrechen" werden die vorgenommenen Änderungen verworfen.


Daten-Konfiguration

Die Eingabeoptionen bestimmter Daten können hier konfiguriert werden. Die gewählten Optionen sorgen dafür, dass entsprechende Eingabefelder und Spalten in Datengittern aktiviert werden oder unsichtbar gemacht werden. Der Sinn ist es, nur die Datenelemente dem Anwender zu zeigen, die er auch benutzen will, und so die Anwendungsoberfläche möglichst übersichtlich und einfach zu halten.

Die gewählten Einstellungen beziehen sich jeweils auf die ganze Veranstaltung (Dateigruppe), die zu diesem Zeitpunkt geöffnet ist. Im einzelnen sind dies folgende Optionen:

  • Soll in Ergänzung zur Segelnummer ein Landeskennzeichen (LK) eingegeben werden? Bei rein nationalen Regatten ist die Verwendung eines LK eigentlich nicht nötig, da es für alle deutschen Segler ja einheitlich "GER" lauten würde.
  • Soll in Ergänzung zur Segelnummer / LK der Name der Yacht eingegeben werden? Dies ist für Regatten interessant, an denen vorwiegend grössere Boote teilnehmen. Die Yachtnamen werden dann auf allen Listen gedruckt. Wahlweise kann der Yachtname zusätzlich zu Segelnummer / LK gedruckt werden oder auch nur der Yachtname. In gleicher Weise werden die Yachtnamen auch in Text- und HTML-Dateien gespeichert.
  • Neu in Vers. 4.6: Soll in Ergänzung zur Segelnummer / LK eine Bugnummer eingegeben werden? In der Startphase von grossen Starterfeldern besteht die Schwierigkeit Frühstarter zu identifizieren, da die betreffende Segelnummer durch die Segel anderer Boote oft verdeckt ist. Hier werden gerne Bugnummern verwendet, die am Bug beidseitig angeheftet werden und leichter erkannt werden können. Die Bugnummern werden dann auf allen Listen gedruckt. Wahlweise kann die Bugnummer zusätzlich zu Segelnummer / LK gedruckt werden oder auch nur die Bugnummer. In gleicher Weise werden die Bugnummern auch in Text- und HTML-Dateien gespeichert.
    Wichtig: Für eine Dateigruppe kann nur entweder die Funktion "Bugnummer" oder "Yachtnamen" aktiviert werden, nicht aber beides gleichzeitig.
  • Soll das volle Geburtsdatum der Segler oder nur der zweistellige Geburtsjahrgang der Segler erfasst werden? In der Funktion "Klassen" wird pro Klasse festgelegt, ob diese Daten überhaupt eingegeben werden sollen.
  • Soll bei Yardstick-Regatten eine individuelle Anpassung des Yardsticks vorgenommen werden, um Abweichungen eines Bootes vom Standard der Bootsklasse auszugleichen (z. B. +1, wenn kein Spi gefahren wird oder -1 für Faltpropeller, wenn Festpropeller Standard ist)?
  • Sollen die DSV-Nummern bei der Eingabe der Seglerdaten und auf den Listen unterdrückt werden? Dies ist für lokale Club-Regatten vielleicht sinnvoll, da die Segler nur dem eigenen Club angehören.
  • Soll ein Check-In -Kennzeichen bei der Anmeldung der Segler im Meldebüro durch WinRegatta verwaltet werden, oder soll dies manuell geschehen?
  • Wenn PC-gestütztes Check-In gewählt wurde, soll über WinRegatta auch das Vorliegen einer ordnungsgemäss ausgefüllten Meldekarte und die Ausgabe der Segelanweisung an den Segler registriert werden?
  • Die Anzahl der geplanten Ebenen für Sekundär-Wertungen kann hier gewählt werden (0 bis 5).
  • Soll der Name des Obmanns des Schiedsgerichts erfasst werden?
  • Soll die Windstärke in kn, Bft oder m/s eingegeben werden?
  • Soll die Bahnlänge in sm oder km eingegeben werden?
  • Neu in Vers. 4.5: Der Strom-Faktor zur Gewichtung des Stromeinflusses in der Schabrod-Stromformel (Wertung von Flussregatten) kann hier gewählt werden. Sinnvolle Werte für den Strom-Faktor sind 0,75 bis 1,00. Dieser Faktor kann ebenfalls in der Funktion "Wf-Protokoll" eingegeben werden. Der Strom-Faktor wird in der Ini-Datei gespeichert und steht beim nächsten Start von WinRegatta wieder zur Verfügung.
  • Neu in Vers. 4.7: Wahlweise kann das Nachmeldegeld zusätzlich zum normalen Meldegeld erfasst werden. Wenn diese Funktion unter "Optionen" aktiviert wird, dann werden bei der Seglereingabe zwei zusätzliche Eingabefelder angeboten, um das Nachmeldegeld und die Zahlungsart einzugeben.
    Auf den Listen "Quittung für Segler" und "Meldegeld-Abrechnung" wird das Nachmeldegeld gesondert ausgewiesen.

Mit "OK" werden die gewählten Optionen aktiviert und in der Ini-Datei gespeichert. Zusätzlich werden die Optionen in der Regatta-Datei "*.R48" gespeichert, so dass beim Öffnen der Dateigruppe einer bestimmten Veranstaltung die gleichen Optionen aktiviert werden, die auch bei der letzten Bearbeitung dieser Veranstaltung benutzt wurden.
Mit "Abbrechen" werden die vorgenommenen Änderungen verworfen.


Listen-Druck / Text-Datei

Hier können Optionen für den Druck von Listen bzw. für das Speichern in Text-Dateien und HTML-Dateien gewählt werden. Auch diese Einstellungen beziehen sich jeweils auf die ganze Veranstaltung (Dateigruppe), die zu diesem Zeitpunkt geöffnet ist. Im einzelnen sind dies folgende Optionen:

  • Die Grösse des Seitenrandes oben und unten beim Listendruck. Zum Beispiel kann hiermit ein freier Rand auf den Listen gelassen werden für einen vorgedruckten Werbeblock.
  • Die Wahl einer kleinen Bitmap-Grafik zum Druck auf den Melde- und Ergebnislisten oben links. Dies kann ein Segelmotiv oder auch der Club-Stander des Veranstalters sein. Großformatige Bitmap-Grafiken (in MB-Größe) sollten mit einem Grafik-Programm verkleinert werden, da es sonst zu Problemen beim Drucken durch WinRegatta kommen kann. Abhängig vom Motiv können verschiedene Darstellungsformen der Grafik gewählt werden. Auf den Check-Listen wird die Grafik nicht gedruckt.
    Neu in Vers. 4.5: Die Bitmap-Datei (*.BMP) kann mit Klick auf die Taste "Durchsuchen" aus einem beliebigen Verzeichnis gewählt werden.
  • Neu in Vers. 4.4: Eine Werbegrafik am unteren Seitenrand kann zum Druck auf Melde- und Ergebnislisten gewählt werden. Diese Grafik in Form eines Werbebanners hat bei Seiten im Hochformat eine Größe von 715 x 50 Pixel. Bei Seiten im Querformat sind dies 1025 x 72 Pixel. Die Grafik wird automatisch auf obige Größen angepaßt.
    Die Grafik muß eine BMP-Datei (*.BMP) sein und sollte möglichst die Größe von 1025 x 72 Pixel haben. Andere Größen sind auch möglich, da vor dem Druck eine automatische Anpassung auf obige Größen erfolgt. Dies kann dann aber zu leichten Qualitätsverlusten der gedruckten Grafik führen. Wenn eine andere Größe verwendet wird, dann ist es wichtig, dass das Seitenverhältnis möglichst dem von 1025 : 72 Pixel entspricht, da sonst Verzerrungen entstehen.
    Neu in Vers. 4.5: Die Bitmap-Datei (*.BMP) kann mit Klick auf die Taste "Durchsuchen" aus einem beliebigen Verzeichnis gewählt werden.

    Neu in Vers. 4.6: Die Dateinamen der Grafik-Dateien werden für jede Regatta in der jeweiligen Dateigruppe gespeichert und beim erneuten Öffnen der Regatta wieder verwendet. Bitte beachten Sie folgende Einschräkungen: Die Grafik-Dateien müssen in einem (beliebigen) gemeinsamen Ordner gespeichert werden, und die Länge der Dateinamen darf nur maximal 18 Stellen lang sein.

  • Bei internationalen Regatten kann der Listenkopf bei Melde- und Ergebnislisten sowie bei Text- und HTML-Dateien wahlweise mit deutschem oder englischem Kopf ausgegeben werden.
  • Melde- und Ergebnislisten sowie Text- und HTML-Dateien können wahlweise mit deutschem oder englischem Kopf ausgegeben werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe. Die gewählte Sprache wird gespeichert und beim nächsten Druck der Listen dieser Dateigruppe wieder voreingestellt.
  • Die gewünschte Namensstruktur der Segler (Hans Mustermann, Mustermann Hans oder Mustermann, Hans) für die Datenausgabe kann hier gewählt werden.
  • Als Letztes kann gewählt werden, ob in den Text-Dateien die Mannschaft eines Bootes in einem Datensatz nebeneinander oder jedes Mannschaftsmitglied in einem eigenen Datensatz gespeichert werden soll.

Mit "OK" werden die gewählten Optionen aktiviert und in der Ini-Datei gespeichert. Zusätzlich werden die Optionen in der Regatta-Datei "*.R48" gespeichert, so dass beim Öffnen der Dateigruppe einer bestimmten Veranstaltung die gleichen Optionen aktiviert werden, die auch bei der letzten Bearbeitung dieser Veranstaltung benutzt wurden.
Mit "Abbrechen" werden die vorgenommenen Änderungen verworfen.


HTML-Datei

HTML-Datei für Melde- und Ergebnislisten

Ab WinRegatta Version 4.3 kann zusätzlich zu dem bisheringen Standardkopf ein erweiterter Listenkopf gewählt werden.
Neun Elemente stehen für den erweiterten Kopf zur Auswahl.
Für jedes Element kann die Schriftgröße in vier Abstufungen eingestellt werden.
Als unterste Kopfzeile wird das Datum und die Zeit der Erstellung der HTML-Datei gezeigt.
Der erweiterte Listenkopf wird linksbündig dargestellt, während der Standardkopf - wie bisher - mittig geschrieben wird.
Diese Konfiguration der Kopfauswahl wird in der Ini-Datei gespeichert und bei der nächsten HTML-Speicherung wieder voreingestellt.

Mit "OK" werden die gewählten Optionen aktiviert und in der Regattadatei und Ini-Datei gespeichert.
Mit "Abbrechen" werden die vorgenommenen Änderungen verworfen.


Funktion "Klassen"

Der Hauptteil dieses Fensters dient der Definition der Wertungsklassen. In dem Datengitter werden die eingegebenen Daten angezeigt. Die Dateneingabe selbst erfolgt über die Eingabefelder in der unteren Zeile.

Die Eingabefelder sind mit den entsprechenden Spalten des Datengitters vertikal ausgerichtet. Der zu bearbeitende Datensatz (Wertungsklasse) kann durch Anklicken der entsprechenden Zeile im Datengitter gewählt werden.

Ganz unten befinden sich vier Schalter zur Steuerung der Dateneingabe. Mit dem Plus-Schalter kann ein neuer Satz erzeugt werden. Der Minus-Schalter löscht den ausgewählten Satz. Mit den beiden rechten Schaltern können die vorgenommenen Änderungen an einem Datensatz akzeptiert bzw. verworfen werden.

Wird eine "Wheel"-Maus verwendet, so können die Daten in dem Datengitter mit dem Mausrad vertikal bewegt werden, sobald sich der Mauszeiger über dem Datengitter befindet.

Weitere Details:

Veranstaltungsdaten

Klassendaten


Veranstaltungsdaten

Im oberen Teil des Fensters "Klassen" werden Daten über die Veranstaltung erfasst.

Oben links befinden sich Eingabefelder für den Namen und das Datum der Veranstaltung und den Namen des Wettfahrtleiters. Falls unter "Optionen" aktiviert, erscheint hier auch ein Feld zur Eingabe des Obmanns des Schiedsgerichts . Die Felder für Wettfahrtleiter und Schiedsrichter sind so groß gehalten, dass zusätzlich zum Namen auch eine Club-Abkürzung (z.B. Hans Mustermann / SCX) eingegeben werden kann.


Klassendaten

Der Hauptteil dieses Fensters "Klassen" dient der Definition der Wertungsklassen.

Im folgenden sollen die einzelnen Eingabefelder besprochen werden: Ein Mausklick auf den Plus-Schalter erzeugt einen neuen, leeren Datensatz. Als erstes wird die Nummer der neuen Wertungsklasse (KlNr) eingegeben. Gültige Werte sind die Ziffern 1 bis 15. Eingaben außerhalb dieses Wertebereichs werden mit einem Hinweis zurückgewiesen. Die KlNr muss eindeutig sein. Wird eine schon existierende KlNr eingegeben, so wird diese mit einem Hinweis zurückgewiesen. Mit der Tab-Taste oder Enter-Taste (natürlich auch mit der Maus) kann man zum nächsten Feld springen.

Wichtig ist es zu verstehen, dass WinRegatta die Eingabe in ein Feld erst dann als beendet betrachtet, wenn der Anwender dieses Feld verläßt. Erst dann erfolgt die Prüfung und Verarbeitung der eingegebenen Daten.

Beim Verlassen des KlNr-Feldes werden in die meisten anderen Felder schon Standardwerte eingesteuert, die bei Bedarf geändert werden können. In dem Feld "Klassen-Name" wird eine sinnvolle Bezeichnung für die Wertungsklasse eingegeben, z.B. "Zugvogel RL-Regatta".

Die meisten anderen Felder haben vorgegebene Eingabewerte, die eine Fehleingabe unmöglich machen:

  • Wertungs-Art :
    Klassen-Wertung;
    Yardstick-Wertung;
    Yardstick/Strom;
    Känguruh-Start; Neu in Vers. 4.2
    ORC-Club Zeit/Zeit (nur WinRegatta Plus)
    ORC-Club Zeit/Distanz (nur WinRegatta Plus)

  • Ergebnis-Art:
    Rangplatz;
    Gestoppte Zeit;
    Uhrzeit
    Indiv. Startzeit Neu in Vers. 4.4b

  • Punkt-System:
    LPS = Low-Point-System; BPS = Bonuspunkt-System.

  • Ranglisten-Wertung:
    Aktiviert = Ranglisten-Punkte werden berechnet.

  • Ranglisten-Faktor:
    Werte 1,00 bis 1,60 (gilt normalerweise nur für Ranglisten-Regatten).

  • Crew-Stärke:
    1 bis 3 und für die Plus-Version 1 bis 6 (bei der Seglereingabe werden entsprechende Eingabefelder bereitgestellt).

  • Jahrgang:
    Aktiviert = bei der Seglereingabe wird das Geburtsdatum oder das zweistellige Geburtsjahr erfasst (abhängig von der Einstellung unter "Optionen").

  • Pri/Sek:
    P = Primär-Wertungsklasse; S = Sekundär-Wertungsklasse.

  • Team-Wertung: Neu in Vers. 4.6
    Aktiviert = diese Klasse gehört zu einer Team-Wertung. Boote dieser Klasse können in bis acht Teams eingeteilt werden, die dann gegeneinander segeln.
  • Gruppen-Wertung:
    Aktiviert = diese Klasse gehört zu einer Gruppenwertung. Nur WinRegatta Plus.

  • MO-F Wertung:
    Aktiviert = diese Klasse gehört zu einer Wertung "Meisterschafts-Ordnung für olympische Klassen". Nur WinRegatta Plus.

Wettfahrtergebnisse können später nur für primäre Klassen eingegeben werden. Mit einer sekundären Klasse kann eine Sekundär-Wertung vorgenommen werden, ohne zusätzlich Ergebnisdaten eingeben zu müssen. Z.B. kann eine Primär-Wertung die gesamte Zugvogel RL-Regatta auswerten und eine Sekundär-Wertung nur die Senioren dieser Klasse als Untermenge auswerten.

Die Spalte "Segler" enthält die Anzahl der Segler, die der Klasse zugeordnet wurden. Dieser Wert wird von WinRegatta ermittelt und hier eingestellt.

All diese Klassendaten werden in der Datei "*.K48" gespeichert.
Nachdem die Wertungsklassen definiert wurden, kann die Eingabe der Seglerdaten beginnen.


Funktion "Segler"

Im Fenster "Segler" werden die Meldedaten der Segler erfasst.

Wichtig: Für WinRegatta ist die Eingabe in ein Feld erst dann beendet, wenn der Anwender dieses Feld verläßt. Erst dann erfolgt die Prüfung und Verarbeitung der eingegebenen Daten.

Im Feld oben links wird die Nummer der Wertungsklasse eingegeben, für die nun Segler erfasst werden sollen. Die Zuordnung der Segler zu der hier gewählten Klasse geschieht automatisch. Es kann aber auch ein "A" für "Alle Klassen" eingegeben werden. In diesem Falle können die Segler gemischt für unterschiedliche Klassen erfasst werden. Die Zuordnung des Seglers zu einer Klasse muss nun aber manuell durch Eingabe der entsprechenden Klassennummer in dem Feld "P" (Primär-Klasse) geschehen.

Durch Doppelklick auf das KlNr-Feld wird eine Liste aller definierten Klassen gezeigt, aus der alternativ die gewünschte Klasse durch Anklicken gewählt werden kann. In dem Feld "Klassen-Name" wird der Name der gewählten Klasse angezeigt. Dies ist ein "Nur-Lese-Feld", d.h. eine Tastatureingabe ist hier nicht möglich. Die für die gewählte Klasse bereits erfassten Segler werden im Datengitter angezeigt und können ergänzt oder geändert werden.

Hinweis: Die prinzipiellen Aussagen im Abschnitt "Funktion Klassen" über Datengitter, Eingabefelder und Navigationstasten gelten auch für die Seglereingabe.

Im unteren Bereich des Bildschirms werden nur die Eingabefelder sichtbar bzw. aktiv gestellt, die entsprechend der gewählten Wertungsklasse benötigt werden. Z.B. werden abhängig von der Mannschaftsstärke Felder für den Vorschoter und das 3. Mannschaftsmitglied aktiviert oder gesperrt. Das gleiche gilt für den Geburtsjahrgang bzw. das Geburtsdatum der Segler. Die Felder Bootstype und Yardstick werden nur aktiviert, wenn für die Klasse die Ergebnis-Art "Zeit" definiert wurde und damit eine Yardstick-Wertung möglich ist. Weitere Felder und Spalten im Datengitter werden abhängig von den gewählten Optionen aktiviert oder verborgen. Hierzu gehören das Landeskennzeichen (LK), der Yachtname, das Check-In-Zeichen und die Anzahl der Ebenen der Sekundär-Wertung.

Bitte speichern Sie in Zeitabständen die Daten über "Datei / Speichern" bzw. durch Klick auf [image] , damit Ihnen bei einem ungeplanten Systemproblem keine Daten verloren gehen.

Die eingegebenen Seglerdaten werden in der Datei "*.S48" gespeichert.

Weitere Details:

Crew-Daten eingeben

Segelclub und DSV-Nummer eingeben

Bootstyp und Yardstick eingeben

ORC-Club-Daten eingeben

Daten für Gruppenwertung

Klassenzuordnung

Startgeld, Check-In-Kennzeichen

Mehrfacheingabe gleicher Werte

Quittung für Segler

Editieren im Datengitter


Crew-Daten

Segelnummer / Landeskennzeichen (LK)

Nun sollen einige Details der Seglereingabe behandelt werden: Beginnen wir mit der Segelnummer. Diese darf max. 10 Stellen lang sein und aus alpha/numerischen Zeichen bestehen. Eine Segelnummer ggf. in Kombination mit dem LK identifiziert eine Crew und muss innerhalb einer Wertungsklasse eindeutig sein, darf also in einer Klasse nicht doppelt vorkommen. Das heißt aber auch: die gleiche Segelnummer darf mit unterschiedlichen LKs oder in verschiedenen Klassen mehrfach vorkommen.

Yachtnamen

Wenn unter Optionen die Eingabe von Yachtnamen gewählt wurde, dann wird ein entsprechendes Eingabefeld angeboten. Der Yachtname kann max. 16 Stellen betragen. Dieses Feld kann auch leer bleiben. Wichtig ist, dass auch eine Segelnummer eingegeben werden muß, da gegenüber WinRegatta eine Crew nur durch die Segelnummer (wahlweise mit LK) identifiziert wird. Wenn eine Yacht keine Segelnummer hat (z.B. bei seegängigen Yachten), dann kann ein Teil des Yachtnamens oder jede andere fiktive Bezeichnung in das Segelnummernfeld eingegeben werden.

Für den Listendruck kann gewählt werden, ob der Yachtname zusätzlich zu Land/Segelnummer gedruckt werden soll oder auch nur alleine ohne Land/Segelnummer.

Bugnummern (Neu ab Vers. 4.6)

Wenn unter Optionen die Eingabe von Bugnummern gewählt wurde, dann wird ein entsprechendes Eingabefeld angeboten. Die Segelnummern sind oft sehr lang und können durch die Segel der anderen Boote verdeckt werden. Um die Identifikation der Boote im Start-/Zielbereich zu verbessern, kann jedem Boot eine Bugnummer (eine Art Startnummer) zugeordnet werden, die am Bug der Boote angeheftet wird. Die Bugnummer kann alpha/numerische Zeichen enthalten und sollte natürlich recht kurz sein (nicht mehr als drei oder vier Stellen).

Wichtig ist, dass auch eine Segelnummer eingegebenm werden muß, da gegenüber WinRegatta eine Crew nur durch die Segelnummer (wahlweise mit LK) identifiziert wird.

Für eine Dateigruppe kann nur entweder die Funktion "Bugnummer" oder "Yachtnamen" aktiviert werden, nicht aber beides gleichzeitig.

Für den Listendruck kann gewählt werden, ob die Bugnummer zusätzlich zu Land/Segelnummer gedruckt werden soll oder auch nur alleine ohne Land/Segelnummer.

Bis zu sechs Segler pro Boot

Abhängig von der für die Klasse definierten Mannschaftsstärke (Feld "Msch" in der Klassen-Funktion) werden Eingabefelder für ein bis drei Segler pro Boot angeboten. Mit WinRegatta Plus können bis zu sechs Segler pro Boot eingegeben werden.

Seglernamen und Adressen der Steuerleute

Familienname und Vorname der Segler werden in getrennte Felder eingegeben. Dies soll die Übersichtlichkeit in der Anzeige und im Druck der Daten verbessern. Mit einem Doppelklick auf die Namensfelder des Steuermanns kann die Anschrift dieses Seglers (so bekannt) eingegeben werden. Im Feld "Sonstiges" können beliebige Infos über den Segler oder das Boot gespeichert werden. Die Anschriftsdaten können später z.B. verwendet werden, um den Segler wieder zu einer Regatta einzuladen (Serienbrief). Alle Daten werden auch in die Segler-Stammdatei übernommen.

Geburtsdaten

Wenn für die gewählte Klasse die Erfassung von Geburtsdaten gewünscht wurde, werden die Felder "JG" bzw. "Geb.-Dat" (abhängig von "Optionen") angeboten, und die beiden letzten Stellen des Jahrgangs bzw. das volle Geburtsdatum können eingegeben werden. Dies hat keine unmittelbar steuernde Wirkung, sondern soll nur bei der Anzeige und beim Druck der Daten diese Info bereitstellen, wenn z.B. abhängig vom Alter der Segler besondere Wertungen vorgenommen werden (Junioren, Senioren).


Club und DSV-Nummer

In dem Club-Feld wird die Segelclub-Abkürzung des Seglers eingegeben. WinRegatta durchsucht dann die Club-Datenbank. Ist dieser Club darin bereits gespeichert, wird die zugehörige DSV-Nr. geholt und in das DSV-Nr-Feld eingesteuert. Wird die Clubabkürzung nicht gefunden, so wird eine Auswahlliste angeboten, aus der der Anwender den gewünschten Club wählen kann.

Mit Doppelklick auf das Club-Feld erscheint eine Liste aller gespeicherten Clubs, und der gewünschte Club kann hier mit Mausklick ausgewählt werden. Wird vor dem Doppelklick eine Clubabkürzung oder ein Teil einer Abkürzung in das Club-Feld eingegeben, so erscheinen in der Liste nur die Clubs, die alphabetisch gleich oder größer sind.

Während die DSV-Nummern eindeutig sind, können Segelclub-Abkürzungen mehrfach vorkommen. Wird eine Clubabkürzung eingegeben, die es mehrfach gibt, so erscheint eine Liste dieser gleichen Clubs, und es kann der richtige ausgewählt werden.
Neu ab Vers. 4.6: Wenn häufig eine Clubabkürzung gewählt wird, die mehrfach vorkommt (z. B. wenn es der eigene Club ist), dann ist der Umweg über die Auswahlliste recht lästig. Abhilfe: In der Funktion "Clubs" kann der normalerweise gewünschte Club in der ersten Stelle des Feldes "Bemerkungen" mit "#" gekennzeichnet werden. Bei der Seglereingabe wird dieser Club dann - ohne Umweg über die Auswahlliste - direkt eingesteuert. Mit Doppelklick auf das Clubfeld kann jede andere der gleichnamigen Clubabkürzungen gewählt werden.

Neu ab Vers. 4.6 In der Auswahlliste wurde unten links der Schalter "Neuer Club" eingefügt. Durch einen Klick auf diesen Schalter erscheint ein kleines Eingabefenster zum Speichern eines neuen Clubs in der Club-Datenbank.

Durch Eingabe der DSV-Nr. in das entprechende Feld, wird die zugehörige Clubabkürzung in der Club-Datenbank gesucht und in das Club-Feld eingesteuert.Diese Clubsuche mittels der DSV-Nr gilt nicht für die Eingabe im Datengitter, sondern nur für die Eingabefelder unterhalb des Datengitters.

Für Ranglisten-Regatten und Meisterschaften erwartet der DSV Ergebnislisten, die die DSV-Nummern der Segler ausweisen, da nur so der Club eindeutig identifiziert wird. Bei lokalen Regatten dagegen, kann es sinnvoll sein, auf die DSV-Nummer zu verzichten. Unter Optionen kann deshalb "DSV-Nr unterdrücken" gewählt werden. In diesem Falle werden bei der Eingabe der Seglerdaten die DSV-Felder und -Spalten verborgen. Bei der Eingabe einer Clubabkürzung erfolgt dann keine Suche der DSV-Nummer. Mit Doppelklick auf das Club-Feld erscheint nach wie vor eine Auswahlliste der Segelclubs. Die DSV-Nummer des gewählten Clubs wird aber ignoriert. Wenn das Club-Feld eines Seglers geändert wird, so wird eine eventuell gespeicherte DSV-Nummer gelöscht, um fehlerhafte Kombinationen von Club und DSV-Nummer zu vermeiden.

Wenn die Option "DSV-Nr unterdrücken" gewählt wurde, dann werden auf allen Melde- und Ergebnislisten und in den Text- und HTML-Dateien die DSV-Nummern unterdrückt. Dies führt zu mehr Übersichtlichkeit.


Bootstyp und Yardstick

Die Eingabe der Bootstypen und die entsprechende Einsteuerung des Yardsticks wird abhängig von der gewählten Wertungsklasse unterschiedlich behandelt.

Wahl einer Einzelklasse oben links im Feld "KlNr":
Für Klassen mit der Ergebnisart "Gestoppte Zeit" oder "Uhrzeit" werden die Felder "Boots-Typ" und "Yst" angeboten. Das gleiche gilt für Klassen mit der Wertungs-Art "Känguruh-Start", obwohl hier die Ergebnis-Art "Rangplatz" ist. Der Känguruh-Start benötigt ja den Yardstick zur Berechnung des Start-Intervals der Boote.

Nach der Eingabe eines Bootstyps durchsucht WinRegatta die Boote-Datenbank. Ist dieser Bootstyp darin bereits gespeichert, wird die zugehörige Yardstickzahl geholt und in das Yardstick-Feld eingesteuert. Wird der Bootstyp nicht gefunden, so wird eine Auswahlliste angeboten, aus der der Anwender den gewünschten Bootstyp wählen kann.

Mit Doppelkick auf das Feld Boots-Typ erscheint eine Liste der gespeicherten (und aktivierten) Bootstypen, und der gewünschte Typ kann hier mit Mausklick ausgewählt werden. Ansonsten gilt hier die gleiche Logik, wie im Abschnitt "Club und DSV-Nummer " beschrieben.

Im Unterschied zu den Club-Abkürzungen sind die Bezeichnungen der Bootstypen viel länger und unsystematischer. Es besteht hier die Gefahr, dass der eingetippte Bootstyp nicht gefunden wird, nur weil die Schreibweise, unter der er in der Boote-Datei gespeichert ist, sich leicht von dem unterscheidet, was eingetippt wurde. Hier gilt die Empfehlung, die Bootstypen möglichst nur über die Auswahlliste zu wählen.

Wenn mit Doppelklick auf das Feld Boots-Typ die Auswahlliste wirklich alle gespeicherten Bootstypen (über 1800) zeigen würde, dann wäre es schwierig, den gesuchten Typ in der Liste zu finden. Man sähe den Wald vor lauter Bäumen nicht, da bestenfalls 5% aller Bootstypen an Regatten eines bestimmten Clubs teilnehmen. Um hier eine bessere Übersicht zu erhalten, werden die Typen, die im Einzelfall interessant sind, in der Funktion "Boote " markiert. Nur Bootstypen, die in der linken Spalte mit einem "x" gekennzeichnet wurden, gelten als aktiv und werden bei der Segler-Eingabe in der Auswahlliste gezeigt.

Das Yardstick-Feld ist ein "Nur Lesen"-Feld. Yardstickzahlen können hier also nicht direkt eingegeben werden, sondern müssen durch die richtige Wahl des Bootstyps aus der Datenbank geholt werden.

Wahl "A" für "Alle Klassen" oben links im Feld "KlNr":
In diesem Falle werden im Datengitter alle Segler angezeigt, die in der geöffneten Dateigruppe gespeichert sind. Und zwar Segler, die bestimmten Wertungsklassen zugeordnet wurden und auch Segler, die noch keiner Klasse zugeordnet wurden (das "P"-Feld ist leer). Die Felder "Boots-Typ" und "Yst" werden hier immer angeboten, so dass für alle Segler ein Bootstyp eingegeben werden kann, auch wenn der Segler noch keiner Klasse zugeordnet wurde. Bis einschließlich WinRegatta Version 4.3 wurde bei der Eingabe eines Bootstyps auch zwangsweise der entsprechende Yardstick eingesteuert.

Neu ab Vers. 4.4: Für Segler, die zu einer Klasse mit der Ergebnisart "Gestoppte Zeit" oder "Uhrzeit" oder der Wertungs-Art "Känguruh-Start" gehören, wird - wie bisher - bei der Eingabe eines Bootstyps zwangsweise der entsprechende Yardstick eingesteuert. Bei Seglern, die zu einer Klasse mit Ergbnis-Art "Rangplatz" oder Wertungs-Art "ORC-Club" gehören oder noch keine Klassenzuordnung haben, wird bei der Eingabe eines Bootstyps kein Yardstick gesucht und eingesteuert. Hier ist die Schreibweise des eingegebenen Bootstyps auch ohne Bedeutung.

Diese Neuerung erlaubt es, Segler zur Orientierung mit einem Bootstyp zu kennzeichnen, ohne dass zwangsweise die Boote-Datei nach einem Yardstick durchsucht wird. Zum Beispiel, kann man die Opti-Segler mit "Opti A" oder "Opti B" kennzeichnen, obwohl der offizielle Bootstyp in der Yardstick-Tabelle "Optimist" heißt. Bei einem Import von Meldedaten kann ein solcher Bootstyp auch importiert werden, zur besseren Orientierung bei der späteren Klassenzuordnung der Segler.

Neu ab Vers. 4.4a: Unter "Optionen / Daten-Konfiguration" wurde die neue Funktion "Yardstick immer einsteuern" eingefügt. Wird diese Option aktiviert, so wird bei der Eingabe eines Bootstyps zwingend der Yardstick gesucht und eingesteuert. WinRegatta verhält sich also wie vor der Version 4.4.

Wird diese Option deaktiviert, so wird bei der Eingabe eines Bootstyps der Yardstick nur für Segler, die zu einer Klasse mit der Ergebnisart "Gestoppte Zeit" oder "Uhrzeit" oder der Wertungs-Art "Känguruh-Start" angehören, gesucht und eingesteuert. WinRegatta verhält sich wie in der Version 4.4 eingeführt.

Mit dieser Option kann der Anwender zwischen der alten und der neuen Funktionalität der Yardstick-Suche und -Einsteuerung wählen.

Neu ab Vers. 4.6: In der Auswahlliste wurde unten links der Schalter "Neuer Bootstyp" eingefügt. Durch einen Klick auf diesen Schalter erscheint ein kleines Eingabefenster zum Speichern eines neuen Bootstyps in der Boote-Datenbank. Außerdem kann gewählt werden, ob alle Bootstypen oder nur die mit "x" aktivierten Bootstypen angezeigt werden sollen. Zusätzlich kann gewählt werden, dass ein gefundener Bootstyp automatisch aktiviert wird (in der Boote-Datenbank ein "x" erhält).

Individuelle Anpassung des Yardsticks:
Bei Yardstick-Regatten wird häufig eine individuelle Anpassung des Yardsticks vorgenommen, um Abweichungen eines Bootes vom Standard der Bootsklasse auszugleichen (z. B. +1, wenn kein Spi gefahren wird oder -1 für Faltpropeller, wenn Festpropeller Standard ist). Diese Funktion muß über "Optionen / Daten-Konfiguration " durch Anklicken von "Individuelle Yardstick-Korrektur" aktiviert werden. Bei der Segler-Eingabe werden bei Klassen mit der Ergebnisart "Gestoppte Zeit" oder "Uhrzeit" dann zwei zusätzliche Eingabefelder angeboten: Das Feld "YK" zur Eingabe der Yardstick-Korrektur im Wertebereich von -1 bis -9 und +1 bis +9. Im Eingabefeld "YK-Grund" kann der Grund für die Yardstick-Korrektur (z. B. "ohne Spi" oder "Faltpropeller") eingegeben werden. Bei der Wertung werden die Korrekturwerte berücksichtigt und auf den Melde- und Ergebnislisten erscheinen entsprechende Hinweise.


Yachtnamen oder Bugnummer

Yachtnamen oder Bugnummern

Yachtnamen

Wenn unter Optionen die Eingabe von Yachtnamen gewählt wurde, dann wird ein entsprechendes Eingabefeld angeboten. Der Yachtname kann max. 16 Stellen betragen. Dieses Feld kann auch leer bleiben. Wichtig ist, dass auch eine Segelnummer eingegeben werden muß, da gegenüber WinRegatta eine Crew nur durch die Segelnummer (wahlweise mit LK) identifiziert wird. Wenn eine Yacht keine Segelnummer hat (z.B. bei seegängigen Yachten), dann kann ein Teil des Yachtnamens oder jede andere fiktive Bezeichnung in das Segelnummernfeld eingegeben werden.

Für den Listendruck kann gewählt werden, ob der Yachtname zusätzlich zu Land/Segelnummer gedruckt werden soll oder auch nur alleine ohne Land/Segelnummer.

Bugnummern (Neu ab Vers. 4.6)

Wenn unter Optionen die Eingabe von Bugnummern gewählt wurde, dann wird ein entsprechendes Eingabefeld angeboten. Die Segelnummern sind oft sehr lang und können durch die Segel der anderen Boote verdeckt werden. Um die Identifikation der Boote im Start-/Zielbereich zu verbessern, kann jedem Boot eine Bugnummer (eine Art Startnummer) zugeordnet werden, die am Bug der Boote angeheftet wird. Die Bugnummer kann alpha/numerische Zeichen enthalten und sollte natürlich recht kurz sein (nicht mehr als drei oder vier Stellen).

Wichtig ist, dass auch eine Segelnummer eingegeben werden muß, da gegenüber WinRegatta eine Crew nur durch die Segelnummer (wahlweise mit LK) identifiziert wird.

Für eine Dateigruppe kann nur entweder die Funktion "Bugnummer" oder "Yachtnamen" aktiviert werden, nicht aber beides gleichzeitig.

Für den Listendruck kann gewählt werden, ob die Bugnummer zusätzlich zu Land/Segelnummer gedruckt werden soll oder auch nur alleine ohne Land/Segelnummer.

Ergebniseingabe nach Bugnummern (Neu ab Vers. 4.7b)

Wenn unter Optionen die Verwendung von Bugnummern gewählt wurde, dann kann in der Funktion "Ergebnisse" die Eingabe von Ergebnissen nach Bugnummern statt nach Segelnummern erfolgen.

Beispiel Yachtname_Bugnummer


ORC-Club-Daten

Nur WinRegatta Plus:

  • Wenn bei der Klassendefinition unter Wertungs-Art " ORC-Club Zeit/Zeit" eingegeben wurde, so wird bei der Seglereingabe anstelle des Yardstick-Feldes das "TMF"-Feld angeboten zur Eingabe des TMF-Faktors (z. B. 0,8695) für dieses Boot.
  • Wenn bei der Klassendefinition unter Wertungs-Art " ORC-Club Zeit/Distanz" eingegeben wurde, so werden bei der Seglereingabe Eingabefelder für die Faktoren "GPH" (z. B. 788,4), "PLT" (z. B. 0,712) und "PLD" (z. B. 230,1) für diese Yacht angeboten.

Siehe auch
Regeln der Wertung

Beispiel ORC-Club-Wertung


Daten für Gruppenwertung

Nur WinRegatta Plus:
Wenn bei der Klassendefinition Gruppenwertung (Gr-W) aktiviert wurde, so wird das Feld "Quali" zur Eingabe des Qualifikationsranges angeboten. Als Qualifikationsrang kann z.B. der Rang des Seglers in der Aktuellen Rangliste eingegeben werden. Dieser Wert wird für die erste Gruppeneinteilung der Segler für eine Gruppenwertung verwendet.


Klassenzuordnung

In den Feldern "P" und "S1" bis "S5" erfolgt die Zuordnung der Segler zu den Wertungsklassen.

"P" bedeutet die Zuordnung zu einer Primär-Klasse. Optional können die Segler über "S1" bis "S5" zusätzlich zu bis zu fünf Sekundär-Klassen für Sekundär-Wertungen zugeordnet werden.

Die Zuordnung zu einer Primär-Klasse ist für jede Crew zwingend, um diese Crew für die spätere Ergebniseingabe und Wertung zu aktivieren. Wenn keine Primär-Klasse eingegeben wird, dann bleibt die Crew mit all den eingegebenen Daten zwar gespeichert, sie wird aber als inaktiv betrachtet. Eine Aktivierung kann später jederzeit durch Zuordnung zu einer Primär-Klasse vorgenommen werden.

Wenn für die Seglereingabe eine einzelne Klasse gewählt wurde, dann wird diese Klassennummer in das Feld "P" automatisch eingesteuert. Wurde "A" für "Alle Klassen" gewählt, so muss in das Feld "P" eine Klassennummer manuell eingegeben werden. Durch Doppelklick auf das Feld "P" erscheint eine Auswahlliste mit allen primären Wertungsklassen, und durch Doppelklick auf die Felder "S1" bis "S5" wird eine Auswahlliste mit allen sekundären Wertungsklassen gezeigt. Wenn später die Zuordnung einer Crew zu einer Primär-Klasse geändert werden soll, so ist "A" für alle Klassen zu wählen, damit alle Segler angezeigt werden. Jetzt kann in dem Feld "P" die Klassen-Zuordnung für die ausgewählte Crew geändert werden. Über die Funktion "Optionen " kann die Anzahl der Ebenen der Sekundär-Wertung für eine Veranstaltung festgelegt werden. Entsprechend werden die Felder "S1" bis "S5" angeboten oder verborgen.


Meldegeld, Check-In-Kennzeichen

Meldegeld und Zahlungsart

Die Felder "M-Geld" und "Z-Art" dienen der Erfassung des Meldegeldes und der Zahlungsart.
Die Bedeutung der Zahlungsart-Abkürzungen: "B" = Bar; "S" = Scheck; "U" = Überweisung; "F" = vom Meldegeld befreit.
Hinweis: Ein Meldegeldbetrag ohne Zahlungsart wird in der Meldegeldabrechnung in der Spalte "Bar" aufsummiert.

Nachmeldegeld (Neu ab Vers. 4.7)

Ab der Version 4.7 kann wahlweise das Nachmeldegeld zusätzlich zum normalen Meldegeld erfasst werden.

Unter " Optionen " kann die Erfassung des Nachmeldegeldes aktiviert werden. Wenn aktiviert, dann werden bei der Seglereingabe zwei zusätzliche Felder "NM-Geld" und "ZA" zur Eingabe des Nachmeldegeldes und der Zahlungsart angeboten.

Auf den Listen "Quittung für Segler" und "Meldegeld-Abrechnung" wird das Nachmeldegeld gesondert ausgewiesen.

Check-In-Kennzeichen

Für grössere Veranstaltungen empfiehlt es sich, im Feld "Ch-In" ein Check-In-Kennzeichen für Segler einzugeben, nachdem sie das Meldebüro vollständig durchlaufen haben (Meldekarte vollständig, Startgeld bezahlt, Segelanweisung erhalten). Hierdurch kann die Übersicht für das Meldebüro erhöht werden. Es besteht ebenfalls die Möglichkeit, durch entsprechende Eingaben die ordnungsgemässe Meldekarte und die Ausgabe der Segelanweisung zu registrieren. Diese Daten erscheinen dann beim Druck der "Check-Liste für Meldebüro" und "Checkliste für den Start". Bei kleinen und mittleren Veranstaltungen ist die PC-gestützte Verwaltung des Check-Ins wohl nicht nötig. In diesem Falle können diese Felder über die Funktion " Optionen " verborgen werden.


Mehrfacheingabe gleicher Werte

Neu ab Vers. 4.4

In der Funktion "Segler" können mit der Taste "Segler Multi-Auswahl" gleiche Werte für alle markierten Seglersätze gleichzeitig eingegeben werden.
Dies gilt für alle Spalten, in denen üblicherweise gleiche Werte vorkommen und zwar für die Spalten "P" (Primärklasse) bis "Check-In".

Mit folgenden Bedienungsschritten wird eine Mehrfacheingabe erreicht:

  • In der Funktion "Segler" die gewünschte Klassennummer oder "A" für "Alle Klassen" wählen.
  • Auf den Schalter "Segler Multi-Auswahl" klicken.
  • Die Sätze markieren, für die gleiche Werte eingegeben werden sollen. Die Eingabefelder, bei denen Mehrfacheingaben möglich sind, sind jetzt aktiv.
  • Jetzt in dem entsprechenden Eingabefeld den Wert eingeben. Es können auch Werte in mehreren Eingabefeldern gleichzeitig eingegeben werden.
  • Der Schalter mit dem Häkchen (akzeptieren) unten links ist jetzt aktiv. Klick auf dieses Häkchen akzeptiert die Eingaben und kopiert die eingegebenen Werte in alle markierten Sätze.
  • Es werden nur neu eingegebene Werte in die markierten Sätze kopiert. Werte, die vorher schon in diesen Feldern enthalten waren, werden nicht berücksichtigt.
  • Wenn eine Primärklassennummer auf diese Weise kopiert wird, dann erfolgt eine Prüfung auf doppelte Segelnummern mit gleichem Landeskenner in der gleichen Klasse. Sollte dies der Fall sein, erfolgt eine Fehlermeldung, und das Speichern der doppelten Segelnummer wird verweigert.


Segler-Quittung

Oft fordern die Segler eine Quittung, in der die Teilnahme an der Regatta und das gezahlte Meldegeld und ggf. das Nachmeldegeld bescheinigt werden. Da diese Quittung meistens wohl während der Abfertigung des Seglers im Meldebüro verlangt wird, wird der Quittungsdruck für den markierten Segler in der Funktion "Segler" über das Menü "Bearbeiten / Quittung" bzw. mit Klick auf [image] ausgelöst.
Mit Klick auf [image] können mittels der Shift- und Strg-Taste mehrere Segler gleichzeitig markiert werden, für die dann die Quittungen gedruckt werden.


Editieren im Datengitter

Ab WinRegatta Version 3 hat das Datengitter zusätzliche Funktionen erhalten:

Daten sortieren

Mit Mausklick auf den Spaltenkopf kann nach jeder Spalte aufsteigend sortiert werden. Ein zweiter Klick auf den Kopf der gleichen Spalte sortiert die Daten in absteigender Folge. Für die normale Bearbeitung wird empfohlen, nach "Segel-Nr" zu sortieren.

Editieren im Datengitter

  • Mit Klick auf [image] wird dieser Modus eingeschaltet. Dies erlaubt das direkte Eingeben und Ändern der Daten im Datengitter. Dies beinhaltet auch die Suche von Clubs und Bootstypen mit Doppelklick auf die entsprechende Datenzelle in der Club- bzw. Boot-Spalte. Bei der Eingabe von Daten kann auch freizügig zwischen dem Datengitter und den unteren Eingabefeldern gewechselt werden. Das Arbeiten im Datengitter ist vor allem vorteilhaft, wenn in einer Spalte mehrere Zeilen editiert werden sollen, weil mit den Pfeiltasten der Tastatur leicht navigiert werden kann.
  • Mit dem Scrollbalken kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste, den Pfeiltasten der Tastatur erfolgt die Auswahl der Zelle im Datengitter.
  • Die Daten der ausgewählten Zelle können geändert werden.
  • Die geänderten Daten werden akzeptiert durch Verlassen der Zeile oder durch Klick auf [image] unten links. Die geänderten Daten werden verworfen mit der Esc-Taste oder durch Klick auf [image] unten links.
  • Ein neuer Datensatz wird erzeugt durch Klick auf [image] oder mit der Einfg-Taste.
  • Der ausgewählte Satz wird gelöscht durch Klick auf [image] unten links oder durch gleichzeitige Betätigung der Tasten Strg und Entf.
  • Mit Klick auf [image] können alle Segler der ausgewählten Klasse gelöscht werden. Wurde "A" für "Alle Klassen" gewählt, so werden alle Segler der Veranstaltung (Dateigruppe) gelöscht.

Suchmodus

  • Mit Klick auf [image] wird dieser Modus eingeschaltet.
  • Mit dem Scrollbalken kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Den Suchbegriff an beliebiger Stelle in der Spalte eingeben, in der gesucht werden soll. Es erfolgt eine "Inkrementelle Suche".
  • Mit Klick auf [image] oder durch gleichzeitige Betätigung der Tasten Strg und Entf kann der ausgewählte Segler gelöscht werden.
  • Mit Klick auf [image] können alle Segler der ausgewählten Klasse gelöscht werden. Wurde "A" für "Alle Klassen" gewählt, so werden alle Segler der Veranstaltung (Dateigruppe) gelöscht.

Einzel-Auswahl

  • Mit Klick auf [image] wird der Modus "Einzel-Auswahl" aktiviert. In diesem Modus können die Daten der ausgewählten Crew nur in den Feldern unterhalb des Datengitters eingegeben bzw. geändert werden. Ein Editieren im Datengitter ist hier nicht möglich.
  • Mit dem Scrollbalken kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste und den vertikalen Pfeiltasten erfolgt die Auswahl der Zeilen.
  • Mit den horizentralen Pfeiltasten werden die Spalten horizontal verschoben.
  • Ein neuer Datensatz wird erzeugt durch Klick auf [image] oder mit der Einfg-Taste.
  • Mit Klick auf [image] oder durch gleichzeitige Betätigung der Tasten Strg und Entf kann die ausgewählte Crew gelöscht werden.
  • Mit Klick auf [image] können alle Segler der ausgewählten Klasse gelöscht werden. Wurde "A" für "Alle Klassen" gewählt, so werden alle Segler der Veranstaltung (Dateigruppe) gelöscht.
Multi-Auswahl
  • Mit Klick auf [image] wird der Modus "Multi-Auswahl" aktiviert. In diesem Modus sind die Eingabefelder gesperrt. Es können somit keine Daten eingegeben werden. In diesem Modus können mehrere Crews gleichzeitig ausgewählt werden, um sie z. B. zu löschen.
  • Mit dem Scrollbalken kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste und den vertikalen Pfeiltasten erfolgt die Auswahl der Zeilen.
  • Mit den horizentralen Pfeiltasten werden die Spalten horizontal verschoben.
  • Mit Mausklick und Shift- oder Strg-Taste können mehrere Zeilen ausgewählt werden.
  • Mit Klick auf [image] oder durch gleichzeitige Betätigung der Tasten Strg und Entf können die ausgewählten Crews gelöscht werden.
  • Mit Klick auf [image] können alle Segler der ausgewählten Klasse gelöscht werden. Wurde "A" für alle Klassen gewählt, so werden alle Segler der Veranstaltung (Dateigruppe) gelöscht.
Die eingegebenen Seglerdaten werden in der Datei "*.S48" gespeichert.


Funktion "Ergebnisse"

Die eingegebenen Ergebnisdaten werden in der Datei "*.E48" gespeichert.

Ergebnisse für einzelne Klasse und Wettfahrt eingeben

Im Fenster "Ergebnisse" werden die gesegelten Ergebnisse der Segler erfasst. Ergebnisse können nur für Primär-Klassen eingegeben werden. Für die Wertung einer sekundären Klasse (Sekundär-Wertung) werden die eingegebenen Ergebnisse der primären Klasse des Seglers herangezogen. Die Ergebniseingabe geschieht pro Wertungsklasse und Wettfahrt. Im Feld "Kl-Nr" oben links wird die Nummer der primären Wertungsklasse eingegeben. Durch Doppelklick auf das KlNr-Feld wird eine Liste aller definierten primären Klassen gezeigt, aus der alternativ die gewünschte Klasse durch Anklicken gewählt werden kann. Der Name dieser Klasse wird zur Information im Feld rechts daneben angezeigt. Im Feld "Wf-Nr" wird die Wettfahrt gewählt, für die die Ergebnisse erfasst werden sollen. Nun werden im Datengitter die Segler der gewählten Klasse mit ihren möglicherweise schon eingegebenen Ergebnissen der gewählten Wettfahrt angezeigt.

Ergebnisse für mehrere Klassen gemischt eingeben

Oft starten mehrere Startgruppen auf einer Bahn in zeitlichen Abständen von normalerweise 5 Minuten. In einer Startgruppe befinden sich Segler einer Wertungsklasse oder auch mehrerer Wertungsklassen. Die Segler erreichen gemischt das gleiche Ziel. Da macht es Sinn, die Ergebnisse ebenfalls gleichzeitig für mehrere Klassen einzugeben. Dies kann geschehen, indem im Feld "Kl-Nr" nicht die Nummer einer einzelnen Klasse, sondern "M" für Mehrere Klassen eingegeben wird. Dies wird übrigens auch mit Doppelklick auf das "KlNr"-Feld erreicht. Dann erscheint eine Auswahlliste aller primären Klassen und "M" für mehrere Klassen. Wenn "M" gewählt wird, können in einem Dialogfenster die Klassen, für die die Ergebnisse gemischt eingegeben werden sollen, bestimmt werden. Die gewählten Klassennummern werden im Feld "Klassen-Name" angezeigt, und die Segler dieser Klassen erscheinen im Datengitter.

WinRegatta bietet unterschiedliche Funktionen zur Ergebniseingabe an:

Rangeingabe nach Segelnummern

Rangeingabe nach Zieleinlauf

Eingabe gesegelte Zeit


Rang nach Segelnummern

Rangeingabe nach Segelnummern

Nachdem die Klasse(n) und Wettfahrt gewählt wurden, für die Ergebnisse eingegeben werden sollen, werden die Segler dieser Klasse sortiert nach Segelnummern. im Datengitter angezeigt. Abhängig davon, wie die Ergebnisart für diese Klasse definiert wurde (siehe Eingabe Klassendaten ), werden Felder für Rangeingabe oder für Zeiteingabe angeboten.

Rangeingabe

Im Feld "Rang" wird der gesegelte Rang eingegeben. Wenn dieser Rangplatz schon für einen anderen Segler dieser Klasse und Wettfahrt eingegeben wurde, so fragt WinRegatta, ob dieses als Totes Rennen gewertet werden soll. Bei einer Ja-Antwort wird es als Totes Rennen übernommen und im Wertungslauf gibt es eine Platz- und Punkte-Teilung der betroffenen Segler. Wird das Tote Rennen verneint, dann wird gefragt, ob dieser Rang eingefügt werden soll. Antwortet der Anwender hier mit ja, so wird der Rang eingefügt, d.h. alle Ränge, die gleich oder größer sind, werden um eins erhöht. Wird ein Rangplatz eingegeben, der größer ist als die Zahl der gemeldeten Segler dieser Klasse, so erhält der Anwender eine Warnung. Wird ein eingegebener Rang gelöscht, so fragt WinRegatta, ob die hierdurch entstandene Lücke geschlossen werden soll. Bei einer Ja-Antwort werden alle Ränge größer als der gelöschte Rang um eins reduziert.

Suche Segelnummer bei großen Starterfeldern

Bei einem zahlenmäßig großen Starterfeld ist es möglicherweise schwierig, den Segler in dem Datengitter zu finden, dessen Ergebnis als nächstes eingegeben werden soll. Durch Eingabe der Segelnummer im Feld "Suche S-Nr" wird zu dem entsprechenden Segler gesprungen, sobald das Feld mit der Tab- oder Enter-Taste verlassen wird. Ein Feld für den Landeskenner (LK) gibt es hier nicht. Denn wenn eine Segelnummer eingegeben wird, die bei unterschiedlichen LKs oder in verschiedenen Klassen mehrfach vorkommt, so wird ein Auswahlfenster angeboten, zur Wahl des richtigen Seglers.

Tip: Das Suchfeld mit Tab oder Enter verlassen und nach Eingabe des Ergebnisses dieses Seglers auch das Ergebnisfeld mit Tab oder Enter verlassen (keine Maus benutzen). Dadurch wird automatisch wieder das Suchfeld angesprungen.

Eingabe von DNC, DNF, OCS usw.

Sind Besonderheiten im Ergebnis für einen Segler einzugeben, so kann dies im Feld "DNF.." geschehen. Für die Eingabe dieser Besonderheiten ist es sinnvoll die Sortierung der Daten im Datengitter von "Segel-Nr." nach "Rangfolge" zu ändern. Bei einer Sortierung nach Rangfolge erscheinen alle Segler, die noch kein Ergebnis haben, nämlich ganz oben im Datengitter. Die Sortierung erfolgt durch Klick auf den Spaltenkopf der entsprechenden Spalte.

Mit Doppelklick auf das Feld "DNF.." oder auf die ausgewählte Zeile im Datengitter erscheint eine Liste mit den Kennzeichen, die in der WR hierfür definiert wurden, z.B. DNS, DNF, OCS, DSQ usw. Natürlich können diese Kennzeichen auch eingetippt werden. Mit RDG wird eine Wiedergutmachung vorgenommen. Das Feld "W’GutPkt" öffnet sich, und es können die Wiedergutmachungs-Punkte eingegeben werden. Diese Punkte müssen vom Schiedsgericht festgelegt werden und dem beabsichtigten Wiedergutmachungsplatz entsprechen.
Mit DPI und SCP können Wertungsstrafen vergeben werden. Im Feld "Strafe" werden die Strafplätze eingegeben, um die der gesegelte Platz erhöht werden soll.
Im Wertungslauf werden diese Strafplätze dann berücksichtigt.
Bei einer Z-Flaggenstrafe (ZFP) berechnet und berücksichtigt WinRegatta die 20%-Strafe automatisch.

Neu ab Vers. 4.5: Bei der Eingabe der Z-Flaggenstrafe (ZFP) wird ein Feld sichtbar, in dem eingegeben werden kann, wie oft der Segler bei Startwiederholungen einer Wettfahrt Frühstarts verursacht hat. Die Z-Flaggenstrafe kann für einen Segler in einer Wettfahrt nämlich mehrfach zur Anwendung kommen. Zum Beispiel: Beim Start der Wettfahrt verursacht der Segler einen Frühstart und wird mit ZFP (20%) bestraft. Die Wettfahrt wird aus welchen Gründen auch immer abgebrochen. Bei der Startwiederholung dieser Wettfahrt verursacht der Segaler erneut einen Frühstart. Er wird erneut mit ZFP bestraft. Jetzt beträgt die Strafe 40% der gemeldeten Boote. Theoretisch könnte dies bei weiteren Startwiederholungen auch ein drittes oder viertes Mal geschehen. Die Strafe würde sich dann auf 60% bzw. 80% erhöhen.

Automatische Eingabe von DNC

Oft reisen viele gemeldete Segler zur Regatta nicht an und erhalten DNC als Ergebnis. Bei großen Starterfeldern sind dies oft zehn und mehr Segler. Durch Klick auf den Symbolschalter "DNC" wird für alle Segler, die noch kein Ergebnis haben, DNC automatisch eingesteuert.

Bei einer "Längeren Wettfahrtserie " (siehe WR A9), z. B. Mittwochs- oder Freitags-Wettfahrten, erhalten die für die Wettfahrtserie gemeldeten aber nicht erschienenen Segler ein DNA. Mit dem Symbolschalter "DNA" erfolgt eine automatische Einsteuerung von DNA.

Ergebnisse löschen

Mit Klick auf [image] können alle Ergebnisse der Segler der gewählten Klasse(n) und der gewählten Wettfahrt gelöscht werden.


Rang nach Bugnummern

Rangeingabe nach Bugnummern

Im vorhergehenden Kapitel wurde die Ergebniseingabe nach Segelnummern beschrieben.
Neu ab Vers. 4.7b:
In gleicher Weise wie nach Segelnummern können die Ergebnisse wahlweise auch nach Bugnummern eingegeben werden.
Wenn unter Optionen die Verwendung von Bugnummern aktiviert wurde, dann erscheint in der Funktion "Ergebnisse" die zusätzliche Spalte "Bug-Nr". Das gleiche gilt auch für das Fenster "Ergebniseingabe nach Zieleinlauf". Durch Klick auf den Spaltenkopf kann nach Bugnummern sortiert werden.

Wenn unter "Optionen" Bugnummern aktiviert wurden, dann ändert sich für die Ergebniseingabe die Überschrift des Suchfeldes (unten links) von "Suche Seg-Nr" in "Suche Bug-Nr". Folglich können Sie jetzt in dieses Feld eine Bugnummer eingeben, um ein Boot für die nächste Ergebniseingabe zu suchen.
Wenn Sie aber trotz der Verwendung von Bugnummern, die Ergebniseingabe lieber nach Segelnummern vornehmen möchten, dann können Sie mit Doppelklick auf das Suchfeld auf "Suche Seg-Nr" umschalten. Mit einem erneuten Doppelklick können Sie wieder zurück auf "Suche Bug-Nr" schalten.

Die "Ergebniseingabe nach Zieleinlauf" funktioniert auch mit Bugnummern genau so wie mit Segelnummern.


Rang nach Zieleinlauf

Rangeingabe nach Zieleinlauf

Diese Eingabe-Funktion ist besonders vorteilhaft, wenn Segler unterschiedlicher Klassen gemischt ins Ziel einlaufen. Aktiviert wird diese Funktion mit Klick auf [image] . Jetzt wird das Fenster "Seglerwahl für Zieleinlauf" sichtbar, in dem alle Segler der gewählten Klasse(n) gezeigt werden, für die in dieser Wettfahrt noch keine Ergebnisse eingegeben wurden.

Mit Klick auf einen Spaltenkopf wird im Zieleinlauffenster nach dieser Spalte sortiert.

Im Zieleinlauffenster Segler anklicken

Ein Klick auf den Segler in diesem neuen Fenster, für den als nächstes das Ergebnis eingegeben werden soll, führt dazu, dass der Segler in diesem Fenster verschwindet und im Datengitter des Hauptfensters mit seinem Ergebnisrang erscheint. Oder anders erklärt: In einer sogenannten Zieleinlaufliste wurden die Segelnummern (ggf. mit den LKs) in der Reihenfolge ihres Zieleinlaufs, unabhängig von ihrer Klassenzugehörigkeit, notiert. Diese Zieleinlaufliste wird jetzt verwendet, und die Segelnummern werden in der gleichen Reihenfolge in dem Zieleinlauffenster angeklickt. Dies führt dazu, dass die Segler in dieser Reihenfolge in das Hauptfenster mit der richtigen Rangzuordnung übernommen werden. Bei der Rangzuordnung berücksichtigt WinRegatta die Wertungsklasse des jeweiligen Seglers und vergibt den nächsthöheren Rang für diese Klasse.

Wurde irrtümlich ein falscher Segler angeklickt, so kann dies durch Klick auf [image] rückgängig gemacht werden. Dieser Segler erscheint jetzt wieder im Auswahlfenster, und der richtige Segler kann nun gewählt werden.

Zwei gleiche Rangplätze pro Klasse können hier nicht eingegeben werden. Die Ergebnisse eines Toten Rennens müssen somit über die Funktion "Eingabe nach Segel-Nr." erfasst werden.

Suche Segelnummer bei großen Starterfeldern

Bei einem zahlenmäßig großen Starterfeld ist es möglicherweise schwierig, den Segler in dem Zieleinlauffenster zu finden, dessen Ergebnis als nächstes eingegeben werden soll. Das Feld "Suche S-Nr." (unten links) ist auch bei "Eingabe nach Zieleinlauf" aktiv. Eine Segelnummer, die hier eingegeben wird, wird bei Verlassen des Feldes in dem Zieleinlauffenster gesucht, in das Hauptfenster übernommen, und der Rang wird zugeordnet.

Ein Feld für den Landeskenner (LK) gibt es hier nicht. Denn wenn eine Segelnummer eingegeben wird, die bei unterschiedlichen LKs oder in verschiedenen Klassen mehrfach vorkommt, so wird ein Auswahlfenster angeboten, zur Wahl des richtigen Seglers.

Tip: Das Suchfeld mit Tab oder Enter verlassen und nach Eingabe des Ergebnisses dieses Seglers auch das Ergebnisfeld mit Tab oder Enter verlassen (keine Maus benutzen). Dadurch wird automatisch wieder das Suchfeld angesprungen.

Gemischte Eingabe von gesegeltem Rang und gesegelter Zeit

In der Funktion "Eingabe nach Ziel-Einlauf" können auch Klassen, für die als Ergebnis-Art "Rang" oder "Zeit " definiert wurde, gemischt verarbeitet werden. Wird ein Segler angeklickt, der zu einer Rangklasse gehört, so wird automatisch der nächsthöhere Rang dieser Klasse vergeben. Wird ein Segler einer Zeitklasse angeklickt, so springt der Cursor auf das Eingabefeld "Ziel-Zeit", und der Anwender gibt hier die Zeit ein, die er für diesen Segler in der Zieleinlaufliste findet.

Ergebnisse löschen

Durch Klick auf [image] können alle Ergebnisse der Segler der gewählten Klasse(n) und der gewählten Wettfahrt gelöscht werden. Die Segler werden nun automatisch wieder in das Zieleinlauffenster übernommen, da sie ja keine Ergebnisse mehr haben.

Eingabe von DNC, DNF, OCS usw.

Nachdem alle Rang- und Zeitzuordnungen vorgenommen wurden, müssen ggf. noch die Ergebnisse der nicht ins Ziel gekommenen Segler eingegeben werden, z.B. "aufgegeben", "nicht gestartet", "wegen Frühstart disqualifiziert", usw. Hierzu wird nun wieder die Funktion "Eingabe nach Segel-Nr." aktiviert. Dies kann geschehen durch Schließen des Zieleinlauffensters oder durch Klicken auf [image] . Um die Segler ohne Ergebnisse leichter zu finden, kann die Sortierung nach "Rangplatz" gewählt werden. Dann stehen diese Segler ganz oben im Datengitter und "DNF", DNC", "OCS", usw. können einfach eingegeben werden. Mit Doppelklick auf das Feld "DNF.." oder auf die ausgewählte Zeile im Datengitter erscheint eine Liste mit den Kennzeichen, die in der WR hierfür definiert wurden. Für eine automatische Einsteuerung von DNC siehe hier .

Die eingegebenen Ergebnisdaten werden in der Datei "*.E48" gespeichert.


Gesegelte Zeit

Eingabe Gesegelte Zeit

Hier soll die Eingabe von Zeitergebnissen betrachtet werden. Wenn "Gestoppte Zeit" oder "Uhrzeit" als Ergebnisart für die gewählte Klasse definiert wurde (siehe Eingabe Klassendaten ), dann werden Felder für die Zeiteingabe angeboten. Im Datengitter sind zwei Zeitspalten zu sehen, und zwar "Ziel-Zeit" und "Geseg Zeit" . Bei der Ergebnisart "Indiv. Startzeit" wird zusätzlich noch die Spalte "Startzeit" gezeigt. Bei der Ergebniseingabe wird immer die Gestoppte Zeit oder die Uhrzeit eingegeben. Die Gesegelte Zeit wird von WinRegatta automatisch ermittelt.

Zeitnahme beim Zieldurchgang

WinRegatta unterstützt drei Arten der Zeitnahme:
1. Gestoppte Zeit bei Verwendung einer Stoppuhr.
2. Uhrzeit z.B. bei Verwendung einer Funkuhr.
3. Indiv. Startzeit bei individuellem Start im Startfenster

Gestoppte Zeit für mehrere Startgruppen

Die gestoppte Zeit ist die Zeit, die die Stoppuhr beim Zieldurchgng des Bootes anzeigte. Dies muss aber nicht gleich der gesegelten Zeit sein. Wenn z.B. mehrere Startgruppen in 5 Minuten-Abständen gestartet wurden, und dieses Boot zur zweiten Startgruppe gehörte, dann ist die gestoppte Zeit 5 Minuten größer als die gesegelte Zeit. Dieses unterstellt, dass die Stoppuhr beim Startsignal der ersten Gruppe gestartet wurde und dann bis zum Ende der Wettfahrt durchläuft. Der Zeitunterschied zwischen gestoppter und gesegelter Zeit wird bei WinRegatta "Zeitversatz" genannt. Durch Klick auf [image] wird ein Dialogfenster geöffnet, in dem für jede Klasse mit Ergebnisart = "Gestoppte Zeit" der Zeitversatz eingegeben werden kann. Dieses gilt natürlich immer nur für die Wettfahrt, die für die Ergebniseingabe gewählt wurde. Die gesegelte Zeit wird durch WinRegatta mit Hilfe der gestoppten Zeit und des Zeitversatzes errechnet und gespeichert.

Zeitnahme als Uhrzeit

Dies ist die zweite Möglichkeit der Zeitnahme. Die Uhrzeit des Starts einer jeden Startgruppe wird notiert. Beim Zieldurchgang eines jeden Bootes wird die Uhrzeit notiert. Durch Klick auf [image] wird ein Dialogfenster geöffnet, in dem für jede Klasse mit Ergebnisart = "Uhrzeit" die Startuhrzeit eingegeben werden kann. Dieses gilt natürlich immer nur für die Wettfahrt, die für die Ergebniseingabe gewählt wurde. Die gesegelte Zeit wird durch WinRegatta mit Hilfe der Zieluhrzeit und der Startuhrzeit errechnet und gespeichert.

Die Verwendung der Uhrzeit als Ergebnisart ist besonders vorteilhaft, wenn bei großen Regatten getrennte Start- und Zielschiffe verwendet werden und Funkuhren zur Zeitnahme benutzt werden. Auch kann es nicht passieren, dass die Stoppuhr während der Wettfahrt irrtümlich gestoppt wird.

Zeitnahme mit Individueller Startzeit Neu in Vers. 4.4b

Dies ist die dritte Möglichkeit der Zeitnahme. Hier starten die Boote nicht gleichzeitig beim Startsignal, sondern die Boote können in einem festgelegten Zeitfenster (z. B. innerhalb von 15 Minuten) ihren Startzeitpunkt individuell wählen. Diese Startmethode bietet sich bei größeren Yachten an, wenn das Startgebiet beengt ist.

Für jede Yacht wird die Uhrzeit des Starts und des Zieldurchgangs notiert. Bei der Ergebniseingabe werden diese beiden Zeiten pro Yacht eingegeben. Die individuelle Startzeit und die Zielzeit können gleichzeitig eingegeben werden oder auch in getrennten Zeitabschnitten. Zum Beispiel kann die Startzeit nach dem Start und später die Zielzeit eingegeben werden. WinRegatta errechnet die gesegelte Zeit, sobald beide Zeiten - die Startzeit und die Zielzeit - eingegeben wurden.

Wichtig: Bei Zeitnahme mittels Uhrzeit darf die Zielzeit nicht über Mitternacht (23:59:59) hinausgehen, d. h. Startzeit und Zielzeit müssen sich innerhalb des gleichen Tages befinden. Für Langzeitregatten , die über einen Tag hinaus laufen, muß die Zeitnahme mit gestoppter Zeit geschehen. Hier kann die gesegelte Zeit max. 99:59:59 Stunden betragen.

Totes Rennen nach gesegelter oder berechneter Zeit

Wird für zwei oder mehr Segler der gleichen Klasse die gleiche Zeit eingegeben, so kann dieses vom Anwender - wie schon bei der Rangeingabe beschrieben - als Totes Rennen deklariert werden. Im Wertungslauf wird auch auf ein Totes Rennen nach berechneter Zeit geprüft und entsprechend behandelt.

Gemischte Eingabe von gesegelter Zeit und gesegeltem Rang

Es können auch Ergebnisse für Klassen mit Rangeingabe und solche mit Zeiteingabe gemischt eingegeben werden. In diesem Falle werden Rang- und Zeitfelder gleichzeitig angeboten. Wird ein Segler einer Rangklasse ausgewählt, so wird das Rangfeld aktiviert. Entsprechend wird bei einem Segler einer Zeitklasse das Zeitfeld eingabebereit gemacht.

Suche Segelnummer bei großen Starterfeldern

Bei einem zahlenmäßig großen Starterfeld ist es möglicherweise schwierig, den Segler in dem Datengitter zu finden, dessen Ergebnis als nächstes eingegeben werden soll. Durch Eingabe der Segelnummer im Feld "Suche S-Nr" wird zu dem entsprechenden Segler gesprungen, sobald das Feld mit der Tab- oder Enter-Taste verlassen wird. Ein Feld für den Landeskenner (LK) gibt es hier nicht. Denn wenn eine Segelnummer eingegeben wird, die bei unterschiedlichen LKs oder in verschiedenen Klassen mehrfach vorkommt, so wird ein Auswahlfenster angeboten, zur Wahl des richtigen Seglers.

Tip: Das Suchfeld mit Tab oder Enter verlassen und nach Eingabe des Ergebnisses dieses Seglers auch das Ergebnisfeld mit Tab oder Enter verlassen (keine Maus benutzen). Dadurch wird automatisch wieder das Suchfeld angesprungen.

Neu ab Vers. 4.7b
Bei Verwendung von Bugnummern kann in dem Suchfeld statt der Segelnummer wahlweise auch eine Bugnummer eingegeben werden, um einen Segler für die Ergebniseingabe zu suchen.

Eingabe von DNC, DNF, OCS usw.

Hier gilt das Gleiche wie unter Rangeingabe nach Segelnummer beschrieben.

Ergebnisse löschen

Mit Klick auf [image] können alle Ergebnisse der Segler der gewählten Klasse(n) und der gewählten Wettfahrt gelöscht werden.


Funktion "Wf-Protokoll"

Im Fenster "Wf-Protokoll" kann für jede Wettfahrt ein Protokoll geführt werden: Im Feld "Kl-Nr" oben links wird mittels Tastatur oder Doppelklick die Nummer der Wertungsklasse eingegeben. Der Name dieser Klasse wird zur Information im Feld rechts daneben angezeigt. Wurde für diese Klasse bereits ein Wertungslauf durchgeführt, dann existieren für die gewerteten Wettfahrten bereits Datensätze, die im Datengitter angezeigt werden. Andernfalls können für die gesegelten Wettfahrten, die noch nicht gewertet wurden, Protokollsätze manuell angelegt werden. Das Prinzip der Dateneingabe ist hier das gleiche, wie bereits für andere Eingabefunktionen beschrieben.

Ab WinRegatta Version 4.3 kann im Feld "Kl-Nr" ein "M" für "Mehrere Klassen" gewählt werden und die Protokolldaten für mehrere Klassen gleichzeitig eingegeben werden.

Die Protokolldaten können wahlweise auf den Ergebnislisten gedruckt und in der HTML-Datei ausgegeben werden.

Das Wettfahrt-Protokoll wird in der Datei "*.W48" gespeichert.

Protokolldaten eingeben


Protokolldaten eingeben

Daten, die der Wertungslauf einsteuert

Für jede bereits gewertete Wettfahrt wurden folgende Protokolldaten durch den Wertungslauf eingesteuert:

  • Wf-Status = Gültige Wf
  • Anzahl Segler gemeldet
  • Anzahl Segler gestartet
  • Anzahl Segler gezeitet

Daten, die pro Wettfahrt manuell eingegeben werden können

  • Datum der Wettfahrt
  • Startzeit der Wettfahrt
  • Zielzeit des ersten Seglers der Klasse
  • Endezeit der Wettfahrt
  • Windstärke wahlweise in Knoten (Kn), Beaufort (Bft) oder Meter/Sekunde (m/s)
  • Windrichtung, z. B. SSW, West oder 270°
  • Bahnlänge wahlweise in Seemeilen (sm) oder Kilometer (km)
  • Stromgeschwindigkeit (km/h) bei Flussregatten
  • Geschwindigkeit des ersten Seglers der Klasse wird automatisch errechnet und angezeigt, sobald die hierfür erforderlichen Angaben (Startzeit, Zielzeit des Ersten und Bahnlänge) eingegeben wurden.

Bei Flußregatten, die mit der Schabrod-Stromformel gewertet werden sollen (Wertungsart = "Yardstick/Strom"), muss vor dem Wertungslauf für jede Wettfahrt ein Protokollsatz angelegt werden und mindestens die Stromgeschwindigkeit und Bahnlänge eingegeben werden.

Protokoll für eine abgebrochene Wettfahrt

Für eine abgebrochene Wettfahrt kann ein Protokollsatz manuell angelegt und im Feld "Wf-Status" die Bezeichnung "Abgebrochen" eingegeben werden. Da für eine abgebrochene Wettfahrt wegen fehlender Ergebnisse kein Wertungslauf stattfinden kann, können die Anzahl gemeldeter und gestarteter Segler auch nicht automatisch eingesteuert werden. Deshalb werden in diesem Falle zwei zusätzliche Eingabefelder angeboten, um diese Daten manuell eingeben zu können.

Bemerkung zum Ablauf der Wettfahrt

Im Eingabefeld ganz unten kann eine längere Bemerkung zum Ablauf und Ergebnis der Wettfahrt eingegeben werden, z.B. warum die Wettfahrt abgebrochen wurde oder dass besonders gute Segelbedingungen herrschten oder dass wegen des starken Windes 3 Boote kenterten, usw.

Wf-Protokoll auf Ergebnislisten

Auf allen Ergebnislisten und in der HTML-Datei der Ergebnislisten kann das Wf-Protokoll am Ende der Liste gedruckt bzw. gespeichert werden. Hierbei hat der Anwender die Wahl, entweder gar keine Protokolldaten auszugeben oder nur die Wind- /Bahndaten oder nur die Wettfahrtzeiten oder eben alle Protokoll-Daten. Die Geschwindigkeit des Ersten wird nur ausgegeben, wenn sowohl die Wind-/Bahndaten als auch die Wettfahrtzeiten aktiviert wurden.

Das Wettfahrt-Protokoll wird in der Datei "*.W48" gespeichert.


Funktion "Wertung"

Nachdem alle Ergebnisse der zu wertenden Wettfahrten eingegeben wurden, kann nun mit dem Wertungslauf die Berechnung der Regatta-Ergebnisse erfolgen.

Alle Segler, die der Klasse zugeordnet sind, die gewertet werden soll, werden in die Wertung einbezogen. Für diese Segler müssen die gesegelten Ergebnisse, einschliesslich der Besonderheiten wie "nicht gestartet" (DNS), "aufgegeben" (DNF), "disqualifiziert" (DSQ), "Wiedergutmachung gegeben" (RDG), usw. für die zu wertenden Wettfahrten vollständig eingegeben sein.

Bei unvollständig eingegebenen Ergebnisdaten bricht WinRegatta nach einem Hinweis den Wertungslauf ab.

Regeln der Wertung

Sekundär-Wertung

Wertungslauf


Regeln der Wertung

Die Wertung erfolgt nach den Wettfahrtregeln - WR 2017-2020

Bei einer Wertung mit Streicher (1 bis 6 Streicher sind möglich) werden die jeweils schlechtesten Wettfahrtergebnisse eines Seglers, beginnend mit der frühesten Wettfahrt, gestrichen.

Es gibt zwei Wertungssysteme

Wahlweise wird nach dem Low-Point-System (LPS) oder dem Bonuspunkt-System (BPS) gewertet, wobei der DSV die Verwendung von LPS empfiehlt.

Der Hauptunterschied zwischen diesen beiden Wertungssystemen ist die Punktzahl, die den Plätzen zugeordet wird:

Platz: | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | ...
LPS (Punkte): | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | ...
BPS (Punkte): | 0 | 3 | 5,7 | 8 | 10 | 11,7 | 13 | 14 | 15 | ...

Es gibt mehrere Wertungsarten

  • Klassen-Wertung
    Wenn in einer Wertungsklasse Boote des gleichen Typs - also mit vergleichbaren Segeleigenschaften - starten, dann kann eine Klassenwertung durchgeführt werden. Hierbei wird die Rangfolge durch den gesegelten Rang oder die gesegelte Zeit in der Wettfahrt bestimmt.
  • Yardstick-Wertung
    Wenn in einer Wertungsklasse unterschiedliche Bootstypen - also mit unterschiedlichen Segeleigenschaften - starten, so kann mit der Yardstick-Wertung die Rangfolge durch die berechnete Zeit auf Grund der Yardstickzahl des Bootstyps bestimmt werden.
    Yardstick-Formel: Berechnete Zeit (Sek) = gesegelte Zeit (Sek) dividiert durch die Yardstickzahl des Bootes multipliziert mal 100.
  • Yardstick/Strom-Wertung
    Wird eine Wettfahrt im Flussrevier nur stromabwärts gesegelt, so kann bei einer Yardstick-Wertung mit der Schabrod-Stromformel die Stromgeschwindigkeit neutralisiert werden. Dies ist sinnvoll, da ein langsames Boot dem "schiebenden" Strom länger ausgesetzt ist als ein schnelleres Boot. Das langsame Boot hat also einen ungerechtfertigten Vorteil, der mit der Stromformel kompensiert wird. Ein Strom-Faktor dient der Gewichtung des Stromeinflusses in der Formel. Ursprünglich war ein Faktor von 0,75 fest einprogrammiert.
    Neu in Vers. 4.5: Der Strom-Faktor kann unter "Optionen / Daten-Konfiguration" oder in der Funktion "Wf-Protokoll" gewählt werden. Der gewählte Faktor wird in der Ini-Datei gespeichert und steht beim nächsten Start von WinRegatta wieder zur Verfügung. Sinnvolle Werte für den Strom-Faktor sind 0,75 bis 1,00.
  • ORC-Club-Wertung Zeit/Zeit nur WinRegatta Plus
    Eine Yacht, die an einer ORC-Regatta nach dem Zeit/Zeit-System teilnehmen möchte, benötigt einen ORC- oder IMS-Messbrief, der den TMF-Faktor (z. B. 0,8728) enthält. Die Rangfolge wird durch die berechnete Zeit auf Grund des TMF-Faktors der Yacht bestimmt.

    Formel: Berechnete Zeit in Sek = gesegelte Zeit in Sek multipliziert mit TMF.
  • ORC-Club-Wertung Zeit/Distanz nur WinRegatta Plus
    Eine Yacht, die an einer ORC-Regatta nach dem Zeit/Distanz-System teilnehmen möchte, benötigt einen ORC- oder IMS-Messbrief, der die Faktoren "GPH" (z. B. 788,4), "PLT" (z. B. 0,712) und "PLD" (z. B. 230,1) enthält. Die Rangfolge wird durch die berechnete Zeit mittels der PLT- und PLD-Faktoren der Yacht und der Bahnlänge bestimmt.

    Formel: Berechnete Zeit in Sek = (gesegelte Zeit in Sek x PLT) - (Distanz in sm x PLD).
  • Gruppen-Wertung nur WinRegatta Plus
    Bei sehr großen Starterfeldern in einer Wertungsklasse ist eine Gruppenwertung sinnvoll, da die große Anzahl von Booten in einer Startgruppe nicht mehr ordnungsgemäß gestartet werden kann. Bei der Gruppenwertung werden die Boote in zwei oder mehr Gruppen eingeteilt, die dann nacheinander starten. Die Gruppenwertung erstellt aber ein Gesamtergebnis über alle Gruppen hinweg.
  • Ranglisten-Wertung
    Einer Ranglisten-Wertung kann eine Klassen-, Yardstick- ORC- oder auch Gruppen-Wertung zu Grunde liegen. Bei dieser Wertung werden für die Segler zusätzlich Ranglistenpunkte berechnet, unter Verwendung der Berechnungsformel für Ranglistenpunkte (siehe Ordnungsvorschriften des DSV) und des Ranglistenfaktors der Regatta.

Wiedergutmachung, Wertungsstrafe, Z-Flaggenstrafe

Bei Wiedergutmachung (RDG) werden die im Feld "W´GutPk" eingegebenen Punkte im Wertungslauf anstelle der Punkte des gesegelten Platzes genommen.
Mit DPI und SCP können Wertungsstrafen vergeben werden. Im Feld "Strafe" werden die Strafplätze eingegeben, um die der gesegelte Platz erhöht werden soll.
Im Wertungslauf werden diese Strafplätze dann berücksichtigt.
Bei einer Z-Flaggenstrafe (ZFP) berechnet und berücksichtigt WinRegatta die 20%-Strafe automatisch.

Neu ab Vers. 4.5: Ein Segler kann in einer Wettfahrt auch mehrere Z-Flaggenstrafen erhalten, z. B. wenn er beim Start und bei einer Startwiederholung der gleichen Wettfahrt einen Frühstart verursacht. Bei zwei Z-Flaggenstrafen erhält er eine 40%-Strafe. Theoretisch kann es auch eine 60%-Strafe werden, wenn er nämlich bei mehreren Startwiederholungen der gleichen Wettfahrt drei Frühstarts verursacht.

Totes Rennen

Im Falle eines Toten Rennens von zwei oder mehreren Booten nach gesegeltem Rang, gesegelter Zeit oder berechneter Zeit (bei Yardstick- oder ORC-Wertung), erfolgt eine Platz- und Punkte-Teilung wie durch die WR vorgegeben.

Punktgleichheit im Gesamtergebnis

Bei Punktgleichheit im Gesamtergebnis mehrerer Segler wird die Rangfolge nach der WR bestimmt.

Längere Wettfahrtserie

Eine Besonderheit der Wertung soll hier noch erwähnt werden: Bei DNC "Nicht ins Startgebiet gekommen" unterscheiden die Regeln der ISAF (WR A9) zwischen einer "normalen Regatta" und zwischen einer "längeren Wettfahrtserie" , wie z.B. einer Serie, die über mehrere Wochen läuft, wobei an bestimmten Tagen eine Wettfahrt gesegelt wird oder auch mehrere Wettfahrten gesegelt werden. DNC erhält als Punkte die Anzahl der gemeldeten Segler + 1. Bei einer "normalen Regatta" erhalten die anderen nicht durchs Ziel gegangenen oder disqualifizierten Segler ebenfalls als Punkte die gemeldeten Segler + 1. Bei einer "längeren WF-Serie" erhalten diese dagegen als Punkte die Anzahl der ins Startgebiet gekommenen Segler + 1. Hierdurch sollen die angereisten, aber nicht ins Ziel gekommenen oder später disqualifizierten Segler gegenüber den nicht angereisten Seglern vorteilhafter gestellt werden.

Die Lösung in WinRegatta: DNC sollte nur für "normale Regatten" verwendet werden. Für "längere Wettfahrtserie" sollte anstelle von "DNC" der neue Begriff "DNA" verwendet werden. DNA = "Nicht ins Startgebiet gekommen" - gilt nur für "längere Wettfahrtserie". DNA ist keine offizielle Kennzeichnung der WR, sondern wurde nur zum Zwecke der Lösung dieses Problems in WinRegatta definiert. DNA erhält als Punkte die Anzahl der für die Serie gemeldeten Segler + 1. Alle anderen nicht durchs Ziel gegangenen oder disqualifizierten Segler erhalten als Punkte die Anzahl der ins Startgebiet gekommenen Segler + 1 (oder anders gesagt: die Anzahl der für die Serie gemeldeten Segler + 1 minus Anzahl der für diese Wettfahrt n i c h t angereisten Segler).


Sekundär-Wertung

Mit der Definition der Wertungsklassen und der Zuordnung der Segler zu diesen Klassen können auch Sekundärwertungen (Kombinationswertungen) vorgenommen werden.

Ein Beispiel: "Senioren-Wertung"

Eine Untermenge einer Wertungsklasse "Zugvogel" soll als "Senioren"-Wertung erfolgen. Zusätzlich zur primären Klasse "Zugvogel" wird also eine sekundäre Klasse "Zugvogel Senioren" definiert und diese Klassennummer den Senioren als sekundäre Klasse zugeordnet. Der Wertungslauf der Klasse "Zugvogel Senioren" wertet also eine Untermenge der primären Klasse "Zugvogel". Zusätzliche Ergebniseingaben sind hierfür nicht nötig.

Da es sich in diesem Beispiel um eine Sekundärklasse handelt, die eine Untermenge nur e i n e r Primärklasse ist, hat der Anwender für die Wertung folgende Wahlmöglichkeit: Die Sekundärklasse wird eigenständig, d. h. unabhängig von der Primärklasse neu berechnet, oder es werden die Ergebnisse aus der Primärwertung für die Sekundärklasse übernommen. Wenn die Sekundärklasse neu berechnet wird, kann es bei einzelnen Seglern zu Änderungen in der Rangfolge gegenüber der Primärwertung kommen. Dies ist zwar rechnerisch erklärbar, führt bei den Seglern aber oft zu Irritationen. Wenn dagegen die Ergebnisse aus der Primärwertung für die Sekundärklasse übernommen werden, dann ändert sich die Rangfolge nicht. Die gewählte Wertungsvariante wird in der Klassendatei gespeichert und steht bei einer erneuten Wertung dieser Klasse wieder zur Verfügung.

Ein zweites Beispiel: "Stadtmeisterschaftswertung"

Alle heimischen Segler einer Veranstaltung mit mehreren Wertungsklassen sollen zusätzlich über alle Klassen hinweg als Stadtmeisterschaft gewertet werden. Neben der Anlage von primären Klassen für die verschiedenen Bootstypen wird eine zusätzliche sekundäre Klasse "Stadtmeisterschaft" angelegt. Da diese Wertung über mehrere Bootstypen gehen wird, muss als Wertungsart "Yardstick-Wertung" gewählt werden. Dies bedeutet auch, dass die Ergebnisart "Z" für Zeit sein muss, d.h. es müssen für alle Klassen, deren Segler in die Stadtmeisterschaftswertung einbezogen werden sollen, die gesegelte Zeit und auch die entsprechenden Yardstickzahlen erfasst werden. Nun wird die Nummer der Stadtmeisterschaftsklasse allen heimischen Seglern als sekundäre Wertungsklasse zugeordnet. Ein Wertungslauf mit Angabe dieser Klassennummer ergibt die Stadtmeisterschaftswertung, ohne dass weitere Ergebnisse eingegeben werden müssen.

Da für die Zuordnung der Segler zu sekundären Wertungsklassen fünf Felder (S1 bis S5) zur Verfügung stehen, können für die gleichen Segler neben der primären Wertung fünf unabhängige sekundäre Wertungen vorgenommen werden. An den obigen Beispielen soll dies verdeutlicht werden: Für die Segler, die in der Stadtmeisterschaft gewertet werden sollen, wird die Nummer der Stadtmeisterschaftsklasse in das Feld "S1" eingegeben, und für die Zugvogel-Senioren wird die Nummer der Seniorenklasse in das Feld "S2" eingegeben.


Wertungslauf

Nachdem für die gesegelten Wettfahrten die Ergebnisse eingegeben wurden, kann der Wertungslauf vorgenommen werden.
Hierzu wird das Fenster "Wertung" geöffnet. Im Feld "Kl-Nr" wird mittels Tastatur oder Doppelklick die Nummer der zu wertenden Klasse eingegeben. Dies kann die Nummer einer primären wie auch einer sekundären Wertungsklasse sein. Der Name dieser Klasse wird zur Information in dem benachbarten Feld angezeigt.

Durchführung des Wertungslaufes

Unter der Überschrift "Wettfahrten, die gewertet werden sollen" befinden sich 15 Auswahlfelder, eins für jede der möglichen Wettfahrten. Die Felder der Wettfahrten, für die bereits Ergebnisse eingegeben wurden, sind offen. Die Felder für alle anderen Wettfahrten sind gesperrt, da ohne Ergebnisse eine Wertung ja keinen Sinn machen würde. Jetzt werden die Wettfahrten "angekreuzt", die in die Wertung einbezogen werden sollen. Dies müssen nicht notwendigerweise alle Wettfahrten sein, die schon Ergebnisse haben. Soll eine Wertung mit Streicher vorgenommen werden, so ist die Anzahl der zu streichenden Wettfahrten im Feld "Streicher" zu setzen. Maximal können 6 Wettfahrten gestrichen werden.

Wenn es sich bei der zu wertenden Klasse um eine Sekundärklasse handelt, die eine Untermenge nur einer Primärklasse ist, werden zwei Radioschalter eingeblendet. Hier können Sie wählen, ob die Sekundärklasse eigenständig, d. h. unabhängig von der Primärklasse neu berechnet werden soll, oder ob die Ergebnisse aus der Primärwertung für die Sekundärklasse übernommen werden sollen.

Andere Parameter wie Wertungsart (Klassen-, Yardstick- oder ORC-Wertung), das zu verwendende Punktsystem (LPS oder BPS), ob Ranglistenwertung sowie der Ranglistenfaktor wurden für diese Klasse schon im Rahmen der Klassendefinition festgelegt.

Mit einem Klick auf den Schalter "Start" wird die Wertung durchgeführt. Wurden die Ergebnisse der angekreuzten Wettfahrten unvollständig eingegeben, so wird der Wertungslauf mit einem entsprechenden Hinweis abgebrochen. Dies gilt bei Yardstick-Wertung auch für die fehlende Yardstickzahl eines Bootes.

Ergebnisse des Wertungslaufes

War die Wertung erfolgreich, so werden die Ergebnisse in dem Datengitter angezeigt. Die Segler werden in der Reihenfolge des Gesamtergebnisses der gewerteten Wettfahrtserie angezeigt. Neben der Segelnummer (ggf. LK und/oder Yachtname) wird der Name des Steuermanns zur besseren Orientierung gezeigt. Dann folgen pro Wettfahrt berechneter Rang, berechnete Punkte, ganz rechts die Gesamtpunkte und bei Ranglisten-Regatten auch die Ranglistenpunkte. Bei Streicher werden die gestrichenen Punkte in Klammern angezeigt. Wiedergutmachungs-Punkte (RDG) sind mit einem "w", Wertungsstrafe-Punkte (SCP) mit einem "s", DPI mit einem "d" und Z-Flaggenstrafe-Punkte (ZFP) mit einem "z" gekennzeichnet.

Durch Ankreuzen von entsprechenden Feldern im Block "Details anzeigen" können wahlweise folgende zusätzliche Informationen angezeigt werden: Die Club-Abkürzung des Steuermannes, bei Klassen mit der Ergebnisart "Zeit" die gesegelte Zeit und bei Klassen mit der Wertungsart "Yardstick" oder "ORC" die berechnete Zeit sowie Bootstyp und Yardstickzahl oder ORC-Faktoren. Die Wahl der Detailanzeige wird pro Klasse gespeichert und bei einer späteren Wertung der Klasse wieder automatisch voreingestellt.

Im Eingabefeld unten rechts kann ein längerer Hinweis zur Regatta eingegeben werden, z.B. Infos über vorliegende Proteste und Zeitpunkt der Protestverhandlung oder nach der letzten Wettfahrt der Serie gute Wünsche für die Heimreise der Segler. Dieser Hinweis kann wahlweise auf der Ergebnisliste gedruckt werden.
Neu in Vers. 4.5: Dieser Hinweis kann nun zusätzlich auch in der Funktion "Drucken" eingegeben bzw. geändert werden. Dies vereinfacht die Handhabung.


Teamwertung

Teamwertung (Neu ab Vers. 4.6)

Was beinhaltet die Teamwertung?

Boote können Teams zugeordnet werden. Die Teams segeln dann gegeneinander. Die Segelleistungen aller Boote eines Teams bilden das Teamergebnis. Maximal können acht Teams gebildet werden.

Die Bildung von Teams:

In der Funktion "Klassen" wird die entsprechende Wertungsklasse in der Spalte "Team-W" für eine Teamwertung gekennzeichnet.
In der Funktion "Segler" erscheint für die Seglereingabe dann eine Spalte "Team". Hier können die Boote mit den Ziffern 1 bis 8 den Teams zugeordnet werden.

Die Teamwertung kann auf Primärklassen, wie auch auf Sekundärklassen angewendet werden.

Die Ergebniseingabe:

Die Ergebniseingabe ändert sich durch eine Teamwertung überhaupt nicht. Die normalen Ergebnisse einer Wertungsklasse werden erst beim Druck der Team-Ergebnisliste zu Teamergebnissen zusammengerechnet.

Die Berechnung der Teamergebnisse:

In der Teamwertung werden die Gesamtpunkte der Wettfahrtserie der zugeordneten Boote eines Teams addiert und durch die Anzahl der Boote des Teams dividiert. Dieser Mittelwert der Punkte ergibt das Teamergebnis. Durch die Mittelwertbildung ist es möglich, dass Teams mit einer ungleichen Zahl von Booten gegeneinander segeln, ohne dass die Ergebnisse verfälscht werden.

Es können 1 bis 3 Teamstreicher angegeben werden, die zu Streichungen der jeweils schlechtesten Ergebnisse führen. Durch die Streicher können auch Boote mit schwacher Segelleistung mitmachen, ohne dass das Team benachteiligt wird.

Druck der Teamergebnisse:

Mit der Ergebnisliste "Teamwertung, 1 bis 8 Teams..." können die Teamergebnisse gedruckt werden. Die Liste zeigt in den Spalten "T1" bis "T8" die Gesamtpunkte der Wettfahrtserie der Boote des entsprechenden Teams.

Im unteren Teil der Liste werden die kumulierten Punkte und der Mittelwert der Punkte gezeigt. In der letzten Zeile wird die Rangfolge auf Basis der Mittelwerte gezeigt.

Die Teamergebnisse können nicht als Text- oder HTML-Datei gespeichert werden. Wenn die Ergebnisse elektronisch gespeichert, verschickt oder ins Internet hochgeladen werden sollen, so wird die Ausgabe als PDF-Datei empfohlen.

Die ganz normalen Ergebnisse einer Klasse mit dem Kennzeichen "Teamwertung" können weiterhin mit allen bisherigen Listenformaten gedruckt und auch gespeichert werden.

Beispiel Team-Wertung


Funktion "Drucken"

Im Fenster "Drucken" können verschiedene Listenformate ausgewählt werden. Im rechten Abschnitt des Fensters wird zur Orientierung eine Kurzbeschreibung der gewählten Liste gezeigt.
Im Feld "Kl-Nr" wird die Nummer der Wertungsklasse eingegeben bzw. mit Doppelklick gewählt. Der Name dieser Klasse erscheint zur Information im Feld rechts daneben.
Im Feld "Kopien" wird die Anzahl der zu druckenden Exemplare angegeben.
Melde- und Ergebnisdaten können anstatt in Listen auch in Textdateien oder HTML-Dateien ausgegeben und damit exportiert werden.
Je nach gewähltem Listentyp werden weitere Optionsfelder angeboten.

Struktur der Seglernamen wählen

In der Seglerdatei werden die Vornamen und Familiennamen der Segler in getrennten Feldern gespeichert. Über das Menü "Optionen " kann der Anwender wählen, wie die Namen in den Listen erscheinen sollen (z.B. Hans Mustermann, Mustermann Hans oder Mustermann, Hans).

Listenrand oben und unten wählen

Über das Menü "Optionen" kann auch die Größe des oberen und unteren Listenrandes bestimmt werden. Zum Beispiel kann hiermit ein freier Rand auf den Listen gelassen werden für einen vorgedruckten Werbeblock.

Kleine Grafik oben links drucken

Auf den Melde- und Ergebnislisten kann oben links eine kleine Grafik gedruckt werden. Eine Bitmap-Datei (BMP) der gewünschten Grafik, z.B. ein nettes Segelmotiv oder der Club-Stander des Veranstalters, kann unter Optionen / Listen-Druck gewählt werden. Grossformatige Bitmap-Grafiken (in MB-Grösse) sollten mit einem Grafik-Programm verkleinert werden, da es sonst zu Problemen beim Drucken durch WinRegatta kommen kann.

Werbegrafik am unteren Seitenrand Neu ab Vers. 4.4

Eine Grafik (z. B. Werbung für Sponsoren) kann wahlweise am unteren Seitenrand (Fusszeile) über die ganze Seitenbreite auf allen Seiten von Melde- und Ergebnislisten gedruckt werden. Bei einem Druck in eine PDF-Datei erscheint diese Grafik ebenfalls.

Der Druck und die gewünschte Grafikdatei können unter Optionen / Listen-Druck gewählt werden. Diese Grafik in Form eines Werbebanners hat bei Druckseiten im Hochformat eine Größe von 715 x 50 Pixel. Bei Seiten im Querformat sind dies 1025 x 72 Pixel. Die Grafik wird automatisch auf obige Größen angepaßt. Die Grafik muß eine BMP-Datei sein und sollte möglichst die Größe von 1025 x 72 Pixel haben. Andere Größen sind auch möglich, da vor dem Druck eine automatische Anpassung auf obige Größen erfolgt. Dies kann dann aber zu leichten Qualitätsverlusten der gedruckten Grafik führen. Wenn eine andere Größe verwendet wird, dann ist es wichtig, dass das Seitenverhältnis möglichst dem von 1025 : 72 Pixel entspricht, da sonst Verzerrungen entstehen.

Neu ab Vers. 4.6: Die Dateinamen der Grafik-Dateien werden für jede Regatta in der jeweiligen Dateigruppe gespeichert und beim erneuten Öffnen der Regatta wieder verwendet. Bitte beachten Sie folgende Einschräkungen: Die Grafik-Dateien müssen in einem (beliebigen) gemeinsamen Ordner gespeichert werden, und die Länge der Dateinamen darf nur maximal 18 Stellen lang sein.

Zweisprachiger Listenkopf für Melde- und Ergebnislisten

Unter Optionen kann Deutsch oder Englisch gewählt werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe.

Listenvorschau

Wenn eine Listenvorschau angezeigt wird, kann über entsprechende Symbolschalter die Druckereinstellung geändert werden und auch die angezeigte Liste in eine Datei (*.QRP) gespeichert werden. Um diese gespeicherte Druckliste später zu drucken, gehen Sie bitte in die Vorschau einer beliebigen Liste und klicken dann auf das "Öffnen"-Symbol im Vorschaufenster.

Mehrere Klassen wählen

In dem Feld "Kl-Nr" kann nicht nur die Nummer einer einzelnen Klasse, sondern "M" für Mehrere Klassen eingegeben werden. Dies kann übrigens auch mit Doppelklick auf das "Kl-Nr"-Feld geschehen. Dann erscheint eine Auswahlliste aller Klassen und "M" für mehrere Klassen. Wenn "M" gewählt wird, können in einem Dialogfenster die Klassen, für die die Listen gedruckt werden sollen, bestimmt werden. Die gewählten Klassennummern werden im Feld "Klassen-Name" angezeigt.
Bitte beachten Sie: Wurden mehrere Klassen gewählt, so werden die gewählten Klassen bei Melde- und Ergebnislisten nacheinander jede Klasse einzeln auf ein Blatt gedruckt. Bei Checklisten werden die Segler der gewählten Klassen gemischt (nach Segelnummern sortiert) auf ein Blatt gedruckt.

Weitere Informationen über die Funktion "Drucken":

Listen für Meldebüro

Listen für Wettfahrtleitung

Ergebnislisten

Speichern in Text-Datei

Speichern in HTML-Datei


Listen für Meldebüro

Diese Listen sollen das Meldebüro bei der Durchführung der Regatta-Veranstaltung unterstützen.

Check-Liste für Meldebüro ...

Die Check-Liste für Meldebüro zeigt alle Segler der gewählten Klasse oder Klassen sortiert nach Segelnummern oder Yachtnamen. Die Spalten "Meldekarte", "Meldegeld", "Segelanweisung" und "Check-In" können mit entsprechenden Eintragungen versehen werden und sollen den Meldevorgang im Meldebüro unterstützen. Bei grösseren Veranstaltungen ist es sinnvoll, diese Daten durch WinRegatta verwalten zu lassen. Durch entsprechende Wahl der Optionen können diese Daten in Winregatta eingegeben werden und erscheinen dann gedruckt auf dieser Checkliste. Wenn das Check-In-Kennzeichen in WinRegatta eingegeben wurde, dann kann vor dem Druck dieser Liste gewählt werden, ob alle Segler der Klasse(n) in der Liste erscheinen sollen oder nur die m i t einem Check-In oder aber nur die o h n e Check-In. Des Weiteren kann eine bestimmte Anzahl von Leerzeilen am Ende der Liste gedruckt werden. Dies erlaubt es dem Meldebüro, "Spätmelder" manuell in die Check-Liste einzutragen.

Werden mehrere Klassen ("M") gewählt, so werden die Segler der gewählten Klassen gemischt (nach Segelnummern sortiert) auf ein Blatt gedruckt.

Meldeliste ...

Die Meldeliste zeigt alle Segler der gewählten Klasse, sortiert nach Segelnummern oder Yachtnamen. Die Meldeliste enthält nur die Segler e i n e r Klasse. Werden mehrere Klassen ("M") gewählt, so werden die Daten nacheinander für jede Klasse e i n z e l n auf ein Blatt gedruckt. Es können Listen für primäre und für sekundäre Klassen gedruckt werden. Je nach der Mannschaftsstärke der Klasse werden ein bis sechs Zeilen pro Boot gedruckt.

Unter Optionen kann "DSV-Nr unterdrücken " gewählt werden. In diesem Falle wird die Spalte "DSV-Nr" nicht gedruckt.

Wahlweise kann am unteren Seitenrand eine Werbegrafik über die ganze Seitenbreite gedruckt werden - Details .

Für Internationale Regatten kann unter Optionen ein englischer Listenkopf gewählt werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe und wird gespeichert. Beim erneuten Druck der Meldelisten dieser Dateigruppe wird die gewählte Sprache wieder voreingestellt. Beim Speichern der Meldeliste in eine Text- oder HTML-Datei wird die gewählte Sprache ebenfalls verwendet.
  • Auswahl der Segler mittels Check-In-Kennzeichen
    Wenn das Check-In-Kennzeichen in WinRegatta eingegeben wurde, dann kann vor dem Druck über das Drop-Down-Feld "Segler drucken..." gewählt werden, ob
    • alle Segler der Klasse in der Liste erscheinen sollen oder
    • nur die m i t einem Check-In oder aber
    • nur die o h n e Check-In.
  • Weitere Optionen für die Meldeliste
    Über die Auswahl "Drucken von ..." können für den rechten Teil der Liste unterschiedlich Daten gewählt werden:
    • Der volle Clubname des Seglers. Macht nur Sinn, wenn die DSV-Nummern der Segler gespeichert wurden.
    • Der Bootstyp mit Yardstickzahl (bei Yardstick-Wertung) oder mit den verschiedenen ORC-Faktoren (bei ORC-Wertung) und die Klassenzuordnung des Seglers.
    • Eine Yardstick-Korrektur mit Begründung (nur bei Yardstick-Wertung, wenn unter Optionen "Individuelle Yardstick-Korrektur " aktiviert wurde).
    • ORC-Club-Faktoren (GPH, PLT und PLD) bei ORC-Club-Wertung Zeit/Distanz. Nur WinRegatta Plus.

Liste der Club-Namen ...

In den verschiedenen Listen werden die Segelclubs der Segler aus Platzgründen nur mit der Club-Abkürzung und DSV-Nummer dargestellt. Mit der Liste "Club-Namen" können die vollen Namen der Segelclubs aller Segler (einschliesslich Vorschoter) dieser Veranstaltung gedruckt werden. Diese Liste ist z.B. interessant für Pressevertreter, die mit den Club-Abkürzungen nicht viel anfangen können oder für die Wettfahrtleitung bei großen Veranstaltungen, um bei der Siegerehrung den vollen Club-Namen der platzierten Segler nennen zu können.

Hinweis: Für diese Liste müssen die DSV-Nummern nicht unterdrückt, sondern bei der Seglereingabe gespeichert worden sein, da sonst die Clubs nicht eindeutig identifizierbar sind.

Unabhängig von der gewählten Klasse enthält diese Liste die unterschiedlichen Clubnamen der Segler a l l e r Klassen der Veranstaltung.

Meldegeld-Abrechnung ...

Wurde das Startgeld der Segler mit WinRegatta erfasst (s. Funktion "Segler"), so kann eine Abrechnung der Meldegelder der Veranstaltung gedruckt werden. Diese Liste zeigt die eingenommenen Meldegelder, aufgeschlüsselt nach Klassen und Zahlungsarten.

Unabhängig von der gewählten Klasse zeigt diese Liste die Meldegelder a l l e r Klassen der Veranstaltung.

Ab Version 4.7 wird das eingenommene Nachmeldegeld pro Klasse gesondert aufgeführt.

Quittung für Segler ...

Dieses Dokument enthält eine Bestätigung der Crew über die Meldung zur Regatta und über das gezahlte Meldegeld und ggf. Nachmeldegeld. Da diese Quittung meistens wohl während der Abfertigung des Seglers im Meldebüro gedruckt wird, wird der Druck in der Funktion "Segler" über das Menü "Bearbeiten / Quittung drucken" oder mit Klick auf [image] ausgelöst. Es können auch Quittungen für mehrere Segler gleichzeitig gedruckt werden, indem durch Klick auf [image] mehrere Segler markiert werden, bevor der Druck gestartet wird.

Text-Datei für den Urkunden-Druck ...

Unter "Listen für Meldebüro" kann eine Textdatei für den Urkundendruck erstellt werden. Diese Datei enthält alle relevanten Daten für den Druck von Siegerurkunden in einem Satz pro Boot. Als Dateiname wird der Name der Klasse mit dem Präfix "Urk_" zur Unterscheidung von Ergebnisdaten und Meldedaten voreingestellt. Diese Datei kann sehr einfach in eine Textanwendung oder in Excel importiert werden. Die Kopfzeilen, die zur Identifizierung der Datei dienen, werden am Ende der Datei gespeichert. Dadurch steht der Satz mit den Spaltenüberschriften an erster Stelle und dient somit als Steuersatz für einen Urkundendruck mittels einer Serienbrieffunktion.


Listen für Wettfahrtleitung

Diese Listen sollen die Wettfahrtleitung bei der Durchführung der Regatta-Veranstaltung unterstützen.

Check-Liste für den Start ...

Die Check-Liste für den Start sollte sinnvoller Weise alle Segler der Klassen e i n e r Startgruppe enthalten. Die Segler der gewählten Klasse oder Klassen werden sortiert nach Segelnummern oder Yachtnamen gezeigt. Diese Liste soll die Wettfahrtleitung während der Startphase unterstützen. Hier kann die Anmeldung der Segler beim Startschiff vermerkt werden, und es können Segler, die nicht starten oder einen Frühstart verursachen, notiert werden. Am Ende der Liste kann eine bestimmte Anzahl von Leerzeilen gedruckt werden. Dies erlaubt ein manuelles Nachtragen von "Spätmeldern" in die Liste.

Mit dem Auswahlschalter "Spalten" kann die Anzahl der Spalten (1 bis 3) in der Liste gewählt werden. Wenn "Auto" gewählt wird, dann bestimmt WinRegatta automatisch die Spaltenzahl auf Grund der Anzahl der Boote der gewählten Klasse(n) plus der gewünschten Leerzeilen. Dies dient der Optimierung des Listenumfanges. Wurde die Option "Yachtnamen" oder "Bug-Nummer" gewählt oder handelt es sich um eine Klasse mit Yardstick-Wertung, so wird die Liste grundsätzlich einspaltig gedruckt.

Neu in Vers. 4.6: Bei einspaltigem Format der Liste werden zusätzliche Spalten gedruckt. Hierdurch kann das Startgeschehen besser überwacht und dokumentiert werden. Zusätzliche Spalten: "Check-In", "am Start", "im Ziel" und "DNF, OCS..."

Liste für den Zieleinlauf ...

Die Liste für den Zieleinlauf dient der Dokumentation des Zieleinlaufs von einer oder auch von mehreren Klassen, die in ein gemeinsames Ziel segeln. Bei der späteren Ergebniseingabe mit der Funktion "Eingabe nach Zieleinlauf" ist diese Liste besonders vorteilhaft. Als Muster bei der Erstellung dieser Liste diente die "Zieldurchgangsliste" aus dem DSV-Wettfahrtleiter-Handbuch.

In der Reihenfolge des Zieldurchgangs werden die Segelnummern (ggf. mit dem Landeskennzeichen und/oder Yachtnamen) notiert. Bei Klassen mit Zeitergebnissen muss natürlich pro Boot auch die gestoppte Zeit bzw. die Uhrzeit des Zieldurchganges notiert werden. Wird beim Zieldurchgang ein Protest angemeldet, so sollte dies ebenfalls festgehalten werden. Im oberen Teil der Liste sollten alle anderen relevanten Informationen zur Wettfahrt festgehalten werden und natürlich auch die Segelnummern der Boote, die nicht durchs Ziel gegangen sind, in den entsprechenden Zeilen notiert werden. Die Wettfahrtzeiten sowie die Wind- und Bahndaten können hier ebenfalls festgehalten werden zur späteren Eingabe in das WF-Protokoll von WinRegatta.

Segeln mehrere Klassen auf der gleichen Bahn und soll eine gemeinsame Zieleinlaufliste verwendet werden, so sind die Klassennummern aller beteiligten Klassen ("M" für mehrere Klassen) zu wählen. Die gemeldeten Boote dieser Klassen werden im Feld "Max. Anzahl Boote" summiert. Sollten zum Zeitpunkt des Listendrucks noch nicht alle Segler in WinRegatta gespeichert sein (Spätmelder), so kann der Wert "Max Anzahl Boote" entsprechend erhöht werden, damit genügend Zeilen gedruckt werden. Sekundärklassen können nicht gewählt werden, da Ergebnisse ja nur für Primärklassen erfasst werden.

Die Liste wird ein- bis dreispaltig gedruckt, abhängig von der Anzahl der Boote. Der Anwender kann aber auch die Spaltenzahl wählen, z. B. um mehr Platz pro Boot für Bemerkungen zu haben. Wurde die Option "Yachtnamen" oder "Bug-Nummer" gewählt, so wird die Liste grundsätzlich einspaltig gedruckt.

Liste für Bahnmarkenkontrolle m i t Segelnummern ...

Diese Liste ähnelt der "Check-Liste für den Start" und soll die Kontrolle der Boote an den Bahnmarken unterstützen.
Beim Runden der Bahnmarken können hier die Segelnummern abgehakt und Beobachtungen notiert werden. Dieser Listentyp ist besonders für kleine Starterfelder geeignet, da wegen des begrenzten Listenumfanges die Segelnummern schnell gefunden werden können.

Neu in Vers. 4.5: Ganz rechts wurde eine Spalte "Check-In" eingefügt. Ein Boot, das vom Meldebüro ein Check-In-Kennzeichen erhalten hat, wird in dieser Spalte mit "Ja" gekennzeichnet. Bei der Bahnmarkenkontrolle ist es hilfreich zu erkennen, wenn ein nicht erschienenes Boot auch beim Check-In im Meldebüro fehlte.
Diese Check-In-Spalte wird nur auf einspaltigen CheckListen gedruckt und auch nur dann, wenn unter "Optionen" der Check-In aktiviert wurde.

Liste für Bahnmarkenkontrolle o h n e Segelnummern ...

Diese Liste ähnelt der "Liste für den Zieleinlauf" und soll die Kontrolle der Boote an den Bahnmarken unterstützen.
Die Segelnummern und besondere Beobachtungen können hier in der Reihenfolge des Rundens der Bahnmarken notiert werden. Dieser Listentyp ist besonders für große Starterfelder geeignet.

Liste für Boote Check-Out / Check-IN ... Neu in Vers. 4.5

Mit dieser Liste kann die Wettfahrtleitung überprüfen, ob alle Boote, die ausgelaufen sind auch wieder in den Hafen zurückgekehrt sind.
Diese Liste zeigt alle Boote der gewählten Klasse(n) sortiert nach Segelnummern. Die Liste enthält folgende Spalten: Landeskenner, Segelnummer, Yachtname oder Bug-Nummer (optional), Steuermann-Name, Auslaufen und Rückkehr.
Die Steuerleute unterschreiben vor dem Auslaufen zur Wettfahrt in der Spalte "Auslaufen" und nach der Rückkehr in der Spalte "Rückkehr".

Zieleinlauf-Liste ... Neu in Vers. 4.4

Diese Liste kann für Primärklassen pro Wettfahrt gedruckt werden. Die Liste zeigt die Segelnummer, den Namen des Steuermannes / der Steuerfrau und den Rang bzw. die gesegelte Zeit beim Zieleinlauf.

Diese Liste kann nach der Ergebniseingabe einer Wettfahrt und vor dem Wertungslauf gedruckt und zur Eingabekontrolle der Ergebnisse verwendet werden. Andererseits kann die Liste auch zu jeder späteren Zeit – auch für zurückliegende Wettfahrten - gedruckt werden. Sinnvoll ist es auch, diese Liste nach der Wettfahrt und vor der Wertung am schwarzen Brett auszuhängen - zur Information und Kontrolle für die Segler.

Ergebnisliste für Siegerehrung... Neu in Vers. 4.4

Diese Liste zeigt anstelle der Ergebnisse der Einzelwettfahrten die vollen Clubnamen der Steuerleute.

Für den Druck kann gewählt werden:

  • alle Boote
  • das erste Drittel der Boote
  • eine bestimmte Anzahl der Boote

Die Wahl der zu druckenden Boote wird in der Ini-Datei gespeichert und beim nächsten Druck dieser Liste wieder voreingestellt.
Außerdem kann wahlweise der Druck der Clubabkürzung und der DSV-Nr. unterdrückt werden.

Ergebnisliste für die Presse... Neu in Vers. 4.4

Anstelle der Ergebnisse der Einzelwettfahrten wird der volle Club-Name der Steuerleute gedruckt.
Wahlweise kann anstelle von JG, Clubabkürzung und DSV-Nr. der Heimatort der Steuerleute ausgegeben werden. Voraussetzung ist natürlich, dass der Heimatort im Adressenbereich des Steuermannes / der Steuerfrau erfaßt wurde. Eine möglicherweise eingegebene PLZ wird beim Druck eliminiert.

Für den Druck kann gewählt werden:

  • alle Boote
  • das erste Drittel der Boote
  • eine bestimmte Anzahl der Boote

Die Wahl der zu druckenden Boote wird in der Ini-Datei gespeichert und beim nächsten Druck dieser Liste wieder voreingestellt.

WfLtr / Jury-Dokumentation... Neu in Vers. 4.8

Wettfahrtleiter, sein Stellvertreter und bis zu 5 Jurymitglieder werden mit ihren Namen, Club-Zugehörigkeit und Lizenznummern gedruckt.
Die liste kann während der Regatta ausgehangen werden, und den Ergebnislisten als Anlage beigefügt werden.


Ergebnislisten

Ergebnislisten drucken

Es können sechs verschiedene Listenformate - je nach der Wertungsart und der Anzahl der gewerteten Wettfahrten - gewählt werden. Die Ergebnisliste zeigt alle Segler der gewählten Klasse mit den durch die Wertung berechneten Ergebnissen. Die Segler sind nach ihrem Gesamtergebnis sortiert. Es können Ergebnislisten für primäre und für sekundäre Klassen gedruckt werden. Je nach der Crew-Stärke der Klasse erscheinen ein bis sechs Zeilen pro Boot auf den Listen. Vor dem Druck einer Ergebnisliste erfolgt in jedem Falle ein automatischer Wertungslauf, um letzte Änderungen zu berücksichtigen.

Vor der Vorschau und vor dem Druck einer Ergebnisliste prüft WinRegatta, ob die Anzahl der für diese Klasse gewerteten Wettfahrten auf den gewählten Listentyp paßt. Ist die Anzahl der Wettfahrten zu groß, wird eine Warnung an den Anwender gegeben.

Werden mehrere Klassen ("M") gewählt, so werden die Daten nacheinander für jede Klasse e i n z e l n auf ein Blatt gedruckt.

Bei ORC-Club-Wertung Zeit/Distanz werden mit dem Listenformat "Einzel-Wettfahrt-Ergebnis" auch die ORC-Club-Faktoren GPH, PLT und PLD gedruckt. Nur WinRegatta Plus.

UnterOptionen kann "DSV-Nr unterdrücken" gewählt werden. In diesem Falle wird die Spalte "DSV-Nr" auf den Listen nicht gedruckt. Auf der gleichen Optionsseite kann auch bestimmt werden, ob der Name des Obmanns des Schiedsgerichts eingegeben werden soll. Der Name des Schiedsrichters wird dann im Listenkopf gedruckt. Um Platz auf der Liste zu sparen, wird in diesem Falle auf den Druck des Regatta-Reviers verzichtet.
Für Internationale Regatten kann unter Optionen ein englischer Listenkopf gewählt werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe und wird gespeichert. Beim erneuten Druck der Ergebnislisten dieser Dateigruppe wird die gewählte Sprache wieder voreingestellt. Beim Speichern der Ergebnislisten in Text- oder HTML-Dateien wird die gewählte Sprache ebenfalls verwendet.

Optionen für Ergebnislisten

  • Im Auswahlfeld "Ergebnis-Status" kann der Ergebnisstatus gewählt werden. Dieser Status wird pro Klasse gespeichert. Beim späterem erneuten Ergebnisdruck der Klasse wird der gespeicherte Ergebnisstatus wieder automatisch voreingestellt.
    • "Vorl. Zwischen-Ergebnis" (Protestfrist noch nicht abgelaufen).
      Es wird ein verkürzter Listenkopf gedruckt, um Platz zu sparen.
    • "Zwischen-Ergebnis" (nach Ablauf der Protestfrist bzw. nach Abschluss möglicher Protestverhandlungen, aber noch nicht alle geplanten Wettfahrten gesegelt).
      Es wird ein verkürzter Listenkopf gedruckt, um Platz zu sparen.
    • "End-Ergebnis" (alle geplanten Wettfahrten wurden gesegelt und keine Proteste mehr anhängig).
      Es wird ein erweiterter Listenkopf gedruckt. Bei Ranglistenregatten werden die Ranglistenpunkte gedruckt, was bei einem Zwischenergebnis ja keinen Sinn machen würde.
  • Im Auswahlblock "Drucken am Ende der Liste ..." kann der Druck des Wettfahrtprotokolls gewählt werden. Diese Wahl wird pro Klasse gespeichert. Beim späterem erneuten Ergebnisdruck der Klasse wird der gespeicherte Auswahlblock wieder automatisch voreingestellt.
    Folgendes kann in unterschiedlicher Kombination gewählt werden:
    • Keine Protokolldaten
    • Wind-/Bahndaten
    • Wettfahrtzeiten Die mittlere Geschwindigkeit des Siegers der Klasse wird nur gedruckt, wenn sowohl die Wind-/Bahndaten als auch die Wettfahrtzeiten zum Druck gewählt wurden.
    • Hinweis zur Regatta (max. 250 Stellen), z.B. Infos über vorliegende Proteste und Zeitpunkt der Protestverhandlung oder nach der letzten Wettfahrt der Serie gute Wünsche für die Heimreise der Segler.
      Dieser Hinweis konnte bisher nur in der Funktion "Wertung " eingegeben werden.
      Neu in Vers. 4.5: Die Eingabe des "Hinweises zur Regatta" kann nun zusätzlich auch in der Funktion "Drucken " vorgenommen werden. Dies vereinfacht die Handhabung. Das Memo-Feld zur Eingabe oder Änderung des Hinweises wird nur sichtbar, wenn der Druck einer Ergebnisliste für eine einzelne Klasse gewählt wurde.


Speichern in Text-Datei

Im Fenster "Drucken" können die Melde- und Ergebnisdaten anstatt in Listen auch in Textdateien ausgegeben und damit exportiert werden. Die Auswahl der Daten, die in Textdateien gespeichert werden sollen, erfolgt in gleicher Weise wie beim Drucken der Daten. Durch Klick auf den Schalter "Text-Datei" erfolgt das Speichern. Der Name der gewählten Klasse wird als Dateiname voreingestellt. Wenn der Klassenname Zeichen enthält, die als Dateiname nicht erlaubt sind (z. B. '/'), so werden diese Zeichen im Dateinamen durch Leerzeichen ersetzt. Zur besseren Übersicht beginnt der Dateiname einer Meldeliste mit "Mel_" und einer Ergebnisliste mit "Erg_". Dieser voreingestellte Dateiname kann natürlich geändert werden. Das Verzeichnis zum Speichern der Textdateien wird in der Ini-Datei abgelegt und steht beim nächsten Programmstart wieder zur Verfügung.

Besonderheiten beim Speichern von Text-Dateien

  • In der Textdatei wird die Spaltentrennung mit Tab-Zeichen vorgenommen. Hierdurch ist ein Export der Daten nach Excel oder in eine Textanwendung sehr einfach möglich. Zu beachten ist, dass in der Textdatei alle Daten (auch numerische) als Text-Strings gespeichert sind. Beim Import in Excel ist es deshalb wichtig, dass als Datenformat für jede Spalte "Text" gewählt wird, da es sonst zu Fehlinterpretationen bei den Ergebnisdaten kommen kann.

  • Landeskenner, Yachtnamen und Geburtsjahrgänge werden abhängig von den eingestellten Optionen der Klasse gespeichert bzw. nicht gespeichert.

  • Über Optionen kann zusätzlich zur Namensstruktur der Segler auch gewählt werden, ob die Crew eines Bootes untereinander in mehreren Datensätzen oder Nebeneinander im gleichen Datensatz gespeichert werden soll.
  • UnterOptionen kann "DSV-Nr unterdrücken" gewählt werden. In diesem Falle werden die DSV-Nummern nicht gespeichert.
  • Unter Optionen kann ein englischer Listenkopf gewählt werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe und wird gespeichert. Beim erneuten Speichern der Melde- oder Ergebnislisten dieser Dateigruppe wird die gewählte Sprache wieder voreingestellt.

  • Bei der Meldeliste kann wahlweise der Clubname des Seglers gespeichert werden. Alternativ kann der Bootstyp , die Yardstickzahl (bei Yardstick-Wertung), die ORC-Faktoren (bei ORC-Wertungen) und die Klassenzuordnung der Segler gespeichert werden.

  • Wird ein Ergebnislistentyp für eine, drei oder vier Wettfahrten gewählt, so werden pro Wettfahrt der Rang und die Punkte von allen gewerteten Wettfahrten gespeichert. Wird dagegen ein Ergebnislistentyp für sechs oder mehr Wettfahrten gewählt, so werden pro Wettfahrt nur die Punkte gespeichert. Der Anwender kann also durch die Wahl des Listentyps bestimmen, ob Rang und Punkte oder nur die Punkte pro Wettfahrt gespeichert werden sollen.

  • Unabhängig von der gewählten Ergebnisliste werden in der Textdatei alle gewerteten Wettfahrten gespeichert.
  • Bei Yardstick- oder ORC-Wertung werden bei allen Ergebnislisten der Bootstyp und der Yardstick bzw. der TMF- oder GPH-Faktor gespeichert.
  • Wenn bei Yardstick- oder ORC-Wertung auch die gesegelten und berechneten Zeiten gespeichert werden sollen, dann ist der Listentyp "4 Wf, mehrzeilig, Yardstick, ORC" oder "Einzei-Wettfahrt-Ergebnis" zu wählen.
  • Bei ORC-Club-Wertung nach dem Zeit/Distanz-System werden mit dem Listentyp "Einzel-Wettfahrt-Ergebnis" auch die Faktoren GPH, PLT und PLD gespeichert.
  • Wettfahrtzeiten und Wind-/Bahndaten und Wettfahrtzeiten werden n i c h t gespeichert.
  • Vor dem Speichern erfolgt in jedem Falle eine automatische Wertung , um die Ergebnisse zu aktualisieren.
  • Unter "Listen für Meldebüro" kann eine Textdatei für den Urkundendruck erstellt werden. Details finden Sie hier .


Speichern in HTML-Datei

In der Funktion "Drucken" können die Melde- und Ergebnisdaten anstatt in Listen auch im HTML-Format in Dateien ausgegeben und damit exportiert werden. Eine HTML-Datei kann direkt mit einem Internet-Explorer geöffnet werden und im Internet publiziert werden.

Die Auswahl der Daten, die in HTML-Dateien gespeichert werden sollen, erfolgt in gleicher Weise wie beim Drucken der Daten. Durch Klick auf den Schalter "HTML-Datei" erfolgt das Speichern. Der Name der gewählten Klasse wird als Dateiname voreingestellt. Wenn der Klassenname Zeichen enthält, die als Dateiname nicht erlaubt sind (z. B. '/'), so werden diese Zeichen im Dateinamen durch Leerzeichen ersetzt. Zur besseren Übersicht beginnt der Dateiname einer Meldeliste mit "Mel_" und einer Ergebnisliste mit "Erg_". Dieser voreingestellte Dateiname kann natürlich geändert werden. Das Verzeichnis zum Speichern der HTML-Dateien wird in der Ini-Datei abgelegt und steht beim nächsten Programmstart wieder zur Verfügung.

Besonderheiten beim Speichern von HTML-Dateien

  • Landeskenner, Yachtnamen und Geburtsjahrgänge werden abhängig von den eingestellten Optionen der Klasse gespeichert bzw. nicht gespeichert.
  • UnterOptionen kann "DSV-Nr unterdrücken" gewählt werden. In diesem Falle werden die DSV-Nummern nicht gespeichert.
  • Unter Optionen kann ein englischer Listenkopf gewählt werden. Diese Wahl gilt dann für alle Klassen der Dateigruppe und wird gespeichert. Beim erneuten Speichern der Melde- oder Ergebnislisten dieser Dateigruppe wird die gewählte Sprache wieder voreingestellt.

  • Bei der Meldeliste kann wahlweise der Clubname des Seglers gespeichert werden. Alternativ kann der Bootstyp , die Yardstickzahl (bei Yardstick-Wertung), die ORC-Faktoren (bei ORC-Wertungen) und die Klassenzuordnung der Segler gespeichert werden.

  • Wird ein Ergebnislistentyp für eine, drei oder vier Wettfahrten gewählt, so werden pro Wettfahrt der Rang und die Punkte von allen gewerteten Wettfahrten gespeichert. Wird dagegen ein Ergebnislistentyp für sechs oder mehr Wettfahrten gewählt, so werden pro Wettfahrt nur die Ränge gespeichert. Der Anwender kann also durch die Wahl des Listentyps bestimmen, ob Rang und Punkte oder nur der Rang pro Wettfahrt gespeichert werden sollen.

  • Unabhängig von der gewählten Ergebnisliste werden in der HTML-Datei alle gewerteten Wettfahrten gespeichert.
  • Bei Yardstick- oder ORC-Wertung werden bei allen Ergebnislisten der Bootstyp und der Yardstick bzw. der TMF- oder GPH-Faktor gespeichert.
  • Wenn bei Yardstick- oder ORC-Wertung auch die gesegelten und berechneten Zeiten gespeichert werden sollen, dann ist der Listentyp "4 Wf, mehrzeilig, Yardstick, ORC" oder "Einzel-Wettfahrt-Ergebnis" zu wählen. Die Punkte pro Wettfahrt werden in diesem Falle aus Platzgründen nicht gespeichert.
  • Bei ORC-Club-Wertung nach dem Zeit/Distanz-System werden mit dem Listentyp "Einzel-Wettfahrt-Ergebnis" auch die Faktoren GPH, PLT und PLD gespeichert.
  • Wettfahrtzeiten und Wind-/Bahndaten werden gespeichert, wenn diese für die Ergebnisausgabe gewählt wurden.
  • Vor dem Speichern erfolgt in jedem Falle eine automatische Wertung , um die Ergebnisse zu aktualisieren.

Listenkopf in der HTML-Datei

  • Ab WinRegatta Version 4.3 kann optional ein "Erweiterter Listenkopf" gewählt werden
  • Unter Optionen kann entweder der Standardkopf - wie bisher - gewählt werden oder ein erweiterter Listenkopf.
  • Es können bis zu neun verschiedene Elemente gewählt werden, die linksbündig ausgegeben werden.
  • Für jedes dieser Elemente kann die Schriftgröße in vier Abstufungen festgelegt werden.
  • Die Auswahl wird in der Datei "*.R48" und in der Ini-Datei gespeichert und bei einer späteren HTML-Speicherung wieder voreingestellt.
  • Als unterste Kopfzeile wird Datum und Uhrzeit der Erstellung der HTML-Datei gezeigt.

Optionen für Ergebnislisten als HTML-Datei

  • Im Auswahlfeld "Ergebnis-Status" kann der Ergebnisstatus gewählt werden. Dieser Status wird pro Klasse gespeichert. Beim späterem erneuten Ergebnisdruck der Klasse wird der gespeicherte Ergebnisstatus wieder automatisch voreingestellt.
    • "Vorl. Zwischen-Ergebnis" (Protestfrist noch nicht abgelaufen).
      Es wird die Bezeichnung "Zwischenergebnis" ausgegeben, in der Annahme, dass Vorläufige Zwischenergebnisse kaum mittels HTML-Datei publiziert werden.
    • "Zwischen-Ergebnis" (nach Ablauf der Protestfrist bzw. nach Abschluss möglicher Protestverhandlungen, aber noch nicht alle geplanten Wettfahrten gesegelt).
    • "End-Ergebnis" (alle geplanten Wettfahrten wurden gesegelt und keine Proteste mehr anhängig).
      Bei Ranglistenregatten werden die Ranglistenpunkte gedruckt, was bei einem Zwischenergebnis ja keinen Sinn machen würde.
  • Im Auswahlblock "Drucken am Ende der Liste ..." kann das Speichern des Wettfahrtprotokolls in der HTML-Datei gewählt werden. Diese Wahl wird pro Klasse gespeichert. Bei einem späteren erneuten Speichern der Klasse wird der gespeicherte Auswahlblock wieder automatisch voreingestellt.
    Folgendes kann in unterschiedlicher Kombination gewählt werden:
    • Keine Protokolldaten
    • Wind-/Bahndaten
    • Wettfahrtzeiten Die mittlere Geschwindigkeit des Siegers der Klasse wird nur gespeichert, wenn sowohl die Wind-/Bahndaten als auch die Wettfahrtzeiten zur Ausgabe gewählt wurden.
    • Hinweis zur Regatta (max. 250 Stellen), sofern in der Funktion "Wertung " oder in der Funktion "Drucken " dieser Hinweis eingegeben wurde.


Funktion "Stammdaten"

Mit der Funktion "Stammdaten" können Seglerdaten über mehrere Regatten hinweg archiviert werden. In Vorbereitung einer künftigen Regatta können diese Daten wieder reaktiviert werden. Es können Daten mehrerer Veranstaltungen in einer Stammdatei gespeichert oder auch beliebig viele Stammdateien angelegt werden.

In Vorbereitung einer künftigen Regatta können die Segler aus einer Stammdatei wieder in die aktuelle Regattadatei (Dateigruppe) übernommen werden und damit für eine neue Veranstaltung wieder reaktiviert werden, um den Eingabeaufwand der Meldedaten zu reduzieren.

In der Stammdatei werden alle Daten der ersten drei Segler pro Boot einschließlich der Adressen der Steuerleute (falls eingegeben) gespeichert, mit Ausnahme der Ergebnisse und der Klassenzuordnung, da diese für eine nächste Veranstaltung nicht relevant sind.

Zusätzlich werden pro Crew

  • "Name der Veranstaltung",
  • "Datum der Veranstaltung" und
  • "Klassen-Name"

gespeichert. Diese Daten können bei der Reaktivierung der Seglerdaten als Auswahlkriterien dienen.

In der Stammdatenfunktion werden zwei Datengitterkomponenten verwendet, die dem Anwender eine große Funktionsvielfalt bieten, diese Daten zu speichern und zu verwalten.

Datengitter-Funktionen

Seglerdaten in Stammdatei archivieren

Stammdaten verwalten

Stammdaten pflegen

Stammdaten reaktivieren


Datengitter-Funktionen

In der Stammdatenfunktion werden Datengitterkomponenten verwendet, die dem Anwender eine große Funktionsvielfalt bieten. Der Anwendungsbildschirm zeigt zwei Datengitter. Im oberen Datengitter werden alle Seglerdaten der aktuell geöffneten Regattadatei (Dateigruppe ) gezeigt. Im unteren Datengitter erscheinen die Segler, die in der geöffneten Stammdatei schon gespeichert sind.

Spaltenkonfiguration im Datengitter

  • Mit Klick auf [image] können die Spalten gewählt werden, die sichtbar sein sollen.
  • Durch Ziehen am Spaltenkopf nach links oder rechts kann die Spaltenfolge geändert werden.
  • Beim Beenden von WinRegatta wird die Spaltenkonfiguration in der Datei "Grid.ini" gespeichert, damit der Anwender beim nächsten Anwendungsstart wieder die gleiche Konfiguration vorfindet.
  • Mit Klick auf [image] kann die momentane Konfiguration gespeichert werden (in "Gridstd.ini"), um sie später mit Klick auf [image] wieder zu restaurieren.
Daten sortieren
  • Mit Mausklick auf den Spaltenkopf kann nach jeder Spalte aufsteigend sortiert werden. Ein zweiter Klick auf den Kopf der gleichen Spalte sortiert die Daten in absteigender Folge.

Navigation im Datengitter

  • Mit Mausklick in eine Zelle des Datengitters können eine Zeile und Spalte selektiert werden.
  • Mit den Bildtasten und den vertikalen Pfeiltasten der Tastatur sowie mit dem Scrollbalken kann vertikal gescrollt werden.
  • Mit der Maus, der Tabtaste und den horizontalen Pfeiltasten erfolgt die Auswahl der Spalte (Zelle) in einem Datensatz. Mit der Pos1- und Endetaste wird die erste bzw. letzte Spalte der Zeile ausgewählt.

Segler suchen und auswählen

  • Den Suchbegriff an beliebiger Stelle in der Spalte eingeben, in der gesucht werden soll. Es erfolgt eine inkrementelle Suche.
  • Mit Mausklick und Shift- oder Strg-Taste können mehrere Datensätze markiert werden.

Editieren im Datengitter

  • Siehe Stammdaten pflegen


Seglerdaten in Stammdatei archivieren

Im oberen Datengitter werden alle Segler der aktuell geöffneten Regattadatei (Dateigruppe) gezeigt. Diese Daten können hier nicht verändert werden (eine Änderung ist nur in der Funktion "Segler" möglich). Der Ordnungsbegriff ist der Familienname, gefolgt von dem Vornamen des Steuermannes bzw. der Steuerfrau.

Um Seglerdaten aus der aktuellen Dateigruppe in die Stammdatei zu übernehmen, werden die Datensätze (Zeilen) im oberen Datengitter markiert. Mit Klick auf [image] werden die markierten Segler dann in die geöffnete Stammdatei (unteres Datengitter) nach folgender Regel kopiert:

  • Falls noch kein Satz für diesen Segler vorhanden ist, wird ein neuer Satz eingefügt und gespeichert.
  • Wenn in der Stammdatei schon ein Satz mit dem gleichen Namen existiert, dann wird dieser mit den neuen Daten aktualisiert. Eine Ausnahme gibt es hier: Falls der Seglersatz, der in die Stammdatei übernommen werden soll, keine Adresse des Steuermannes enthält, dann werden die Adressfelder in der Stammdatei nicht überschrieben, damit eine evtl. schon vorhandene Adresse erhalten bleibt.

In der Stammdatei werden alle Daten der ersten drei Segler pro Boot einschließlich der Adressen der Steuerleute (falls eingegeben) gespeichert mit Ausnahme der Klassenzuordnung und der Ergebnisse, da diese für eine künftige Veranstaltung nicht relevant sind.

Zusätzlich werden pro Crew

  • "Name der Veranstaltung",
  • "Datum der Veranstaltung" und
  • "Klassen-Name"

gespeichert. Diese Daten können später bei der Reaktivierung der Seglerdaten als Auswahlkriterien dienen.


Stammdaten verwalten

Im unteren Datengitter werden alle Segler gezeigt, die in der geöffneten Stammdatei gespeichert sind. Der Ordnungsbegriff ist der Familienname, gefolgt von dem Vornamen des Steuermannes bzw. der Steuerfrau.

Die Stammdaten werden in einer Datei im Format der Paradox-Datenbank gespeichert. Diese Datei hat als Dateierweiterung ".DB" und wird direkt auf der Festplatte geführt. Ein Speichern dieser Datei ist somit nicht nötig, es sei denn der Dateiname soll geändert werden. Es können beliebig viele Stammdateien angelegt werden, z.B. für jede Veranstaltung oder für jede Klasse eine Datei. Es können aber auch die Daten aus mehreren Veranstaltungen in einer Stammdatei zusammengefaßt werden.

Verwaltung der Stammdateien

  • "Neu"
     Eine neue (leere) Stammdatei wird erzeugt. Ein Dialogfenster erscheint, in dem Sie dieser neuen Datei einen selbstgewählten Namen geben sollten. Der Pfad und der Dateiname werden im Kopf des unteren Datengitters angezeigt. Nun können Seglerdaten vom oberen Datengitter in diese Datei gespeichert werden.
  • "Öffnen"
    Diese Funktion ermöglicht die Auswahl und das Öffnen einer Stammdatei. Das zuletzt benutzte Verzeichnis ist in der Ini-Datei gespeichert und wird nun voreingestellt. Die Stammdaten dieser geöffneten Datei werden im unteren Datengitter angezeigt und können nun bearbeitet werden. Beim nächsten Start von WinRegatta wird die zuletzt benutzte Stammdatei automatisch wieder geöffnet.
  • "Speichern unter..."
    Hier kann die geöffnete Stammdatei unter einem neuen Dateinamen (ggf. auch in ein anderes Verzeichnis oder auf ein anderes Laufwerk) gespeichert werden. Ein Speichern unter dem gleichen Namen ist nicht nötig, da die Stammdateien auf der Festplatte und nicht im Hauptspeicher geführt werden.
  • "Löschen Datei..."
     Hier kann eine bestimmte Stammdatei, die nicht mehr benötigt wird, gelöscht werden.


Stammdaten pflegen

Im unteren Datengitter werden alle Segler gezeigt, die in der geöffneten Stammdatei gespeichert sind. Die Stammdaten können hier ergänzt oder auch selektiv gelöscht werden.

Editieren im Datengitter

  • Mit Klick auf [image] wird der Editmodus eingeschaltet.
  • Mit dem Scrollbalken und mit den Bildtasten kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Die Daten der ausgewählten Zelle können geändert werden.
  • Die geänderten Daten werden beim Verlassen des Datensatzes (Zeile) akzeptiert.
    Mit der Esc-Taste werden die Änderungen der zuletzt bearbeiteten Zelle verworfen. Wird die Esc-Taste erneut betätigt, so werden alle Änderungen des Datensatzes verworfen.

Such- und Auswahlmodus

  • Mit Klick auf [image] wird dieser Modus eingeschaltet.
  • Mit dem Scrollbalken und den Bildtasten kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Den Suchbegriff an beliebiger Stelle in der Spalte eingeben, in der gesucht werden soll. Es erfolgt eine inkrementelle Suche.
  • Mit Mausklick und Shift- oder Strg-Taste können mehrere Datensätze markiert werden.
  • Mit Klick auf [image] oder durch gleichzeitige Betätigung der Tasten Strg und Entf können die markierten Datensätze gelöscht werden.

Stammdaten exportieren

  • Mit Klick auf [image] können die Stammdaten (unteres Datengitter) in eine Textdatei, Excel-Tabelle oder HTML-Datei gespeichert und damit exportiert werden.

  • Es werden die sichtbaren Spalten im Datengitter in der angezeigten Reihenfolge abgespeichert. Vor dem Exportieren sollte das Datengitter so konfiguriert werden, wie die Daten in der Exportdatei gewünscht werden.

  • Während des Speichervorganges kann gewählt werden, ob alle Datensätze oder nur die markierten Datensätze exportiert werden sollen.
  • Beispiel: Exportieren von Adressdaten für eine Serienbriefaktion zur Einladung zu einer Regatta:
    • Die Segler einer Veranstaltung vom Vorjahr sollen mittels der Serienbrief-Funktion von Word wieder zur diesjährigen Veranstaltung eingeladen werden.
    • Voraussetzung ist natürlich, dass die Adressdaten eingegeben wurden. Dies kann in der Funktion "Segler " mit Doppelklick auf das Feld des Steuermannes geschehen oder in der Funktion "Stammdaten".
    • Mit Klick auf den Spaltenkopf "Regatta-Veranstaltung" die Stammdaten nach dem Veranstaltungsnamen sortieren.
    • Mit Klick auf [image] die Spalten sichtbar machen, die die Adresse der Steuerleute enthalten. Alle nichtrelevanten Spalten unsichtbar machen.
    • Den Block der Segler der letztjährigen Veranstaltung markieren.
    • Mit Klick auf [image] die markierten Datensätze als Textdatei oder Excel-Tabelle speichern.
    • Diese Daten können dann von Word zur Serienbriefschreibung verwendet werden.


Stammdaten reaktivieren

Im unteren Datengitter werden alle Segler gezeigt, die in der geöffneten Stammdatei gespeichert sind. Jeder Datensatz repräsentiert eine Crew mit allen Daten. Diese Daten können hier auch ediert und somit ergänzt werden und auch gelöscht werden. Der Ordnungsbegriff ist der Familienname, gefolgt von dem Vornamen des Steuermannes bzw. der Steuerfrau. Diese Namensdaten können allerdings nicht geändert werden, da sie eine Indexfunktion für den Zugriff haben.

Übernahme von Seglern aus der Stammdatei für eine neue Regatta

Die Segler können einzeln oder in Gruppen in die aktuelle Dateigruppe überführt werden.

  • Auswahlkriterien können z. B. sein:
    • Ein bestimmter Bootstyp
    • Der Name einer Wertungsklasse (Klassenname)
    • Der Name einer Regatta-Veranstaltung
    • Das Datum einer Veranstaltung
  • Wie kann diese Auswahl vorgenommen werden?
    • Mit Klick auf [image] den Such- und Auswahlmodus einschalten.
    • Nach der Spalte des gewünschten Auswahlkriteriums sortieren durch Klick auf den Spaltenkopf.
    • Die Datensätze des gewünschten Kriteriums jetzt als Block markieren (mit Hilfe der Shift- und/oder Strg-Taste).
    • Durch Klick auf [image] die markierten Sätze in die aktuelle Dateigruppe (oberes Datengitter) kopieren.
  • Das Kopieren der Datensätze erfolgt nach folgenden Regeln:
    • Wenn für den Steuermann / die Steuerfrau bereits ein Datensatz im oberen Datengitter vorhanden ist, dann werden die Felder dieses Satzes aktualisiert.
    • Wenn der Steuermann / die Steuerfrau im oberen Datengitter noch nicht existiert, so wird ein neuer Datensatz erstellt, und alle Datenfelder werden kopiert, allerdings mit Ausnahme der Felder, die in dem Stammdatensatz als Auswahlkriterium dienten (Name der Veranstaltung, Regattadatum, Klassenname), denn diese Informationen sind für eine neue Veranstaltung nicht relevant.
  • Editieren der reaktivierten Seglerdaten in der Funktion "Segler ":
    • Die aus der Stammdatei übernommenen Segler haben keine Klassenzuordnung, denn die Felder "P" und "S1" bis "S5" sind leer.
    • Nun die Funktion "Segler " aufrufen und "A" für "Alle Klassen" auswählen. Alle Segler der Dateigruppe werden angezeigt.
    • Die Datensätze der reaktivierten Segler können nun mit den neuen Meldedaten abgeglichen und editiert werden, z. B. geänderte Segelnummer, anderer Vorschoter usw.
    • Entsprechend der für die neue Regatta definierten Klassen sind die Segler durch Eingabe einer Klassennummer den Klassen zuzuordnen .
    • Segler, die übernommen wurden, die aber für diese neue Regatta nicht gemeldet haben, können gelöscht werden oder auch inaktiv (Feld "P" = leer) bestehen bleiben.


Funktion Clubs

Funktion "Clubs" - Pflege der Club-Datenbank

Im Fenster "Clubs" kann die Datenbank der Segelclubs gepflegt werden. Eine Club-Datenbank mit allen Clubs, die dem DSV angeschlossen sind (ca. 1330 verschiedene Clubs), wird mit WinRegatta geliefert. Der Änderungsstand der Club-Datenbank ist im Bemerkungsfeld des ersten Satzes der Tabelle vermerkt. Neue bzw. fehlende Clubs können mit ihren entsprechenden DSV-Nummern und Club-Namen eingegeben werden oder im Rahmen der Seglerdateneingabe erfasst werden. Im Datengitter kann auch eine Bemerkung zu dem Club eingegeben werden. Alle Felder erscheinen bei der Seglereingabe im Auswahlfenster (Doppelklick auf das Club-Feld) zur Wahl des richtigen Clubs für den Segler.

Alle diese Club-Daten werden in der Datei "Clubs-4.DB" gespeichert. Nach der Installation von WinRegatta befindet sich diese Datei im Installationsordner von WinRegatta.
Ab WinRegatta Version 4.5 können mit einem "Öffnen-Dialog" unterschiedliche Club-Datenbanken geöffnet und mit einem "Speichern unter-Dialog" auch in andere Ordner mit geänderten Dateinamen gespeichert werden.

Arbeiten im Datengitter


Arbeiten im Datengitter

Daten sortieren

Mit Mausklick auf den Spaltenkopf kann nach jeder Spalte aufsteigend sortiert werden. Ein zweiter Klick auf den Kopf der gleichen Spalte sortiert die Daten in absteigender Folge.

Editiermodus

  • Mit Klick auf [image] wird der Editiermodus eingeschaltet.
  • Mit dem Scrollbalken, den Bildtasten und dem Mausrad kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Die Daten der ausgewählten Zelle können geändert werden.
  • Die geänderten Daten werden akzeptiert durch Verlassen der Zeile oder durch Klick auf [image] unten links. Die geänderten Daten werden verworfen mit der Esc-Taste oder durch Klick auf [image] unten links.
  • Ein neuer Clubsatz wird erzeugt durch Klick auf [image] unten links oder mit der Einfg-Taste.
  • Der ausgewählte Club wird gelöscht durch Klick auf [image] unten links.

Such- und Auswahlmodus

  • Mit Klick auf [image] wird dieser Modus eingeschaltet.
  • Mit dem Scrollbalken, mit den Bildtasten und dem Mausrad kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Den Suchbegriff an beliebiger Stelle in der Spalte eingeben, in der gesucht werden soll. Es erfolgt eine inkrementelle Suche.
  • Mit Mausklick und Shift- oder Strg-Taste können mehrere Clubs markiert werden.
  • Mit Klick auf [image] oder durch gleichzeitige Betätigung der Tasten Strg und Entf können die markierten Clubs gelöscht werden.

Clubs-Datei nach Excel exportieren Neu ab Vers. 4.4

  • Mit Klick auf [image] werden alle Daten des Datengitters (alle Clubs) nach Excel exportiert.
  • Die Excel-Tabelle wird mit gleichem Pfad und Dateinamen wie die geöffnete Clubs-Datei gespeichert, z. B. "Clubs-4.xls".

Datei-Funktionen Neu ab Vers. 4.5

  • Mit Klick auf [image] kann eine beliebige Clubs-Datei (Club-Datenbank) geöffnet werden.
  • Mit Klick auf [image] wird eine neue, leere Clubs-Datei erstellt.
  • Mit Klick auf [image] kann die aktive Clubs-Datei unter einem anderen Dateinamen in einen beliebigen Ordner gespeichert werden.


Funktion Boote

Funktion "Boote" - Pflege der Boote-Datenbank

Im Fenster "Boote" kann die Datenbank der Bootstypen gepflegt werden. Der Stand der Boote-Datenbank ist im Bemerkungsfeld des ersten Satzes der Tabelle vermerkt.

Diese Datenbank enthält die Yardstick-Tabelle der Kreuzer-Abteilung mit über 1800 verschiedene Bootstypen. Diese Yardstick-Tabelle ist urheberrechtlich geschützt durch Copyright des DSV. Zusätzlich benötigte Bootstypen können mit ihren entsprechenden Yardstickzahlen eingegeben werden oder im Rahmen der Seglerdateneingabe erfasst werden. Im Datengitter kann auch eine Bemerkung zu dem Bootstyp eingegeben werden.

Alle diese Boots-Daten werden in der Datei "Boote-4.DB" gespeichert. Nach der Installation von WinRegatta befindet sich diese Datei im Installationsordner von WinRegatta. Ab WinRegatta Version 4.5 können mit einem "Öffnen-Dialog" unterschiedliche Bootedateien geöffnet und mit einem "Speichern unter-Dialog" auch in andere Ordner mit geänderten Dateinamen gespeichert werden.

Aktivierung von relevanten Bootstypen

Es ist sicher ein großer Vorteil, einen ständigen Zugriff auf die Yardsticktabelle zu haben. Aber es entstehen hierdurch auch einige Probleme, die zu lösen sind:

Im Unterschied zu den Club-Abkürzungen sind die Bezeichnungen der Bootstypen viel länger und unsystematischer. An den Regatten eines bestimmten veranstaltenden Clubs nimmt sicher nur eine begrenzte Anzahl der Bootstypen teil. Es macht somit Sinn, die Bootstypen, die für den Veranstalter interessant sein können, in der Boote-Tabelle zu kennzeichnen. Dies geschieht durch Eingabe eines "x" in der linken Spalte des Datengitters. Die so markierten Bootstypen gelten fortan als "aktiv". In der Auswahlliste bei der Seglereingabe werden nur die so aktivierten Bootstypen gezeigt. Dies erhöht in hohem Masse die Übersichtlichkeit. Mit einem Klick im Auswahlfenster können aber auch alle Bootstypen wieder angezeigt werden.

Bezeichnung des Bootstyps verkürzen

Ein weiteres Problem stellt die oft sehr lange Bezeichnung eines Bootstyps dar. Es ist schwierig, den hierfür erforderlichen Platz bei den verschiedenen Anzeigen auf dem Bildschirm und auf den Drucklisten zur Verfügung zu stellen. Auf den Drucklisten erfolgt übrigens bei zu langen Namen ein Wortumbruch, und es wird eine zusätzliche Zeile eingeschoben. Diese langen Namen sind sicher nötig, um einen bestimmten Bootstyp zu identifizieren, aber im Einzelfall kann der Name auch sinnvoll gekürzt werden. Es wird empfohlen, hierbei den ursprünglichen Bootstyp in der Tabelle nicht zu verändern, sondern einen neuen Datensatz als Duplikat mit gekürzter Bezeichnung anzulegen und diesen mit "x" zu aktivieren. Um auch später nachvollziehen zu können, von welchem Bootstyp welches Duplikat angelegt wurde, sollten im Bemerkungsfeld dieser Datensätze entsprechende Querverweise eingegeben werden.

Eine neue Boote-Datei anlegen

Für Clubs, an deren Regatten wiederkehrend die gleichen Bootstypen teilnehmen, kann es interessant sein, auf die umfangreiche Bootedatei ganz zu verzichten und sich eine eigene, kleine Datei anzulegen. Das Gleiche kann auch für bestimmte Regattagebiete sinnvoll sein, für die revierspezifische Yardstickzahlen vereinbart wurden.

Mit Klick auf den Symbolschalter "Neue Bootedatei" wird eine neue, leere Bootedatei erzeugt. Mit dem Speichern-unter-Dialog kann dieser Datei ein individueller Dateiname gegeben werden.

Arbeiten im Boote-Datengitter


Arbeiten im Boote-Datengitter

Daten sortieren

Mit Mausklick auf den Spaltenkopf kann nach jeder Spalte aufsteigend sortiert werden. Ein zweiter Klick auf den Kopf der gleichen Spalte sortiert die Daten in absteigender Folge.

Editmodus

  • Mit Klick auf [image] wird der Editmodus eingeschaltet.
  • Mit dem Scrollbalken, den Bildtasten und dem Mausrad kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Die Daten der ausgewählten Zelle können geändert werden.
  • Die geänderten Daten werden akzeptiert durch Verlassen der Zeile oder durch Klick auf [image] unten links. Die geänderten Daten werden verworfen mit der Esc-Taste oder durch Klick auf [image] unten links.
  • Ein neuer Datensatz wird erzeugt durch Klick auf [image] unten links oder mit der Einfg-Taste.
  • Der ausgewählte Bootstyp wird gelöscht durch Klick auf [image] unten links.
  • Such- und Auswahlmodus
  • Mit Klick auf [image] wird dieser Modus eingeschaltet.
  • Mit dem Scrollbalken, mit den Bildtasten und dem Mausrad kann vertikal gescrollt werden.
  • Mit Maus, Tabtaste, Entertaste und den Pfeiltasten erfolgt die Auswahl der Zelle im Datengitter.
  • Den Suchbegriff an beliebiger Stelle in der Spalte eingeben, in der gesucht werden soll. Es erfolgt eine inkrementelle Suche.
  • Mit Mausklick und Shift- oder Strg-Taste können mehrere Bootstypen markiert werden.
  • Mit Klick auf [image] oder durch gleichzeitige Betätigung der Tasten Strg und Entf können die markierten Bootstypen gelöscht werden.

Boote-Datei (Yardsticktabelle) nach Excel exportieren Neu ab Vers. 4.4

  • Mit Klick auf [image] werden alle Daten des Datengitters (die gesamte Yardsticktabelle) nach Excel exportiert.
  • Die Excel-Tabelle wird mit gleichem Pfad und Dateinamen wie die geöffneten Bootedatei gespeichert, z. B. "Boote-4.xls".

Datei-Funktionen Neu ab Vers. 4.5

  • Mit Klick auf [image] kann eine beliebige Bootedatei (Boote-Datenbank) geöffnet werden.
  • Mit Klick auf [image] wird eine neue, leere Bootedatei erstellt.
  • Mit Klick auf [image] kann die aktive Bootedatei unter einem anderen Dateinamen in einen beliebigen Ordner gespeichert werden.


Funktion Gruppenwertung

Funktion Gruppenwertung (nur WinRegatta Plus)

Bei großen Starterfeldern mit mehr als 80 Booten in einer Wertungsklasse wird es schwierig, einen fairen Start durchzuführen. Noch problematischer ist es, wenn das Revier in der Größe begrenzt ist und dadurch das Längenverhältnis von Startlinie und Startkreuz kritisch wird. Eine Gruppenwertung ist hier die empfohlene Lösung.

Bei einer Gruppenwertung werden die Boote in zwei oder auch mehr Gruppen eingeteilt. Jede Gruppe bildet eine Startgruppe. Die Gruppen starten auf der gleichen Startlinie, z. B. im Fünfminutenabstand. Die Segler der jeweiligen Gruppe segeln gegeneinander. Es wird aber nur e i n e Ergebnisliste über alle Gruppen hinweg erstellt.

In WinRegatta Plus ist eine sehr komfortable Lösung der Gruppenwertung implementiert, die alle üblichen Varianten dieser Wertungsart beinhaltet.

Die Gruppeneinteilung der Boote erfolgt weitgehend automatisch und wegen des automatisierten Ablaufs auch ohne Fehlerrisiko. In einem Dialog können mit wenigen Mausklicks alle Varianten der Gruppenbildungen vorgenommen werden.

Die erste Gruppeneinteilung vor der ersten Wettfahrt kann wahlweise automatisch oder manuell oder auch automatisiert nach dem Zufallsprinzip vorgenommen werden.

Es können auch nachträgliche Korrekturen an Ergebnissen für Wettfahrten, die in einer früheren Gruppeneinteilung gesegelt wurden, problemlos vorgenommen werden.

Die Wertung der einzelnen Startgruppen erfolgt mittels Primärklassen, die bei der Klassendefinition als "Gruppenwertung" ("Gr-W") gekennzeichet sind. Hierdurch wird sichergestellt, dass nach einer neuen Gruppeneinteilung der Boote die bisher gesegelten Wettfahrten nicht neu berechnet werden, sondern nur die ursprünglich berechneten Ergebnisse dieser Wettfahrten in das Gesamtergebnis übernommen werden.

Die Wertung des Gesamtergebnisses über alle Gruppen erfolgt in einer Sekundärklasse, die ebenfalls als "Gruppenwertung" ("Gr-W") gekennzeichnet ist. Hier ist kein zusätzlicher Aufwand für die Eingabe der gesegelten Ergebnisse nötig. Bei der Wertung des Gesamtergebnisses wird bei keiner Wettfahrt eine Neuberechnung vorgenommen, sondern nur die ursprünglich berechneten Wf-Ergebnisse der Gruppen in das Gesamtergebnis übernommen. Die naturgemäß häufigen Punktgleichen im Gesamtergebnis werden ganz normal - wie in den Wettfahrt-Regeln definiert - gelöst.

Weitere Details:

Methoden der Gruppenwertung

Wertungsklassen

Seglerdaten

Gruppeneinteilung

Ergebniseingabe

Wertung Gruppenwettfahrten

Wertung Finalwettfahrten

Druck von Ergebnislisten


Methoden der Gruppenwertung

Es sind zwei unterschiedliche Methoden der Gruppenwertung üblich:

Einteilung der Boote in die Gruppen B (blue), G (green), R (red) und Y (yellow):

Üblicherweise werden bei dieser Methode der Gruppenwertung die Gruppen mit Blue, Green, Red und Yellow bezeichnet und die Boote auch mit diesen Farben gekennzeichnet. Entsprechend werden in Winregatta die Gruppen als B, G, R und Y geführt.

Aus diesen vier Gruppen werden zwei Gruppenpaare gebildet. Ein Gruppenpaar bildet jeweils eine Startgruppe. Nach jeder Wettfahrt werden die Paarungen geändert und damit die Zusammensetzung der Startgruppen.
Details finden Sie hier .

Einteilung der Boote in wechselnde Gruppen:

Es werden zwei Gruppen gebildet. Bei sehr großen Meldezahlen sind auch drei oder vier Gruppen möglich. Jede Gruppe bildet eine Startgruppe. Diese Gruppenkonstellation bleibt für einen Regattatag bestehen. Für den nächsten Tag werden die Gruppen an Hand des bis dahin gesegelten Gesamtergebnisses neu eingeteilt.
Details finden Sie hier .


Gruppen B, G, R und Y

Erklärungen der Gruppenbezeichnungen finden Sie hier.

Nehmen wir an, dass 97 Boote für eine Regatta gemeldet haben. Diese Regatta ist für 12 Wettfahrten ausgeschrieben, von denen sollen 9 Rennen (mindestens vier) zur Vorrunde gehören und drei zum Finale (die Anzahl der Vorrundenläufe und Finalläufe ist häufig unterschiedlich). Natürlich kann auch auf Finalläufe verzichtet werden. In diesem Falle würden alle Segler in allen Läufen in nur einer Ergebnisliste erscheinen. Wichtig ist, dass die Segelanweisung zum Ausdruck bringt, ob und wie Finalläufe vorgesehen sind.

Diese 97 Boote werden nun in vier Gruppen B (blue) , G (green), R (red), Y (yellow) eingeteilt. Als Kriterium für die Einteilung dient der Qualifikations-Rang des Steuermannes / der Steuerfrau. Üblicherweise ist dies der Rang in der Aktuellen Rangliste des DSV oder auch in einer internationalen Rangliste.

Gruppe B: 25 Boote, Gruppe G: 24 Boote, Gruppe R: 24 Boote, Gruppe Y: 24 Boote.

Einteilung:
Rang 1 -Gruppe B
Rang 2 -Gruppe G
Rang 3 -Gruppe R
Rang 4 -Gruppe Y
Rang 5 -Gruppe Y
Rang 6 -Gruppe R
Rang 7 -Gruppe G
Rang 8 -Gruppe B
Rang 9 -Gruppe B
usw.

Aus diesen vier Gruppen werden nun Gruppenpaare gebildet, zum Beispiel B mit G ein Gruppenpaar und R mit Y ein weiteres Gruppenpaar. Die Segler eines Gruppenpaares bilden jeweils eine Start- und Wertungsgruppe. Pro Wettfahrt gibt es also zwei unabhängige Startgruppen.

Zum Beispiel:
1. WF Gruppenpaare B/G und R/Y
2. WF Gruppenpaare B/R und G/Y
3. WF Gruppenpaare B/Y und G/R
4. WF Gruppenpaare B/G und R/Y
5. WF Gruppenpaare B/R und G/Y
6. WF Gruppenpaare B/Y und G/R
usw.

Nach jedem Lauf wird nur eine Gesamtergebnisliste erstellt, d. h. es gibt in jedem Lauf 2 erste, 2 zweite, 2 dritte, ...., zwei 48. Plätze und einen 49. Platz.

Nach der 6. WF können dann die Gruppen B, G, R und Y anhand der Gesamtergebnisliste neu eingeteilt werden. Es kann aber auch die bisherige Gruppeneinteilung belassen werden, da durch die 6 verschiedenen Gruppenpaarungen ohnehin eine Vermischung der Segler in den Startgruppen stattfindet.

Finalläufe:
Nach dem 9. Rennen (Ende der Vorrunde) gibt es immer noch nur eine Gesamtergebnisliste. Wenn Finalläufe gesegelt werden sollen, dann werden nun die ersten 49 Boote (oder jede andere vorher festgelegte Zahl von Booten) auf der Liste in die Goldgruppe, die restlichen in die Silbergruppe eingeteilt.

Die Goldgruppe segelt nun um die Plätze 1 bis 49. Die Ergebnisliste wird einfach weitergeführt. Am Ende gibt es also eine Liste mit 12 Rennen, wovon beispielsweise 2 (egal ob aus Vorrunde oder Finale ) gestrichen werden können.
Die Silbergruppe segelt in den Finalläufen als eigenständige Gruppe um die Plätze 50 bis 97. Hierbei ersegeln sie pro Lauf auch die Punkte 1 bis 48. Die Gesamtränge ergeben aber die Plätze 50 bis 97. Es kann natürlich vorkommen, dass der 49. Platz der Goldgruppe eine höhere Gesamtpunktzahl hat, als der 1. Platz (50 Platz) der Silbergruppe. Dies ist logisch und kann akzeptiert werden. Die Silbergruppe streicht natürlich - genau wie die Goldgruppe - die beiden schlechtesten Läufe aus allen 12 Rennen.

Was passiert mit einem DNC, DNS, BFD, .....?
o Während der Gruppenwertung in den 9 Vorrunden-Wettfahrten:
Diese Boote erhalten folgende Punkte: Anzahl der Boote der größten Gruppe +1 (in diesem Beispiel 49 + 1 = 50).
o Während der Final-Wettfahrten erhalten die Boote folgende Punkte:
Goldgruppe = Anzahl Boote + 1. Silbergruppe = Anzahl Boote + 1.

Vorteile dieser Methode:
Geringer administrativer Aufwand für die Wettfahrtleitung, da die Gruppeneinteilung weniger häufig vorgenommen werden muß. Das einzelne Boot bleibt immer in der gleichen Gruppe. Dies erleichtert die Kennzeichnung der Boote.

Dominierende Segler der Bootsklasse, die in ihren Startgruppen oft den 1. Platz ersegeln, werden nach diesem System zwangsläufig auch in der gleichen Startgruppe direkt gegeneinander segeln.


Wechselnde Gruppen

Nehmen wir an, dass 97 Boote für eine Regatta gemeldet haben. Diese Regatta ist für 12 Wettfahrten ausgeschrieben, von denen sollen 9 Rennen (mindestens vier) zur Vorrunde gehören und drei zum Finale (die Anzahl der Vorrundenläufe und Finalläufe ist häufig unterschiedlich). Natürlich kann auch auf Finalläufe verzichtet werden. In diesem Falle würden alle Segler in allen Läufen in nur einer Ergebnisliste erscheinen. Wichtig ist, dass die Segelanweisung zum Ausdruck bringt, ob und wie Finalläufe vorgesehen sind.

Diese 97 Boote werden dann in 2 Gruppen eingeteilt. Bei sehr großen Meldezahlen können auch drei oder vier Gruppen gebildet werden. WinRegatta Plus unterstützt bis zu vier Gruppen. Als Kriterium für die Einteilung dient der Qualifikations-Rang des Steuermannes / der Steuerfrau. Üblicherweise ist dies der Rang in der Aktuellen Rangliste des DSV oder auch in einer internationalen Rangliste..

Gruppe 1: 49 Boote, Gruppe 2: 48 Boote.

Einteilung:
Rang 1 -Gruppe 1
Rang 2 -Gruppe 2
Rang 3 -Gruppe 2
Rang 4 -Gruppe 1
Rang 5 -Gruppe 1
Rang 6 -Gruppe 2
Rang 7 -Gruppe 2
Rang 8 -Gruppe 1
usw.

Diese beiden Gruppen segeln dann am ersten Tag völlig getrennt - wie zwei eigenständige Klassen - 2 oder 3 Wettfahrten. Nach diesen Läufen wird nur eine Gesamtergebnisliste erstellt, d. h. es gibt in jedem Lauf 2 erste, 2 zweite, 2 dritte, ...., zwei 48. Plätze und einen 49. Platz.

Anhand dieser Ergebnisliste werden dann die Gruppen 1 und 2 für den nächsten Tag neu eingeteilt.

Finalläufe:
 Nach dem 9. Lauf (Ende der Vorrunde) gibt es immer noch nur eine Gesamtergebnisliste. Wenn Finalläufe gesegelt werden sollen, dann werden nun die ersten 49 Boote (oder eine beliebige andere Zahl von Booten) auf der Liste in die Goldgruppe, die restlichen in die Silbergruppe eingeteilt.

Die Goldgruppe segelt nun um die Plätze 1 bis 49. Die Ergebnisliste wird einfach weitergeführt. Am Ende gibt es also eine Liste mit 12 Rennen, wovon beispielsweise 2 (egal ob aus Vorrunde oder Finale) gestrichen werden können.

Die Silbergruppe segelt in den Finalläufen als eigenständige Gruppe um die Plätze 50 bis 97. Hierbei ersegeln sie pro Lauf auch die Punkte 1 bis 48. Die Gesamtränge ergeben aber die Plätze 50 bis 97. Es kann natürlich vorkommen, dass der 49. Platz der Goldgruppe eine höhere Gesamtpunktzahl hat als der 1. Platz (50 Platz) der Silbergruppe. Dies ist logisch und kann akzeptiert werden. Die Silbergruppe streicht natürlich - genau wie die Goldgruppe - die beiden schlechtesten Läufe aus allen 12 Rennen.

Was passiert, wenn am ersten Tag nur ein Lauf zustande kommt?
Man könnte dann die Gruppen für den nächsten Tag entweder so lassen, oder sie nach dem bis dahin gesegelten Gesamtergebnis auch neu aufteilen (siehe oben).

Es gibt noch Proteste, die erst am nächsten Abend verhandelt werden sollen?
In der Segelanweisung muß stehen, dass die Gruppen auch ohne Berücksichtigung eventueller Proteste eingeteilt werden können.

Was passiert mit einem DNC, DNS, BFD, .....?
 o Während der Gruppenwertung in den 9 Vorrunden-Wettfahrten:
Diese Boote erhalten folgende Punkte: Anzahl der Boote der größten Gruppe +1 (in diesem Beispiel 20 + 1 = 21).
o Während der Final-Wettfahrten erhalten die Boote folgende Punkte:
Goldgruppe = Anzahl Boote + 1. Silbergruppe = Anzahl Boote + 1.

Vorteile diese Methode:
Starke Vermischung der Segler in den Startgruppen durch Neueinteilung der Gruppen nach jeweils 2 bis 3 Wettfahrten auf der Basis der bis dahin gesegelten Ergebnisse.

Es können bei großen Meldezahlen auch leicht 3 oder 4 Startgruppen nach dem gleichen Prinzip gebildet werden.

Nachteile dieser Methode:
Höherer administrativer Aufwand für die Wettfahrtleitung durch mehrfache Neueinteilung der Gruppen und Kennzeichnung der Boote.

Wenn die Bootsklasse von zwei starken Seglern dominiert wird, und diese beiden Segler in ihren Gruppen jeweils den 1. Rang belegen, dann werden diese beiden bei der erneuten Einteilung der Gruppen wieder in unterschiedlichen Gruppen landen und somit nicht direkt gegeneinander segeln.


Wertungsklassen

Für jede geplante Startgruppe muß mit der Funktion "Klassen " eine primäre Wertungsklasse definiert werden. Bei der Klassendefinition wird die Klasse mit einem "P" als Primärklasse gekennzeichnet. In der Spalte "Gr-W " wird die Checkbox aktiviert als Kennzeichen, dass die Klasse zur Gruppenwertung gehört.

Des Weiteren muß eine sekundäre Wertungsklasse zur Berechnung des Gesamtergebnisses über alle Gruppen definiert werden. Diese Klasse erhält ein "S" für Sekundärklasse. Die Checkbox "Gr-W" wird ebenfalls aktiviert.

Wenn Untermengen der Boote (z. B. Junioren, Frauen) gewertet werden sollen, dann müssen jeweils weitere Sekundärklassen definiert werden, die ebenfalls als "Gr-W" zu kennzeichnen sind. Bitte beachten Sie hierbei, dass WinRegatta die Sekundärklasse mit der niedrigsten Klassennummer für die Ermittlung des Gesamtergebnisses verwendet.


Seglerdaten

Mit der Funktion "Segler" werden die Meldedaten der Segler ganz normal erfasst. Alle Boote sollten hierbei einer der definierten Primärklassen zugeordnet werden. Durch Aufruf dieser Klasse in der Funktion "Drucken" können dann Meldelisten und Checklisten für das Meldebüro vor der ersten Gruppeneinteilung der Boote gedruckt werden.

Nachdem die erste Gruppeneinteilung erfolgt ist, sollten in der Funktion "Segler" keine Änderungen der Klassenzuordnung mehr vorgenommen werden. Die richtige Klassenzuordnung geschieht im Rahmen der Gruppenbildung in der Funktion "Gruppenwertung". Meldelisten mit allen Booten können dann durch Aufruf der Sekundärklasse, die für das Gesamtergebnis vorgesehen ist, gedruckt werden.

In die Spalte "Quali" ist der Qualifikationsrang (z. B. Platz in der Aktuellen Rangliste des DSV oder in einer internationalen Rangliste) einzugeben. Dieser Rang dient als Kriterium für die automatisierte Gruppenbildung vor dem ersten Start. Wenn keine Rangliste mit Qualifikationsrängen zur Verfügung steht, dann kann die "Quali"-Spalte auch mit Zufallszahlen gefüllt werden. Soll die Gruppenbildung vor dem ersten Start nicht automatisiert nach dem Qualifikationsrang erfolgen, so kann diese Gruppeneinteilung auch manuell nach beliebigen anderen Kriterien erfolgen. Für eine manuelle Gruppeneinteilung kann die Spalte "Quali" leer bleiben.

Die Zuordnung der Segler zu Sekundärklassen für evtl. Wertungen von Untermengen kann bei der Seglereingabe ab der Spalte "S2" vorgenommen werden. Wichtig ist, dass die Spalte "S1" frei bleibt, da diese für die automatisierte Gruppenbildung verwendet wird.


Gruppeneinteilung

Mit der Funktion "Gruppen" werden die Boote in Gruppen eingeteilt. Die Einteilung vor dem ersten Start erfolgt üblicherweise anhand eines Qualifikationsmerkmals. Dies ist meistens wohl der Rangplatz in der Aktuellen Rangliste des DSV oder in einer internationalen Rangliste der Bootsklasse. Dieser Qualifikationsrang wird für jedes Boot in die Spalte "Quali" eingegeben. Die Eingabe des Qualifikationsranges kann im Datengitter der Funktion "Gruppen" erfolgen oder auch in der Funktion "Segler" während der Seglereingabe.

Die Gruppeneinteilung vor dem ersten Start kann aber auch manuell nach beliebig anderen Kriterien vorgenommen werden. Die Spalte "Quali" kann dann leer bleiben.

Die Gruppeneinteilung der Boote erfolgt weitgehend automatisch und wegen des automatisierten Ablaufs auch ohne Fehlerrisiko. In einem Dialog können mit wenigen Mausklicks alle beschriebenen Gruppenbildungen vorgenommen werden.

  • die Anfangseinteilung der Boote vor dem ersten Start , kann automatisiert anhand des Qualifikationsranges erfolgen oder manuell nach beliebigen anderen Kriterien vorgenommen werden.
  • eine Gruppeneinteilung nach gesegelten Wettfahrten anhand des bis dahin gesegelten Gesamtergebnisses erfolgt immer automatisiert.
  • die Bildung von Gold- und Silbergruppen für evtl. geplante Finalläufe erfolgt ebenfalls automatisiert.

Eine durchgeführte Gruppeneinteilung kann mehrfach wiederholt werden, solange in dieser Gruppenkonstellation noch nicht gesegelt wurde.

Nachträgliche Korrekturen der Gruppeneinteilung einzelner Boote sind auch möglich. Details finden Sie hier .


Vor dem ersten Start

Gruppeneinteilung vor dem ersten Start

In der Funktion "Gruppen" wird mit Klick auf "Gruppenbildung vor dem ersten Start" der Dialog aufgerufen, um die erste Gruppeneinteilung vorzunehmen.

Es stehen zwei unterschiedliche Arten der Gruppenbildung zur Wahl:

  1. Feste Gruppen B, G, R und Y , aus denen dann für jede Wettfahrt jeweils zwei Gruppenpaare gebildet werden.
    WinRegatta erwartet, dass zwei Primärklassen mit der Kennzeichnung "Gr-W" und eine Sekundärklasse mit der Kennzeichnung "Gr-W" definiert wurden, andernfalls erscheint ein entsprechender Hinweis.
    Jedes Gruppenpaar wird einer Primärklasse zugeordnet und bildet für diese Wettfahrt eine Start- und Wertungsgruppe.
    Die Boote von beiden Gruppenpaaren werden der Sekundärklasse zugeordnet zur Ermittlung des Gesamtergebnisses.
  2. Wechselnde Gruppen, die nach jeweils 2-3 Wettfahrten (am Ende eines Segeltages) wieder neu eingeteilt werden.
    Je nach der Anzahl der gemeldeten Boote können zwei, drei oder vier Gruppen gebildet werden (normal dürften aber zwei Gruppen ausreichen).
    WinRegatta erwartet, dass abhängig von der Anzahl der geplanten Gruppen zwei, drei oder vier Primärklassen mit der Kennzeichnung "Gr-W" und eine Sekundärklasse mit der Kennzeichnung "Gr-W" definiert wurden, andernfalls erscheint ein entsprechender Hinweis.
    Entsprechend der geplanten Gruppen werden die Boote den Primärklassen zugeordnet. Jede Primärklasse bildet eine Start- und Wertungsgruppe.
    Alle Boote werden der Sekundärklasse zugeordnet zur Ermittlung des Gesamtergebnisses.

Wenn zusätzlich Untermengen der Boote (z. B. Junioren, Frauen) gewertet werden sollen, dann müssen jeweils weitere Sekundärklassen definiert werden, die ebenfalls als "Gr-W" zu kennzeichnen sind. Bitte beachten Sie hierbei, dass WinRegatta die Sekundärklasse mit der niedrigsten Klassennummer für die Ermittlung des Gesamtergebnisses verwendet.

Automatisierte Gruppeneinteilung vor dem ersten Start (empfohlen):

Wenn in dem Dialog die automatische Gruppenbildung gewählt wurde, dann erfolgt die Gruppeneinteilung der Boote voll automatisch. Der Qualifikationsrang (aus einer Rangliste) in der "Quali"-Spalte dient als Kriterium, um einen möglichst gleichen Mix an Segelleistungen in den Gruppen zu erreichen.

Wenn keine Rangliste mit Qualifikationsrängen zur Verfügung steht, so kann wahlweise die "Quali"-Spalte auch mit Zufallszahlen gefüllt werden. Mit Klick auf den Schalter "Quali-Spalte mit Zufallszahlen füllen" wird der Zufallsgenerator gestartet.

Manuelle Gruppeneinteilung vor dem ersten Start:

Wenn eine automatische Gruppeneinteilung anhand des Qualifikationsranges nicht gewünscht wird, dann kann in dem Dialog eine manuelle Gruppeneinteilung gewählt werden. In diesem Falle hat die "Quali"-Spalte keine Bedeutung und kann leer bleiben. Die manuelle Einteilung kann nach beliebigen anderen Kriterien erfolgen.

Wurde im Dialog die Gruppenart "Feste Gruppen B, G, R und Y" gewählt, so kann der Anwender für jedes Boot in der Spalte "Gruppe" das Kennzeichen B, G, R oder Y eingeben. Die Zuordnung des Bootes zu den entsprechenden Primär- und Sekundärklassen wird dann von WinRegatta in die Spalten "P-KL" und "S-Kl" vorgenommen.

Wurde im Dialog die Gruppenart "Wechselnde Gruppen" gewählt, so kann der Anwender für jedes Boot in der Spalte "P-Kl" die Primärklassennummer der gewünschten Gruppe eingeben. Die richtige Sekundärklasse zur Bildung des Gesamtergebnisses steuert WinRegatta dann in die Spalte "S-Kl" ein.

Sehr wichtig:
Nachdem der Anwender die manuelle Gruppeneinteilung beendet hat (alle Boote wurden einer Gruppe zugeordnet), muss der Schalter "Ende der Manuellen Gruppenbildung" angeklickt werden. WinRegatta überprüft die Vollständigkeit der Gruppenzuordnung und gibt ggf. einen Hinweis an den Anwender.

Eine durchgeführte Gruppeneinteilung kann mehrfach wiederholt werden, solange in dieser Gruppenkonstelation noch nicht gesegelt wurde.

Nachträgliche Korrekturen der Gruppenzuordnung:

Nachdem die manuelle oder auch automatische Gruppeneinteilung beendet wurde, können trotzdem noch einzelne Zuordnungen geändert werden. Die Änderung wird in der Spalte "Gruppe" bzw. in der Spalte "P-KL" eingegeben. WinRegatta fordert dann aber eine Bestätigung der Korrektur, um unbeabsichtigte Änderungen zu vermeiden.

Nachdem in einer bestimmten Gruppenkonstellation bereits gesegelt wurde, dürfen diese Gruppenzuordnungen natürlich nicht mehr verändert werden.


Nach gesegelten Wfn

Gruppeneinteilung nach gesegelten Wettfahrten

Nachdem Wettfahrten gesegelt und gewertet wurden, können in der Funktion "Gruppen" mit dem Dialog "Neue Gruppen nach gesegelten Wettfahrten" neue Gruppenpaare gebildet werden, oder es können die Boote anhand des bisher gesegelten Gesamtergebnisses in neue Gruppen aufgeteilt werden.

Die Art der Gruppenbildung vor dem ersten Start bildet auch die Basis für die Gruppenbildung nach gesegelten Wettfahrten.

Wichtiger Hinweis:
Nach gesegelten Wettfahrten können Gruppeneinteilungen nicht mehr geändert werden!
Es ist deshalb sehr zu empfehlen, v o r h e r eine Sicherungskopie der Dateigruppe zu erstellen. Zum Beispiel mit dem Menüpunkt "Datei / Speichern unter..." einen neuen Dateinamen wählen!

Eine durchgeführte Gruppeneinteilung kann mehrfach wiederholt werden, solange in dieser Gruppenkonstellation noch nicht gesegelt wurde.

Nachträgliche Korrekturen der Gruppeneinteilung einzelner Boote sind auch möglich. Details finden Sie hier.


Gruppeneinteilung für Finalwettfahrten

Wenn die letzten Wettfahrten als Finalläufe geplant sind, kann in der Funktion "Gruppen" mit dem Dialog "Gruppenbildung für Final-Wettfahrten" die Einteilung in eine Goldgruppe und eine Silbergruppe erfolgen. Die Boote der ersten Hälfte der Gesamtergebnisliste werden der Goldgruppe und restlichen Boote der Silbergruppe zugeordnet. Die Anzahl der Segler für die Goldgruppe kann aber auch frei gewählt werden.

Die ersten beiden Primärklassen der Gruppenwertung für die Finalwertung verwenden. Die Klassennamen entsprechend anpassen, z. B. "Goldgruppe" und "Silbergruppe". Die Kennzeichnung "Gr-W" muß bei diesen beiden Primärklassen erhalten bleiben.

Eine Sekundärklasse ist für die Finalläufe nicht nötig.


Ergebniseingabe

Nachdem Wettfahrten gesegelt wurden, werden mit der Funktion "Ergebnisse" für jede Primärklasse die gesegelten Ergebnisse eingegeben.

Da die Startgruppen normalerweise auf der gleichen Bahn in ein gemeinsames Ziel segeln, wird wohl auch eine gemischte Zieleinlaufliste geführt. Es empfiehlt sich deshalb, bei der Ergebniseingabe alle beteiligten Primärklassen aufzurufen (Kl-Nr = "M") und mit "Eingabe nach... Ziel-Einlauf" die Ergebnisse gemischt einzugeben.

Für die Sekundärklasse zur Ermittlung des Gesamtergebnisses erfolgt keine Ergebniseingabe, da hier die eingegebenen Ergebnisse der Primärklassen herangezogen werden.


Wertung Gruppenwettfahrten

Wertung von Gruppenwettfahrten

Mit der Funktion "Wertung " kann jetzt die Auswertung der Wettfahrt erfolgen.

Wertung der einzelnen Startgruppen

Zuerst müssen nacheinander die Primärklassen der jeweiligen Gruppen gewertet werden. Danach erfolgt mit der Wertung der Sekundärklasse die Bildung des Gesamtergebnisses über alle Gruppen.

Die Funktion "Wertung" zeigt im Falle von Gruppenwertung zwei Reihen von Checkboxen. In der oberen Reihe werden die Wettfahrten markiert, die in die Wertung einbezogen werden sollen. In der unteren Reihe werden die Wettfahrten markiert, die in einer früheren Gruppeneinteilung gesegelt wurden. Die Ergebnisse dieser Wettfahrten werden fixiert, d. h. bei der Wertung werden die Wettfahrtergebnisse nicht neu berechnet - dies würde wegen der geänderten Gruppeneinteilung ja zu falschen Ergebnissen führen - sondern es werden die früher berechneten Ränge und Punkte ungeändert übernommen.

Wertung des Gesamtergebnisses

Bei der Wertung der Sekundärklasse (Gesamtergebnis) werden alle zu wertenden Wettfahrten fixiert und die berechneten Ergebnisse der Primärklassen ohne Änderung übernommen und zu einem Gesamtergebnis addiert.

Wertung von Untermengen

Die Wertung von weiteren Sekundärklassen für Untermengen der Segler (Junioren, Frauen) erfolgt ebenso wie für das Gesamtergebnis beschrieben.

Automatische Fixierung bei neuer Gruppeneinteilung

Nach der Einteilung von neuen Gruppen aktiviert WinRegatta die entsprechenden Checkboxen der unteren Reihe für die bisher gesegelten Wettfahrten automatisch, so dass eine unbeabsichtigte Neuberechnung der bisherigen Wettfahrten vermieden wird.

Rückwirkende Korrektur von Ergebnissen

Eine Korrektur von Ergebnissen für einzelne Boote in zurückliegenden Wettfahrten (z. B. späte Disqualifikation), die in einer früheren Gruppeneinteilung gesegelt wurden, ist auch problemlos möglich:

  • Wenn in der Funktion "Ergebnisse" eine Wettfahrt gewählt wird, die in einer früheren Gruppeneinteilung gesegelt wurde (Checkbox der unteren Reihe aktiviert), dann rekonstruiert WinRegatta die frühere Gruppeneinteilung, und die Ergebnisse können nun korrigiert werden.
  • Beim Verlassen der Funktion "Ergebnisse" erfolgt automatisch eine neue Wertung der korrigierten Wettfahrt, und die Gruppeneinteilung wird wieder auf den aktuellen Stand gebracht.
  • Da diese Funktionen teilweise für den Anwender unsichtbar im Hintergrund ablaufen, wird der Anwender mit entsprechenden Mitteilungen informiert gehalten.
Die Berechnung der Wettfahrtpunkte wurde geändert (neu ab Vers. 4.5) :
  • Bei Gruppen mit ungleicher Anzahl von Seglern werden jetzt die Wettfahrtpunkte für DNC, DNF, DSQ usw. nach der Seglerzahl der größten Gruppe + 1 berechnet.
    Siehe Wettsegelordnung des DSV.


Wertung Finalwettfahrten

Wertung von Finalwettfahrten

Nach einer Gruppeneinteilung für Finalläufe sind nur noch zwei Primärklassen nötig (je eine für die Gold- und Silbergruppe).

Die Finalwertung kann die bisherigen Ergebnisse der Gruppenwertung einbeziehen oder eine völlig neue Wertung beginnen.

  • Bisherige Ergebnisse in die Finalwertung einbeziehen:
    Diese Art der Finalwertung ist zu empfehlen und wohl auch der Normalfall.

    Wie folgt vorgehen:
    • Die ersten beiden Primärklassen der Gruppenwertung für die Finalwertung verwenden. Die Klassennamen entsprechend anpassen, z. B. "Goldgruppe" und "Silbergruppe". Die Kennzeichnung "Gr-W" muß bei diesen beiden Primärklassen erhalten bleiben.
    • Nachdem die erste Finalwettfahrt gesegelt wurde, werden die Ergebnisse in die nächste Wettfahrt eingegeben.
    • Die beiden Primärklassen werden nacheinander gewertet, wobei natürlich die Wettfahrten, die vor den Finalläufen gesegelt wurden, wiederum fixiert sein müssen.
    • Entsprechende Anzahl Streicher wählen.
    • Die Gesamtränge der Silbergruppe werden automatisch angepasst: Der erste Rang der Silbergruppe = letzter Rang der Goldgruppe + 1.
  • Finalwertung völlig neu beginnen:
    Die Ergebnisse der Gruppenwertung dienten nur zur Bildung der Gold- und Silbergruppe, ansonsten werden die bisherigen Ergebnisse ignoriert (diese Art der Finalwertung ist weniger zu empfehlen).

    Wie folgt vorgehen:
    • Zwei neue Primärklassen definieren (für Gold- und Silbergruppe). Bei diesen neuen Klassen das Kennzeichen "Gr-W" nicht aktivieren. Die bisherigen Klassen der Gruppenwertung bleiben aber ungeändert bestehen.
    • Im Dialog zur Gruppenbildung für Finalwettfahrten die neuen Primärklassen für Gold und Silbergruppen angeben.
    • In der Funktion "Ergebnisse" die Klassennummern der neuen Klassen wählen und nacheinander die Wettfahrten 1, 2 und 3 wählen und mit Klick auf [image] alle Ergebnisse dieser Wettfahrten löschen.
    • Nun die gesegelten Ergebnisse der ersten Finalwettfahrt als Wettfahrt 1 für die Gold- und Silbergruppe eingeben.
    • Nacheinander die Klassen der Gold- und Silbergruppe als Wettfahrt 1 werten.
    • Mit den weiteren Finalwerttfahrten entsprechend verfahren.
    • Bei den wenigen Finalwettfahrten werden wohl keine Wettfahrten gestrichen.
    • Die Gesamtränge der Silbergruppe werden automatisch angepasst: Der erste Rang der Silbergruppe = letzter Rang der Goldgruppe + 1.


Druck von Ergebnislisten

Der Listendruck oder das Speichern in Text- oder HTML-Dateien erfolgt ganz normal. Im Listenkopf wird aber als Wertungsart "Gruppenwertung" ausgegeben.


Funktion "MO-Finale"

Im Fenster "Finale" werden die Parameter für die Finalwettfahrt gesetzt, wenn eine Meisterschaft nach der Meisterschafts-Ordnung für olympische Klassen - MO-F - gültig ab 01. April 2006, gesegelt werden soll.

MO-F Wertungsregeln

MO-F Wertungsklassen

MO-F Vorbereitung

MO-F Wertung

MO-F Ergebnislisten

MO-F Beispieldaten


MO-F Wertungsregeln

Diese Meisterschaftsordnung für olympisches Format (MO-F) gilt ab dem 01.04.2006 für olympische Klassen und Juniorenmeisterschaften.

Bei Meisterschaften werden mindestens vier Wettfahrten als Qualifikationswettfahrten gesegelt. Die 10 punktbesten Boote nach den Qualifikationswettfahrten segeln dann eine Finalwettfahrt. Die restlichen Boote (ab Rang 11) segeln ein Flottenfinale.

Punktewertung:

  • Die Qualifiktionswettfahrten werden normal nach dem Low Point System und ggf. mit Streicher gewertet.
  • Die Qualifiktionswettfahrten können auch als Gruppenwertung durchgeführt werden.
  • Das Flottenfinale kann wahlweise in einer, zwei, oder drei Startgruppen gesegelt und gewertet werden.
  • Die Punktewertung der Finalwettfahrt der 10 punktbesten Boote wird verdoppelt und kann nicht gestrichen werden.
  • Die Punktewertung des Flottenfinales wird verdoppelt, und es werden jeweils 20 Punkte addiert. Auch die Punkte dieser Wettfahrt können nicht gestrichen werden.
  • Sollte das Flottenfinale keine gültige Wertung haben, jedoch das Finale, so ergibt sich das Gesamtergebnis, indem jedem Teilnehmer des Flottenfinales 20 Punkte zu seinen Wertungspunkten aus der Qualifikation addiert werden.
  • Sollte bei gültiger Wertung des Flottenfinales keine gültige Finalwertung zu Stande kommen, so geht die Wertung des Flottenfinales nicht in das Gesamtergebnis ein.


MO-F Wertungsklassen

Die Wertung von MO-F erfordert einige Besonderheiten bei der Definition von Wertungsklassen:

Qualifikationswettfahrten als e i n e Startgruppe (keine Gruppenwertung):

  • Eine primäre Wertungsklasse ist für die Wertung der Qualifikationswettfahrten erforderlich. Dies ist eine ganz normale primäre Klasse. In der Funktion "Segler" werden alle Boote dieser Klasse zugeordnet.
  • Optional können für die Qualifikationswettfahrten auch Sekundärklassen verwendet werden, um Teilmengen der Boote zu werten - z. B. Junioren oder Frauen. In der Funktion "Segler" werden die Boote den Sekundärklassen ab Spalte "S3" zugeordnet. Die Spalten "S1" und "S2" bitte freilassen. Diese Spalten sind für die Wertung des Gesamtergebnisses nach Abschluß der Finalwettfahrt reserviert.

Qualifikationswettfahrten als Gruppenwertung:

  • Mit der Funktion "Gruppen" wird die Qualifikation als normale Gruppenwertung durchgeführt.
  • WinRegatta unterstützt zwei Arten von Gruppenwertung, die wahlweise verwendet werden können:
    • Feste Zuordnung der Boote zu vier Gruppen, aus denen dann jeweils zwei Gruppenpaare als Startgruppen gebildet werden, oder
    • täglich wechselnde Zuordnung der Boote zu zwei oder drei Stargruppen.
  • Für jede Startgruppe muß eine Primärklasse definiert werden. Für diese Klassen muß das Kennzeichen "GR-W " aktiviert werden. Die Zuordnung der Segler zu diesen Klassen erfolgt automatisch in der Funktion "Gruppen".
  • Zur Ermittlung des Gesamtergebnisses der Gruppenwertung muß eine Sekundärklasse definiert werden. Auch für diese Klassen muß das Kennzeichen "GR-W " aktiviert werden. Die Zuordnung der Segler zu dieser Klasse erfolgt automatisch in der Funktion "Gruppen" und zwar in der Spalte "S1".
  • Optional können für die Gruppenwertung der Qualifikations zusätzliche Sekundärklassen verwendet werden, um Teilmengen der Boote zu werten - z. B. Junioren oder Frauen. Auch hier das Kennzeichen "GR-W " nicht vergessen. In der Funktion "Segler" werden die Boote diesen Sekundärklassen ab Spalte "S3" zugeordnet. Die Spalte "S2" bitte freilassen, da sie für die Wertung des Gesamtergebnisses nach dem Finale benötigt wird.

Klassendefinition für die Finalwettfahrt:

  • Zur Wertung der Finalewettfahrt der 10 punktbesten Boote wird eine weitere primäre Klasse benötigt. Diese Klasse erhält bei der Klassendefinition das Kennzeichen "MO-F " im Feld ganz rechts. Boote werden dieser Klasse vorerst n i c h t zugeordnet.
  • Zur Wertung des Flottenfinales wird eine weitere primäre Klasse benötigt, die ebenfalls das Kennzeichen "MO-F" erhält. Auch hier werden vorerst keine Boote zugeordnet.
  • Zur Ermittlung des Gesamtergebnisses von beiden Finalklassen wird eine sekundäre Klasse benötigt. Auch diese Klasse erhält das Kennzeichen "MO-F". Die Zuordnung der Boote erfolgt auch hier später.
  • Diese Klassen mit der MO-F-Kennzeichnung können am Anfang der Veranstaltung definiert werden oder auch später, z. B. nachdem die Qualifikationswettfahrten gesegelt wurden.
  • Die Zuordnung der Boote zu diesen Klassen erfolgt nach Abschluß der Qualifikationswertung automatisch mit der Funktion "Finale".
  • Optional können auch weitere Sekundärklassen verwendet werden, um nach dem Finale Teilmengen der Boote zu werten - z. B. Junioren oder Frauen. Auch hier das Kennzeichen "MO-F " nicht vergessen. In der Funktion "Segler" werden die Boote diesen Sekundärklassen ab Spalte "S3" zugeordnet.

Klassendefinition für das Flottenfinale mit Gruppenwertung:

  • Wenn die Anzahl der Boote des Flottenfinales für eine einzelne Startgruppe zu groß ist, so kann das Flottenfinale wahlweise in zwei oder drei Startgruppen gesegelt und gewertet werden.
  • Zusätzlich zu der oben erwähnten Primärklasse für das Finale der 10 punktbesten Boote und der Sekundärklasse für das Gesamtergebnis muß für jede Gruppe des Flottenfinales eine Primärklasse und zur Ermittlung des Gesamtergenisses des Flottenfinales eine Sekundärklasse definiert werden. Auch diese Klassen müssen mit "MO-F" gekennzeichnet werden.


MO-F Vorbereitung

Wichtiger Hinweis:

Nachdem alle Qualifikationswettfahrten gesegelt und gewertet wurden, kann die Vorbereitung des Finales erfolgen. Wichtig ist, dass die Wertung der Qualifikation endgültig ist und z. B. keine Proteste mehr ausstehen, denn das Qualifikationsergebnis ist ja die Basis zur Ermittlung der 10 punktbesten Boote für das Finale.

Bitte erstellen Sie jetzt unbedingt eine Datensicherung der Dateigruppe der Qualifikation . Sollte es später bei der Wertung der Finalwettfahrt zu Problemen kommen, dann muß ggf. auf die Datensicherung der Qualifikation zurückgegriffen werden.

Vorbereitung des Finales:

Spätestens jetzt müssen die MO-F Wertungsklassen in der Funktion "Klassen" definiert worden sein (s. MO-F Wertungsklassen).

Klicken Sie auf das Register "Finale" (dies Register ist erst sichtbar, wenn für mindestens eine Klasse das Kennzeichen "MO-F" gesetzt wurde). In dieser Funktion werden die Parameter für die Finalwertung gesetzt. Danach erfolgt eine automatische Zuordnung der Boote zu den mit "MO-F" gekennzeichneten Klassen.

Wichtig: bitte stellen Sie sicher, dass vor dem Setzen der Parameter für das Finale als letzter Wertungslauf das Gesamtergebnis der Qualifikation ermittelt wurde, da nur so die 10 punktbesten Boote festgestellt werden können.

Im Datengitter der Funktion "Finale" sehen Sie alle Boote der Qualifikation. Mit Klick auf einen Spaltenkopf werden die Daten nach dieser Spalte sortiert. Die Spalte "Rang" zeigt den jeweiligen Gesamtrang der Qualifikation.

Führen Sie in der Funktion "Finale" nun folgende Schritte aus:

  • Beginnen Sie mit Klick auf "Soll die nächste Wettfahrt als Finale gesegelt werden?" . Die Eingabefelder sind jetzt eingabebereit.
  • Wählen Sie die Anzahl der punktbesten Boote für das Finale. Die Anzahl 10 ist voreingestellt, da die MO-F dies so vorsieht. Es ist aber möglich, eine andere Zahl einzugeben, sollte dies aus bestimmten Gründen (z. B. bei einer künftigen Regeländerung) erforderlich sein.
  • Im nächsten Feld geben Sie bitte die Nummer der Finalwettfahrt ein.
  • Entsprechend Ihrer Klassendefinition geben Sie nun die Klassennummer für das Finale der 10 punktbesten Boote ein.
  • Als nächstes wählen Sie bitte die Anzahl der Startgruppen für das Flottenfinale (1 bis 3).
  • In den folgenden Feldern werden die Klassennummern für die Startgruppen des Flottenfinales eingegeben. Bei zwei oder drei Startgruppen ist auch die Sekundärklassennummer zur Wertung des Flottengesamtergebnisses einzugeben.
  • Als nächstes geben Sie bitte die Sekundärklassennummer zur Wertung des Gesamtergebnisses aller Boote ein.
  • Mit dem letzten Feld kann der Multiplikator für die Punkte der Finalwettfahrt bestimmt werden. Der Wert 2,0 ist voreingestellt, da von der MO-F vorgeschrieben. Es können aber auch 1,0 oder 1,5 als Multiplikatoren gewählt werden.
  • Mit Klick auf "Übernehmen" werden diese Werte auf Plausibilität geprüft, übernommen und intern gespeichert. Folgende Funktionen laufen hierbei automatisch ab:
    • Die Eingabefelder werden gesperrt, um unbeabsichtigte Änderungen zu vermeiden.
    • Im Datengitter werden die Boote nach der Spalte "Rang" aufsteigend sortiert.
    • Die 10 punktbesten (dies entspricht den 10 rangbesten) Boote werden in der Spalte "P" der Klasse für die Wertung des Finales zugeordnet.
    • Alle anderen Boote werden in der Spalte "P" der Klasse für die Wertung des Flottenfinales zugeordnet. Wird das Flottenfinale in zwei oder drei Startgruppen gesegelt, so werden die Boote der Flotte den entsprechenden Primärklassen nach dem Meander-System zugeordnet.
    • In der Spalte "S2" werden die Boote der Flotte der Sekundärklasse zur Ermittlung des Gesamtergebnisses des Flottenfinales zugeordnet (nur bei zwei oder drei Flottengruppen).
    • In der Spalte "S1" werden alle Boote der Sekundärklasse zur Ermittlung des Gesamtergebnisses zugeordnet.

Solange noch keine Ergebnisse der Finalwettfahrt eingegeben und gewertet wurden, kann mit Klick auf "Zurücksetzen" die eingegebenen Werte gelöscht werden und eine Neueingabe erfolgen.

Nachdem Finalergebnisse eingegeben und gewertet wurden, ist ein "Zurücksetzen" nicht mehr möglich. Sollte es trotzdem nötig sein hier Änderungen vorzunehmen, so muß auf die Datensicherung der Qualifiktion zurückgegriffen werden und die Parameter der Finalwettfahrt erneut eingegeben werden.

Flottenfinale wird nicht gesegelt:

Wenn trotz gültiger Finalwertung der 10 punktbesten Boote das Flottenfinale nicht durchgeführt wird, so ist das Häkchen "Das Flottenfinale wurde n i c h t durchgeführt" zu setzen. Bei der Wertung der Flottenklasse werden dann jedem Boot 20 Punkte addiert. Eine Ergebniseingabe für das Flottenfinale ist natürlich nicht nötig (es liegen ja auch keine Ergenisse vor). Ein Wertungslauf der Finalwettfahrt der Flottenklassen muß aber durchgeführt werden, damit die 20 Punkte berücksichtigt werden.


MO-F Wertung

Finalergebnisse eingeben

Nachdem die Finalwettfahrt gesegelt wurde, werden in der Funktion "Ergebnisse" die Klassennummer und die Wettfahrt des Finales gewählt und die gesegelten Ränge eingegeben. Die "Eingabe nach Zieleinlauf" eignet sich hierfür am besten, da in der Regel eine Zieleinlaufliste vorliegt.

Das gleiche gilt für das Flottenfinale. Es werden die Klassennummer und die Wettfahrt des Flottenfinales gewählt und die gesegelten Ränge der Flotte eingegeben. Auch hier empfiehlt sich die "Eingabe nach Zieleinlauf".

MO-F Wertung

In der Funktion "Wertung" werden die Finalklassen gewertet und ein Gesamtergebnis gebildet. Da die Finalklassen das Kennzeichen "MO-F" haben, erscheinen nach der Eingabe der Klassennummer zwei Reihen von Checkboxen. Die Häkchen in der oberen Reihe markieren die Wettfahrten, die gewertet werden sollen. Die Häkchen der unteren Reihe bedeuten, dass die betreffenden Wettfahrten nicht neu berechnet werden, sondern dass die Wettfahrtpunkte fixiert sind. Die fixierten Punkte werden also nicht neu berechnet, sondern lediglich zum Gesamtergebnis addiert.

Wertung des Finales

  • Die Nummer der Finalklasse wird oben links eingegeben oder mit Doppelklick auf das Klassenfeld aus der Liste gewählt. Die nun sichtbaren beiden Checkbox-Reihen zeigen für die Qualifikationswettfahrten Häkchen. Das heißt, die Wettfahrten der Qualifikation werden nicht neu berechnet (da die Quali-Wettfahrten ja in einer anderen Klassenkonstelation gesegelt wurden), sondern die Punkte der Wettfahrten werden lediglich zum Gesamtergebnis addiert. Die Checkboxen der Qualifikationswettfahrten sind außerdem inaktiv gestellt, damit diese Häkchen nicht mehr verändert werden können.
  • Die Finalwettfahrt hat aktive Checkboxen, d. h. es wurden Ergebnisse eingegeben. Ein Häkchen muß mit Klick auf die obere Checkbox jetzt gesetzt werden, damit diese Finalwettfahrt in die Wertung einbezogen wird. Die untere Checkbox darf kein Häkchen haben, denn diese Wettfahrt soll ja neu berechnet werden. Übrigens, egal welche der beiden Checkboxen der Finalwettfahrt Sie anklicken, WinRegatta setzt immer nur das Häkchen in der oberen Box.
  • Bitte vergessen Sie nicht die richtige Anzahl von Streichern (oben rechts) zu wählen.
  • Mit Klick auf "Start" wird nun die Wertung durchgeführt und die Ergebnisse werden in dem Datengitter angezeigt. Auf Grund der in der Funktion "Finale" eingegebenen Parameter weiß WinRegatta, dass es sich hier um die Wertung des Finales handelt. Entsprechend werden die fixierten Punkte der Qualifikationswettfahrten in das Gesamtergebnis übernommen. Für die Finalwettfahrt werden die Punkte berechnet und doppelt zum Gesamtergebnis addiert. Es werden entsprechend der gewählten Anzahl Streicher die schlechtesten Wettfahrtpunkte gestrichen, wobei die Punkte der Finalwettfahrt hiervon unberührt bleiben - so wie es die MO-F Regeln vorsehen.

Wertung des Flottenfinales

  • Die Vorgehensweise ist ähnlich wie oben für das Finale beschrieben. Die Nummer der Flottenfinalklasse wird gewählt und das Häkchen für Wettfahrt des Flottenfinales gesetzt.
  • Auch hier muß die Anzahl der geplanten Streicher gewählt werden.
  • Mit Klick auf "Start" wird die Wertung durchgeführt und die Ergebnisse werden in dem Datengitter angezeigt. Die fixierten Punkte der Qualifikationswettfahrten werden in das Gesamtergebnis übernommen. Für die Finalwettfahrt werden die Punkte berechnet, verdoppelt und zusätzlich noch 20 Punkte zum Gesamtergebnis addiert. Es werden entsprechend der gewählten Anzahl Streicher die schlechtesten Wettfahrtpunkte gestrichen, wobei die Punkte der Finalwettfahrt hiervon unberührt bleiben - so wie es die MO-F Regeln vorsehen.
  • Der Gesamtrangplatz der Flotte beginnt nicht mit 1 sondern mit der Anzahl Boote des Finales + 1. Also normalerweise 11.
  • Wurde das Flottenfinale in mehreren Gruppen gesegelt, so werden zuerst die Primärklassen der Gruppen gewertet. Mit der anschließenden Wertung der entsprechenden Sekundärklasse wird das Gesamtergebnis der Flotte gebildet.
  • Wenn bei gültiger Wertung des Finales das Flottenfinale nicht gesegelt wurde, dann muß die Flottenwertung trotzdem durchgeführt werden, damit die vorgesehenen 20 Punkte pro Boot zum Gesamtergebnis addiert werden. Dass das Flottenfinale nicht gesegelt wurde, muß WinRegatta in der Funktion "Finale" durch das entsprechende Häkchen mitgeteilt werden.

Wertung der Sekundärklasse für das Gesamtergebnis

  • Die Nummer der Sekundärklasse wird oben links eingegeben oder mit Doppelklick auf das Klassenfeld aus der Liste gewählt. Wie bei den vorangegangenen Wertungen haben die beiden Checkbox-Reihen der Qualifikationswettfahrten Häkchen. Das heißt, die Wettfahrten der Qualifikation sind fixiert und werden nicht neu berechnet.
  • Die Check-Boxen der Finalwettfahrt sind aktiv. Mit Klick auf eine der beiden Check-Boxen setzt WinRegatta automatisch Häkchen in beiden Boxen. Das heißt, bei der Ermittlung des Gesamtergebnisses aller Boote wird die Finalwettfahrt nicht neu berechnet, sondern die Wettfahrtpunkte des Finales und des Flottenfinales werden lediglich zum Gesamtergebnis addiert.
  • Bitte vergessen Sie nicht die richtige Anzahl von Streichern (oben rechts) zu wählen.
  • Mit Klick auf "Start" wird die Wertung durchgeführt und die Ergebnisse werden in dem Datengitter angezeigt. Die Punkte aller Wettfahrten sind fixiert und werden zum Gesamtergebnis addiert. Es werden entsprechend der gewählten Anzahl Streicher die schlechtesten Wettfahrtpunkte gestrichen, wobei die Punkte der Finalwettfahrt hiervon unberührt bleiben - so wie es die MO-F Regeln vorsehen.
  • Bei jeder Wertung des Gesamtergebnisses erfolgt intern immer zu erst eine automatische Wertung der Finalklasse und der Flottenfinalklasse, um eventuelle Änderungen von gesegelten Ergebnissen, die seit der letzten Wertung vorgenommen wurden, zu berücksichtigen.

Optionale Sekundärklassen zur Wertung von Teilmengen der Boote

  • Sekundärklassen zur Wertung von Teilmengen der Boote (z. B. Junioren oder Frauen) müssen auch das Kennzeichen "MO-F" haben.
  • Die Vorgehensweise ist ähnlich wie oben für die Wertung des Gesamtergebnisses beschrieben.
  • Die einzelnen Wettfahrtränge und Wettfahrtpunkte entsprechen denen des Gesamtergebnisses.

Punktgleichheit im Gesamtergebnis

  • Bei jeder Wertung der MO-F Klassen prüft WinRegatta auf Punktgleichheiten im Gesamtergebnis. Die Auflösung der Punktgleichheit wird gemäß der WR nach "Besseren Rängen" bzw. nach "Letzter Wettfahrt" vorgenommen. Im Gegensatz zu den Streichern, wird bei der Auflösung von Punktgleichheiten die Finalwettfahrt mit einbezogen.


MO-F Ergebnislisten

Der Listendruck und das Speichern in Text- oder HTML-Dateien erfolgt ganz normal.

Es gibt aber zwei Unterschiede:

  • Im Listenkopf wird bei Meldelisten und Ergebnislisten als Wertungsart "MO-Finale" ausgegeben.
  • Bei den Ergebnislisten wird als Spaltenkopf der Finalwettfahrt anstelle der Wettfahrtnummer das Wort "Finale" gedruckt. Dies soll helfen, die vom Low Point System abweichende Punktezahl zu verstehen. Wenn Ergebnislisten als Text- oder HTML-Datei gespeichert werden, so wird in der Finalwettfahrt in jedem Falle die Rangspalte und die Punktespalte ausgegeben.

Vor der Ausgabe einer Ergebnisliste führt WinRegatta intern in jedem Falle eine Wertung durch, um letzte Änderungen zu berücksichtigen.


Meldedaten-Import

Was ist der Zweck des Imports von Meldedaten?

Viele Segelclubs haben auf ihrer Website Möglichkeiten zur Online-Meldung zu Regatten eingerichtet. Üblicherweise wird auf der Website ein Formular zum Eintragen der Meldedaten bereitgestellt. Nachdem der Segler alle erforderlichen Meldedaten eingetragen hat, kann er das Formular abschicken. Der Online-Meldeprozess ist damit für den Segler abgeschlossen.

Es ist nun sinnvoll, die Online-Meldedaten nach WinRegatta zu importieren, um sie nicht manuell eingeben zu müssen. Der Webmaster sollte Vorkehrungen treffen, die Meldedaten aus dem Formular der Website in eine Datei im CSV-Format zu speichern. Die Meldedaten e i n e s Formulars sind in jeweils e i n e n Satz der CSV-Datei zu speichern.

Wie sieht die Struktur der CSV-Datei aus?

In der CSV-Datei können die zu importierenden Datenfelder in beliebiger Reihenfolge erscheinen. Als Trennzeichen für die Felder dient ein Strichpunkt (;). Ein Feld ohne Inhalt (leeres Feld) wird ebenfalls durch einen Strichpunkt abgeschlossen, so dass in diesem Falle zwei Strichpunkte nebeneinander stehen.

Der Dateiname und das Verzeichnis zur Speicherung der CSV-Datei können beliebig gewählt werden.

Neu ab Vers. 4.5: Der erste Satz der CSV-Datei kann wahlweise als Überschriftszeile verwendet werden, in dem die Feldnamen in der entsprechenden Feldfolge angegeben werden können (jeweils mit Strichpunkt getrennt). Dies kann der Übersichtlichkeit dienen, z. B. wenn die CSV-Datei mit Excel geöffnet wird. Die Felder sind dann vertikal ausgerichtet als Spalten mit Spaltenüberschriften. Als Kennzeichnung hat der Satz mit den Feldnamen in den ersten beiden Stellen "##" gespeichert. WinRegatta erkennt hierdurch diesen Satz als Überschriftszeile und ignoriert ihn für den Import.

Welche Daten können importiert werden?

Grundsätzlich können alle Seglerdaten, die in der Funktion "Segler" von WinRegatta über die Tastatur eingegeben werden können, auch aus einer CSV-Datei importiert werden. Bei "WinRegatta Plus" sind dies auch die Daten der 4., 5. und 6. Crew-Mitglieder und auch die Faktoren für eine ORC-Club-Wertung.

Falls die Primärklassen-Nr. nicht importiert wurde, haben die importierten Daten noch keine Zuordnung zu Klassen.
In der Funktion "Segler" können Sie nach dem Import die Zuordnung vornehmen:
Wählen Sie im Feld "KlNr" oben links "A" für "Alle Klassen". In der Spalte "P" geben Sie die Klassennummer ein, der die Crew zugeordnet werden soll.
Um für den Anwender die Zuordnung zu den Klassen zu erleichtern, wird empfohlen auch für Meldungen zu Klassenregatten ein Feld für den Bootstyp in dem Online-Meldeformular vorzusehen, in dem für eine Opti-Regatta z. B. "Opti A" oder "Opti B" einzutragen ist. Eine Yardstickzahl ist in diesem Falle natürlich nicht nötig.

Wie erkennt WinRegatta die Datenfelder und die Feldfolge der CSV-Datei?

WinRegatta bietet dem Anwender in der Import-Funktion eine Ini-Datei mit dem Namen "Meldedaten.ini" an, in der die maximal möglichen Felder aufgeführt sind. Der Anwender gibt nun rechts neben dem Namen eines Feldes in der Ini-Datei eine Zahl ein, die der Reihenfolge dieses Feldes in der CSV-Datei entspricht. Hiermit ist WinRegatta in der Lage, die Daten aus einer CSV-Datei mit einer beliebigen Auswahl und Reihenfolge von Feldern den richtigen Feldern in der Seglerdatei von WinRegatta zuzuordnen.

Der Editor zur Bearbeitung der Ini-Datei wird von WinRegatta automatisch aufgerufen. Diese Ini-Datei für den CSV-Import wird in dem gleichen Ordner gespeichert, in dem auch alle anderen Ini-Dateien gespeichert sind.

Wie kann ein Meldeformular auf der Website aussehen?

Man kann ein spezielles Meldeformular für eine bestimmte Regatta anbieten oder auch ein generelles Meldeformular für mehrere, unterschiedliche Regatten.

Zum Beispiel gibt es in einem speziellen Meldeformular für eine Opti-Regatta keine Felder für den Vorschoter oder für einen Yardstick. Wird dagegen ein generelles Formular angeboten, so lässt der Opti-Segler die Felder für Vorschoter und Yardstick leer. Die CSV-Datei enthält dann für die leeren Felder nebeneinanderstehende Strichpunkte. Eine entsprechend vorbereitete Ini-Datei synchronisiert dann die Felder für den Import.

Was passiert, wenn die Daten eines Bootes mehrfach importiert werden?

WinRegatta prüft beim Import die Segelnummer, den Namen und Vornamen des Steuermannes/der Steuerfrau. Wenn k e i n Satz mit diesen drei Werten in der Seglerdatei gefunden wurde, dann wird ein neuer Satz erzeugt in dem die importierten Daten gespeichert werden.

Wenn dagegen in der Seglerdatei ein Satz mit diesen drei identischen Werten bereits vorhanden ist, dann wird der bestehende Satz mit den importierten Werten überschrieben. Alle evtl. vorgenommenen Änderungen dieses Seglersatzes seit dem ersten Import werden also überschrieben und sind damit verloren.

Meldedaten-Import durchführen

Import von raceoffice.org

Import-Plausibilitätsprüfung

Beispiel Meldedaten-Import


Import-Durchführung

CSV-Datei:

Die CSV-Datei enthält pro gemeldetem Boot einen Datensatz mit allen Datenfeldern, die importiert werden sollen. Die Felder sind durch einen Strichpunkt (;) getrennt. Fehlt ein Feldwert, so folgen zwei Strichpunkte aufeinander. Die CSV-Datei kann eine beliebige Auswahl der Meldedatenfelder in beliebiger Reihenfolge enthalten.

Meldedaten Ini-Datei:

Eine Ini-Datei mit dem Namen "Meldedaten.ini" übernimmt die Synchronisation des Imports der Felder aus der CSV-Datei in die entsprechenden Felder der Seglerdatei (*.S48) in WinRegatta.

Diese Ini-Datei enthält alle Feldnamen der Datenfelder, die maximal importiert werden können. Dies sind Segelnummern, Crewdaten, Adressen der Steuerleute, Club-Zugehörigkeit der Segler, Bootstyp, Yardstick, ggf. Faktoren für ORC-Club-Wertung, usw.

Neu ab Vers. 4.4: Ab Version 4.4 können drei Felder zusätzlich importiert werden. Dies sind: Primärklassen-Nr, Individuelle Yst-Korrektur und Yst-Korrekturgrund .
Durch den Import der Primärklassen-Nr. kann die Zuordnung der Boote zu den Klassen bereits während des Imports geschehen. Hierdurch erübrigt sich die nachträgliche Zuordnung. Die Klassen-Nr wird nur importiert, wenn es sich um eine gültige Nummer (1 bis 15) handelt, und wenn diese Klasse vor dem Import als Primärklasse definiert wurde. Sonst bleibt das Klassenfeld "P" leer.

Vorbereitung der Ini-Datei:

Mit dem Menü "Datei / Meldedaten Ini-Datei" wird die Ini-Datei in einem Editor geöffnet. Geben Sie nun rechts neben dem Gleichheitszeichen (= ) eines jeden Feldnamens der Felder, die in der CSV-Datei enthalten sind, eine Ziffer ein, die der Reihenfolge des Feldes in der CSV-Datei entspricht. Felder, die in der CSV-Datei nicht vorkommen, also nicht importiert werden, bekommen keine Ziffer. Speichern Sie dann die Ini-Datei.

Import der Meldedaten:

Öffnen Sie die Dateigruppe, in die die Meldedaten importiert werden sollen.

Mit dem Menü "Datei / Meldedaten importieren" wird ein Dialogfenster geöffnet (siehe unten). In diesem Fenster werden die gewählten Felder in der gewählten Reihenfolge gezeigt. Bitte überprüfen Sie die Vollständigkeit und die Reihenfolge der Felder auf Richtigkeit.

Wenn Unstimmigkeiten vorliegen, dann können Sie mit Klick auf "Ini-Datei" die Ini-Datei erneut im Editor öffnen und Korrekturen vornehmen.

Wenn alles stimmt, dann klicken Sie auf "Weiter". In dem dann folgenden Datei-Öffnen-Dialog wählen Sie den Ordner und Namen der CSV-Datei. Danach erfolgt der Import aller Meldedaten, die in der CSV-Datei gespeichert sind.

Wichtiger Hinweis: Die zu importierende CSV-Datei darf während des Imports nicht mit Excel geöffnet sein.
Wenn die CSV-Datei mit Excel geöffnet ist, dann kommt es zu Zugriffskonflikten und der Import wird mit Fehler-Nr. 801 abgebrochen.

Importierte Daten den Wertungsklassen zuordnen.

Falls die Primärklassen-Nr. nicht importiert wurde, haben die importierten Daten noch keine Zuordnung zu Klassen.

In der Funktion "Segler" können Sie nach dem Import die Zuordnung vornehmen:
Wählen Sie im Feld "KlNr" oben links "A" für "Alle Klassen". In der Spalte "P" geben Sie die Klassennummer ein, der die Crew zugeordnet werden soll.
Es ist zu empfehlen in dem Online-Meldeformular den Bootstyp auch für Klassenregatten eintragen und importieren zu lassen, da dies bei der Klassenzuordung hilft. Eine Yardstickzahl ist in diesem Falle natürlich nicht nötig.


Import von raceoffice.org

Meldedaten-Import von dem Online-Meldeportal "raceoffice.org" (Neu ab Vers. 4.5):

Wenn Sie die CSV-Datei von raceoffice.org heruntergeladen haben, dann wählen Sie für den Import den Menüpunkt "Datei > raceoffice.org Meldedaten-Import".
Die erforderliche Ini-Datei ist in WinRegatta unter dem Namen "MeldedatenImportraceoffice.ini" mit der richtigen Feldfolge bereits gespeichert und erfordert keine weitere Anpassung.

Wichtiger Hinweis: Die zu importierende CSV-Datei darf während des Imports nicht mit Excel geöffnet sein.
Wenn die CSV-Datei mit Excel geöffnet ist, dann kommt es zu Zugriffskonflikten und der Import wird mit Fehler-Nr. 801 abgebrochen.

Importierte Daten den Wertungsklassen zuordnen.

Falls die Primärklassen-Nr. nicht importiert wurde, haben die importierten Daten noch keine Zuordnung zu Klassen.

In der Funktion "Segler" können Sie nach dem Import die Zuordnung vornehmen:
Wählen Sie im Feld "KlNr" oben links "A" für "Alle Klassen". In der Spalte "P" geben Sie die Klassennummer ein, der die Crew zugeordnet werden soll.
Es ist zu empfehlen in dem Online-Meldeformular den Bootstyp auch für Klassenregatten eintragen und importieren zu lassen, da dies bei der Klassenzuordung hilft. Eine Yardstickzahl ist in diesem Falle natürlich nicht nötig.


Import-Plausibilitätsprüfung

Neu ab Vers. 4.4

Beim Import erfolgt wahlweise eine Prüfung der Daten, um Probleme durch fehlerhafte Daten zu vermeiden:

  • Jahrgang zweistellig?
    Wird ein vierstelliger Jahrgang importiert, so wird dieser auf zwei Stellen gekürzt.
  • Geburtsjahr zweistellig?
    Wird ein vierstelliges Jahr als Geburtstag importiert, so wird dies auf zwei Stellen gekürzt.
  • Hat das lange Geburtsdatum richtiges Datumsformat?
  • Hat die DSV-Nr richtiges Format?
  • Ist die DSV-Nr in der Clubdatei vorhanden?
  • Wird mit der Clubabkürzung und der DSV-Nr. ein Club in der Clubdatei gefunden?
    Gültige Paarung?
  • Hat ein Segler mit einem Landeskenner anders als "GER" oder "G" (Ausländer) eine gültige Kombination von deutscher Clubabkürzung und DSV-Nr?
    Wenn ja, dann wird dies akzeptiert und gespeichert.
    Wenn nein...

    • Wurde bei ausländischem Segler der Landeskenner bereits als DSV-Nr. importiert?
      Wenn nein ...
      • Dann wird der ausländische Landeskenner als DSV-Nr. gespeichert, aber nur wenn auch eine Clubabkürzung importiert wurde.

Die Ergebnisse dieser Prüfung werden in einem Fehlerprotokoll angezeigt und können wahlweise gedruckt werden. Hierdurch wird eine gezielte Korrektur der Fehler möglich.
Diese Prüfung kann über einen Radioschalter im Importfenster wahlweise an- und abgeschaltet werden.
Wenn unter "Option" die Checkbox "DSV-Nr unterdrücken" aktiviert wurde, dann findet keine Prüfung der DSV-Nr statt, da die DSV-Nr ja keine Bedeutung hat.


Import-Beispieldaten

Mit WinRegatta werden Beispieldaten für den Import von Meldedaten aus einer CSV-Datei mitgeliefert.

Details finden Sie hier


Känguruh-Start

Das Känguruh-Startverfahren wird gerne bei Clubregatten für Yardstickklassen verwendet. Es ist ein interessantes Startverfahren und lockert das Regattasegeln auf. Außerdem ist die Wertung einfach, da keine Zielzeit genommen werden muß. Der Zieleinlauf ist gleichzeitig das Ergebnis der Wettfahrt.

An Hand der Yardstickzahlen der teilnehmenden Bootstypen werden Zeitintervalle für den Start berechnet. Der theoretisch langsamste Bootstyp mit der höchsten Yardstickzahl wird "Nullboot" genannt und startet zuerst. Die anderen Boote starten dann danach in einem berechneten Zeitabstand, der sich aus ihrem jeweiligen Yardstick errechnet. Es entsteht also eine Verfolgungsjagd und das Boot, das als erstes das Ziel erreicht, hat gewonnen.

Wichtig ist es zu verstehen, dass die berechneten Startintervalle nur für eine bestimmte Wettfahrtdauer richtig sind. Es ist also wichtig, die geplante Wettfahrtdauer nach Bahnlänge und Windverhältnissen gut abzuschätzen bzw. einzuhalten.

Känguruh-Startliste erstellen


Känguruh-Startliste erstellen

Die Vorbereitung einer Känguruh-Wertung:

In der Funktion "Klassen" wird eine Wertungsklasse definiert. Für die Wertungsart dieser Klasse wird "Känguruh-Start" und als Ergebnisart wird "Rangplatz" gewählt.

In der Funktion "Segler" werden die Meldedaten der Segler einschließlich Bootstyp und Yardstick eingegeben.

Berechnung der Startliste:

Über Menü "Datei / Känguruh-Startliste erstellen" wird das Känguruh-Startfenster aufgerufen (siehe unten).

WinRegatta durchsucht nun die Klassendefinitionen der geöffneten Dateigruppe nach einer Klasse mit der Wertungsart "Känguruh-Start". Die Nummer und der Name dieser Klasse werden in dem Känguruh-Startfenster angezeigt.

In den entsprechenden Feldern muss nun die geplante Wettfahrtdauer und die Wettfahrtnummer eingegeben werden. Als Wettfahrtdauer können max. 99 Stunden und 59 Minuten eingegeben werden.

Mit Klick auf "Startliste" erfolgt die Berechnung und Anzeige der Startliste.

Mit Klick auf "Drucken" wird die Startliste gedruckt. Da jede Crew eine Startliste erhalten muß, kann hier auch die Anzahl der zu druckenden Listen gewählt werden.

Neu ab Vers. 4.5:

  • Die Startliste wurde erweitert, um für die Wettfahrtleitung und für die Segler zusätzliche Informationen bereit zu stellen:
    • Bisher enthielt die Startliste eine Zeile pro Bootstyp. Jetzt wird für jedes Boot eine Zeile gedruckt mit folgenden zusätzlichen Spalten: Segelnummer, Yachtname (wenn der Yachtname unter Optionen aktiviert wurde) und Steuermann/frau.
    • Der Yardstick des Nullbootes (größter Yardstick) wird durch WinRegatta automatisch ermittelt und braucht nicht mehr durch den Anwender eingegeben zu werden.

Ergebniseingabe und Wertung:

Wie bei einer Klassenwertung werden die Rangplätze des Zieleinlaufs als Ergebnisse eingegeben. Die Wertng erfolgt auch ganz normal.


Eingeschränktes Benutzerkonto

Grundsätzliches:

Unter Windows kann der Systemadministrator für den Anwender ein Benutzerkonto mit eingeschränkten Zugriffsrechten einrichten. Der Anwender kann dann nur in dem ihm zugeordneten Bereich Daten verändern und speichern.

Für den WinRegatta-Anwender als eingeschränkter Benutzer bedeutet dieses, dass folgende Dateien in Bereichen der Festplatte gespeichert werden, für die der Anwender volle Zugriffsrechte besitzt:

  • Die Regattadaten
    Die Dateien einer Regattaveranstaltung bilden eine Dateigruppe, die aus fünf oder auch aus sechs Dateien besteht.
    Diese Dateien kann der Benutzer in einem beliebigen Ordner speichern, in einem Bereich, für den er volle Rechte besitzt. Also hier kein Problem!
  • Clubs- und Boote-Dateien
    Nach der Installation von WinRegatta befinden sich diese Dateien im Installationsordner von WinRegatta. Diese Dateien sollte der Benutzer in einem Ordner speichern, für den er volle Rechte besitzt.
  • Beispiel-Dateien
    Nach der Installation von WinRegatta befinden sich diese Dateien im Unterordner "Beispiel-Daten" des Installationsordners von WinRegatta. Diese Dateien sollte der Benutzer ebenfalls in einem Ordner speichern, für den er volle Rechte besitzt.
  • Ini-Dateien
    Die verschiedenen Ini-Dateien stellen das Gedächtnis von WinRegatta dar und werden während des Programmablaufs verändert. Die Ini-Dateien müssen also auch in einem Bereich gespeichtert werden, für den der Benutzer volle Rechte hat. Das Verlagern der Ini-Dateien muss zwingend über den Menü-Punkt "Datei > Ordner für Ini-Dateien wählen..." geschehen. Auf diese Weise weiß WinRegatta wohin die Dateien verlagert wurden.

Benutzerkonto unter Windows XP einrichten

Benutzerkonto unter Windows7 einrichten


Benutzerkonto unter Windows XP einrichten

Benutzerkonto unter XP einrichten

  • Benutzerkonto und Ordnerstruktur anlegen:
    • Der Systemadministrator installiert WinRegatta in dem Standardordner.
    • Der Systemadministrator richtet für den WinRegatta-Anwender ein Benutzerkonto mit eingeschänkten Rechten ein. Als Name für dieses Benutzerkonto könnte z. B. "RegattaWertung" gewählt werden.
  • Organisationsvorschlag für WinRegatta durch Benutzer mit eingeschränkten Rechten:
    • Im Ordner "c:\Dokumente und Einstellungen\RegattaWertung" einen Unterordner "WinRegatta " hinzufügen.
    • Im Ordner "WinRegatta" folgende Unterordner hinzufügen:
      "RegattaDaten", "ClubsBoote" und "WinRegatta48 ".
    • Im Ordner "WinRegatta48" folgende Unterordner hinzufügen:
      "BeispielDaten" und "Ini-Dateien ".
    • Die Dateien "Clubs-4_2017.db" und "Boote-4_2017" von dem Installationsordner in den neuen Ordner "ClubsBoote " kopieren.
    • Die "Beisp-Daten" von dem Installationsordner in den neuen Ordner "BeispielDaten " kopieren.
    • WinRegatta starten. Jetzt in der Funktion "Clubs" mit dem "Öffnen-Symbol" (unten) "Clubs-4_2017.db" in dem neuen Ordner "ClubsBoote" öffnen. Das gleiche in der Funktion "Boote" mit "Boote-4_2017.db" vornehmen (WinRegatta merkt sich diese Ordneradresse für die Zukunft).
    • Mit Menü "Datei > Ordner für In-Dateien wählen..." den neuen Ordner "Ini-Dateien" wählen und auf "Übernehmen" klicken.
      Hierdurch werden alle Ini-Dateien, die WinRegatta benötigt, von dem Installationsordner in diesen neuen Ordner kopiert. Damit hat der Benutzer "RegattaWertung" volle Schreibrechte auf alle Ini-Dateien.
      Hinweis: die verschiedenen Ini-Dateien stellen das Gedächtnis von WinRegatta dar und werden für den Programmablauf benötigt.
    • Die eigenen Regatta-Daten können in dem neuen Ordner "RegattaDaten" gespeichert werden. Bei Bedarf können hier weitere Unterordner für unterschiedliche Regatten angelegt werden.
  • Hinweise zur obigen Ordnerstruktur:
    • "WinRegatta": Unter diesem Ordner werden alle Regatta-spezifischen Daten zusammengefasst.
    • "ClubsBoote": In diesem Ordner werden die Tabellen der DSV-Clubs und der Bootstypen mit den Yardstickzahlen gespeichert. Eigene Tabellen, z. B. mit Revier-Yardstickzahlen, können hier ebenfalls gespeichert werden.
    • "RegattaDaten": Hier können die Daten der eigenen Regatten gespeichert werden. Weitere Unterordner für unterschiedliche Regatten können angelegt werden, um eine gute Übersichtlichkeit zu erhalten.
    • "WinRegatta48": Hier werden alle Versions-spezifischen Daten von WinRegatta gespeichert. Bei einem Versionswechsel wird ein zusätzlicher Ordner (z. B. WinRegatta49) mit entsprechenden Unterordnern angelegt.
    • "BeispielDaten": Mit jeder WinRegatta-Version werden aktuelle Beispieldaten mitgeliefert, die hier abgelegt werden können. In diesen Beispielen sind die WinRegatta-Funktionen und die Wertungsregeln abgebildet.
    • "Ini-Dateien": Die Umgebeungs- und Steuerungsparameter für den Betrieb von WinRegatta werden hier in Form von Ini-Dateien abgelegt. Diese Dateien sind Versions-spezifisch und müssen durch WinRegatta über das Menü "Datei > Ordner für Ini-Dateien wählen..." in diesen Ordner kopiert werden.
      In der Datei "IniDateiOrdner.ini" wird das Verzeichnis festgehalten, in das die Ini-Dateien kopiert wurden. Diese Datei befindet sich immer im Installationsordner von WinRegatta. Hierdurch weiß WinRegatta stets, wo sich die Ini-Dateien befinden.

Es bleibt aber ein Problem:
Das Problem liegt in der Unterstützungs-Software der Pardox-Datenbank, bekannt als Borland Database Engine (BDE) .
Beim ersten Start einer Anwendung, die die BDE benutzt, wird die Datei "PDOXUSRS.NET" erzeugt.
Mit dieser Datei kontrolliert die BDE die Datenbank-Anwender. So wird z. B. eine Datentabelle, die ein Benutzer geöffnet hat, für andere Benutzer gesperrt, damit keine konkurrierenden Zugriffe geschehen.

Während der Verarbeitung wird diese Datei wiederholt verändert und gespeichert. Der eingeschränkte Benutzer hat keine Schreibrechte auf diese Datei. Auch dann nicht, wenn diese Datei in seinen eigenen Benutzerbereich verschoben würde.

Die Lösung für Windows XP Professional:
Der Windows Explorer des XP Pro erlaubt dem Systemadministrator, die Zugriffsrechte einer einzelnen Datei individuell einzustellen. So kann er dem eingeschränkten Benutzer die vollen Rechte für die Datei "PDOXUSRS.NET" vergeben, egal wo die Datei gespeichert ist.
Wie folgt vorgehen:

  • Sicherheitseinstellungen für Windows XP Pro ändern:
    • Den Windows Explorer öffnen.
    • Im Explorer das Menü "Extras" öffnen, dann Menüpunkt "Ordneroptionen" und dann auf den Reiter "Ansicht" klicken.
    • Den vierten Eintrag "Einfache Datenfreigabe verwenden" deaktivieren (Häkchen entfernen). Hierdurch erhält die Eigenschaft einer Datei den zusätzlichen Reiter "Sicherheit".
  • Rechte für das eingeschränkte Benutzerkonto erweitern:
    • Die Datei "PDOXUSRS.NET" suchen (normalerweise in C:\). Mit der rechten Maustaste auf diese Datei klicken und im Kontextmenü "Eigenschaften" wählen.
    • Im Fenster "Eigenschaften" den Reiter "Sicherheit" öffnen, und für das eingescränkte Benutzzerkonto nun die vollen Zugriffsrechte für diese Datei aktivieren.
  • WinRegatta durch den eingeschränkten Benutzer verwenden:
    • Wechsel in das Benutzerkonto "Regatta".
    • Der WinRegatta-Anwender startet WinRegatta Version 4.8 oder höher.
    • Er sollte nun ohne Probleme mit WinRegatta arbeiten können.

Die Lösung für Windows XP Home:
Eine offizielle Microsoft-Lösung gibt es nicht, da der Explorer von XP Home die Zugriffsrechte einer einzelnen Datei nicht verändern kann.

Eine Quelle im Internet verweist aber auf ein kostenfreies Fremdprogramm , das genau das bewirkt, was in XP Pro möglich ist. Das heißt, der Explorer von XP Home erhält mit diesem Programm die Funktionalität, wie sie der XP Pro Explorer besitzt.

Dies funktioniert aber nur, wenn die Festplatte oder die Partition für das NTFS-Dateisystem formatiert wurde.

Das Programm heißt "FaJo XP File Security Extension (XPFSE)". Es ist beschrieben auf der Website www.fajo.de/portal/index.php . Dort gibt es auch eine Download-Möglichkeit.

Das XPFSE-Programm sollte sehr vorsichtig eingesetzt werden, da bei unsachgemäßem Einsatz auch Probleme entstehen können. Auf der obigen Website ist hierzu einiges beschrieben.

Die Empfehlung ist, nur die Zugriffsrechte von "PDOXUSRS.NET" zu erweitern, und danach das Programm über "Systemsteuerung / Software" wieder zu deinstallieren.


Benutzerkonto unter Windows7 einrichten

Benutzerkonto anlegen:

  • Der Systemadministrator installiert WinRegatta in dem Standardordner.
    Details
  • Der Systemadministrator richtet für den WinRegatta-Anwender ein Benutzerkonto mit eingeschänkten Rechten ein. Als Name für dieses Benutzerkonto könnte z. B. "RegattaWertung" gewählt werden.

Arbeiten als eingeschränkter Benutzer:

  • Nach der Installation in das Benutzerkonto "RegattaWertung" wechseln.
  • Der Benutzer "RegattaWertung" hat nur im Ordner "Bibliothek\Dokumente\Eigene Dokumente" Schreibrechte. Bei Dateien in anderen Ordnern (z. B. auch im Installationsordner von WinRegatta) hat der Benutzer nur Lese- und Ausführungsrechte.
  • Dateien verändern, löschen oder verschieben ist nur mit Administratorenrechten erlaubt. Der Benutzer "RegattaWertung" kann z. B. mit dem Windows Explorer keine Dateien in dem Installationsordner verschieben, aber Kopieren der Dateien ist möglich, da die Originaldateien dabei ja erhalten bleiben.
  • Es können auch Dateien geändert werden. Hierbei bleibt die Originaldatei erhalten und die geänderte Datei wird quasi als Kopie automatisch in einem gesonderten Ordner gespeichert. Der Benutzer "RegattaWertung" hat dann in diesem Ordner volle Rechte auf diese geänderte Dateien.

Ein Beispiel: Mit WinRegatta wird die Dateigruppe "Bsp-Indiv-Startzeit.R48" geöffnet. Diese Dateigruppe befindet sich nach der WinRegatta-Installation im Ordner "c:\Programme (x86)\Regatta\WinReg48\Beisp-Daten". Obwohl der Benutzer "RegattaWertung" hier keine Schreibrechte hat, kann diese Dateigruppe geöffnet und geändert werden. Wenn die Dateigruppe unter gleichem Namen oder mit "Speichern unter..." unter einem anderen Dateinamen gespeichert wird, erfogt dies automatisch in dem Ordner

"c:\Benutzer\RegattaWertung\AppData\Local\VirtualStore\Program Files (x86)\WinRegatta48\Beisp-Dateien"

Beim erneuten Öffnen der Dateigruppe wird der obiger Ordner wieder automatisch gewählt. Die Original-Dateigruppe bleibt unverändert in dem ursprünglichen Ordner erhalten.
Wichtiger Hinweis: Die so gespeicherten Dateien sind "Versteckte Dateien und Ordner". Um diese Dateien mit dem Windows Explorer zu sehen, muss im Explorer folgende Einstellung vorgenommen werden:
Im Explorer auf Register "Organisieren" klicken, dann "Ordner- und Suchoptionen" auswählen, dann auf Register "Ansicht" klicken und unter "Versteckte Dateien und Ordner" den Punkt "Ausgeblendete Dateien, Ordner und Laufwerke anzeigen" wählen.

Organisationsvorschlag für WinRegatta durch Benutzer mit eingeschränkten Rechten:

  • Im Ordner "Bibliotheken\Dokumente\Eigene Dokumente" einen Unterordner "WinRegatta " hinzufügen.
  • Im Ordner "WinRegatta" folgende Unterordner hinzufügen:
    "RegattaDaten", "ClubsBoote" und "WinRegatta48 ".
  • Im Ordner "WinRegatta48" folgende Unterordner hinzufügen:
    "BeispielDaten" und "Ini-Dateien ".
  • Die Dateien "Clubs-4_2017.db" und "Boote-4_2017" von dem Installationsordner in den neuen Ordner "ClubsBoote " kopieren.
  • Die "Beisp-Daten" von dem Installationsordner in den neuen Ordner "BeispielDaten " kopieren.
  • WinRegatta starten. Jetzt in der Funktion "Clubs" mit dem "Öffnen-Symbol" (unten) "Clubs-4_20173.db" in dem neuen Ordner "ClubsBoote" öffnen. Das gleiche in der Funktion "Boote" mit "Boote-4_2017.db" vornehmen (WinRegatta merkt sich diese Ordneradresse für die Zukunft).
  • Mit Menü "Datei > Ordner für In-Dateien wählen..." den neuen Ordner "Ini-Dateien" wählen und auf "Übernehmen" klicken (diese Funktion erfordert Administratorenrechte ).
    Hierdurch werden alle Ini-Dateien, die WinRegatta benötigt, von dem Installationsordner in diesen neuen Ordner kopiert. Damit hat der Benutzer "RegattaWertung" volle Schreibrechte auf alle Ini-Dateien.
    Hinweis: die verschiedenen Ini-Dateien stellen das Gedächtnis von WinRegatta dar und werden für den Programmablauf benötigt.
  • Die eigenen Regatta-Daten können in dem neuen Ordner "RegattaDaten" gespeichert werden. Bei Bedarf können hier weitere Unterordner für unterschiedliche Regatten angelegt werden.

  • Hinweise zur obigen Ordnerstruktur:
    • "WinRegatta": Unter diesem Ordner werden alle Regatta-spezifischen Daten zusammengefasst.
    • "ClubsBoote": In diesem Ordner werden die Tabellen der DSV-Clubs und der Bootstypen mit den Yardstickzahlen gespeichert. Eigene Tabellen, z. B. mit Revier-Yardstickzahlen, können hier ebenfalls gespeichert werden.
    • "RegattaDaten": Hier können die Daten der eigenen Regatten gespeichert werden. Weitere Unterordner für unterschiedliche Regatten können angelegt werden, um eine gute Übersichtlichkeit zu erhalten.
    • "WinRegatta48": Hier werden alle Versions-spezifischen Daten von WinRegatta gespeichert. Bei einem Versionswechsel wird ein zusätzlicher Ordner (z. B. WinRegattta48) mit entsprechenden Unterordnern angelegt.
    • "BeispielDaten": Mit jeder WinRegatta-Version werden aktuelle Beispieldaten mitgeliefert, die hier abgelegt werden können. In diesen Beispielen sind die WinRegatta-Funktionen und die Wertungsregeln abgebildet.
    • "Ini-Dateien": Die Umgebeungs- und Steuerungsparameter für den Betrieb von WinRegatta werden hier in Form von Ini-Dateien abgelegt. Diese Dateien sind Versions-spezifisch und müssen durch WinRegatta über das Menü "Datei > Ordner für Ini-Dateien wählen..." in diesen Ordner kopiert werden.
      In der Datei "IniDateiOrdner.ini" wird das Verzeichnis festgehalten, in das die Ini-Dateien kopiert wurden. Diese Datei befindet sich immer im Installationsordner von WinRegatta. Hierdurch weiß WinRegatta stets, wo sich die Ini-Dateien befinden.


Daten-Export/Import

Daten-Export/Import Neu ab Vers. 4.6

Grundsätzliches:

Die Weiterentwicklung von WinRegatta erfordert oft eine Erweiterung der Datenbank. Für zusätzliche Funktionen in einer neuen WinRegatta-Version werden z. B. neue Datenfelder in der Datenbank benötigt.
Hierdurch sind die Regattadaten nicht mehr Versions-kompatibel. Eine neue WinRegatta-Version mit erweiterter Datenbank kann dann eine Dateigruppe, die mit einer älteren Version erstellt wurde, nicht mehr öffnen und umgekehrt.

Die Lösung:

In der alten WinRegatta-Version werden die Regattadaten in eine CSV-Datei exportiert und die neue WinRegatta-Version importiert die Daten aus der CSV-Datei.
Hierdurch werden die Daten Versions-kompatibel.

Dieser Vorgangang funktioniert auch umgekehrt: Die Daten einer neuen Version werden exportiert und in eine ältere Version importiert.

Diese Daten-Export/Import-Funktion wurde erstmals in WinRegatta Version 4.6 implementiert.


Regattadaten-Export in CSV-Datei

Export-Durchführung:

Öffnen Sie die Dateigruppe, deren Daten in eine CSV exportiert werden sollen.

Mit dem Menü "Datei / Dateigruppe als CSV-Datei exportieren..." wird ein Dialogfenster geöffnet, in dem der Ordner gewählt werden kann, in den die CSV-Datei gespeichert werden soll. Der Dateiname der geöffneten Dateigruppe wird als Dateiname für die CSV-Datei voreingestellt. Dieser Dateiname wird um die WinRegatta-Version, mit der der Export durchgeführt wurde, ergänzt. Es kann aber auch ein beliebiger Name für die CSV-Datei gewählt werden.

Struktur einer Dateigruppe:

Eine Dateigruppe von WinRegatta besteht bekanntlich aus folgenden 5 bzw. 6 Dateien mit gleichem Dateinamen, aber mit unterschiedlichen Dateinamen-Erweiterungen:

  • Allgemeine Daten der Regatta = *.R47 (ein Datensatz mit 53 Datenfeldern. Beim Öffnen der Dateigruppe steht dieser Dateiname stellvertretend für die ganze Gruppe)
  • Klassendaten = *.K47 (ein Datensatz pro definierter Klasse, 28 Datenfelder)
  • Seglerdaten = *.S47 (ein Datensatz pro gemeldetem Boot, 69 Datenfelder)
  • Ergebnisdaten = *.E47 (ein Datensatz pro Boot und gesegelter Wettfahrt, 19 Datenfelder)
  • Wettfahrtprotokoll = *.W47 (ein Datensatz pro Klasse und Wettfahrt, 25 Datenfelder)
  • Erweiterte Crew = *.C47 (nur WinRegatta Plus. Ein Datensatz pro gemeldeter, erweiterter Crew, d. h. mehr als drei Sgler pro Boot, 19 Datenfelder)

Struktur der CSV-Datei:

Alle Datensätze einer Dateigruppe werden in eine CSV_Datei gespeichert. Ein Satz der Dateigruppe bildet jeweils einen Satz der CSV_Datei. Je nach der Anzahl der gemeldeten Boote und der gesegelten Wettfahrten kann die CSV-Datei mehre hundert Datensätze enthalten.

In einer CSV-Datei sind die Datenfelder eines Datensatzes aneinander gereiht und durch Semikolon (;) getrennt. Für die Identifikation der Daten ist die Reihenfolge der Datenfelder entscheidend.
Im ersten Feld eines Datensatzes ist ein Kennzeichen gespeichert, damit der Satz einer der 5 bzw. 6 Dateien der Dateigruppe zugeordnet werden kann.

Diese Kennzeichen sind:
#Reg, #Kla, #Seg, #Crw, #Er, #WfP.

Anzeigen der Daten einer CSV-Datei:

Die CSV-Datei kann mit einem Editor oder mit Excel angezeigt werden.


Regattadaten-Import aus CSV-Datei

Import-Durchführung:

WinRegatta starten und mit Menü "Datei / Neu" eine neue (leere) Dateigruppe erzeugen.

Auf Menü "Datei / Dateigruppe von CSV-Datei importieren..." klicken und in dem Dialogfenster die CSV-Datei auswählen, die importiert werden soll.
Bitte warten bis der Import beendet ist. Dann mit "Datei / Speichern unter..." die importierten Daten unter einem freigewählten Dateinamen speichern.
Jetzt die gespeicherte Dateigruppe mit "Datei / Schließen" beenden.
Danach kann die Dateigruppe mit "Datei / Oeffnen..." wieder geöffnet werden und die importierten Daten verwendet werden.

Hinweis:
Das Speichern der Daten nach dem Import und das anschließende wieder Öffnen ist wichtig, da dadurch die importierten Daten initialisiert werden.

Interner Ablauf des Imports:

In der CSV-Datei sind alle Daten einer Regatta-Veranstaltung gespeichert und werden in eine WinRegatta-Dateigruppe importiert.

In der CSV-Datei sind die Datenfelder eines Datensatzes aneinander gereiht und durch Semikolon (;) getrennt. Für die Identifikation der Daten ist die Reihenfolge der Datenfelder entscheidend.
Im ersten Feld eines Datensatzes ist ein Kennzeichen gespeichert, damit der Satz einer der 5 bzw. 6 Dateien der Dateigruppe zugeordnet werden kann.

Diese Kennzeichen sind:
#Reg, #Kla, #Seg, #Crw, #Er, #WfP.

Anhand des Kennzeichens und der Reihenfolge der Datenfelder werden die Daten beim Import in die jeweils zutreffende Datei und in die richtigen Felder der Datei übernommen.


Datenbeispiele

In dem Installationspaket von WinRegatta befinden sich Dateigruppen mit Beispieldaten.
Die Dateinamen sind:

"Bsp-Regeln-2017"
"Bsp-Sekundaer-W "

"Bsp-Uhrzeit "

" Bsp-Indiv-Startzeit"

"Bsp-Stgeld-Abr"
"Bsp-WF-Protokoll"
"Bsp-Yacht-Namen"
"Bsp-Ystick-StromW "

"Bsp-Meldedatenimport "

"Bsp-Känguruh-Start "

Für Anwender von WinRegatta Plus sind zusätzliche Beispieldaten vorhanden:

Im Unterverzeichnis "ORC" die Dateigruppen "Bsp-ORC-Zeit-Zeit" und "Bsp-ORC-Zeit-Distanz" als Beispiele für ORC-Club-Wertungen.
Im Unterverzeichnis "GrWert" finden Sie 19 Dateigruppen mit Beispielen, die die verschiedenen Phasen einer Gruppenwertung darstellen und erklären.

Im Unterverzeichnis "MO-Finale" finden Sie 5 Dateigruppen mit Beispielen, die die verschiedenen Phasen einer MO-Finale-Wertung erklären.
Im Unterverzeichnis "Crew" die Dateigruppe "Bsp-Crew-6" als Beispiel für eine Crew-Stärke von 1 bis 6 Segler pro Boot.

Empfehlung:

  • Diese Dateien sollten vom Inhalt her nicht verändert werden, da mit ihnen die Wertungsregeln von WinRegatta und der WR erklärt werden können. Wenn Sie mit diesen Daten testen und experimentieren möchten, dann erstellen Sie bitte vorher mit "Datei / Speichern unter" eine Kopie.
  • Öffnen Sie diese Dateien und führen Sie mit der Funktion "Wertung" einen Wertungslauf der verschiedenen Klassen durch. In dem Bermerkungsfeld unten rechts finden Sie eine Beschreibung der jeweiligen Klasse und der Regeln.
  • Sie können die Ergebnislisten der einzelnen Klassen auch drucken mit aktiviertem Schalter "Hinweis zur Regatta". Dann können Sie die Regeln auch auf dem Papier nachvollziehen. Dies ist vor allem für das Verständnis der recht komplizierten Regeln zur Lösung von Punktgleichheiten wichtig.


Beispiel Wertungsregeln

Beispiel Wertungsregeln (Bsp-Regeln-2017)

Totes Rennen, Punktgleichheit, Wiedergutmachung, Wertungsstrafe

  • In dieser Dateigruppe werden die wichtigsten Wertungsregeln der WR 2017 - 2020 mit Beispieldaten erklärt.
  • In der Funktion "Wertung" werden die angewandten Regeln im Bemerkungsfeld erklärt. Die gleiche Erklärung erscheint unten auf der gedruckten Ergebnisliste.

Empfehlung: diese Daten nicht verändern!


Beispiel Sekundärwertung

Beispiel Sekundärwertung (Bsp-Sekundaer-W)

Sekundärwertung über mehrere Klassen:
In dieser Dateigruppe werden mit 3 Primärklassen und 8 Sekundärklassen die Möglichkeiten der Sekundärwertung dargestellt.

  • Klasse 1: "Laser-Meisterschaft" - Primärklasse. Ranglistenwertung mit RL-Punkten, 15 Wettfahrten nach gesegeltem Rang, 3 Streicher.
  • Klasse 2 bis Klasse 6: Diese fünf Sekundärklassen werten jeweils eine Untermenge der Klasse 1. Zum Beispiel "Laser Junioren", "Laser Masters" oder "Laser Frauen". Es findet also eine Sekundärwertung in fünf Ebenen statt. Nur die Wettfahrten 1 bis 6 der insgesamt 12 gesegelten Wettfahrten werden für diese Wertungen mit einem Streicher herangezogen. Als Punktsystem wird das Low-Point-System aber auch das Bonuspunktsystem verwendet.
  • Klasse 7: "A-Jollen Rangliste" - Primärklasse. Drei Wettfahrten als Ranglistenwertung. Hier muss die gesegelte Zeit gestoppt werden, weil in der Sekundärklasse 9 eine Yardstickwertung über verschiedene Bootstypen der Klassen 7 und 8 vorgenommen werden soll.
  • Klasse 8: "Jollenkreuzer" - Primärklasse. Drei Wettfahrten werden nach dem Low-Point-System gewertet. Yardstickwertung über mehrere Bootstypen. 3-Mann-Boote.
  • Klasse 9: "HSC Club-Wertung" - Sekundärklasse als Untermenge von zwei Primärklassen. Yardstickwertung der Segler des HSC-Clubs aus den Klassen 7 und 8.
  • Klasse 10: "Senioren-Wertung" - Sekundärklasse als Untermenge nur e i n e r Primärklasse (7). Bei dieser Sekundärwertung wurde gewählt, die Ergebnisse unabhängig von der Primärklasse neu zu berechnen. Die Rangfolge der Segler 208, 202, und 204 hat sich gegenüber der Primärklasse geändert. Dies ist rechnerisch in Ordnung, führt bei den Seglern aber oft zu Irritationen.
  • Klasse 11: "Senioren-Wertung" - Sekundärklasse als Untermenge nur e i n e r Primärklasse (7). Bei dieser Sekundärwertung wurde gewählt, die Ergebnisse der Primärklasse für die Sekundärklasse zu übernehmen. Gegenüber der Primärklasse ändert sich hier die Rangfolge der Segler nicht. Aus diesem Grunde ist dies die empfohlene Wertungsalternative.


Beispiel Uhrzeit

Beispiel Uhrzeit (Bsp-Uhrzeit)

Beispieldaten für Ergebniseingabe als Uhrzeit

  • In dieser Regatta mit einer Primärklasse und drei gesegelten Wettfahrten werden die Ergebnisse als Uhrzeit genommen.
  • Beim Start einer Wettfahrt wird die Startuhrzeit notiert.

  • Beim Zieldurchgang eines jeden Bootes wird die Uhrzeit notiert und später bei der Ergebniseingabe eingegeben.

  • Einzelheiten finden Sie hier .


Beispiel Individuelle Startzeit

Beispiel Individuelle Startzeit (Bsp-Indiv-StartZeit)

Beispieldaten für Zeitnahme mit Individueller Startzeit Neu in Vers. 4.4b

  • In dieser Regatta mit einer Primärklasse und zwei gesegelten Wettfahrten kann jedes Boot in einem vorgegebenen Zeitfenster seine Startzeit selbst bestimmen.
  • Pro Boot wird die individulle Startzeit und die Zielzeit notiert.

  • Bei der Ergebniseingabe werden diese beiden Zeiten für jedes Boot eingegeben. WinRegatta errechnet hieraus die gesegelte Zeit.

  • Weitere Einzelheiten finden Sie hier .


Beispiel Team-Wertung

Beispiel Team-Wertung (Bsp-Team-Wertung) (Neu ab Vers. 4.6)

  • In diesem Beispiel werden die Boote der Wertungsklasse 1 in vier Teams eingeteilt (max. sind acht Teams möglich). Die Teams segeln dann gegeneinander.
  • In der Klasse 2 werden wiederum andere Boote in vier Teams eingeteilt, wobei einige Boote keinem Team zugeordnet sind.
  • Die Klasse 3 ist eine Sekundärklasse und führt eine Teamwertung durch, wobei verschiedene Boote aus den Klassen 1 und 2 gemischt in zwei Teams gewertet werden.

Funktion der Team-Wertung


Beispiel Startgeldabrechnung

Beispiel Meldegeldabrechnung (Bsp-Meldegeld-Abr)

Beispieldaten für die Druckliste "Startgeld-Abrechnung"

  • Diese Regatta mit fünf Primärklassen und einer Sekundärklasse dient als Beispiel für eine Meldegeldabrechnung.
  • Ab Vers. 4.7 kann wahlweise das Nachmeldegeld zusätzlich erfasst werden. Das Nachmeldegeld wird dann ebenfalls in der Abrechnung ausgewiesen.
  • Es werden in der Abrechnung immer a l l e Primärklassen der Regatta gedruckt, unabhängig von der Klassennummer, die beim Druck eingegeben wird.


Beispiel Wettfahrtprotokoll

Beispiel Wettfahrtprotokoll (Bsp-Wf-Protokoll)

Beispieldaten für Wettfahrtprotokolle

  • In dieser Regatta mit zwei Primärklassen und vier gesegelten Wettfahrten wird das vollständige Wettfahrtprotokoll gezeigt.
  • Bitte drucken Sie diese beiden Klassen mit der Ergebnisliste für vier Wettfahrten und aktivieren Sie hierbei den Druck von Wind-/Bahndaten, Wettfahrtzeiten und Hinweis.


Beispiel Yachtnamen

Beispiel Yachtnamen oder Bugnummern (Bsp-Yachtname_BugNr) (Neu ab Vers. 4.6)

Beispieldaten für Yachtnamen oder Bugnummern zusätzlich zur Segelnummer / LK

  • In dieser Regatta mit einer Primärklasse und drei gesegelten Wettfahrten wurde zusätzlich zu Segelnummer und Landeskenner (LK) auch der Yachtname oder eine Bugnummer pro Boot eingegeben.
  • Über das Menü "Optionen " kann gewählt werden, ob Yachtnamen oder Bugnummern verwendet werden sollen oder nicht.
  • Wichtig ist, dass auch eine Segelnummer eingegeben werden muss, da gegenüber WinRegatta eine Crew nur durch die Segelnummer (wahlweise mit LK) identifiziert wird.
  • Die letzten beiden Yachten in diesem Beispiel hatten keine Segelnummer im Segel. Hier wurde deshalb ein Teil des Yachtnamens als Segelnummer verwendet.
  • Über das Menü "Optionen" kann außerdem gewählt werden, ob auf den Drucklisten und in der HTML-Datei und Textdatei die Segelnummer (ggf. LK) zusätzlich zum Yachtnamen oder der Bugnummer gezeigt wird oder eben n u r der Yachtname oder die Bugnummer (ohne Segelnummer) ausgegeben werden soll.


Beispiel Stromwertung

Beispiel Yardstick-Korrektur und Stromwertung (Bsp-Ystick-Strom-W)

Beispieldaten für Individuelle Yardstick-Korrektur und Stromwertung

  • Klasse 1: Yardstick-Wertung mit individueller Yardstick-Korrektur. Über "Optionen" kann die Funktion "Individuelle Yardstick-Korrektur" aktiviert bzw. deaktiviert werden. Bitte mit Listenformat "4 Wf, mehrzeilig, Yardstick, ORC" drucken!
  • Klasse 2: In dieser Regatta wird eine Wettfahrt stromab auf einem Flussrevier gesegelt. Bei der Klassendefinition wird als Wertungsart "Yardstick/Strom" eingegeben. Dies führt zu einer Yardstickwertung mit der Schabrod-Stromformel. Dies ist sinnvoll, da ein langsames Boot dem "schiebenden" Strom länger ausgesetzt ist als ein schnelleres Boot. Das langsame Boot hat also einen ungerechtfertigten Vorteil, der mit der Stromformel teilweise kompensiert wird. Bitte mit Listenformat "4 Wf, mehrzeilig, Yardstick, ORC" drucken!
  • Vor dem Wertungslauf muss mit der Funktion "WF-Protokoll" ein Protokollsatz für diese Wettfahrt mit der Stromgeschwindigkeit und der Bahnlänge angelegt werden. Die Stromgeschwindigkeit wird im WF-Protokoll auf den Ergebnislisten ausgewiesen.


Beispiel Meldedaten-Import

Beispieldaten für den Import von Meldedaten aus einer CSV-Datei:

  • Das Beispiel zeigt den Meldedaten-Import von gemischten Klassen. Das heißt, ein Meldeformular auf der Website des Clubs enthält Meldefelder für unterschiedliche Klassen (unterschiedliche Crew-Stärke, Yardstick-Regatten, Geburtsdaten usw.)
  • Die Meldedaten werden in eine CSV-Datei mit Strichpunkt als Feldseparator gespeichert. Felder, die nicht ausgefüllt wurden, werden als Leerfelder in die CSV-Datei ünernommen, d. h. es folgen zwei Strichpunkte aufeinander.
    Neu ab Vers. 4.5: Der erste Satz in der CSV-Datei kann wahlweise als Überschiftszeile verwendet werden, in dem die Feldnamen in der entsprechenden Feldfolge angegeben werden können. Als Kennzeichen hat dieser Satz in den ersten beiden Stellen "##" gespeichert. Beim Import wird dieser Satz ignoriert.
    Der Vorteil der Überschriftszeile: Wenn die CSV-Datei mit Excel geöffnet wird, dann sind die Felder mit den Überschriften vertikal ausgerichtet.

  • Eine Ini-Datei mit dem Namen "Meldedaten.ini" übernimmt die Synchronisation des Imports der Felder aus der CSV-Datei in die entsprechenden Felder der Seglerdatei (*.S48) in WinRegatta. Nach der Installation von WinRegatta befindet sich diese Ini-Datei im Installationsordner von WinRegatta. Mit Menü "Datei / Ordner für Ini-Dateien wählen" kann aber ein beliebiger anderer Ordner für alle Ini-Dateien gewählt werden.

  • Mit Menü "Datei / Meldedaten Ini-Datei " kann die Ini-Datei editiert werden.

  • Mit Menü "Datei / Meldedaten importieren" werden die Meldedaten importiert. Falls die Klassennummern nicht importiert wurden, dann haben die importierten Boote noch keine Zuordnung zu Klassen. In der Funktion "Segler" können die Zuordnungen zu den Primärklassen vorgenommen werden.

Beispieldaten für den raceoffice.org Meldedaten-Import (Neu ab Vers. 4.5):

  • Die Meldedaten für eine Veranstaltung werden online von raceoffice.org erfasst und als CSV-Datei heruntergeladen.
  • Eine passende Ini-Datei ist unter dem Namen "MeldedatenRaceOffice.ini " bereits in WinRegatta gespeichert.
  • Mit Menü "Datei / raceoffice.org Meldedaten Import " werden die Meldedaten importiert.

Einzelheiten siehe:

Meldedaten-Import

Import von raceoffice.org

Import-Durchführung

Import-Plausibilitätsprüfung


Beispiel Känguruh-Start

Beispieldaten für die Berechnung einer Känguruh-Startliste

  • In dieser Regatta sind zwei Primärklassen definiert.
    Klasse 1 "Opti-Regatta" als Klassenwertung.
    Klasse 2 "Mittwochs-Wettfahrten" als Känguruh-Start.
  • Über Menü "Datei / Känguruh-Startliste erstellen" wird die Klasse 2 automatisch für die Berechnung der Startliste ausgewählt.
  • Einzelheiten siehe:

    Känguruh-Start
    Känguruh-Startliste erstellen


Beispiel ORC-Wertung

Beispieldaten für ORC-Club-Wertung nach dem Zeit/Zeit-System
(Nur WinRegatta Plus)

  • Im Unterverzeichnis "ORC" befindet sich die Dateigruppe "Bsp_ORC-Zeit-Zeit" mit einer Primärklasse und vier gesegelten Wettfahrten und zeigt eine ORC-Club-Wertung nach dem Zeit/Zeit-System.
  • Bei der Seglereingabe wurde für jedes Boot ein "TMF" -Faktor (z. B. 0,8728) eingegeben.
  • Formel: Berechnete Zeit (Sek) = gesegelte Zeit (Sek) multipliziert mit TMF.
  • Bitte drucken Sie diese Ergebnisse mit dem Listenformat "4 Wf, mehrzeilig, Yardstick, ORC"

Beispieldaten für ORC-Club-Wertung nach dem Zeit/Distanz-System
(Nur WinRegatta Plus)

  • Im Unterverzeichnis "ORC" befindet sich die Dateigruppe "Bsp_ORC-Zeit-Distanz" mit einer Primärklasse und zwei gesegelten Wettfahrten und zeigt eine ORC-Club-Wertung nach dem Zeit/Distanz-System.
  • Bei der Seglereingabe wurden für jede Yacht die Faktoren "GPH" (z. B. 788,4), "PLT" (z. B. 0,712) und "PLD" (z. B. 230,1) eingegeben.
  • Formel: Berechnete Zeit in Sek = (gesegelte Zeit in Sek x PLT) - (Distanz in sm x PLD).
  • Bitte drucken Sie die einzelnen Wettfahrten mit dem Listenformat "Einzel-Wettfahrt-Ergebnis" und das Gesamtergebnis mit dem Format "4 Wf, mehrzeilig, Yardstick, ORC".
  • Der Faktor "GPH" (Sekunden pro Seemeile) wird zur Ermittlung der berechneten Zeit nicht benötigt. Der GPH erscheint aber auf den Ergebnislisten als Anhaltspunkt für das Geschwindigkeitspotential der Yacht.


Beispiel Gruppenwertung

Beispiel Gruppenwertung (verschiedene Dateien)

Beispieldaten für Gruppenwertung
(Nur WinRegatta Plus)

  • Im Unterverzeichnis "GrWert" befinden sich 14 Dateigruppen, die beispielhaft die einzelnen Phasen einer Gruppenwertung zeigen.
  • Die Dateinamen sind "sprechend" und geben Hinweise über die Art der Gruppenbildung und über die gewerteten Wettfahrten.
  • Beispiele zu Finalläufen mit Gold- und Silbergruppen sind hier auch enthalten.


Beispiel MO-Finale

Beispiel MO-Finale (verschiedene Dateien)

Beispieldaten für MO-Finale
(Nur WinRegatta Plus)

Im Unterverzeichnis "Beisp\MO-Finale" befinden sich 8 Dateigruppen, die beispielhaft die einzelnen Phasen einer MO-Finalwertung zeigen.

Beispiel: Qualifikationswettfahrten

  • Im Unterverzeichnis "MO-Finale" befindet sich die Dateigruppe "Bsp1_Qualifikation" mit der Primärklasse 1, die fünf gewertete Qualifikationswettfarten mit einem Streicher enthält.
  • Mit der sekundären Wertungsklasse 2 wird die Teilmenge "Junioren" gewertet.
  • Mit der sekundären Wertungsklasse 3 wird die Teilmenge "Frauen" gewertet.
  • Die Klassen 4, 5 und 6 werden später zur Wertung der Finalwettfahrt benötigt und sind z. Zt. noch inaktiv.

Beispiel: MO-F Vorbereitung

  • Die Qualifikation ist mit fünf gesegelten Wettfahrten abgeschlossen.
  • Die Dateigruppe "Bsp2_MO-F_Vorbereitung" zeigt die Vorbereitung für die nun anstehende Finalwettfahrt. Die erforderlichen Wertungsklassen wurden bereits difiniert:

  • Primärklasse 4 zur Wertung des Finales der 10 punktbesten Boote der Qualifikation.
  • Primärklasse 5 zur Wertung des Flottenfinales ab Rang 11.
  • Sekundärklasse 6 zur Ermittlung des Gesamtergebnisses aus Finale und Flottenfinale.
  • Mit den Sekundärklassen 2 und 3 können die Teilmengen der Boote "Junioren" und "Frauen" ermittelt werden. Diese beiden Klassen wurden bereits während der Qualifikation verwendet. Für die Wertung der Finalwettfahrt muß in der Funktion "Klassen" nun das Kennzeichen "MO-F" für diese Klassen gesetzt werden.
  • In der Funktion "Finale" wurden die Parameter entsprechend dieser Klassendefinition eingegeben. Mit Klick auf "Übernehmen" wurden die Boote den Klassen 4, 5 und 6 automatisch zugeordnet.

Beispiel: MO-F Ergebniseingabe

  • Die Dateigruppe "Bsp3_MO-F_Ergebniseingabe" zeigt die Eingabe der Finalergebnisse.
  • Die gesegelten Ergebnisse der Finalwettfahrt werden in Funktion "Ergebnisse" in Klasse 4 Wettfahrt 6 eingegeben.
  • Die gesegelten Ergebnisse der Flottenfinalwettfahrt werden in Funktion "Ergebnisse" in Klasse 5 Wettfahrt 6 eingegeben.
  • Die Sekundärklassen benötigen keine Ergebniseingabe.

Beispiel: MO-F Wertung

  • Die Dateigruppe "Bsp4_MO-F_Wertung" zeigt die Wertung der Finalergebnisse.
  • Nachdem die Ergebnisse der Finalwettfahrt eingegeben wurden, werden nun die Primärklassen 4 und 5 mit jeweils 6 Wettfahrten und 1 Streicher gewertet.

  • Danach werden die Sekundärklassen gewertet, die ihre Ergebnisse von den Primärklassen übernehmen.
  • Die Ergebnisse können nun als Endergebnis gedruckt oder in Text- oder HTML-Dateien gespeichert werden.
  • Vor jedem Druck oder Speichern von Ergebnissen erfolgt intern ein automatischer Wertungslauf, um mögliche Ergebnisänderungen seit der letzten Wertung zu berücksichtigen.

Beispiel: MO-F Kein Flottenfinale

  • Die Dateigruppe "Bsp5_MO-F_Kein Flottenfinale" zeigt die Wertung, wenn kein Flottenfinale gesegelt wurde.
  • Wenn bei gültiger Wertung des Finales der 10 punktbesten Boote das Flottenfinale nicht gesegelt wurde, dann muß die Flottenwertung trotzdem durchgeführt werden, damit die vorgesehenen 20 Punkte pro Boot zum Gesamtergebnis addiert werden.
  • In der Funktion "Finale" wird WinRegatta mit einem entsprechenden Häkchen informiert, dass das Flottenfinale nicht gesegelt wurde.
  • Danach wird in der Funktion "Wertung" die Finalwettfahrt der Flottenklasse gewertet. Ergebnisse müssen keine eingegeben werden - es liegen ja auch keine Ergebnisse vor.

Beispiel: MO-F Qualifikationswettfahrten als Gruppenwertung

  • Die Dateigruppe "Bsp6_MO-F_Qualifikation_Als_Gruppenwertung" zeigt fünf Qualifikationswettfahrten, die in drei Gruppen gewertet wurden.
  • Mit den Primärklassen 1, 2 und 3 werden die drei Startgruppen gewertet. Die Gruppeneinteilung wird üblicherweise nach jedem Segeltag auf der Basis des aktuellen Gesamtergebnisses neu vorgenommen.
  • Mit der Wertung der Sekundärklasse 4 wird das Gesamtergebnis der Qualifikation ermittelt.
  • Mit der Wertung der Sekundärklasse 5 wird die Teilmenge U19 ermittelt.

Beispiel: MO-F Vorbereitung für Flottenfinale mit drei Startgruppen

  • Die Dateigruppe "Bsp7_MO-F_Vorbereitung_Flottenfinale_Mit_Drei_Startgruppen" zeigt die Vorbereitung für diese Finalwertung.
  • In der Funktion "Finale" wurden die erforderlichen Parameter eingegeben.
  • Mit Klick auf "Übernehmen" wurden die Parameter auf Plausibilität geprüft und die entsprechende Klassenzuordnung der Boote vorgenommen.

Beispiel: MO-F Mit Flottenfinale in drei Startgruppen

  • Die Dateigruppe "Bsp8_MO-F_Wertung_Flottenfinale_Mit_Drei_Startgruppen" zeigt die Wertung der Flotte in drei Startgruppen.
  • Nachdem alle Ergebnisse der Finalwettfahrt 6 eingegeben wurden, werden die Primärklassen 6, 7, 8 und 9 mit jeweils einem Streicher gewertet.
  • Mit der Wertung der Sekundärklasse 10 wird das Gesamtergebnis der Flotte - ebenfalls mit einem Streicher - ermittelt. Hier ist der erste Rangplatz nicht 1 sondern 11.
  • Mit der Wertung der Sekundärklasse 11 wird das Gesamtergebnis aller Klassen mit einem Streicher ermittelt.
  • Mit der Wertung der Sekundärklasse 12 wird die Teilmenge U19 gewertet.


Beispiel 6 Segler/Boot

Beispiel 6 Segler/Boot (Bsp-Crew-6)

Beispieldaten für 1 bis 6 Segler pro Boot
(Nur WinRegatta Plus)

  • Diese Dateigruppe mit 6 Primärklassen zeigt die möglichen Crew-Stärken von 1 bis 6 Seglern pro Boot.
  • Die Klasse 7 ist eine Sekundärklasse, der alle Segler der Klassen 1 bis 6 zugeordnet wurden. Somit erscheinen auf den Ergebnislisten der Klasse 7 die unterschiedlichen Crew-Stärken. Pro Boot wird jeweils eine Zeile pro Segler gedruckt. Es gibt keine Leerzeile, wenn ein Segler fehlt.
  • Die Daten des 4., 5. und 6. Seglers werden in der neuen Datei "*.C48" gespeichert. In diesem Falle besteht die Dateigruppe also aus 6 Dateien.
  • Die Datei "*.C48" wird nur erstellt, wenn in einer der Klassen eine Crew-Stärke > 3 definiert wurde.


Problembehandlung

WinRegatta wird seit Beginn der Segelsaison 2001 von vielen Clubs sehr erfolgreich eingesetzt. Die meisten Anwender berichten, dass WinRegatta stabil läuft. Es wurde aber auch über einige Probleme berichtet, die aber in den letzten Update-Versionen weitgehend behoben wurden.

Wenn Sie Probleme haben....
 Wenn Sie mit WinRegatta oder Windows in einer Problemsituation sind, so empfiehlt es sich, WinRegatta zu beenden und neu zu starten. Da die Ursache auch im Windows liegen kann, ist auch ein Neustart von Windows ratsam, um wieder eine saubere Ausgangsbasis zu erhalten. Um in einer solchen Situation die Datenverluste gering zu halten, sollten Sie die Änderungen Ihrer Regatta-Daten in Zeitabständen speichern (z.B. in Abständen von 10 bis 15 Minuten).

Bitte versuchen Sie, nach Möglichkeit die Umstände und ggf. die Fehlernummer , unter denen ein Problem auftritt, festzuhalten. Bitte informieren Sie mich über Details eventueller Probleme, damit ich sie untersuchen und beheben kann. Für Ihr Verständnis und für Ihre Hilfe danke ich Ihnen sehr.

Bekannte Probleme

Fehler-Codes


Bekannte Probleme

Einige Probleme und Einschränkungen sind bekannt, konnten aber noch nicht behoben werden:

  1. Abbruch bei vernetzten PCs mit Drucker
    Wenn WinRegatta auf einem vernetzten PC installiert wurde und der Drucker im Netz für diesen PC nicht verfügbar ist, dann führt der Start von WinRegatta zu einem Abbruch! Die Ursache dieses Fehlers wird untersucht.
    Vorgeschlagene Umgehung: Vor dem Start von WinRegatta sicherstellen, dass der Standarddrucker im Netz verfügbar ist.
  2. Druckfunktion mehrere Kopien
    In der Funktion Drucken können mehrere Kopien der zu druckenden Liste gewählt werden.
    Einige Anwender berichten, dass immer nur ein Exemplar gedruckt wird, obwohl zwei oder mehr Kopien gewählt wurden.
    Internet-Quellen berichten, dass einzelne Druckertreiber die Aufforderung der Anwendung, mehrere Kopien zu drucken, ignorieren.
    Vorgeschlagene Umgehung: Den Druckvorgang einer Liste mehrfach starten oder - falls vorhanden - einen Kopierer benutzen.
  3. Eingabefelder überlappen bei WinRegatta unter Windows 7:
    Unter Windows 7 kann folgendes Problem auftreten:
    Verschiedene Eingabefelder (z. B. in der Funktion "Segler" die Eingabefelder im unteren Teil des Bildschirms) überlappen sich. Eine saubere Eingabe der Daten ist damit unmöglich.
    Das gleiche Problem kann auch bei Drucklisten als Vorschau auftreten.

    URSACHE:
    Bei der "Systemsteuerung > Bildschirmauflösung" können Sie bei Windows 7 nicht nur die Auflösung in der bisherigen Form ändern, sondern es gibt zusätzlich den Menüpunkt "Text und weitere Elemente vergrössern oder verkleinern".
    Hier können Sie 100%, 125% oder 150% wählen. Bei 125% gibt es bei WinRegatta die besagten Überlappungen der Eingabefelder.

    TEMPORÄRE LÖSUNG:
    Beim Arbeiten mit WinRegatta verändern Sie die Bildschirmauflösung bitte nur in der bisher üblichen Form mittels "Systemsteuerung > Bildschirmauflösung".
  4. Möglicher Fehler bei WinRegatta Version 4.6:
    Wenn mit WinRegatta Version 4.6 eine Regatta-Dateigruppe geöffnet wird, die mit WinRegatta Version 4.1 bis 4.5 erstellt wurde, dann kann unter bestimmten Umständen ein Fehler auftreten.

    LÖSUNG:
         Mit Menü "Datei > Neu" eine neue Dateigruppe erstellen. Die neue Regatta-Datei "*.R04" umbenennen in den Dateinamen der fehlerhaften Dateigruppe und die alte Regatta-Datei (*.R04) durch die neue ersetzen.
    Die Seglerdaten und die Ergebnisdaten der alten Dateigruppe bleiben dabei erhalten.


Fehlerliste

Fehler-Codes

In fast allen Bereichen von WinRegatta wurde eine Fehlererkennung implementiert, die beim Auftreten eines Fehlers

  • einen Anwendungsabbruch verhindert,
  • das verursachende Anwendungsmodul identifiziert und
  • den Anwender mit einer Fehlernummer informiert.

Sollten Sie eine Fehlersituation erleben, dann notieren Sie bitte die Fehlernummer und die Umstände, unter denen der Fehler auftrat, z. B. die Abfolge von Anwendungsschritten, die zu diesem Fehler führt.
Bitte geben Sie mir diese Informationen , damit die Fehlerursache lokalisiert und behoben werden kann. Vielen Dank im Voraus.

Bei wiederkehrendem Auftreten eines Problems, bitte die Regatta-Daten speichern und WinRegatta beenden. Es ist auch ein Neustart von Windows zu empfehlen, weil Windows unter Stress auch Probleme verursachen kann. Dann WinRegatta neu starten.

Liste der Fehler-Codes:

Funktion "Segler"

161 Procedure SNrOK, oberer Teil
162 Procedure SNrOK, unterer Teil
171 Procedure MoveErgebnisse, oberer Teil
172 Procedure MoveErgebnisse, unterer Teil
173 Procedure CountSegler
175 Procedure BugNrHeaderClick - Sortierung Bugnummer (Segler-Fenster)
180 Procedure MakeCrewFile

Funktion "Ergebnisse"

201 Procedure ValidateGesegRg: Bei Prüfung auf Ranglücke, nachdem ein Rang gelöscht wurde
202 Procedure ValidateGesegRg: Fehler bei Rangeingabe obwohl schon DNF usw. existiert
203 Procedure ValidateGesegRg: Fehler bei eingegebenen Rang grösser als Anzahl Segler in der Klasse
204 Procedure ValidateGesegRg: Fehler bei Prüfung doppelter Rang in gleicher Klasse
205 Procedure ValidateGesegRg: Fehler bei Rangeinfügung
206 Procedure ValidateGestZt: Fehler während Prüfung auf richtiges Zeitformat
207 Procedure ValidateGestZt: Fehler während Prüfung auf doppelte gesegelte Zeit
211 Procedure LoadEFields: Funktion Ergebniseingabe
215 Procedure SetCountField
216 Procedure SetCountField
217 Procedure SetCountField
221 Procedure LBoxSuchSNrClick
222 Procedure SucheSegelNr - suchen in SegZE-Tabelle (Zieleinlauf-Fenster)
223 Procedure SucheSegelNr - suchen in Seg-Tabelle (Hauptfenster)
230 Procedure SetDnaDnc: automatische DNA-Auffüllung
226 Procedure YachtNameHeaderClick - Sortierung Bugnummer (Zieleinlauf-Fenster)
227 Procedure YachtNameHeaderClick - Sortierung Bugnummer (Haupt-Fenster)
230 Procedure SetDnaDnc: automatische DNA-Auffüllung
231 Procedure SetDnaDnc: automatische DNC-Auffüllung
240 Procedure OnCellClick: cxGridZE bei Ergebnisse nach Zieleinlauf
241 Procedure OnCellClick: cxGridZE bei Ergebnisse nach Zieleinlauf
242 Procedure ValidateIndivStartZt: Fehler während Prüfung auf richtiges Zeitformat
243 Procedure ValidateGestZt: Fehler während Prüfung auf doppelte gesegelte Zeit

Funktion "Wertung"

260 Procedure LadeListe: Segler und Ergebnisdaten
261 Procedure LadeListe: bei Strom-Formel
262 Procedure LadeListe: Anzahl Ergebnis-Wfn
263 Procedure LadeListe: Suche Ergebnis-Record, lade Ergebnisse
270 Löse Punktgleichheit letzte WF
272 Löse Punktgleichheit vorletzte WF

Funktion "Drucken"

401 Preview: Fehler bei Preview allgemein
402 Preview: Fehler bei Preview Meldeliste
403 Preview: Fehler bei Preview Ergebnislisten
404 Preview: Fehler bei Preview Checklisten
411 Liste 4 Wettfahrten: Fehler bei QR-BeforePrint
412 Liste 4 Wettfahrten: Fehler bei Detailband BeforePrint
413 Liste 4 Wettfahrten: Fehler bei Headerband BeforePrint
414 Liste Siegerehrung/Presse: Fehler bei QR-BeforePrint
415 Liste Siegerehrung/Presse: Fehler bei Detailband BeforePrint
416 Liste Siegerehrung/Presse: Fehler bei Headerband BeforePrint
417 Liste Zieleinlauf: Fehler bei QR-BeforePrint
418 Liste Zieleinlauf: Fehler bei Detailband BeforePrint
421 Quittungsdruck: Fehler bei Einzel-Quittung
422 Quittungsdruck: Fehler bei Multi-Quittung

Funktion "Clubs"

501 Procedure AddClub
503 Function ClubFound
505 Procedure ClubsBeforePost
509 Function FindDSV

Funktion "Boote"

551 Procedure AddBoot
553 Function BootFound
555 Procedure BooteBeforePost

Funktion "Datei"

621 Backup_Datei-Gruppe Open/Save-Dialoge
622 Backup_Datei-Gruppe Dateien kopieren

Funktion "Optionen"

700 Open Grafikdatei (Logo)
702 Open Werbegrafik

Funktion "Segler-Stammdatei"

751 OpenStFile: Fehler bei OpenDlgStFile
752 OpenStFile: Fehler bei Post
753 OpenStFile: Fehler bei Open
754 SaveAsStFile: Fehler bei SaveDlgStFile
755 SaveAsStFile: Fehler bei Post
756 SaveAsStFile: Fehler bei Copy File
757 SegToStamm: Fehler bei Stamm.Locate
758 SegToStamm: Fehler bei Felder kopieren
759 SegToStamm: Fehler bei Stamm.Post
760 CreateStFile: Fehler bei StFile Create oder Post
761 DeletDlgStFile: Fehler beim Dialog
762 DeletDlgStFile: Fehler bei Datei-Löschen
765 StammToSeg: Fehler bei SeSta.Locate
766 StammToSeg: Fehler bei Felder kopieren
767 StammToSeg: Fehler bei SeSta.Post
770 ExportStFile: Fehler beim Exportieren nach txt, xls, htm

Funktion "Meldedaten-Import"

801 Öffnen und Lesen CSV-Datei mit Meldedaten
802 Aufbereiten der Meldedaten aus der CSV-Datei
803 Speichern der Meldedaten in den Segler-Record

Funktion "Känguruh-Start"

820 Fehler beim Drucken der Startliste
821 Fehler in Exit-Routine von EdUWfDauer
822 Fehler in Procedure CalcStartList 1. Teil
823 Fehler in Procedure CalcStartList 2. Teil
824 Fehler bei Druck Känguruh-Startliste in Procedure HeaderBandBeforePrint
825 Fehler bei Druck Känguruh-Startliste in Procedure QuickRep1BeforePrint
826 Fehler bei Druck Känguruh-Startliste in Procedure DetailBandBeforePrint

Funktion "CSV-Export"

841 Fehler in Procedure WriteCSVDatei
842 Fehler in Procedure RegToCSV
843 Fehler in Procedure KlaToCSV
844 Fehler in Procedure SegToCSV
845 Fehler in Procedure CrwToCSV
846 Fehler in Procedure ErToCSV
847 Fehler in Procedure WfPToCSV

Funktion "CSV-Import"

851 Fehler in Procedure ReadCSVDatei
852 Fehler in Procedure CSVToReg
853 Fehler in Procedure CSVToKla
854 Fehler in Procedure CSVToSeg
855 Fehler in Procedure CSVToCrw
856 Fehler in Procedure CSVToEr
857 Fehler in Procedure CSVToWfp


Benutzerkonto unter Windows XP

Grundsätzliches:

Unter Windows kann der Systemadministrator für den Anwender ein Benutzerkonto mit eingeschränkten Zugriffsrechten einrichten. Der Anwender kann dann nur in dem ihm zugeordneten Bereich Daten verändern und speichern.

Für den WinRegatta-Anwender als eingeschränkter Benutzer bedeutet dieses, dass folgende Dateien in Bereichen der Festplatte gespeichert werden, für die der Anwender volle Zugriffsrechte besitzt:

  • Die Regattadaten
    Die Dateien einer Regattaveranstaltung bilden eine Dateigruppe, die aus fünf oder auch aus sechs Dateien besteht.
    Diese Dateien kann der Benutzer in einem beliebigen Ordner speichern, in einem Bereich, für den er volle Rechte besitzt. Also hier kein Problem!
  • Clubs- und Boote-Dateien
    Nach der Installation von WinRegatta befinden sich diese Dateien im Installationsordner von WinRegatta. Diese Dateien sollte der Benutzer in einem Ordner speichern, für den er volle Rechte besitzt.
  • Beispiel-Dateien
    Nach der Installation von WinRegatta befinden sich diese Dateien im Unterordner "Beispiel-Daten" des Installationsordners von WinRegatta. Diese Dateien sollte der Benutzer ebenfalls in einem Ordner speichern, für den er volle Rechte besitzt.
  • Ini-Dateien
    Die verschiedenen Ini-Dateien stellen das Gedächtnis von WinRegatta dar und werden während des Programmablaufs verändert. Die Ini-Dateien müssen also auch in einem Bereich gespeichtert werden, für den der Benutzer volle Rechte hat. Das Verlagern der Ini-Dateien muss zwingend über den Menü-Punkt "Date > Ordner für Ini-Dateien wählen..." geschehen. Aud diese Weise weiß WinRegatta wohin die Dateien verlagert wurden.

Es bleibt aber ein Problem:
Das Problem liegt in der Unterstützungs-Software der Pardox-Datenbank, bekannt als Borland Database Engine (BDE) .
Beim ersten Start einer Anwendung, die die BDE benutzt, wird die Datei "PDOXUSRS.NET" erzeugt.
Mit dieser Datei kontrolliert die BDE die Datenbank-Anwender. So wird z. B. eine Datentabelle, die ein Benutzer geöffnet hat, für andere Benutzer gesperrt, damit keine konkurrierenden Zugriffe geschehen.

Während der Verarbeitung wird diese Datei wiederholt verändert und gespeichert. Der eingeschränkte Benutzer hat keine Schreibrechte auf diese Datei. Auch dann nicht, wenn diese Datei in seinen eigenen Benutzerbereich verschoben würde.

Die Lösung für Windows XP Pro:
Der Windows Explorer des XP Pro erlaubt dem Systemadministrator, die Zugriffsrechte einer einzelnen Datei individuell einzustellen. So kann er dem eingeschränkten Benutzer die vollen Rechte für die Datei "PDOXUSRS.NET" vergeben, egal wo die Datei gespeichert ist.
Details

Die Lösung für Windows XP Home:
Eine offizielle Microsoft-Lösung gibt es nicht, da der Explorer von XP Home die Zugriffsrechte einer einzelnen Datei nicht verändern kann.

Eine Quelle im Internet verweist aber auf ein kostenfreies Fremdprogramm , das genau das bewirkt, was in XP Pro möglich ist. Das heißt, der Explorer von XP Home erhält mit diesem Programm die Funktionalität, wie sie der XP Pro Explorer besitzt.
Details

Benutzerkonto einrichten